]> git.pld-linux.org Git - packages/mozjs38.git/blame - mozjs38.spec
Use system virtualenv (should fix build on x32)
[packages/mozjs38.git] / mozjs38.spec
CommitLineData
9b7b3ede
MB
1Summary: SpiderMonkey 38 - JavaScript implementation
2Summary(pl.UTF-8): SpiderMonkey 38 - implementacja języka JavaScript
3Name: mozjs38
4Version: 38.8.0
5Release: 1
6License: MPL v2.0
7Group: Libraries
8Source0: https://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.bz2
9# Source0-md5: af46898414a433f8260c5373efb97d19
10Patch0: %{name}-shell-version.patch
11Patch1: %{name}-pkg-config-version.patch
12Patch2: %{name}-1269317.patch
013c854c 13Patch3: %{name}-system-virtualenv.patch
9b7b3ede 14URL: https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38
9b7b3ede 15BuildRequires: libffi-devel >= 5:3.0.9
9b7b3ede
MB
16BuildRequires: libstdc++-devel >= 6:4.4
17BuildRequires: nspr-devel >= 4.9.2
18BuildRequires: perl-base >= 1:5.6
19BuildRequires: pkgconfig
20BuildRequires: python >= 1:2.5
21BuildRequires: python-virtualenv >= 1.9.1-4
22BuildRequires: readline-devel
23BuildRequires: rpm-perlprov
24BuildRequires: rpmbuild(macros) >= 1.294
25BuildRequires: zlib-devel >= 1.2.3
26Requires: nspr >= 4.9.2
27Requires: zlib >= 1.2.3
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31JavaScript Reference Implementation (codename SpiderMonkey). The
32package contains JavaScript runtime (compiler, interpreter,
33decompiler, garbage collector, atom manager, standard classes) and
34small "shell" program that can be used interactively and with .js
35files to run scripts.
36
37%description -l pl.UTF-8
38Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
39Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
40dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
41która może być używana interaktywnie lub z plikami .js do uruchamiania
42skryptów.
43
44%package devel
45Summary: Header files for JavaScript reference library
46Summary(pl.UTF-8): Pliki nagłówkowe do biblioteki JavaScript
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49Requires: libstdc++-devel
50Requires: nspr-devel >= 4.9.2
51
52%description devel
53Header files for JavaScript reference library.
54
55%description devel -l pl.UTF-8
56Pliki nagłówkowe do biblioteki JavaScript.
57
58%prep
59%setup -q -n mozilla-esr38
60%patch0 -p1
61%patch1 -p1
62%patch2 -p1
013c854c 63%patch3 -p1
9b7b3ede
MB
64
65cd js/src
66
67# Correct sed expression for new sed
68sed -i 's|\^\[:space:\]|^\[\[:space:\]\]|g' configure
69
70%build
71export PYTHON="%{__python}"
72cd js/src
73%configure2_13 \
74 --enable-readline \
75 --enable-system-ffi \
76 --enable-threadsafe \
77 --enable-shared-js \
78 --enable-gcgenerational \
79 --with-system-nspr \
80 --with-system-icu \
81 --with-system-zlib \
82 --with-intl-api
83
84%{__make} \
85 HOST_OPTIMIZE_FLAGS= \
86 MODULE_OPTIMIZE_FLAGS= \
87 MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
88 MOZ_PGO_OPTIMIZE_FLAGS= \
89 MOZILLA_VERSION=%{version}
90
91%install
92rm -rf $RPM_BUILD_ROOT
93
94%{__make} -C js/src install \
95 DESTDIR=$RPM_BUILD_ROOT \
96 MOZILLA_VERSION=%{version}
97
98%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104%postun -p /sbin/ldconfig
105
106%files
107%defattr(644,root,root,755)
108%doc js/src/README.html
109%attr(755,root,root) %{_bindir}/js38
110%attr(755,root,root) %{_libdir}/libmozjs-38.so
111
112%files devel
113%defattr(644,root,root,755)
114%attr(755,root,root) %{_bindir}/js38-config
115%{_includedir}/mozjs-38
116%{_pkgconfigdir}/mozjs-38.pc
This page took 0.096356 seconds and 4 git commands to generate.