]> git.pld-linux.org Git - packages/mono-tools.git/blobdiff - mono-tools.spec
- release 2 (by relup.sh)
[packages/mono-tools.git] / mono-tools.spec
index 102003895c59f1cf3e1e45c14a0117883d248d2f..416f672078d4a3e5b96bb9bc8d165879ffd559ef 100644 (file)
@@ -1,37 +1,44 @@
 #
 # Conditional build:
-%bcond_without gecko           # don't build gecko html renderer
+%bcond_with    gecko           # gecko html renderer
 #
 %include       /usr/lib/rpm/macros.mono
 Summary:       Mono Tools
 Summary(pl.UTF-8):     Narzędzia do mono
 Name:          mono-tools
-Version:       2.8
+Version:       4.2
 Release:       2
 License:       GPL v2+
 Group:         Development/Tools
-# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
-Source0:       http://ftp.novell.com/pub/mono/sources/mono-tools/%{name}-%{version}.tar.bz2
-# Source0-md5: 81d17ee2584acdbc5cfee01adb905e50
+# also available on github
+#Source0:      https://github.com/mono/mono-tools/archive/%{version}/%{name}-%{version}.tar.gz
+Source0:       http://download.mono-project.com/sources/mono-tools/%{name}-%{version}.tar.gz
+# Source0-md5: d4b7c711ff8295173766c44973c6c10e
 Patch0:                %{name}-pwd.patch
+Patch1:                %{name}-configure.patch
 URL:           http://www.mono-project.com/
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: dotnet-gconf-sharp-devel >= 2.16.0
 %{?with_gecko:BuildRequires:   dotnet-gecko-sharp2-devel >= 0.12}
-BuildRequires: dotnet-gnome-desktop-sharp-devel
 BuildRequires: dotnet-gnome-sharp-devel >= 2.16.0
+# gtk-sharp-2.0, glade-sharp-2.0
 BuildRequires: dotnet-gtk-sharp2-devel
 BuildRequires: dotnet-webkit-sharp-devel >= 0.2-1
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
+BuildRequires: glib2-devel >= 2.0
 BuildRequires: libgdiplus
 BuildRequires: mono-compat-links
 BuildRequires: mono-csharp
-BuildRequires: mono-devel >= 2.8
-BuildRequires: mono-monodoc >= 2.8
+BuildRequires: mono-devel >= 2.10
+BuildRequires: mono-monodoc >= 3.2.5-2
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(monoautodeps)
 BuildRequires: sed >= 4.0
+Requires:      hicolor-icon-theme
+Requires:      mono >= 2.10
 Requires:      mono-tools-html-renderer
+Obsoletes:     mono-tools-gtkhtml
 ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -82,24 +89,11 @@ Mono.WebBrowser based monodoc HTML renderer.
 %description monowebbrowser -l pl.UTF-8
 Oparty na Mono.WebBrowser wyświetlacz HTML-a dla monodoc.
 
-%package gtkhtml
-Summary:       GtkHTML based monodoc HTML renderer
-Summary(pl.UTF-8):     Oparty na GtkHTML wyświetlacz HTML-a dla monodoc
-Group:         Development/Tools
-Requires:      %{name} = %{version}-%{release}
-Provides:      mono-tools-html-renderer
-
-%description gtkhtml
-GtkHTML based monodoc HTML renderer.
-
-%description gtkhtml -l pl.UTF-8
-Oparty na GtkHTML wyświetlacz HTML-a dla monodoc.
-
 %package gendarme
 Summary:       A tool to find problems in .NET applications and libraries
 Summary(pl.UTF-8):     Narzędzie znajdujące problemy w aplikacjach i bibliotekach .NET
 Group:         Development/Tools
-Requires:      monodoc >= 2.6
+Requires:      monodoc >= 2.10
 
 %description gendarme
 Gendarme is a extensible rule-based tool to find problems in .NET
@@ -159,14 +153,16 @@ zawartości.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 # as expected by ilcontrast script
 %{__sed} -i -e 's,\$(libdir)/ilcontrast,$(prefix)/lib/ilcontrast,' ilcontrast/Makefile.am
 
-# mono-2.8 path for gasnview.exe
+# mono-2.8+ path for gasnview.exe
 %{__sed} -i -e 's,mono/1.0,mono/2.0,' asn1view/gtk/Makefile.am
 
 %build
+%{__glib_gettextize}
 %{__aclocal}
 %{__autoconf}
 %{__automake}
@@ -178,14 +174,23 @@ rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       pkglibdir=%{_prefix}/lib/mono-tools \
-       pkgconfigdir=%{_pkgconfigdir}
+       pkgconfigdir=%{_pkgconfigdir} \
+       pkglibdir=%{_prefix}/lib/mono-tools
+
+# debug
+%{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/mono-tools/{Mono.Profiler.Widgets.dll,emveepee.exe}.mdb
 
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+%update_icon_cache hicolor
+
+%postun
+%update_icon_cache hicolor
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
@@ -193,14 +198,17 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/emveepee
 %attr(755,root,root) %{_bindir}/gasnview
 %attr(755,root,root) %{_bindir}/gsharp
+%attr(755,root,root) %{_bindir}/ilcontrast
 %attr(755,root,root) %{_bindir}/minvoke
 %attr(755,root,root) %{_bindir}/monodoc
 %attr(755,root,root) %{_bindir}/mperfmon
 %dir %{_prefix}/lib/gsharp
 %attr(755,root,root) %{_prefix}/lib/gsharp/gsharp.exe
 %{_prefix}/lib/gsharp/gsharp.exe.config
-#%%attr(755,root,root) %{_prefix}/lib/mono/1.0/gasnview.exe
+%attr(755,root,root) %{_prefix}/lib/mono/2.0/gasnview.exe
 %{_prefix}/lib/create-native-map
+%dir %{_prefix}/lib/ilcontrast
+%attr(755,root,root) %{_prefix}/lib/ilcontrast/ilcontrast.exe
 %dir %{_prefix}/lib/minvoke
 %attr(755,root,root) %{_prefix}/lib/minvoke/minvoke.exe
 %dir %{_prefix}/lib/mperfmon
@@ -212,8 +220,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_prefix}/lib/monodoc/browser.exe
 %{_prefix}/lib/monodoc/web
 %{_desktopdir}/gsharp.desktop
+%{_desktopdir}/ilcontrast.desktop
 %{_desktopdir}/monodoc.desktop
+%{_pixmapsdir}/ilcontrast.png
 %{_pixmapsdir}/monodoc.png
+%{_iconsdir}/hicolor/*x*/apps/monodoc.png
 %{_pkgconfigdir}/create-native-map.pc
 %{_mandir}/man1/create-native-map.1*
 %{_mandir}/man1/mperfmon.1*
@@ -236,12 +247,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_prefix}/lib/monodoc/MonoWebBrowserHtmlRender.dll
 
-%files gtkhtml
-%defattr(644,root,root,755)
-%{_prefix}/lib/monodoc/GtkHtmlHtmlRender.dll
-
 %files gendarme
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/gd2i
 %attr(755,root,root) %{_bindir}/gendarme
 %attr(755,root,root) %{_bindir}/gendarme-wizard
 %{_prefix}/lib/gendarme
@@ -250,6 +258,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/gendarme-wizard.desktop
 %{_pkgconfigdir}/gendarme-framework.pc
 %{_pixmapsdir}/gendarme.svg
+%{_mandir}/man1/gd2i.1*
 %{_mandir}/man1/gendarme.1*
 %{_mandir}/man5/gendarme.5*
 
This page took 0.135391 seconds and 4 git commands to generate.