]> git.pld-linux.org Git - packages/mono-debugger.git/commitdiff
- from scratch
authorMichal Moskal <michal@moskal.me>
Wed, 26 Feb 2003 21:30:44 +0000 (21:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    mono-debugger.spec -> 1.1

mono-debugger.spec [new file with mode: 0644]

diff --git a/mono-debugger.spec b/mono-debugger.spec
new file mode 100644 (file)
index 0000000..3798147
--- /dev/null
@@ -0,0 +1,62 @@
+%define _snap 20030226
+Summary:       Debugger for mono
+Summary(pl):   Odpluskiwacz dla mono
+Name:          mono-debugger
+Version:       0.2.1
+Release:       0.%{_snap}.0
+License:       GPL
+Group:         Development/Libraries
+Source0:       %{name}-cvs-%{_snap}.tar.bz2
+Patch0:                %{name}-recent-gtk-sharp.patch
+URL:           http://www.go-mono.com/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
+BuildRequires: gtk+2-devel
+BuildRequires: libgnome-devel
+BuildRequires: glib2-devel >= 2.0.0
+BuildRequires: mono-devel >= 0.20-2
+BuildRequires: mono-csharp
+BuildRequires: gtk-sharp-devel >= 0.8
+BuildRequires: readline-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Debugger for mono.
+
+%description -l pl
+Odpluskiwacz dla mono.
+
+%prep
+%setup -q -n debugger
+%patch0 -p0
+
+%build
+%{__libtoolize}
+%{__aclocal}
+%{__autoheader}
+%{__automake}
+%{__autoconf}
+%configure
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
+
+# make .so symlinks, they are dynamically loaded
+for f in $RPM_BUILD_ROOT/%{_libdir}/*.so.* ; do
+       b=$(basename $f)
+       ln -s $b $RPM_BUILD_ROOT%{_libdir}$(echo $b | sed -e 's/\.so.*/.so/')
+done
+
+%files
+%defattr(644,root,root,755)
+%doc NEWS README ChangeLog TODO AUTHORS doc/*.t*
+%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/mono-debugger-jit-wrapper
+%attr(755,root,root) %{_libdir}/*.so*
+%{_libdir}/*.dll
+
+%clean
+rm -rf $RPM_BUILD_ROOT
This page took 0.087527 seconds and 4 git commands to generate.