]> git.pld-linux.org Git - packages/mono-debugger.git/blobdiff - mono-debugger.spec
- cleanup
[packages/mono-debugger.git] / mono-debugger.spec
index cffe037edb7ebbd38d18dac5e7042a880160d575..a419e9de55f51413b5379dec5410b8e67a8c19e6 100644 (file)
@@ -2,26 +2,26 @@
 Summary:       Debugger for mono
 Summary(pl.UTF-8):     Odpluskiwacz dla mono
 Name:          mono-debugger
-Version:       0.50
+Version:       2.6.3
 Release:       1
-License:       GPL
+# mono-debugger itself on MIT, but BFD libs enforce GPL
+License:       GPL v2+
 Group:         Development/Tools
-#Source0Download: http://go-mono.com/sources-stable/
-Source0:       http://go-mono.com/sources/mono-debugger/%{name}-%{version}.tar.bz2
-# Source0-md5: 7f5b02c78c2a3e809f7deaf32e3849f2
-#Source0:      http://primates.ximian.com/~martin/debugger/%{name}-%{version}.tar.gz
+# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
+Source0:       http://ftp.novell.com/pub/mono/sources/mono-debugger/%{name}-%{version}.tar.bz2
+# Source0-md5: 8d36d7913d3e3670d8975617221019d5
 Patch0:                %{name}-termcap.patch
-URL:           http://www.go-mono.com/
+URL:           http://www.mono-project.com/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: glib2-devel >= 2.0.0
+BuildRequires: glib2-devel >= 1:2.0.0
 BuildRequires: libtool
-BuildRequires: mono-csharp >= 1.2.4
-BuildRequires: mono-jay
+BuildRequires: mono-csharp >= 2.0
 BuildRequires: monodoc
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
-Requires:      mono >= 1.2.4
+Requires:      mono >= 2.0
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -35,24 +35,14 @@ Summary:    Development files for mono debugger
 Summary(pl.UTF-8):     Pliki potrzebne programistom korzystającym z bibliotek odpluskiwacza mono
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Obsoletes:     mono-debugger-static
 
 %description devel
 Development files for mono debugger.
 
 %description devel -l pl.UTF-8
-Pliki potrzebne programistom korzystającym z bibliotek odpluskwiacza mono.
-
-%package static
-Summary:       Static mono debugger libraries
-Summary(pl.UTF-8):     Statyczne biblioteki odpluskiwacza mono
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description static
-Static mono debugger libraries.
-
-%description static -l pl.UTF-8
-Statyczne biblioteki odpluskwiacza mono.
+Pliki potrzebne programistom korzystającym z bibliotek odpluskwiacza
+mono.
 
 %package doc
 Summary:       Documentation for mono debugger
@@ -68,7 +58,6 @@ Dokumentacja odpluskwiacza dla mono.
 
 %prep
 %setup -q
-#%patch0 -p1
 %patch0 -p1
 
 %build
@@ -77,8 +66,9 @@ Dokumentacja odpluskwiacza dla mono.
 %{__autoheader}
 %{__automake}
 %{__autoconf}
-%configure
-%{__make}
+%configure \
+       --disable-static
+%{__make} -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -86,9 +76,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-#cp doc/debugger.source $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
-#cp doc/debugger.tree $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
-#cp doc/debugger.zip $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
+# these are used just as DllImport in C# code, so no devel part
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libmonodebugger*.la
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -98,23 +87,26 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc NEWS README ChangeLog TODO AUTHORS doc/*.t* RELEASE-NOTES-*
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_prefix}/lib/mono/1.0/mdb.exe
-%{_prefix}/lib/mono/gac/*
-%{_prefix}/lib/mono/%{name}
+%doc AUTHORS COPYING ChangeLog NEWS README doc/*.txt
+%attr(755,root,root) %{_bindir}/mdb
+%attr(755,root,root) %{_bindir}/mdb-symbolreader
+%attr(755,root,root) %{_libdir}/libmonodebuggerreadline.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libmonodebuggerreadline.so.0
+%attr(755,root,root) %{_libdir}/libmonodebuggerreadline.so
+%attr(755,root,root) %{_libdir}/libmonodebuggerserver.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libmonodebuggerserver.so.0
+%attr(755,root,root) %{_libdir}/libmonodebuggerserver.so
+%{_prefix}/lib/mono/2.0/mdb-symbolreader.exe
+%{_prefix}/lib/mono/2.0/mdb.exe
+%{_prefix}/lib/mono/gac/Mono.Debugger
+%{_prefix}/lib/mono/gac/Mono.Debugger.SymbolWriter
+%{_prefix}/lib/mono/gac/Mono.Debugger.Frontend
 
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/lib*.la
-%{_pkgconfigdir}/*.pc
-
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/lib*.a
-
-#%files doc
-#%defattr(644,root,root,755)
-#%{_libdir}/monodoc/sources/*
+%dir %{_prefix}/lib/mono/%{name}
+%{_prefix}/lib/mono/%{name}/Mono.Debugger.dll
+%{_prefix}/lib/mono/%{name}/Mono.Debugger.SymbolWriter.dll
+%{_prefix}/lib/mono/%{name}/Mono.Debugger.Frontend.dll
+%{_pkgconfigdir}/mono-debugger.pc
+%{_pkgconfigdir}/mono-debugger-frontend.pc
This page took 0.100026 seconds and 4 git commands to generate.