]> git.pld-linux.org Git - packages/monitoring-plugin-check_file_exists.git/commitdiff
keep the source here
authorElan Ruusamäe <glen@delfi.ee>
Mon, 1 Feb 2016 08:42:16 +0000 (10:42 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 1 Feb 2016 08:42:27 +0000 (10:42 +0200)
very trivial file and creating patches for changes creates more noise
than it's worth

check_file_exists.sh [new file with mode: 0755]
monitoring-plugin-check_file_exists.spec

diff --git a/check_file_exists.sh b/check_file_exists.sh
new file mode 100755 (executable)
index 0000000..bc91daf
--- /dev/null
@@ -0,0 +1,27 @@
+#! /bin/bash
+#
+# Author : Diego Martin Gardella [dgardella@gmail.com]
+# Desc : Plugin to verify if a file exists
+#
+#
+
+PROGNAME=`basename $0`
+PROGPATH=`echo $0 | sed -e 's,[\\/][^\\/][^\\/]*$,,'`
+
+. $PROGPATH/utils.sh
+
+if [ "$1" = "" ]
+then
+       echo -e " Use : $PROGNAME <file_name> -- Ex : $PROGNAME /etc/hosts \n "
+       exit $STATE_UNKNOWN
+fi
+
+
+if [ -f $1 ]
+then
+       echo "OK - $1 : EXISTS :: `head -3 $1`" # shows the first three lines of the file
+       exit $STATE_OK
+else
+       echo "CRITICAL : $1 Does NOT exists "
+       exit $STATE_CRITICAL
+fi
index 4c1ce14bf0fa3f8235ad6c6cfae2d807abe1250e..d0ac04d19b78ab173b839736939638ebb24a6545 100644 (file)
@@ -5,8 +5,7 @@ Version:        1.0
 Release:       1
 License:       GPL
 Group:         Networking
-Source0:       https://exchange.nagios.org/components/com_mtree/attachment.php?link_id=2330&cf_id=24&/%{plugin}.sh
-# Source0-md5: 388097c05f6e58f4eeaca2cdf132331e
+Source0:       %{plugin}.sh
 Source1:       %{plugin}.cfg
 URL:           https://exchange.nagios.org/directory/Plugins/System-Metrics/File-System/check_file_exists/details
 BuildRequires: rpmbuild(macros) >= 1.654
This page took 0.104902 seconds and 4 git commands to generate.