]> git.pld-linux.org Git - packages/mongodb.git/commitdiff
Better default config file provided
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Fri, 2 Nov 2012 12:36:02 +0000 (13:36 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Fri, 2 Nov 2012 12:38:26 +0000 (13:38 +0100)
The config file from the 'rpm' source directory seems outdated and it
contains 'fork' directive which may be harmfull when the service is
started by something else than LSB init script.

Init script updated to match the configuration file.

mongod-default.conf [new file with mode: 0644]
mongodb.init
mongodb.spec

diff --git a/mongod-default.conf b/mongod-default.conf
new file mode 100644 (file)
index 0000000..683c8d8
--- /dev/null
@@ -0,0 +1,86 @@
+# mongod/default.conf
+
+# Where to store the data.
+# each instance should use a separate directory
+dbpath=/var/lib/mongodb
+
+#where to log
+# each instance should use different path
+logpath=/var/log/mongodb/mongodb.log
+
+logappend=true
+
+# port to bind to. should be differen for each instance
+#port = 27017
+
+# Disables write-ahead journaling
+# nojournal = true
+
+# Enables periodic logging of CPU utilization and I/O wait
+#cpu = true
+
+# Turn on/off security.  Off is currently the default
+#noauth = true
+#auth = true
+
+# Verbose logging output.
+#verbose = true
+
+# Inspect all client data for validity on receipt (useful for
+# developing drivers)
+#objcheck = true
+
+# Enable db quota management
+#quota = true
+
+# Set oplogging level where n is
+#   0=off (default)
+#   1=W
+#   2=R
+#   3=both
+#   7=W+some reads
+#diaglog = 0
+
+# Ignore query hints
+#nohints = true
+
+# Disable the HTTP interface (Defaults to localhost:28017).
+#nohttpinterface = true
+
+# Turns off server-side scripting.  This will result in greatly limited
+# functionality
+#noscripting = true
+
+# Turns off table scans.  Any query that would do a table scan fails.
+#notablescan = true
+
+# Disable data file preallocation.
+#noprealloc = true
+
+# Specify .ns file size for new databases.
+# nssize = <size>
+
+# Accout token for Mongo monitoring server.
+#mms-token = <token>
+
+# Server name for Mongo monitoring server.
+#mms-name = <server-name>
+
+# Ping interval for Mongo monitoring server.
+#mms-interval = <seconds>
+
+# Replication Options
+
+# in replica set configuration, specify the name of the replica set
+# replSet = setname 
+
+# in master/slave replicated mongo databases (obsolete), specify here whether
+# this is a slave or master
+#slave = true
+#source = master.example.com
+# Slave only: specify a single database to replicate
+#only = master.example.com
+# or
+#master = true
+#source = slave.example.com
+
index f9b8d5393346fc6addb0ab7d4490aeaeb97b43e8..99a4d7002059e5f625da797907292a7a50bc6468 100644 (file)
@@ -64,7 +64,7 @@ start() {
                        pidfile="${MONGOD_PIDFILE%.pid}-$instance.log"
                fi
                daemon --pidfile "$pidfile" --user $MONGOD_USER \
-                       $MONGOD_BIN --config "$config" run
+                       $MONGOD_BIN --config "$config" --fork
                [ $? -eq 0 ] && started=$(($started + 1))
        done
        # at least one started - the service is running
index d5cf278f19064d47272fd2a161a2020445b954c3..2acb4cdd8b9b78874d65d829bcf334d0b2563c32 100644 (file)
@@ -12,6 +12,7 @@ Source0:      http://downloads.mongodb.org/src/%{name}-src-r%{version}.tar.gz
 # Source0-md5: 832bdb6cc659176fd8d6b16a660ccfc6
 Source1:       %{name}.logrotate
 Source2:       %{name}.init
+Source3:       mongod-default.conf
 Patch0:                %{name}-cflags.patch
 Patch1:                %{name}-system-libs.patch
 Patch2:                boost-1.50.patch
@@ -176,7 +177,7 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1} \
 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/mongod
 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mongod
 cp -p rpm/mongod.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/mongod
-cp -p rpm/mongod.conf $RPM_BUILD_ROOT%{_sysconfdir}/mongod/default.conf
+install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/mongod/default.conf
 cp -p debian/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 touch $RPM_BUILD_ROOT%{_var}/log/mongo/mongod.log
This page took 0.047999 seconds and 4 git commands to generate.