]> git.pld-linux.org Git - packages/mongodb.git/commitdiff
- fix building with boost 1.73 auto/th/mongodb-2.2.4-12
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 9 Aug 2020 16:22:47 +0000 (18:22 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 9 Aug 2020 16:22:47 +0000 (18:22 +0200)
- rel 12

boost-1.73.patch [new file with mode: 0644]
mongodb.spec

diff --git a/boost-1.73.patch b/boost-1.73.patch
new file mode 100644 (file)
index 0000000..fdec8cd
--- /dev/null
@@ -0,0 +1,25 @@
+--- mongodb-src-r2.2.4/src/mongo/util/goodies.h.orig   2013-04-01 04:41:49.000000000 +0200
++++ mongodb-src-r2.2.4/src/mongo/util/goodies.h        2020-08-09 18:15:59.585368115 +0200
+@@ -18,7 +18,7 @@
+ #pragma once
+-#include <boost/detail/endian.hpp>
++#include <boost/predef/other/endian.h>
+ #include <boost/thread/condition_variable.hpp>
+ #include "mongo/bson/util/misc.h"
+@@ -99,11 +99,11 @@
+             ((x & 0xff000000) >> 24);
+     }
+-#if defined(BOOST_LITTLE_ENDIAN)
++#if BOOST_ENDIAN_LITTLE_BYTE
+     inline unsigned long fixEndian(unsigned long x) {
+         return x;
+     }
+-#elif defined(BOOST_BIG_ENDIAN)
++#elif BOOST_ENDIAN_BIG_BYTE
+     inline unsigned long fixEndian(unsigned long x) {
+         return swapEndian(x);
+     }
index 03de8ad44e4447392f5d245e48759760ad6825ab..8c2374c227879fce8132be01b3d32f82dad54cbc 100644 (file)
@@ -8,7 +8,7 @@ Summary:        MongoDB client shell and tools
 Summary(pl.UTF-8):     Powłoka kliencka i narzędzia dla bazy danych MongoDB
 Name:          mongodb
 Version:       2.2.4
-Release:       11
+Release:       12
 License:       AGPL v3
 Group:         Applications/Databases
 Source0:       http://downloads.mongodb.org/src/%{name}-src-r%{version}.tar.gz
@@ -26,6 +26,7 @@ Patch5:               gcc4.patch
 Patch6:                no-Werror.patch
 Patch7:                gcc6.patch
 Patch8:                %{name}-pcap.patch
+Patch9:                boost-1.73.patch
 URL:           http://www.mongodb.org/
 BuildRequires: boost-devel >= 1.50
 BuildRequires: libpcap-devel
@@ -158,6 +159,7 @@ konfiguracji oraz skrypty init.d.
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 # Fix permissions
 find -type f -executable | xargs chmod a-x
This page took 0.052772 seconds and 4 git commands to generate.