]> git.pld-linux.org Git - packages/mongodb.git/commitdiff
One more boost 1.50 problem fixed auto/th/mongodb-2.0.6-2
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 11 Jul 2012 14:32:18 +0000 (16:32 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 11 Jul 2012 14:32:18 +0000 (16:32 +0200)
Release 2

boost-1.50.patch
mongodb.spec

index 0b9192caa2fe453a5f842a7d498fa23f41dad858..7ad61aee474580953b72730e9be6c0c033c4cd23 100644 (file)
@@ -115,6 +115,15 @@ diff -ur mongodb-src-r2.0.6.orig/util/time_support.h mongodb-src-r2.0.6/util/tim
 diff -ur mongodb-src-r2.0.6.orig/db/db.cpp mongodb-src-r2.0.6/db/db.cpp
 --- mongodb-src-r2.0.6.orig/db/db.cpp  2012-06-04 15:42:54.000000000 +0200
 +++ mongodb-src-r2.0.6/db/db.cpp       2012-07-11 14:39:15.945377899 +0200
+@@ -326,7 +326,7 @@
+         boost::filesystem::path path( dbpath );
+         for ( boost::filesystem::directory_iterator i( path );
+                 i != boost::filesystem::directory_iterator(); ++i ) {
+-            string fileName = boost::filesystem::path(*i).leaf();
++            string fileName = boost::filesystem::path(*i).filename().string();
+             if ( boost::filesystem::is_directory( *i ) &&
+                     fileName.length() && fileName[ 0 ] == '$' )
+                 boost::filesystem::remove_all( *i );
 @@ -655,11 +655,13 @@
      dbExecCommand = argv[0];
  
index a0c32f995e8643cde5718efb58eeb746c43835fd..1b6324ce88f81aa307fb4387e243cb83ea70fb85 100644 (file)
@@ -3,7 +3,7 @@ Summary:        MongoDB client shell and tools
 Summary(pl.UTF-8):     Powłoka kliencka i narzędzia dla bazy danych MongoDB
 Name:          mongodb
 Version:       2.0.6
-Release:       1
+Release:       2
 License:       AGPL v3
 Group:         Applications/Databases
 Source0:       http://downloads.mongodb.org/src/%{name}-src-r%{version}.tar.gz
This page took 0.0438460000000001 seconds and 4 git commands to generate.