]> git.pld-linux.org Git - packages/mongodb.git/commitdiff
- added pcap patch (fix build errors caused by some libpcap #defines); release 10 auto/th/mongodb-2.2.4-10
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 28 Apr 2019 19:11:15 +0000 (21:11 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 28 Apr 2019 19:11:15 +0000 (21:11 +0200)
mongodb-pcap.patch [new file with mode: 0644]
mongodb.spec

diff --git a/mongodb-pcap.patch b/mongodb-pcap.patch
new file mode 100644 (file)
index 0000000..146f2b3
--- /dev/null
@@ -0,0 +1,35 @@
+#--- mongodb-src-r2.2.4/src/mongo/util/net/sock.h.orig 2013-04-01 04:41:49.000000000 +0200
+#+++ mongodb-src-r2.2.4/src/mongo/util/net/sock.h      2019-04-28 20:26:20.537526400 +0200
+#@@ -59,8 +59,6 @@
+# #else // _WIN32
+# 
+#     inline void closesocket(int s) { close(s); }
+#-    const int INVALID_SOCKET = -1;
+#-    typedef int SOCKET;
+# 
+# #endif // _WIN32
+# 
+#--- mongodb-src-r2.2.4/src/mongo/util/net/sock.cpp.orig       2013-04-01 04:41:49.000000000 +0200
+#+++ mongodb-src-r2.2.4/src/mongo/util/net/sock.cpp    2019-04-28 20:26:36.338355487 +0200
+#@@ -578,7 +578,7 @@
+#         _remote = remote;
+# 
+#         _fd = socket(remote.getType(), SOCK_STREAM, 0);
+#-        if ( _fd == INVALID_SOCKET ) {
+#+        if ( _fd == -1 ) {
+#             LOG(_logLevel) << "ERROR: connect invalid socket " << errnoWithDescription() << endl;
+#             return false;
+#         }
+--- mongodb-src-r2.2.4/src/mongo/util/net/sock.h.orig  2019-04-28 20:27:19.950643872 +0200
++++ mongodb-src-r2.2.4/src/mongo/util/net/sock.h       2019-04-28 20:36:33.543024811 +0200
+@@ -39,6 +39,10 @@
+ #include <openssl/ssl.h>
+ #endif
++// in case it's defined in some (e.g. pcap) headers
++#undef SOCKET
++#undef INVALID_SOCKET
++
+ namespace mongo {
+     const int SOCK_FAMILY_UNKNOWN_ERROR=13078;
index a383d92050767efbb07a5040a648cfd0e4f9d557..8deb20bb2c630a627e592246dee32b081fb483b8 100644 (file)
@@ -8,7 +8,7 @@ Summary:        MongoDB client shell and tools
 Summary(pl.UTF-8):     Powłoka kliencka i narzędzia dla bazy danych MongoDB
 Name:          mongodb
 Version:       2.2.4
-Release:       9
+Release:       10
 License:       AGPL v3
 Group:         Applications/Databases
 Source0:       http://downloads.mongodb.org/src/%{name}-src-r%{version}.tar.gz
@@ -25,6 +25,7 @@ Patch4:               %{name}-shared.patch
 Patch5:                gcc4.patch
 Patch6:                no-Werror.patch
 Patch7:                gcc6.patch
+Patch8:                %{name}-pcap.patch
 URL:           http://www.mongodb.org/
 BuildRequires: boost-devel >= 1.50
 BuildRequires: libpcap-devel
@@ -156,6 +157,7 @@ konfiguracji oraz skrypty init.d.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 # Fix permissions
 find -type f -executable | xargs chmod a-x
This page took 0.114216 seconds and 4 git commands to generate.