]> git.pld-linux.org Git - packages/mongodb.git/blobdiff - mongodb.spec
- rebuild with boost 1.57.0
[packages/mongodb.git] / mongodb.spec
index 1ad540be0fc42165f63b0f0de04c83adc382ec98..7355ed636f8d43c9b7fb7794435fdd173c6036e5 100644 (file)
@@ -1,34 +1,41 @@
 # TODO:
-#      - fix 'libs' subpackage (disabled due to broken 'sharedclient' build option)
+#      - add support for sharding server (init scripts, systemd units, sample config)
 #
 Summary:       MongoDB client shell and tools
 Summary(pl.UTF-8):     Powłoka kliencka i narzędzia dla bazy danych MongoDB
 Name:          mongodb
-Version:       2.2.0
-Release:       0.1
+Version:       2.2.4
+Release:       4
 License:       AGPL v3
 Group:         Applications/Databases
 Source0:       http://downloads.mongodb.org/src/%{name}-src-r%{version}.tar.gz
-# Source0-md5: 832bdb6cc659176fd8d6b16a660ccfc6
+# Source0-md5: 033354c543c053f5d539b573ac8c28b0
 Source1:       %{name}.logrotate
 Source2:       %{name}.init
+Source3:       mongod-default.conf
+Source4:       mongod@.service
 Patch0:                %{name}-cflags.patch
 Patch1:                %{name}-system-libs.patch
 Patch2:                boost-1.50.patch
 Patch3:                %{name}-install.patch
+Patch4:                %{name}-shared.patch
+Patch5:                gcc4.patch
 URL:           http://www.mongodb.org/
 BuildRequires: boost-devel >= 1.50
 BuildRequires: libpcap-devel
 BuildRequires: libstdc++-devel >= 6:4.0
+%ifarch %{x8664}
+BuildRequires: libtcmalloc-devel
+%endif
 BuildRequires: pcre-cxx-devel
 BuildRequires: pcre-devel >= 8.30
 BuildRequires: readline-devel
-BuildRequires: rpmbuild(macros) >= 1.228
+BuildRequires: rpmbuild(macros) >= 1.644
 BuildRequires: scons >= 1.2
 BuildRequires: sed >= 4.0
 BuildRequires: snappy-devel
 BuildRequires: v8-devel
-#Requires:     %{name}-libs = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -69,8 +76,7 @@ Ten pakiet zawiera bibliotekę kliencką mongo.
 Summary:       Header files for MongoDB client library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki klienckiej MongoDB
 Group:         Development/Libraries
-#Requires:     %{name}-libs = %{version}-%{release}
-Requires:      %{name}-static = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description devel
 Mongo (from "huMONGOus") is a schema-free document-oriented database.
@@ -89,7 +95,7 @@ oprogramowania klienckiego dla MongoDB.
 Summary:       Static MongoDB client library
 Summary(pl.UTF-8):     Statyczna biblioteka kliencka MongoDB
 Group:         Development/Libraries
-#Requires:     %{name}-libs = %{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Mongo (from "huMONGOus") is a schema-free document-oriented database.
@@ -107,6 +113,7 @@ Summary:    MongoDB server, sharding server, and support scripts
 Summary(pl.UTF-8):     Serwer MongoDB, serwer dzielący oraz skrypty pomocnicze
 Group:         Applications/Databases
 Requires:      %{name} = %{version}-%{release}
+Requires:      systemd-units >= 38
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
@@ -138,6 +145,8 @@ konfiguracji oraz skrypty init.d.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 # Fix permissions
 find -type f -executable | xargs chmod a-x
@@ -152,6 +161,7 @@ find -type f -executable | xargs chmod a-x
        --extralib=pcrecpp,pcre,snappy \
        --prefix=$RPM_BUILD_ROOT%{_prefix} \
        --full=all \
+       --sharedclient \
        --usev8 \
        --cxx=%{__cxx}
 
@@ -159,30 +169,42 @@ find -type f -executable | xargs chmod a-x
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1} \
        $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,mongod} \
-       $RPM_BUILD_ROOT%{_var}/{lib,log{,/archive}}/mongo
+       $RPM_BUILD_ROOT%{_var}/{lib,log{,/archive}}/mongodb \
+       $RPM_BUILD_ROOT%{systemdunitdir}
 
 # XXX: scons is so great, recompiles everything here!
 %scons install \
+       CPPFLAGS="%{rpmcppflags} -DXP_UNIX" \
        --use-system-all=yes \
        --extralib=pcrecpp,pcre,snappy \
        --prefix=$RPM_BUILD_ROOT%{_prefix} \
        --full=all \
+       --sharedclient \
        --usev8 \
        --cxx=%{__cxx}
 
 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/mongod
 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mongod
 cp -p rpm/mongod.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/mongod
-cp -p rpm/mongod.conf $RPM_BUILD_ROOT%{_sysconfdir}/mongod/default.conf
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/mongod/default.conf
 cp -p debian/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
-touch $RPM_BUILD_ROOT%{_var}/log/mongo/mongod.log
+# mask out the LSB service
+ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/mongod.service
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/mongod@.service
+
+touch $RPM_BUILD_ROOT%{_var}/log/mongodb/mongod.log
 
 # for some reason these are installed twice, remove unwanted copies
-for f in $RPM_BUILD_ROOT%{_includedir}/mongo/* ; do
-       rm -r "$RPM_BUILD_ROOT%{_includedir}/$(basename $f)"
+for f in $RPM_BUILD_ROOT%{_includedir}/mongo/*; do
+       rm -r "$RPM_BUILD_ROOT%{_includedir}/$(basename $f)" || :
 done
 
+%ifarch %{x8664}
+chmod -R a+rX $RPM_BUILD_ROOT/usr/lib
+%{__rm} -r $RPM_BUILD_ROOT/usr/lib
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -191,16 +213,28 @@ rm -rf $RPM_BUILD_ROOT
 
 %pre server
 %groupadd -g 258 -r mongod
-%useradd -u 258 -r -g mongod -d %{_var}/lib/mongo -s /bin/false -c "MongoDB Database Server" mongod
+%useradd -u 258 -r -g mongod -d %{_var}/lib/mongodb -s /bin/false -c "MongoDB Database Server" mongod
 
 %post server
 /sbin/chkconfig --add mongod
 %service mongod restart
+# our systemd macros cannot handle template (multi-instance) units yet
+export SYSTEMD_LOG_LEVEL=warning SYSTEMD_LOG_TARGET=syslog
+/bin/systemd_booted && /bin/systemctl --quiet daemon-reload || :
+if [ $1 -eq 1 ]; then
+       /bin/systemctl --quiet enable mongod@.service || : 
+       /bin/systemd_booted && echo 'Run "/bin/systemctl start mongod@default.service" to start mongod.' || :
+else
+       /bin/systemd_booted && /bin/systemctl --quiet try-restart mongod@default.service || :
+fi
 
 %preun server
 if [ "$1" = "0" ]; then
        %service -q mongod stop
        /sbin/chkconfig --del mongod
+       export SYSTEMD_LOG_LEVEL=warning SYSTEMD_LOG_TARGET=syslog
+       /bin/systemd_booted && /bin/systemctl --quiet stop mongod@default.service || :
+       /bin/systemctl --quiet disable mongod@.service || :
 fi
 
 %postun server
@@ -208,6 +242,7 @@ if [ "$1" = "0" ]; then
        %userremove mongod
        %groupremove mongod
 fi
+%systemd_reload
 
 %triggerpostun server -- %{name}-server < 2.0.6-3
 if [ -f %{_sysconfdir}/mongod.conf.rpmsave ] ; then
@@ -242,11 +277,9 @@ fi
 %{_mandir}/man1/mongostat.1*
 %{_mandir}/man1/mongorestore.1*
 
-%if 0
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libmongoclient.so
-%endif
 
 %files devel
 %defattr(644,root,root,755)
@@ -258,17 +291,18 @@ fi
 
 %files server
 %defattr(644,root,root,755)
-#%dir %{_sysconfdir}
 %dir %{_sysconfdir}/mongod
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mongod/default.conf
 %attr(754,root,root) /etc/rc.d/init.d/mongod
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mongod
 %config(noreplace) /etc/logrotate.d/mongod
+%{systemdunitdir}/mongod.service
+%{systemdunitdir}/mongod@.service
 %attr(755,root,root) %{_bindir}/mongod
 %attr(755,root,root) %{_bindir}/mongos
 %{_mandir}/man1/mongod.1*
 %{_mandir}/man1/mongos.1*
-%attr(755,mongod,mongod) %dir %{_var}/lib/mongo
-%attr(775,root,mongod) %dir %{_var}/log/mongo
-%attr(775,root,mongod) %dir %{_var}/log/archive/mongo
-%attr(640,mongod,mongod) %config(noreplace) %verify(not md5 mtime size) %{_var}/log/mongo/mongod.log
+%attr(755,mongod,mongod) %dir %{_var}/lib/mongodb
+%attr(775,root,mongod) %dir %{_var}/log/mongodb
+%attr(775,root,mongod) %dir %{_var}/log/archive/mongodb
+%attr(640,mongod,mongod) %config(noreplace) %verify(not md5 mtime size) %{_var}/log/mongodb/mongod.log
This page took 0.124713 seconds and 4 git commands to generate.