]> git.pld-linux.org Git - packages/mongo-c-driver.git/commitdiff
- updated to 1.16.2 auto/th/mongo-c-driver-1.16.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 3 May 2020 14:40:24 +0000 (16:40 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 3 May 2020 14:40:24 +0000 (16:40 +0200)
- added sphinx patch (disable parallel sphinx-build to avoid incompatibility warning treated as error)

mongo-c-driver-sphinx.patch [new file with mode: 0644]
mongo-c-driver.spec

diff --git a/mongo-c-driver-sphinx.patch b/mongo-c-driver-sphinx.patch
new file mode 100644 (file)
index 0000000..c2f664b
--- /dev/null
@@ -0,0 +1,21 @@
+Some extensions don't like parallel sphinx-build
+--- mongo-c-driver-1.16.2/build/cmake/SphinxBuild.cmake.orig   2020-02-25 06:38:41.000000000 +0100
++++ mongo-c-driver-1.16.2/build/cmake/SphinxBuild.cmake        2020-05-03 16:05:03.406177913 +0200
+@@ -40,7 +40,7 @@
+       ${CMAKE_COMMAND} -E env
+       "PYTHONDONTWRITEBYTECODE=1"
+       ${SPHINX_EXECUTABLE}
+-         -j ${NPROCS} -qEW -b html
++         -qEW -b html
+          -c "${CMAKE_CURRENT_SOURCE_DIR}"
+          "${CMAKE_CURRENT_SOURCE_DIR}"
+          "${SPHINX_HTML_DIR}"
+@@ -133,7 +133,7 @@
+       ${CMAKE_COMMAND} -E env
+       "PYTHONDONTWRITEBYTECODE=1"
+       ${SPHINX_EXECUTABLE}
+-         -j ${NPROCS} -qEW -b man
++         -qEW -b man
+          -c "${CMAKE_CURRENT_SOURCE_DIR}"
+          "${CMAKE_CURRENT_SOURCE_DIR}"
+          "${SPHINX_MAN_DIR}"
index 48aa82e5ef59e86976c5c89687d49f9368d081e1..3c9b987db78c9938cbfdfc6b53130465b8253480 100644 (file)
 Summary:       Client library written in C for MongoDB
 Summary(pl.UTF-8):     Biblioteka kliencka do MongoDB napisana w C
 Name:          mongo-c-driver
-Version:       1.16.1
+Version:       1.16.2
 Release:       1
 License:       Apache v2.0
 Group:         Libraries
 #Source0Download: https://github.com/mongodb/mongo-c-driver/releases/
 Source0:       https://github.com/mongodb/mongo-c-driver/releases/download/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 21c10593f80599e34aaa6c1ff6d4a681
+# Source0-md5: 6561011b25d0e690d0759247bcd390e4
+Patch0:                %{name}-sphinx.patch
 URL:           https://github.com/mongodb/mongo-c-driver
 BuildRequires: cmake >= 3.1
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel}
 BuildRequires: libicu-devel
 %{?with_ssl:BuildRequires:     openssl-devel}
-BuildRequires: perl-base
 BuildRequires: pkgconfig
+BuildRequires: python
 BuildRequires: snappy-devel
 %{?with_doc:BuildRequires:     sphinx-pdg}
-BuildRequires: zlib-devel
+BuildRequires: zlib-devel >= 1.2.11
+BuildRequires: zstd-devel
 %if %{with tests}
 BuildRequires: mongodb-server
 BuildRequires: openssl
@@ -51,6 +53,7 @@ Summary:      Shared library for mongo-c-driver
 Summary(pl.UTF-8):     Biblioteka współdzielona mongo-c-driver
 Group:         Libraries
 Requires:      libbson = %{version}-%{release}
+Requires:      zlib >= 1.2.11
 
 %description libs
 This package contains the shared library for mongo-c-driver.
@@ -127,6 +130,7 @@ Dokumentacja API biblioteki libbson.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 install -d cmake-build
@@ -144,7 +148,7 @@ cd cmake-build
        -DENABLE_TESTS=%{!?with_tests:OFF}%{?with_tests:ON} \
        -DENABLE_ZLIB=SYSTEM
 
-%{__make}
+%{__make} -j1
 
 %if %{with tests}
 : Run a server
This page took 0.159392 seconds and 4 git commands to generate.