]> git.pld-linux.org Git - packages/microcode-data-intel.git/blobdiff - microcode-data-intel.spec
use https url
[packages/microcode-data-intel.git] / microcode-data-intel.spec
index cec10eb1467ddc60bc2cfb1a74f44a17f220bf62..fb4c66033dbca3687a35b2cc18e485325860aab9 100644 (file)
@@ -1,22 +1,19 @@
-# TODO
-# - do not package intel-microcode2ucode and make package noarch, tool doesn't seem to be used runtime
 Summary:       Microcode definitions for Intel processors
 Summary(pl.UTF-8):     Definicje mikrokodu dla procesorów Intela
 Name:          microcode-data-intel
-Version:       20170707
-Release:       2
+Version:       20180108
+Release:       1
 License:       INTEL SOFTWARE LICENSE AGREEMENT
 Group:         Base
 # http://downloadcenter.intel.com/, enter "processor microcode data file" to the search
-Source0:       http://downloadmirror.intel.com/26925/eng/microcode-%{version}.tgz
-# Source0-md5: fe4bcb12e4600629a81fb65208c34248
+Source0:       https://downloadmirror.intel.com/27431/eng/microcode-%{version}.tgz
+# Source0-md5: 871df55f0ab010ee384dabfc424f2c12
 # Tool for splitting Intel's microcode file. From Fedora
 Source1:       intel-microcode2ucode.c
 # Produces single file for use by boot loader (like grub)
 Source2:       intel-microcode2ucode-single.c
-BuildRequires: cpio
 Provides:      microcode-data
-ExclusiveArch: i686 pentium2 pentium3 pentium4 %{x8664} x32
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -39,40 +36,38 @@ Intel microcode for initrd.
 Mikrokod dla procesorów Intel dla initrd.
 
 %prep
-%setup -q -c
+%setup -qc
 
 %build
 if ! grep -q 0x00000000 microcode.dat; then
-       echo >&2 microcode.dat contains giberrish
+       echo >&2 "microcode.dat contains giberrish"
        exit 1
 fi
 
 %{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode %{SOURCE1}
 %{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode-single %{SOURCE2}
-./intel-microcode2ucode microcode.dat > /dev/null || exit 1
-./intel-microcode2ucode-single microcode.dat > /dev/null || exit 1
+
+./intel-microcode2ucode microcode.dat > 1.log
+./intel-microcode2ucode-single microcode.dat > 2.log
+
+install -d kernel/x86/microcode
+ln microcode.bin kernel/x86/microcode/GenuineIntel.bin
+echo kernel/x86/microcode/GenuineIntel.bin | cpio -o -H newc -R 0:0 > intel-ucode.img
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sbindir},/lib/firmware,/boot}
+install -d $RPM_BUILD_ROOT{/lib/firmware,/boot}
 
-cp -p intel-microcode2ucode $RPM_BUILD_ROOT%{_sbindir}
-mv intel-ucode $RPM_BUILD_ROOT/lib/firmware
-
-cp -p intel-microcode2ucode-single $RPM_BUILD_ROOT%{_sbindir}
-install -d kernel/x86/microcode
-mv microcode.bin kernel/x86/microcode/GenuineIntel.bin
-echo kernel/x86/microcode/GenuineIntel.bin | cpio -o -H newc -R 0:0 > $RPM_BUILD_ROOT/boot/intel-ucode.img
+cp -a intel-ucode $RPM_BUILD_ROOT/lib/firmware
+cp -p intel-ucode.img $RPM_BUILD_ROOT/boot
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_sbindir}/intel-microcode2ucode
 /lib/firmware/intel-ucode
 
 %files initrd
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_sbindir}/intel-microcode2ucode-single
 /boot/intel-ucode.img
This page took 0.556793 seconds and 4 git commands to generate.