]> git.pld-linux.org Git - packages/mediastreamer.git/commitdiff
- added bounds patch to fix possible out of bounds strcmp warning
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 18 Jul 2021 08:20:13 +0000 (10:20 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 18 Jul 2021 08:20:13 +0000 (10:20 +0200)
- added gcc patch to fix missing include

mediastreamer-bounds.patch [new file with mode: 0644]
mediastreamer-gcc.patch [new file with mode: 0644]
mediastreamer.spec

diff --git a/mediastreamer-bounds.patch b/mediastreamer-bounds.patch
new file mode 100644 (file)
index 0000000..0bbe15b
--- /dev/null
@@ -0,0 +1,11 @@
+--- mediastreamer2-4.5.22/src/audiofilters/pulseaudio.c.orig   2021-06-24 23:55:04.000000000 +0200
++++ mediastreamer2-4.5.22/src/audiofilters/pulseaudio.c        2021-07-18 10:10:08.244595475 +0200
+@@ -229,7 +229,7 @@
+  * output: sink and bidirectionnal cards into sink list, source only card into source list
+  * merging is based on pulse audio card description */
+ int pulse_card_compare(pa_device_t *sink, pa_device_t *source) {
+-      return strncmp(sink->description, source->description, 512);
++      return strncmp(sink->description, source->description, PA_STRING_SIZE);
+ }
+ static void pulse_card_merge_lists(pa_device_t *pa_device, bctbx_list_t **pa_source_list) {
diff --git a/mediastreamer-gcc.patch b/mediastreamer-gcc.patch
new file mode 100644 (file)
index 0000000..e1d4850
--- /dev/null
@@ -0,0 +1,10 @@
+--- mediastreamer2-4.5.22/src/utils/mkv_reader.cpp.orig        2021-06-24 23:55:04.000000000 +0200
++++ mediastreamer2-4.5.22/src/utils/mkv_reader.cpp     2021-07-18 09:55:27.905014183 +0200
+@@ -20,6 +20,7 @@
+ #include <algorithm>
+ #include <array>
+ #include <cwchar>
++#include <limits>
+ #include <list>
+ #include <memory>
+ #include <vector>
index 7827c133b6c8d35cef68cb62629673f95f8af201..481ef5943133dbf3794055c6eddb362631cc2d15 100644 (file)
@@ -41,6 +41,8 @@ Patch5:               %{name}-cmake-SDL.patch
 Patch6:                %{name}-types.patch
 Patch7:                %{name}-gsm.patch
 Patch8:                %{name}-cmake-upnp.patch
+Patch9:                %{name}-bounds.patch
+Patch10:       %{name}-gcc.patch
 URL:           http://www.linphone.org/technical-corner/mediastreamer2/overview
 %{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.2.0}
@@ -164,6 +166,8 @@ Statyczne biblioteki mediastreamer.
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
+%patch10 -p1
 
 # cmake checks for python3, so don't require python 2 as well
 %{__sed} -i -e '1s,/usr/bin/python$,%{__python3},' tools/xxd.py
This page took 0.164676 seconds and 4 git commands to generate.