]> git.pld-linux.org Git - packages/mediastreamer.git/blobdiff - mediastreamer.spec
- rel 1,1 for intermediate build
[packages/mediastreamer.git] / mediastreamer.spec
index e6473526c5a686d1cab5c14c22b4703d4c2cddf8..0832ec6cb0cc2547319491d976834d72ce5b986d 100644 (file)
@@ -1,29 +1,42 @@
+# TODO:
+# - libebml2, libmatroska2 (Matroska support)
+# - dtls (polarssl/mbedtls >= 1.4 when released)
 #
 # Conditional build:
+%bcond_without bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
+%bcond_without zrtp            # support for RFC 6189: Media Path Key Agreement for Unicast Secure RTP
 %bcond_without opengl          # X11+OpenGL rendering support
 %bcond_with    pcap            # audio playing from PCAP files
-%bcond_without pulseaudio      # PulseAudio support
+%bcond_without srtp            # SRTP (secure RTP) support
+# audio I/O
+%bcond_without alsa            # ALSA sound I/O support
+%bcond_with    arts            # aRts sound I/O support
+%bcond_with    portaudio       # PortAudio sound I/O support
+%bcond_without pulseaudio      # PulseAudio sound I/O support
 #
 Summary:       Audio/Video real-time streaming
 Summary(pl.UTF-8):     Przesyłanie strumieni audio/video w czasie rzeczywistym 
 Name:          mediastreamer
-Version:       2.9.0
-Release:       4
+Version:       2.11.2
+Release:       1.1
 License:       GPL v2+
 Group:         Libraries
 Source0:       http://download-mirror.savannah.gnu.org/releases/linphone/mediastreamer/%{name}-%{version}.tar.gz
-# Source0-md5: f2ea0fe731a363749a81b6eaac22a62c
+# Source0-md5: 8b654c3e8938d50df9e83d2e353888a6
 Patch0:                %{name}-imagedir.patch
 URL:           http://www.linphone.org/eng/documentation/dev/mediastreamer2.html
 %{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
 BuildRequires: SDL-devel >= 1.2.0
-BuildRequires: alsa-lib-devel
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
 BuildRequires: autoconf >= 2.53
-BuildRequires: automake
+BuildRequires: automake >= 1:1.9
+%{?with_bcg729:BuildRequires:  bcg729-devel >= 1.0}
+%{?with_zrtp:BuildRequires:    bzrtp-devel >= 1.0.0}
 BuildRequires: doxygen
 # libavcodec >= 51.0.0, libswscale >= 0.7.0
 BuildRequires: ffmpeg-devel
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 %{?with_opengl:BuildRequires:  glew-devel >= 1.5}
 BuildRequires: jack-audio-connection-kit-devel
 BuildRequires: intltool >= 0.40
@@ -36,24 +49,31 @@ BuildRequires:      libupnp-devel < 1.7
 BuildRequires: libv4l-devel
 BuildRequires: libvpx-devel >= 0.9.6
 BuildRequires: opus-devel >= 0.9.0
-BuildRequires: ortp-devel >= 0.21.0
+BuildRequires: ortp-devel >= 0.24.0
 BuildRequires: pkgconfig
+BuildRequires: polarssl-devel
+%{?with_portaudio:BuildRequires:       portaudio-devel}
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel >= 0.9.21}
 BuildRequires: sed >= 4.0
 BuildRequires: spandsp-devel >= 0.0.6
-BuildRequires: speex-devel >= 1.2-beta3
+BuildRequires: speex-devel >= 1:1.2-beta3
+BuildRequires: speexdsp-devel >= 1.2-beta3
+%{?with_srtp:BuildRequires:    srtp-devel}
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXv-devel
 BuildRequires: xxd
+%{?with_bcg729:Requires:       bcg729 >= 1.0}
+%{?with_zrtp:Requires: bzrtp >= 1.0.0}
 %{?with_opengl:Requires:       glew >= 1.5}
 Requires:      libtheora >= 1.0-0.alpha7
 Requires:      libupnp >= 1.6
 Requires:      libvpx >= 0.9.6
 Requires:      opus >= 0.9.0
-Requires:      ortp >= 0.21.0
+Requires:      ortp >= 0.24.0
 %{?with_pulseaudio:Requires:   pulseaudio-libs >= 0.9.21}
 Requires:      spandsp >= 0.0.6
-Requires:      speex >= 1.2-beta3
+Requires:      speex >= 1:1.2-beta3
+Requires:      speexdsp >= 1.2-beta3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -72,7 +92,9 @@ Summary(pl.UTF-8):    Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %{?with_opengl:Requires:       OpenGL-devel}
-Requires:      alsa-lib-devel
+%{?with_alsa:Requires: alsa-lib-devel}
+%{?with_bcg729:Requires:       bcg729-devel >= 1.0}
+%{?with_zrtp:Requires: bzrtp-devel >= 1.0.0}
 Requires:      ffmpeg-devel
 %{?with_opengl:Requires:       glew-devel >= 1.5}
 Requires:      libtheora-devel >= 1.0-0.alpha7
@@ -81,10 +103,14 @@ Requires:  libupnp-devel < 1.7
 Requires:      libv4l-devel
 Requires:      libvpx-devel >= 0.9.6
 Requires:      opus-devel >= 0.9.0
-Requires:      ortp-devel >= 0.21.0
+Requires:      ortp-devel >= 0.24.0
+Requires:      polarssl-devel
+%{?with_portaudio:Requires:    portaudio-devel}
 %{?with_pulseaudio:Requires:   pulseaudio-devel >= 0.9.21}
 Requires:      spandsp-devel >= 0.0.6
-Requires:      speex-devel >= 1.2-beta3
+Requires:      speex-devel >= 1:1.2-beta3
+Requires:      speexdsp-devel >= 1.2-beta3
+%{?with_srtp:Requires: srtp-devel}
 Requires:      xorg-lib-libX11-devel
 Requires:      xorg-lib-libXv-devel
 
@@ -117,12 +143,18 @@ Statyczna biblioteka mediastreamer.
 %{__autoheader}
 %{__automake}
 %configure \
+       --enable-alsa%{!?with_alsa:=no} \
+       %{?with_arts:--enable-artsc} \
+       %{?with_bcg729:--enable-bcg729} \
        --enable-external-ortp \
        %{!?with_opengl:--disable-glx} \
        %{?with_pcap:--enable-pcap} \
-       %{?with_pulseaudio:--enable-pulseaudio} \
+       %{?with_portaudio:--enable-portaudio} \
+       --enable-pulseaudio%{!?with_pulseaudio:=no} \
        --disable-silent-rules \
-       --enable-static
+       --enable-static \
+       %{!?with_zrtp:--disable-zrtp} \
+       %{!?with_srtp:--with-srtp=none}
 
 %{__make}
 
@@ -150,11 +182,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/mediastream
+%attr(755,root,root) %{_bindir}/msaudiocmp
 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.3
+%attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.4
 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.3
+%attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.4
 %dir %{_libdir}/mediastreamer
 %dir %{_libdir}/mediastreamer/plugins
 %{_pixmapsdir}/%{name}
This page took 0.416116 seconds and 4 git commands to generate.