]> git.pld-linux.org Git - packages/mediastreamer.git/blob - mediastreamer.spec
- release 5 (by relup.sh)
[packages/mediastreamer.git] / mediastreamer.spec
1 # TODO:
2 # - switch to mbledtls when 2.x is supported (mbed_ssl_init instead of ssl_init)
3 # - dtls (polarssl/mbedtls >= 1.4 with DTLS-SRTP support, not released yet)
4 #
5 # Conditional build:
6 %bcond_without  bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
7 %bcond_without  srtp            # SRTP (secure RTP) support
8 %bcond_without  zrtp            # support for RFC 6189: Media Path Key Agreement for Unicast Secure RTP
9 %bcond_without  matroska        # Matroska support via libebml2/libmatroska2
10 %bcond_without  opengl          # X11+OpenGL rendering support
11 %bcond_with     pcap            # audio playing from PCAP files
12 # audio I/O
13 %bcond_without  alsa            # ALSA sound I/O support
14 %bcond_with     arts            # aRts sound I/O support
15 %bcond_with     portaudio       # PortAudio sound I/O support
16 %bcond_without  pulseaudio      # PulseAudio sound I/O support
17 %bcond_without  static_libs     # static library
18 #
19 Summary:        Audio/Video real-time streaming
20 Summary(pl.UTF-8):      Przesyłanie strumieni audio/video w czasie rzeczywistym 
21 Name:           mediastreamer
22 Version:        2.16.1
23 Release:        5
24 License:        GPL v2+
25 Group:          Libraries
26 Source0:        https://linphone.org/releases/sources//mediastreamer/%{name}-%{version}.tar.gz
27 # Source0-md5:  15b8b129a922180855d04d58cdd08d43
28 Patch0:         build.patch
29 Patch1:         libsrtp2.patch
30 URL:            http://www.linphone.org/technical-corner/mediastreamer2/overview
31 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
32 BuildRequires:  SDL-devel >= 1.2.0
33 %{?with_alsa:BuildRequires:     alsa-lib-devel}
34 %{?with_arts:BuildRequires:     artsc-devel}
35 BuildRequires:  autoconf >= 2.53
36 BuildRequires:  automake >= 1:1.9
37 %{?with_bcg729:BuildRequires:   bcg729-devel >= 1.0}
38 BuildRequires:  bctoolbox-devel
39 %{?with_zrtp:BuildRequires:     bzrtp-devel >= 1.0.6}
40 BuildRequires:  doxygen
41 # libavcodec >= 51.0.0, libswscale >= 0.7.0
42 BuildRequires:  ffmpeg-devel
43 BuildRequires:  gettext-tools
44 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
45 BuildRequires:  jack-audio-connection-kit-devel
46 BuildRequires:  intltool >= 0.40
47 BuildRequires:  libgsm-devel
48 %{?with_pcap:BuildRequires:     libpcap-devel}
49 BuildRequires:  libtheora-devel >= 1.0-0.alpha7
50 BuildRequires:  libtool >= 2:2
51 BuildRequires:  libupnp-devel >= 1.6
52 BuildRequires:  libupnp-devel < 1.7
53 BuildRequires:  libv4l-devel
54 BuildRequires:  libvpx-devel >= 0.9.6
55 %{?with_matroska:BuildRequires: matroska-foundation-devel}
56 BuildRequires:  opus-devel >= 0.9.0
57 BuildRequires:  ortp-devel >= 1.0.0
58 BuildRequires:  pkgconfig
59 BuildRequires:  polarssl-devel
60 %{?with_portaudio:BuildRequires:        portaudio-devel}
61 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.21}
62 BuildRequires:  sed >= 4.0
63 BuildRequires:  spandsp-devel >= 0.0.6
64 BuildRequires:  speex-devel >= 1:1.2-beta3
65 BuildRequires:  speexdsp-devel >= 1.2-beta3
66 %{?with_srtp:BuildRequires:     libsrtp2-devel}
67 BuildRequires:  xorg-lib-libX11-devel
68 BuildRequires:  xorg-lib-libXv-devel
69 BuildRequires:  xxd
70 %{?with_bcg729:Requires:        bcg729 >= 1.0}
71 %{?with_zrtp:Requires:  bzrtp >= 1.0.6}
72 %{?with_opengl:Requires:        glew >= 1.5}
73 Requires:       libtheora >= 1.0-0.alpha7
74 Requires:       libupnp >= 1.6
75 Requires:       libvpx >= 0.9.6
76 Requires:       opus >= 0.9.0
77 Requires:       ortp >= 1.0.0
78 %{?with_pulseaudio:Requires:    pulseaudio-libs >= 0.9.21}
79 Requires:       spandsp >= 0.0.6
80 Requires:       speex >= 1:1.2-beta3
81 Requires:       speexdsp >= 1.2-beta3
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %description
85 Mediastreamer2 is a GPL licensed library to make audio and video
86 real-time streaming and processing. Written in pure C, it is based
87 upon the oRTP library.
88
89 %description -l pl.UTF-8
90 Mediastreamer2 to udostępniona na licencji GPL biblioteka do
91 przesyłania i przetwarzania strumieni audio/video w czasie
92 rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
93
94 %package devel
95 Summary:        Header files and development documentation for mediastreamer libraries
96 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}-%{release}
99 %{?with_opengl:Requires:        OpenGL-devel}
100 %{?with_alsa:Requires:  alsa-lib-devel}
101 %{?with_bcg729:Requires:        bcg729-devel >= 1.0}
102 %{?with_zrtp:Requires:  bzrtp-devel >= 1.0.6}
103 Requires:       ffmpeg-devel
104 %{?with_opengl:Requires:        glew-devel >= 1.5}
105 Requires:       libtheora-devel >= 1.0-0.alpha7
106 Requires:       libupnp-devel >= 1.6
107 Requires:       libupnp-devel < 1.7
108 Requires:       libv4l-devel
109 Requires:       libvpx-devel >= 0.9.6
110 %{?with_matroska:Requires:      matroska-foundation-devel}
111 Requires:       opus-devel >= 0.9.0
112 Requires:       ortp-devel >= 1.0.0
113 Requires:       polarssl-devel
114 %{?with_portaudio:Requires:     portaudio-devel}
115 %{?with_pulseaudio:Requires:    pulseaudio-devel >= 0.9.21}
116 Requires:       spandsp-devel >= 0.0.6
117 Requires:       speex-devel >= 1:1.2-beta3
118 Requires:       speexdsp-devel >= 1.2-beta3
119 %{?with_srtp:Requires:  libsrtp2-devel}
120 Requires:       xorg-lib-libX11-devel
121 Requires:       xorg-lib-libXv-devel
122
123 %description devel
124 Header files and development documentation for mediastreamer
125 libraries.
126
127 %description devel -l pl.UTF-8
128 Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer.
129
130 %package static
131 Summary:        Static mediastreamer libraries
132 Summary(pl.UTF-8):      Statyczne biblioteki mediastreamer
133 Group:          Development/Libraries
134 Requires:       %{name}-devel = %{version}-%{release}
135
136 %description static
137 Static mediastreamer libraries.
138
139 %description static -l pl.UTF-8
140 Statyczne biblioteki mediastreamer.
141
142 %prep
143 %setup -q
144 %patch0 -p1
145 %patch1 -p1
146
147 [ ! -e gitversion.h ] && echo '#define MS2_GIT_VERSION "%{version}"' > src/gitversion.h
148
149 %build
150 %{__libtoolize}
151 %{__gettextize}
152 %{__intltoolize}
153 %{__aclocal}
154 %{__autoconf}
155 %{__autoheader}
156 %{__automake}
157 %configure \
158         --disable-strict \
159         --enable-alsa%{!?with_alsa:=no} \
160         %{?with_arts:--enable-artsc} \
161         %{?with_bcg729:--enable-bcg729} \
162         --enable-external-ortp \
163         %{!?with_opengl:--disable-glx} \
164         %{!?with_matroska:--disable-matroska} \
165         %{?with_pcap:--enable-pcap} \
166         %{?with_portaudio:--enable-portaudio} \
167         --enable-pulseaudio%{!?with_pulseaudio:=no} \
168         --disable-silent-rules \
169         %{?with_static_libs:--enable-static} \
170         %{!?with_zrtp:--disable-zrtp} \
171         %{!?with_srtp:--with-srtp=none}
172
173 %{__make}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177
178 %{__make} install \
179         DESTDIR=$RPM_BUILD_ROOT \
180         install_sh=/usr/bin/install
181
182 # for external plugins
183 install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
184
185 # Remove duplicated documentation
186 %{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html
187
188 %find_lang %{name}
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %post   -p /sbin/ldconfig
194 %postun -p /sbin/ldconfig
195
196 %files -f %{name}.lang
197 %defattr(644,root,root,755)
198 %doc AUTHORS ChangeLog NEWS README.md
199 %attr(755,root,root) %{_bindir}/mediastream
200 %attr(755,root,root) %{_bindir}/msaudiocmp
201 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
202 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
203 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.10
204 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.10
206 %dir %{_libdir}/mediastreamer
207 %dir %{_libdir}/mediastreamer/plugins
208 %{_pixmapsdir}/*.jpg
209
210 %files devel
211 %defattr(644,root,root,755)
212 %doc help/doc/html
213 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so
214 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so
215 %{_libdir}/libmediastreamer_base.la
216 %{_libdir}/libmediastreamer_voip.la
217 %{_includedir}/mediastreamer2
218 %{_pkgconfigdir}/mediastreamer.pc
219
220 %if %{with static_libs}
221 %files static
222 %defattr(644,root,root,755)
223 %{_libdir}/libmediastreamer_base.a
224 %{_libdir}/libmediastreamer_voip.a
225 %endif
This page took 0.0402 seconds and 3 git commands to generate.