]> git.pld-linux.org Git - packages/mediastreamer.git/blob - mediastreamer.spec
- added dependencies and bcond for bv16 codec
[packages/mediastreamer.git] / mediastreamer.spec
1 #
2 # Conditional build:
3 %bcond_with     pcap            # audio playing from PCAP files
4 %bcond_without  static_libs     # static library
5 # transport
6 %bcond_without  srtp            # SRTP (secure RTP) support
7 %bcond_without  zrtp            # support for RFC 6189: Media Path Key Agreement for Unicast Secure RTP
8 # audio I/O
9 %bcond_without  alsa            # ALSA sound I/O support
10 %bcond_with     arts            # aRts sound I/O support
11 %bcond_with     oss             # OSS support (deprecated)
12 %bcond_with     portaudio       # PortAudio sound I/O support
13 %bcond_without  pulseaudio      # PulseAudio sound I/O support
14 # audio codecs
15 %bcond_without  bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
16 %bcond_without  bv16            # BV16 codec support
17 %bcond_without  spandsp         # G726 codec support via spandsp
18 # video I/O
19 %bcond_without  opengl          # X11+OpenGL rendering support
20 %bcond_without  sdl             # SDL support
21 # video codecs
22 %bcond_without  matroska        # Matroska support via bcmatroska2
23 %bcond_without  zxing           # QRcode support via zxing-cpp
24 #
25 Summary:        Audio/Video real-time streaming
26 Summary(pl.UTF-8):      Przesyłanie strumieni audio/video w czasie rzeczywistym 
27 Name:           mediastreamer
28 Version:        4.5.22
29 Release:        1
30 License:        GPL v3+
31 Group:          Libraries
32 #Source0Download: https://gitlab.linphone.org/BC/public/mediastreamer2/tags
33 Source0:        https://gitlab.linphone.org/BC/public/mediastreamer2/-/archive/%{version}/mediastreamer2-%{version}.tar.bz2
34 # Source0-md5:  3cdcfb0a1e3bd1b2774ca1da6316dae6
35 Patch0:         build.patch
36 Patch1:         %{name}-cmake-link.patch
37 Patch2:         libupnp-1.14.patch
38 Patch3:         %{name}-cmake-datadir.patch
39 Patch4:         %{name}-cmake-install-pkgconfig.patch
40 Patch5:         %{name}-cmake-SDL.patch
41 Patch6:         %{name}-types.patch
42 Patch7:         %{name}-gsm.patch
43 Patch8:         %{name}-cmake-upnp.patch
44 URL:            http://www.linphone.org/technical-corner/mediastreamer2/overview
45 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
46 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.0}
47 %{?with_alsa:BuildRequires:     alsa-lib-devel}
48 %{?with_arts:BuildRequires:     artsc-devel}
49 %{?with_bcg729:BuildRequires:   bcg729-devel >= 1.1.1-1}
50 %{?with_matroska:BuildRequires: bcmatroska2-devel}
51 BuildRequires:  bctoolbox-devel >= 0.4.0
52 %{?with_bv16:BuildRequires:     bv16-floatingpoint-devel}
53 %{?with_zrtp:BuildRequires:     bzrtp-devel >= 4.5.15-1}
54 BuildRequires:  cmake >= 3.1
55 BuildRequires:  doxygen
56 # libavcodec >= 51.0.0, libswscale >= 0.7.0
57 BuildRequires:  ffmpeg-devel
58 BuildRequires:  gettext-tools
59 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
60 BuildRequires:  intltool >= 0.40
61 BuildRequires:  libgsm-devel
62 BuildRequires:  libjpeg-turbo-devel
63 %{?with_pcap:BuildRequires:     libpcap-devel}
64 BuildRequires:  libstdc++-devel >= 6:5
65 BuildRequires:  libtheora-devel >= 1.0-0.alpha7
66 BuildRequires:  libupnp-devel >= 1.8
67 BuildRequires:  libv4l-devel
68 BuildRequires:  libvpx-devel >= 0.9.6
69 BuildRequires:  opus-devel >= 0.9.0
70 BuildRequires:  ortp-devel >= 4.5.15-1
71 BuildRequires:  pkgconfig
72 %{?with_portaudio:BuildRequires:        portaudio-devel}
73 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.21}
74 BuildRequires:  python3 >= 1:3
75 BuildRequires:  sed >= 4.0
76 %{?with_spandsp:BuildRequires:  spandsp-devel >= 0.0.6}
77 BuildRequires:  speex-devel >= 1:1.2-beta3
78 BuildRequires:  speexdsp-devel >= 1.2-beta3
79 %{?with_srtp:BuildRequires:     libsrtp2-devel}
80 BuildRequires:  xorg-lib-libX11-devel
81 BuildRequires:  xorg-lib-libXv-devel
82 %{?with_zxing:BuildRequires:    zxing-cpp-devel}
83 %{?with_bcg729:Requires:        bcg729 >= 1.1.1-1}
84 Requires:       bctoolbox >= 0.4.0
85 %{?with_zrtp:Requires:  bzrtp >= 4.5}
86 %{?with_opengl:Requires:        glew >= 1.5}
87 Requires:       libtheora >= 1.0-0.alpha7
88 Requires:       libvpx >= 0.9.6
89 Requires:       opus >= 0.9.0
90 Requires:       ortp >= 4.5
91 %{?with_pulseaudio:Requires:    pulseaudio-libs >= 0.9.21}
92 Requires:       spandsp >= 0.0.6
93 Requires:       speex >= 1:1.2-beta3
94 Requires:       speexdsp >= 1.2-beta3
95 Obsoletes:      mediastreamer-plugin-msbcg729 < 1.1
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %description
99 Mediastreamer2 is a GPL licensed library to make audio and video
100 real-time streaming and processing. Written in pure C, it is based
101 upon the oRTP library.
102
103 %description -l pl.UTF-8
104 Mediastreamer2 to udostępniona na licencji GPL biblioteka do
105 przesyłania i przetwarzania strumieni audio/video w czasie
106 rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
107
108 %package devel
109 Summary:        Header files and development documentation for mediastreamer libraries
110 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer
111 Group:          Development/Libraries
112 Requires:       %{name} = %{version}-%{release}
113 %{?with_opengl:Requires:        OpenGL-devel}
114 %{?with_alsa:Requires:  alsa-lib-devel}
115 %{?with_bcg729:Requires:        bcg729-devel >= 1.1.1-1}
116 %{?with_matroska:Requires:      bcmatroska2-devel}
117 Requires:       bctoolbox-devel >= 0.4.0
118 %{?with_bv16:Requires:  bv16-floatingpoint-devel}
119 %{?with_zrtp:Requires:  bzrtp-devel >= 4.5.15-1}
120 Requires:       ffmpeg-devel
121 %{?with_opengl:Requires:        glew-devel >= 1.5}
122 Requires:       libtheora-devel >= 1.0-0.alpha7
123 Requires:       libupnp-devel >= 1.8
124 Requires:       libv4l-devel
125 Requires:       libvpx-devel >= 0.9.6
126 Requires:       opus-devel >= 0.9.0
127 Requires:       ortp-devel >= 4.5.15-1
128 %{?with_portaudio:Requires:     portaudio-devel}
129 %{?with_pulseaudio:Requires:    pulseaudio-devel >= 0.9.21}
130 Requires:       spandsp-devel >= 0.0.6
131 Requires:       speex-devel >= 1:1.2-beta3
132 Requires:       speexdsp-devel >= 1.2-beta3
133 %{?with_srtp:Requires:  libsrtp2-devel}
134 Requires:       xorg-lib-libX11-devel
135 Requires:       xorg-lib-libXv-devel
136
137 %description devel
138 Header files and development documentation for mediastreamer
139 libraries.
140
141 %description devel -l pl.UTF-8
142 Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer.
143
144 %package static
145 Summary:        Static mediastreamer libraries
146 Summary(pl.UTF-8):      Statyczne biblioteki mediastreamer
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}-%{release}
149
150 %description static
151 Static mediastreamer libraries.
152
153 %description static -l pl.UTF-8
154 Statyczne biblioteki mediastreamer.
155
156 %prep
157 %setup -q -n mediastreamer2-%{version}
158 %patch0 -p1
159 %patch1 -p1
160 %patch2 -p1
161 %patch3 -p1
162 %patch4 -p1
163 %patch5 -p1
164 %patch6 -p1
165 %patch7 -p1
166 %patch8 -p1
167
168 # cmake checks for python3, so don't require python 2 as well
169 %{__sed} -i -e '1s,/usr/bin/python$,%{__python3},' tools/xxd.py
170
171 %build
172 install -d build
173 cd build
174 # NLS missing in cmake
175 CPPFLAGS="%{rpmcppflags} -DENABLE_NLS=1 -DGETTEXT_PACKAGE=\"mediastreamer\" -DLOCALEDIR=\"%{_localedir}\""
176 # note: NON_FREE_CODECS refer to H263, H264, MPEG4 via libavcodec
177 %cmake .. \
178         -DCMAKE_INSTALL_INCLUDEDIR=include \
179         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
180         %{!?with_alsa:-DENABLE_ALSA=OFF} \
181         %{?with_arts:-DENABLE_ARTSC=ON} \
182         %{!?with_bv16:-DENABLE_BV16=OFF} \
183         %{?with_spandsp:-DENABLE_G726=ON} \
184         %{!?with_bcg729:-DENABLE_G729=OFF} \
185         %{?with_bcg729:-DENABLE_G729B_CNG=ON} \
186         %{!?with_opengl:-DENABLE_GL=OFF} \
187         %{!?with_opengl:-DENABLE_GLX=OFF} \
188         %{!?with_matroska:-DENABLE_MKV=OFF} \
189         -DENABLE_NON_FREE_CODECS=ON \
190         %{?with_oss:-DENABLE_OSS=ON} \
191         %{?with_pcap:-DENABLE_PCAP=ON} \
192         %{?with_portaudio:-DENABLE_PORTAUDIO=ON} \
193         %{?with_pulseaudio:-DENABLE_PULSEAUDIO=ON} \
194         %{!?with_zxing:-DENABLE_QRCODE=OFF} \
195         %{?with_sdl:-DENABLE_SDL=ON} \
196         %{!?with_srtp:-DENABLE_SRTP=OFF} \
197         %{!?with_static_libs:-DENABLE_STATIC=OFF} \
198         -DENABLE_UNIT_TESTS=OFF \
199         %{!?with_zrtp:-DENABLE_ZRTP=OFF}
200
201 %{__make}
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205
206 %{__make} -C build install \
207         DESTDIR=$RPM_BUILD_ROOT
208
209 # disable completeness check incompatible with split packaging
210 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_datadir}/Mediastreamer2/cmake/Mediastreamer2Targets.cmake
211
212 # missing from install in cmake
213 install build/tools/msaudiocmp $RPM_BUILD_ROOT%{_bindir}
214 %if %{with pcap}
215 install build/tools/pcap_playback $RPM_BUILD_ROOT%{_bindir}
216 %endif
217 for f in po/*.po ; do
218         lang=$(basename "$f" .po)
219         install -d $RPM_BUILD_ROOT%{_localedir}/${lang}/LC_MESSAGES
220         msgfmt -v -o $RPM_BUILD_ROOT%{_localedir}/${lang}/LC_MESSAGES/%{name}.mo "$f"
221 done
222
223 # for external plugins
224 install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
225
226 # Remove duplicated documentation
227 %{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/mediastreamer2-4.5.0/html
228
229 %find_lang %{name}
230
231 %clean
232 rm -rf $RPM_BUILD_ROOT
233
234 %post   -p /sbin/ldconfig
235 %postun -p /sbin/ldconfig
236
237 %files -f %{name}.lang
238 %defattr(644,root,root,755)
239 %doc CHANGELOG.md README.md
240 %attr(755,root,root) %{_bindir}/mediastream
241 %attr(755,root,root) %{_bindir}/mkvstream
242 %attr(755,root,root) %{_bindir}/msaudiocmp
243 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
244 %attr(755,root,root) %{_libdir}/libmediastreamer.so.11
245 %dir %{_libdir}/mediastreamer
246 %dir %{_libdir}/mediastreamer/plugins
247 %{_datadir}/mediastreamer
248
249 %files devel
250 %defattr(644,root,root,755)
251 %doc build/help/doc/html/*.{css,html,js,png}
252 %attr(755,root,root) %{_libdir}/libmediastreamer.so
253 %{_includedir}/mediastreamer2
254 %{_pkgconfigdir}/mediastreamer.pc
255 %dir %{_datadir}/Mediastreamer2
256 %{_datadir}/Mediastreamer2/cmake
257
258 %if %{with static_libs}
259 %files static
260 %defattr(644,root,root,755)
261 %{_libdir}/libmediastreamer.a
262 %endif
This page took 0.107357 seconds and 3 git commands to generate.