]> git.pld-linux.org Git - packages/mediastreamer.git/blob - mediastreamer.spec
- release 7 (by relup.sh)
[packages/mediastreamer.git] / mediastreamer.spec
1 #
2 # Conditional build:
3 %bcond_without  bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
4 %bcond_without  srtp            # SRTP (secure RTP) support
5 %bcond_without  zrtp            # support for RFC 6189: Media Path Key Agreement for Unicast Secure RTP
6 %bcond_without  matroska        # Matroska support via libebml2/libmatroska2
7 %bcond_without  opengl          # X11+OpenGL rendering support
8 %bcond_with     pcap            # audio playing from PCAP files
9 # audio I/O
10 %bcond_without  alsa            # ALSA sound I/O support
11 %bcond_with     arts            # aRts sound I/O support
12 %bcond_with     portaudio       # PortAudio sound I/O support
13 %bcond_without  pulseaudio      # PulseAudio sound I/O support
14 %bcond_without  static_libs     # static library
15 #
16 Summary:        Audio/Video real-time streaming
17 Summary(pl.UTF-8):      Przesyłanie strumieni audio/video w czasie rzeczywistym 
18 Name:           mediastreamer
19 Version:        2.16.1
20 Release:        7
21 License:        GPL v2+
22 Group:          Libraries
23 Source0:        https://linphone.org/releases/sources/mediastreamer/%{name}-%{version}.tar.gz
24 # Source0-md5:  15b8b129a922180855d04d58cdd08d43
25 Patch0:         build.patch
26 Patch1:         libsrtp2.patch
27 URL:            http://www.linphone.org/technical-corner/mediastreamer2/overview
28 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
29 BuildRequires:  SDL-devel >= 1.2.0
30 %{?with_alsa:BuildRequires:     alsa-lib-devel}
31 %{?with_arts:BuildRequires:     artsc-devel}
32 BuildRequires:  autoconf >= 2.53
33 BuildRequires:  automake >= 1:1.9
34 %{?with_bcg729:BuildRequires:   bcg729-devel >= 1.0}
35 BuildRequires:  bctoolbox-devel >= 0.4.0
36 %{?with_zrtp:BuildRequires:     bzrtp-devel >= 1.0.6}
37 BuildRequires:  doxygen
38 # libavcodec >= 51.0.0, libswscale >= 0.7.0
39 BuildRequires:  ffmpeg-devel
40 BuildRequires:  gettext-tools
41 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
42 BuildRequires:  intltool >= 0.40
43 BuildRequires:  libgsm-devel
44 %{?with_pcap:BuildRequires:     libpcap-devel}
45 BuildRequires:  libtheora-devel >= 1.0-0.alpha7
46 BuildRequires:  libtool >= 2:2
47 BuildRequires:  libupnp1.6-devel
48 BuildRequires:  libv4l-devel
49 BuildRequires:  libvpx-devel >= 0.9.6
50 %{?with_matroska:BuildRequires: matroska-foundation-devel}
51 BuildRequires:  opus-devel >= 0.9.0
52 BuildRequires:  ortp-devel >= 1.0.0
53 BuildRequires:  pkgconfig
54 %{?with_portaudio:BuildRequires:        portaudio-devel}
55 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.21}
56 BuildRequires:  sed >= 4.0
57 BuildRequires:  spandsp-devel >= 0.0.6
58 BuildRequires:  speex-devel >= 1:1.2-beta3
59 BuildRequires:  speexdsp-devel >= 1.2-beta3
60 %{?with_srtp:BuildRequires:     libsrtp2-devel}
61 BuildRequires:  xorg-lib-libX11-devel
62 BuildRequires:  xorg-lib-libXv-devel
63 BuildRequires:  xxd
64 %{?with_bcg729:Requires:        bcg729 >= 1.0}
65 Requires:       bctoolbox >= 0.4.0
66 %{?with_zrtp:Requires:  bzrtp >= 1.0.6}
67 %{?with_opengl:Requires:        glew >= 1.5}
68 Requires:       libtheora >= 1.0-0.alpha7
69 Requires:       libupnp1.6
70 Requires:       libvpx >= 0.9.6
71 Requires:       opus >= 0.9.0
72 Requires:       ortp >= 1.0.0
73 %{?with_pulseaudio:Requires:    pulseaudio-libs >= 0.9.21}
74 Requires:       spandsp >= 0.0.6
75 Requires:       speex >= 1:1.2-beta3
76 Requires:       speexdsp >= 1.2-beta3
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 Mediastreamer2 is a GPL licensed library to make audio and video
81 real-time streaming and processing. Written in pure C, it is based
82 upon the oRTP library.
83
84 %description -l pl.UTF-8
85 Mediastreamer2 to udostępniona na licencji GPL biblioteka do
86 przesyłania i przetwarzania strumieni audio/video w czasie
87 rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
88
89 %package devel
90 Summary:        Header files and development documentation for mediastreamer libraries
91 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer
92 Group:          Development/Libraries
93 Requires:       %{name} = %{version}-%{release}
94 %{?with_opengl:Requires:        OpenGL-devel}
95 %{?with_alsa:Requires:  alsa-lib-devel}
96 %{?with_bcg729:Requires:        bcg729-devel >= 1.0}
97 Requires:       bctoolbox-devel >= 0.4.0
98 %{?with_zrtp:Requires:  bzrtp-devel >= 1.0.6}
99 Requires:       ffmpeg-devel
100 %{?with_opengl:Requires:        glew-devel >= 1.5}
101 Requires:       libtheora-devel >= 1.0-0.alpha7
102 Requires:       libupnp1.6-devel
103 Requires:       libv4l-devel
104 Requires:       libvpx-devel >= 0.9.6
105 %{?with_matroska:Requires:      matroska-foundation-devel}
106 Requires:       opus-devel >= 0.9.0
107 Requires:       ortp-devel >= 1.0.0
108 %{?with_portaudio:Requires:     portaudio-devel}
109 %{?with_pulseaudio:Requires:    pulseaudio-devel >= 0.9.21}
110 Requires:       spandsp-devel >= 0.0.6
111 Requires:       speex-devel >= 1:1.2-beta3
112 Requires:       speexdsp-devel >= 1.2-beta3
113 %{?with_srtp:Requires:  libsrtp2-devel}
114 Requires:       xorg-lib-libX11-devel
115 Requires:       xorg-lib-libXv-devel
116
117 %description devel
118 Header files and development documentation for mediastreamer
119 libraries.
120
121 %description devel -l pl.UTF-8
122 Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer.
123
124 %package static
125 Summary:        Static mediastreamer libraries
126 Summary(pl.UTF-8):      Statyczne biblioteki mediastreamer
127 Group:          Development/Libraries
128 Requires:       %{name}-devel = %{version}-%{release}
129
130 %description static
131 Static mediastreamer libraries.
132
133 %description static -l pl.UTF-8
134 Statyczne biblioteki mediastreamer.
135
136 %prep
137 %setup -q
138 %patch0 -p1
139 %patch1 -p1
140
141 [ ! -e gitversion.h ] && echo '#define MS2_GIT_VERSION "%{version}"' > src/gitversion.h
142
143 %build
144 %{__libtoolize}
145 %{__gettextize}
146 %{__intltoolize}
147 %{__aclocal}
148 %{__autoconf}
149 %{__autoheader}
150 %{__automake}
151 %configure \
152         --disable-strict \
153         --disable-tests \
154         --enable-alsa%{!?with_alsa:=no} \
155         %{?with_arts:--enable-artsc} \
156         %{?with_bcg729:--enable-bcg729} \
157         --enable-external-ortp \
158         %{!?with_opengl:--disable-glx} \
159         %{!?with_matroska:--disable-matroska} \
160         %{!?with_pcap:--disable-pcap} \
161         %{?with_portaudio:--enable-portaudio} \
162         --enable-pulseaudio%{!?with_pulseaudio:=no} \
163         --disable-silent-rules \
164         %{?with_static_libs:--enable-static} \
165         %{!?with_zrtp:--disable-zrtp} \
166         %{!?with_srtp:--with-srtp=none}
167
168 %{__make}
169
170 %install
171 rm -rf $RPM_BUILD_ROOT
172
173 %{__make} install \
174         DESTDIR=$RPM_BUILD_ROOT \
175         install_sh=/usr/bin/install
176
177 # for external plugins
178 install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
179
180 # Remove duplicated documentation
181 %{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html
182
183 %find_lang %{name}
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %post   -p /sbin/ldconfig
189 %postun -p /sbin/ldconfig
190
191 %files -f %{name}.lang
192 %defattr(644,root,root,755)
193 %doc AUTHORS ChangeLog NEWS README.md
194 %attr(755,root,root) %{_bindir}/mediastream
195 %attr(755,root,root) %{_bindir}/msaudiocmp
196 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
197 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
198 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.10
199 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
200 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.10
201 %dir %{_libdir}/mediastreamer
202 %dir %{_libdir}/mediastreamer/plugins
203 %{_pixmapsdir}/nowebcamCIF.jpg
204
205 %files devel
206 %defattr(644,root,root,755)
207 %doc help/doc/html
208 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so
209 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so
210 %{_libdir}/libmediastreamer_base.la
211 %{_libdir}/libmediastreamer_voip.la
212 %{_includedir}/mediastreamer2
213 %{_pkgconfigdir}/mediastreamer.pc
214
215 %if %{with static_libs}
216 %files static
217 %defattr(644,root,root,755)
218 %{_libdir}/libmediastreamer_base.a
219 %{_libdir}/libmediastreamer_voip.a
220 %endif
This page took 0.092446 seconds and 3 git commands to generate.