]> git.pld-linux.org Git - packages/mediastreamer.git/blob - mediastreamer.spec
29363a667c58c8c546df96bcdd50aac1508251a5
[packages/mediastreamer.git] / mediastreamer.spec
1 #
2 # Conditional build:
3 %bcond_without  bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
4 %bcond_without  srtp            # SRTP (secure RTP) support
5 %bcond_without  zrtp            # support for RFC 6189: Media Path Key Agreement for Unicast Secure RTP
6 %bcond_without  matroska        # Matroska support via libebml2/libmatroska2
7 %bcond_without  opengl          # X11+OpenGL rendering support
8 %bcond_with     pcap            # audio playing from PCAP files
9 # audio I/O
10 %bcond_without  alsa            # ALSA sound I/O support
11 %bcond_with     arts            # aRts sound I/O support
12 %bcond_with     portaudio       # PortAudio sound I/O support
13 %bcond_without  pulseaudio      # PulseAudio sound I/O support
14 %bcond_without  static_libs     # static library
15 #
16 Summary:        Audio/Video real-time streaming
17 Summary(pl.UTF-8):      Przesyłanie strumieni audio/video w czasie rzeczywistym 
18 Name:           mediastreamer
19 Version:        2.16.1
20 Release:        5
21 License:        GPL v2+
22 Group:          Libraries
23 Source0:        https://linphone.org/releases/sources/mediastreamer/%{name}-%{version}.tar.gz
24 # Source0-md5:  15b8b129a922180855d04d58cdd08d43
25 Patch0:         build.patch
26 Patch1:         libsrtp2.patch
27 URL:            http://www.linphone.org/technical-corner/mediastreamer2/overview
28 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
29 BuildRequires:  SDL-devel >= 1.2.0
30 %{?with_alsa:BuildRequires:     alsa-lib-devel}
31 %{?with_arts:BuildRequires:     artsc-devel}
32 BuildRequires:  autoconf >= 2.53
33 BuildRequires:  automake >= 1:1.9
34 %{?with_bcg729:BuildRequires:   bcg729-devel >= 1.0}
35 BuildRequires:  bctoolbox-devel >= 0.4.0
36 %{?with_zrtp:BuildRequires:     bzrtp-devel >= 1.0.6}
37 BuildRequires:  doxygen
38 # libavcodec >= 51.0.0, libswscale >= 0.7.0
39 BuildRequires:  ffmpeg-devel
40 BuildRequires:  gettext-tools
41 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
42 BuildRequires:  intltool >= 0.40
43 BuildRequires:  libgsm-devel
44 %{?with_pcap:BuildRequires:     libpcap-devel}
45 BuildRequires:  libtheora-devel >= 1.0-0.alpha7
46 BuildRequires:  libtool >= 2:2
47 BuildRequires:  libupnp-devel >= 1.6
48 BuildRequires:  libupnp-devel < 1.7
49 BuildRequires:  libv4l-devel
50 BuildRequires:  libvpx-devel >= 0.9.6
51 %{?with_matroska:BuildRequires: matroska-foundation-devel}
52 BuildRequires:  opus-devel >= 0.9.0
53 BuildRequires:  ortp-devel >= 1.0.0
54 BuildRequires:  pkgconfig
55 %{?with_portaudio:BuildRequires:        portaudio-devel}
56 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.21}
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  spandsp-devel >= 0.0.6
59 BuildRequires:  speex-devel >= 1:1.2-beta3
60 BuildRequires:  speexdsp-devel >= 1.2-beta3
61 %{?with_srtp:BuildRequires:     libsrtp2-devel}
62 BuildRequires:  xorg-lib-libX11-devel
63 BuildRequires:  xorg-lib-libXv-devel
64 BuildRequires:  xxd
65 %{?with_bcg729:Requires:        bcg729 >= 1.0}
66 Requires:       bctoolbox >= 0.4.0
67 %{?with_zrtp:Requires:  bzrtp >= 1.0.6}
68 %{?with_opengl:Requires:        glew >= 1.5}
69 Requires:       libtheora >= 1.0-0.alpha7
70 Requires:       libupnp >= 1.6
71 Requires:       libvpx >= 0.9.6
72 Requires:       opus >= 0.9.0
73 Requires:       ortp >= 1.0.0
74 %{?with_pulseaudio:Requires:    pulseaudio-libs >= 0.9.21}
75 Requires:       spandsp >= 0.0.6
76 Requires:       speex >= 1:1.2-beta3
77 Requires:       speexdsp >= 1.2-beta3
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Mediastreamer2 is a GPL licensed library to make audio and video
82 real-time streaming and processing. Written in pure C, it is based
83 upon the oRTP library.
84
85 %description -l pl.UTF-8
86 Mediastreamer2 to udostępniona na licencji GPL biblioteka do
87 przesyłania i przetwarzania strumieni audio/video w czasie
88 rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
89
90 %package devel
91 Summary:        Header files and development documentation for mediastreamer libraries
92 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}-%{release}
95 %{?with_opengl:Requires:        OpenGL-devel}
96 %{?with_alsa:Requires:  alsa-lib-devel}
97 %{?with_bcg729:Requires:        bcg729-devel >= 1.0}
98 Requires:       bctoolbox-devel >= 0.4.0
99 %{?with_zrtp:Requires:  bzrtp-devel >= 1.0.6}
100 Requires:       ffmpeg-devel
101 %{?with_opengl:Requires:        glew-devel >= 1.5}
102 Requires:       libtheora-devel >= 1.0-0.alpha7
103 Requires:       libupnp-devel >= 1.6
104 Requires:       libupnp-devel < 1.7
105 Requires:       libv4l-devel
106 Requires:       libvpx-devel >= 0.9.6
107 %{?with_matroska:Requires:      matroska-foundation-devel}
108 Requires:       opus-devel >= 0.9.0
109 Requires:       ortp-devel >= 1.0.0
110 %{?with_portaudio:Requires:     portaudio-devel}
111 %{?with_pulseaudio:Requires:    pulseaudio-devel >= 0.9.21}
112 Requires:       spandsp-devel >= 0.0.6
113 Requires:       speex-devel >= 1:1.2-beta3
114 Requires:       speexdsp-devel >= 1.2-beta3
115 %{?with_srtp:Requires:  libsrtp2-devel}
116 Requires:       xorg-lib-libX11-devel
117 Requires:       xorg-lib-libXv-devel
118
119 %description devel
120 Header files and development documentation for mediastreamer
121 libraries.
122
123 %description devel -l pl.UTF-8
124 Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer.
125
126 %package static
127 Summary:        Static mediastreamer libraries
128 Summary(pl.UTF-8):      Statyczne biblioteki mediastreamer
129 Group:          Development/Libraries
130 Requires:       %{name}-devel = %{version}-%{release}
131
132 %description static
133 Static mediastreamer libraries.
134
135 %description static -l pl.UTF-8
136 Statyczne biblioteki mediastreamer.
137
138 %prep
139 %setup -q
140 %patch0 -p1
141 %patch1 -p1
142
143 [ ! -e gitversion.h ] && echo '#define MS2_GIT_VERSION "%{version}"' > src/gitversion.h
144
145 %build
146 %{__libtoolize}
147 %{__gettextize}
148 %{__intltoolize}
149 %{__aclocal}
150 %{__autoconf}
151 %{__autoheader}
152 %{__automake}
153 %configure \
154         --disable-strict \
155         --enable-alsa%{!?with_alsa:=no} \
156         %{?with_arts:--enable-artsc} \
157         %{?with_bcg729:--enable-bcg729} \
158         --enable-external-ortp \
159         %{!?with_opengl:--disable-glx} \
160         %{!?with_matroska:--disable-matroska} \
161         %{!?with_pcap:--disable-pcap} \
162         %{?with_portaudio:--enable-portaudio} \
163         --enable-pulseaudio%{!?with_pulseaudio:=no} \
164         --disable-silent-rules \
165         %{?with_static_libs:--enable-static} \
166         %{!?with_zrtp:--disable-zrtp} \
167         %{!?with_srtp:--with-srtp=none}
168
169 %{__make}
170
171 %install
172 rm -rf $RPM_BUILD_ROOT
173
174 %{__make} install \
175         DESTDIR=$RPM_BUILD_ROOT \
176         install_sh=/usr/bin/install
177
178 # for external plugins
179 install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
180
181 # Remove duplicated documentation
182 %{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html
183
184 %find_lang %{name}
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post   -p /sbin/ldconfig
190 %postun -p /sbin/ldconfig
191
192 %files -f %{name}.lang
193 %defattr(644,root,root,755)
194 %doc AUTHORS ChangeLog NEWS README.md
195 %attr(755,root,root) %{_bindir}/mediastream
196 %attr(755,root,root) %{_bindir}/msaudiocmp
197 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
198 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
199 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.10
200 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
201 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.10
202 %dir %{_libdir}/mediastreamer
203 %dir %{_libdir}/mediastreamer/plugins
204 %{_pixmapsdir}/nowebcamCIF.jpg
205
206 %files devel
207 %defattr(644,root,root,755)
208 %doc help/doc/html
209 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so
210 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so
211 %{_libdir}/libmediastreamer_base.la
212 %{_libdir}/libmediastreamer_voip.la
213 %{_includedir}/mediastreamer2
214 %{_pkgconfigdir}/mediastreamer.pc
215
216 %if %{with static_libs}
217 %files static
218 %defattr(644,root,root,755)
219 %{_libdir}/libmediastreamer_base.a
220 %{_libdir}/libmediastreamer_voip.a
221 %endif
This page took 0.061589 seconds and 2 git commands to generate.