]> git.pld-linux.org Git - packages/mediastreamer.git/blame_incremental - mediastreamer.spec
- updated dependencies and pcap bcond
[packages/mediastreamer.git] / mediastreamer.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without bcg729 # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
4%bcond_without srtp # SRTP (secure RTP) support
5%bcond_without zrtp # support for RFC 6189: Media Path Key Agreement for Unicast Secure RTP
6%bcond_without matroska # Matroska support via libebml2/libmatroska2
7%bcond_without opengl # X11+OpenGL rendering support
8%bcond_with pcap # audio playing from PCAP files
9# audio I/O
10%bcond_without alsa # ALSA sound I/O support
11%bcond_with arts # aRts sound I/O support
12%bcond_with portaudio # PortAudio sound I/O support
13%bcond_without pulseaudio # PulseAudio sound I/O support
14%bcond_without static_libs # static library
15#
16Summary: Audio/Video real-time streaming
17Summary(pl.UTF-8): Przesyłanie strumieni audio/video w czasie rzeczywistym
18Name: mediastreamer
19Version: 2.16.1
20Release: 5
21License: GPL v2+
22Group: Libraries
23Source0: https://linphone.org/releases/sources/mediastreamer/%{name}-%{version}.tar.gz
24# Source0-md5: 15b8b129a922180855d04d58cdd08d43
25Patch0: build.patch
26Patch1: libsrtp2.patch
27URL: http://www.linphone.org/technical-corner/mediastreamer2/overview
28%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
29BuildRequires: SDL-devel >= 1.2.0
30%{?with_alsa:BuildRequires: alsa-lib-devel}
31%{?with_arts:BuildRequires: artsc-devel}
32BuildRequires: autoconf >= 2.53
33BuildRequires: automake >= 1:1.9
34%{?with_bcg729:BuildRequires: bcg729-devel >= 1.0}
35BuildRequires: bctoolbox-devel >= 0.4.0
36%{?with_zrtp:BuildRequires: bzrtp-devel >= 1.0.6}
37BuildRequires: doxygen
38# libavcodec >= 51.0.0, libswscale >= 0.7.0
39BuildRequires: ffmpeg-devel
40BuildRequires: gettext-tools
41%{?with_opengl:BuildRequires: glew-devel >= 1.5}
42BuildRequires: intltool >= 0.40
43BuildRequires: libgsm-devel
44%{?with_pcap:BuildRequires: libpcap-devel}
45BuildRequires: libtheora-devel >= 1.0-0.alpha7
46BuildRequires: libtool >= 2:2
47BuildRequires: libupnp-devel >= 1.6
48BuildRequires: libupnp-devel < 1.7
49BuildRequires: libv4l-devel
50BuildRequires: libvpx-devel >= 0.9.6
51%{?with_matroska:BuildRequires: matroska-foundation-devel}
52BuildRequires: opus-devel >= 0.9.0
53BuildRequires: ortp-devel >= 1.0.0
54BuildRequires: pkgconfig
55%{?with_portaudio:BuildRequires: portaudio-devel}
56%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9.21}
57BuildRequires: sed >= 4.0
58BuildRequires: spandsp-devel >= 0.0.6
59BuildRequires: speex-devel >= 1:1.2-beta3
60BuildRequires: speexdsp-devel >= 1.2-beta3
61%{?with_srtp:BuildRequires: libsrtp2-devel}
62BuildRequires: xorg-lib-libX11-devel
63BuildRequires: xorg-lib-libXv-devel
64BuildRequires: xxd
65%{?with_bcg729:Requires: bcg729 >= 1.0}
66Requires: bctoolbox >= 0.4.0
67%{?with_zrtp:Requires: bzrtp >= 1.0.6}
68%{?with_opengl:Requires: glew >= 1.5}
69Requires: libtheora >= 1.0-0.alpha7
70Requires: libupnp >= 1.6
71Requires: libvpx >= 0.9.6
72Requires: opus >= 0.9.0
73Requires: ortp >= 1.0.0
74%{?with_pulseaudio:Requires: pulseaudio-libs >= 0.9.21}
75Requires: spandsp >= 0.0.6
76Requires: speex >= 1:1.2-beta3
77Requires: speexdsp >= 1.2-beta3
78BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80%description
81Mediastreamer2 is a GPL licensed library to make audio and video
82real-time streaming and processing. Written in pure C, it is based
83upon the oRTP library.
84
85%description -l pl.UTF-8
86Mediastreamer2 to udostępniona na licencji GPL biblioteka do
87przesyłania i przetwarzania strumieni audio/video w czasie
88rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
89
90%package devel
91Summary: Header files and development documentation for mediastreamer libraries
92Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer
93Group: Development/Libraries
94Requires: %{name} = %{version}-%{release}
95%{?with_opengl:Requires: OpenGL-devel}
96%{?with_alsa:Requires: alsa-lib-devel}
97%{?with_bcg729:Requires: bcg729-devel >= 1.0}
98Requires: bctoolbox-devel >= 0.4.0
99%{?with_zrtp:Requires: bzrtp-devel >= 1.0.6}
100Requires: ffmpeg-devel
101%{?with_opengl:Requires: glew-devel >= 1.5}
102Requires: libtheora-devel >= 1.0-0.alpha7
103Requires: libupnp-devel >= 1.6
104Requires: libupnp-devel < 1.7
105Requires: libv4l-devel
106Requires: libvpx-devel >= 0.9.6
107%{?with_matroska:Requires: matroska-foundation-devel}
108Requires: opus-devel >= 0.9.0
109Requires: ortp-devel >= 1.0.0
110%{?with_portaudio:Requires: portaudio-devel}
111%{?with_pulseaudio:Requires: pulseaudio-devel >= 0.9.21}
112Requires: spandsp-devel >= 0.0.6
113Requires: speex-devel >= 1:1.2-beta3
114Requires: speexdsp-devel >= 1.2-beta3
115%{?with_srtp:Requires: libsrtp2-devel}
116Requires: xorg-lib-libX11-devel
117Requires: xorg-lib-libXv-devel
118
119%description devel
120Header files and development documentation for mediastreamer
121libraries.
122
123%description devel -l pl.UTF-8
124Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer.
125
126%package static
127Summary: Static mediastreamer libraries
128Summary(pl.UTF-8): Statyczne biblioteki mediastreamer
129Group: Development/Libraries
130Requires: %{name}-devel = %{version}-%{release}
131
132%description static
133Static mediastreamer libraries.
134
135%description static -l pl.UTF-8
136Statyczne biblioteki mediastreamer.
137
138%prep
139%setup -q
140%patch0 -p1
141%patch1 -p1
142
143[ ! -e gitversion.h ] && echo '#define MS2_GIT_VERSION "%{version}"' > src/gitversion.h
144
145%build
146%{__libtoolize}
147%{__gettextize}
148%{__intltoolize}
149%{__aclocal}
150%{__autoconf}
151%{__autoheader}
152%{__automake}
153%configure \
154 --disable-strict \
155 --enable-alsa%{!?with_alsa:=no} \
156 %{?with_arts:--enable-artsc} \
157 %{?with_bcg729:--enable-bcg729} \
158 --enable-external-ortp \
159 %{!?with_opengl:--disable-glx} \
160 %{!?with_matroska:--disable-matroska} \
161 %{!?with_pcap:--disable-pcap} \
162 %{?with_portaudio:--enable-portaudio} \
163 --enable-pulseaudio%{!?with_pulseaudio:=no} \
164 --disable-silent-rules \
165 %{?with_static_libs:--enable-static} \
166 %{!?with_zrtp:--disable-zrtp} \
167 %{!?with_srtp:--with-srtp=none}
168
169%{__make}
170
171%install
172rm -rf $RPM_BUILD_ROOT
173
174%{__make} install \
175 DESTDIR=$RPM_BUILD_ROOT \
176 install_sh=/usr/bin/install
177
178# for external plugins
179install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
180
181# Remove duplicated documentation
182%{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html
183
184%find_lang %{name}
185
186%clean
187rm -rf $RPM_BUILD_ROOT
188
189%post -p /sbin/ldconfig
190%postun -p /sbin/ldconfig
191
192%files -f %{name}.lang
193%defattr(644,root,root,755)
194%doc AUTHORS ChangeLog NEWS README.md
195%attr(755,root,root) %{_bindir}/mediastream
196%attr(755,root,root) %{_bindir}/msaudiocmp
197%{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
198%attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
199%attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.10
200%attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
201%attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.10
202%dir %{_libdir}/mediastreamer
203%dir %{_libdir}/mediastreamer/plugins
204%{_pixmapsdir}/nowebcamCIF.jpg
205
206%files devel
207%defattr(644,root,root,755)
208%doc help/doc/html
209%attr(755,root,root) %{_libdir}/libmediastreamer_base.so
210%attr(755,root,root) %{_libdir}/libmediastreamer_voip.so
211%{_libdir}/libmediastreamer_base.la
212%{_libdir}/libmediastreamer_voip.la
213%{_includedir}/mediastreamer2
214%{_pkgconfigdir}/mediastreamer.pc
215
216%if %{with static_libs}
217%files static
218%defattr(644,root,root,755)
219%{_libdir}/libmediastreamer_base.a
220%{_libdir}/libmediastreamer_voip.a
221%endif
This page took 0.187297 seconds and 4 git commands to generate.