]> git.pld-linux.org Git - packages/mbedtls.git/blame - mbedtls.spec
- disable one more -Werror failing build on th-i686
[packages/mbedtls.git] / mbedtls.spec
CommitLineData
875e57b3
JB
1#
2# Conditional build:
3%bcond_with zlib # zlib compression support (may reduce security, see CRIME)
4#
a3f8074d
JB
5Summary: Light-weight cryptographic and SSL/TLS library
6Summary(pl.UTF-8): Lekka biblioteka kryptograficzna oraz SSL/TLS
7Name: mbedtls
59cd7fbe 8Version: 2.26.0
bf36c92e 9Release: 1
a3f8074d
JB
10License: GPL v2+
11Group: Libraries
9874b67a
JB
12#Source0Download: https://github.com/ARMmbed/mbedtls/releases
13Source0: https://github.com/ARMmbed/mbedtls/archive/v%{version}/%{name}-%{version}.tar.gz
59cd7fbe 14# Source0-md5: 5f66a6278d469b1cca5e035786ae9ea8
9874b67a 15URL: https://www.trustedfirmware.org/projects/mbed-tls/
59cd7fbe 16BuildRequires: cmake >= 2.8.12
a3f8074d 17BuildRequires: doxygen
9874b67a 18BuildRequires: rpm-build >= 4.6
a3f8074d 19BuildRequires: rpmbuild(macros) >= 1.605
875e57b3 20%{?with_zlib:BuildRequires: zlib-devel}
a3f8074d
JB
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
9735fbf4
JB
23# some false positives for format-truncation(?)
24# for stringop-overflow see library/ssl_tls.c /stringop-overflow (workaround no longer works with gcc 11)
645d2dc1
JB
25# maybe-uninitialized fails in tests/suites/test_suite_ssl.function only on i686 builder(???)
26%define specflags -Wno-error=format-truncation -Wno-error=stringop-overflow -Wno-error=maybe-unitialized
59cd7fbe 27
a3f8074d
JB
28%description
29mbedTLS is a light-weight open source cryptographic and SSL/TLS
30library written in C. mbedTLS makes it easy for developers to include
31cryptographic and SSL/TLS capabilities in their (embedded)
32applications with as little hassle as possible.
33
34%description -l pl.UTF-8
35mbedTLS to lekka, mająca otwarte źródła biblioteka kryptograficzna
36oraz SSL/TLS napisana w C. mbedTLS ułatwia programistom dołączanie
37funkcji kryptograficznych i SSL/TLS do swoich (wbudowanych) aplikacji
38przy jak najmniejszym narzucie.
39
40%package devel
41Summary: Development files for mbedTLS
42Summary(pl.UTF-8): Pliki programistyczne biblioteki mbedTLS
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
a3f8074d
JB
45
46%description devel
47This package contains the header files for developing applications
48that use mbedTLS.
49
50%description devel -l pl.UTF-8
51Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
52wykorzystujących bibliotekę mbedTLS.
53
54%package static
55Summary: Static mbedTLS library
56Summary(pl.UTF-8): Statyczna biblioteka mbedTLS
57Group: Development/Libraries
58Requires: %{name}-devel = %{version}-%{release}
59
60%description static
61Static mbedTLS library.
62
63%description static -l pl.UTF-8
64Statyczna biblioteka mbedTLS.
65
875e57b3
JB
66%package apidocs
67Summary: API documentation for mbedTLS library
68Summary(pl.UTF-8): Dokumentacja API biblioteki mbedTLS
69Group: Documentation
9874b67a 70BuildArch: noarch
875e57b3
JB
71
72%description apidocs
73API documentation for mbedTLS library.
74
75%description apidocs -l pl.UTF-8
76Dokumentacja API biblioteki mbedTLS.
77
a3f8074d
JB
78%prep
79%setup -q
80
81%build
82install -d build
83cd build
84%cmake .. \
85 -DLIB_INSTALL_DIR:PATH=%{_libdir} \
875e57b3
JB
86 %{?with_zlib:-DENABLE_ZLIB_SUPPORT=ON} \
87 -DUSE_SHARED_MBEDTLS_LIBRARY=ON
a3f8074d
JB
88
89%{__make}
90%{__make} apidoc
91
92%if %{with tests}
93# Tests are not stable on 64-bit
94ctest --output-on-failure
95%endif
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100%{__make} -C build install \
101 DESTDIR=$RPM_BUILD_ROOT
102
103install -d $RPM_BUILD_ROOT%{_libdir}
104mv $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_libdir}/%{name}
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -p /sbin/ldconfig
110%postun -p /sbin/ldconfig
111
112%files
113%defattr(644,root,root,755)
95cbb035 114%doc ChangeLog LICENSE README.md
64c8d752 115%attr(755,root,root) %{_libdir}/libmbedcrypto.so.*.*.*
59cd7fbe 116%attr(755,root,root) %ghost %{_libdir}/libmbedcrypto.so.6
a3f8074d 117%attr(755,root,root) %{_libdir}/libmbedtls.so.*.*.*
59cd7fbe 118%attr(755,root,root) %ghost %{_libdir}/libmbedtls.so.13
64c8d752 119%attr(755,root,root) %{_libdir}/libmbedx509.so.*.*.*
59cd7fbe 120%attr(755,root,root) %ghost %{_libdir}/libmbedx509.so.1
a3f8074d
JB
121%dir %{_libdir}/%{name}
122%attr(755,root,root) %{_libdir}/%{name}/aescrypt2
123%attr(755,root,root) %{_libdir}/%{name}/benchmark
124%attr(755,root,root) %{_libdir}/%{name}/cert_app
125%attr(755,root,root) %{_libdir}/%{name}/cert_req
126%attr(755,root,root) %{_libdir}/%{name}/cert_write
127%attr(755,root,root) %{_libdir}/%{name}/crl_app
128%attr(755,root,root) %{_libdir}/%{name}/crypt_and_hash
59cd7fbe 129%attr(755,root,root) %{_libdir}/%{name}/crypto_examples
a3f8074d
JB
130%attr(755,root,root) %{_libdir}/%{name}/dh_client
131%attr(755,root,root) %{_libdir}/%{name}/dh_genprime
132%attr(755,root,root) %{_libdir}/%{name}/dh_server
64c8d752
JB
133%attr(755,root,root) %{_libdir}/%{name}/dtls_client
134%attr(755,root,root) %{_libdir}/%{name}/dtls_server
59cd7fbe
JB
135%attr(755,root,root) %{_libdir}/%{name}/ecdh_curve25519
136%attr(755,root,root) %{_libdir}/%{name}/ecdsa
a3f8074d
JB
137%attr(755,root,root) %{_libdir}/%{name}/gen_entropy
138%attr(755,root,root) %{_libdir}/%{name}/gen_key
139%attr(755,root,root) %{_libdir}/%{name}/gen_random_ctr_drbg
140%attr(755,root,root) %{_libdir}/%{name}/gen_random_havege
141%attr(755,root,root) %{_libdir}/%{name}/generic_sum
142%attr(755,root,root) %{_libdir}/%{name}/hello
143%attr(755,root,root) %{_libdir}/%{name}/key_app
59cd7fbe
JB
144%attr(755,root,root) %{_libdir}/%{name}/key_app_writer
145%attr(755,root,root) %{_libdir}/%{name}/key_ladder_demo
146%attr(755,root,root) %{_libdir}/%{name}/key_ladder_demo.sh
bf36c92e 147%attr(755,root,root) %{_libdir}/%{name}/mini_client
a3f8074d 148%attr(755,root,root) %{_libdir}/%{name}/mpi_demo
a3f8074d
JB
149%attr(755,root,root) %{_libdir}/%{name}/pem2der
150%attr(755,root,root) %{_libdir}/%{name}/pk_decrypt
151%attr(755,root,root) %{_libdir}/%{name}/pk_encrypt
152%attr(755,root,root) %{_libdir}/%{name}/pk_sign
153%attr(755,root,root) %{_libdir}/%{name}/pk_verify
59cd7fbe 154%attr(755,root,root) %{_libdir}/%{name}/psa_constant_names
628fc698 155%attr(755,root,root) %{_libdir}/%{name}/query_compile_time_config
a3f8074d
JB
156%attr(755,root,root) %{_libdir}/%{name}/req_app
157%attr(755,root,root) %{_libdir}/%{name}/rsa_decrypt
158%attr(755,root,root) %{_libdir}/%{name}/rsa_encrypt
159%attr(755,root,root) %{_libdir}/%{name}/rsa_genkey
160%attr(755,root,root) %{_libdir}/%{name}/rsa_sign
59cd7fbe 161%attr(755,root,root) %{_libdir}/%{name}/rsa_sign_pss
a3f8074d 162%attr(755,root,root) %{_libdir}/%{name}/rsa_verify
59cd7fbe 163%attr(755,root,root) %{_libdir}/%{name}/rsa_verify_pss
a3f8074d 164%attr(755,root,root) %{_libdir}/%{name}/selftest
a3f8074d
JB
165%attr(755,root,root) %{_libdir}/%{name}/ssl_client1
166%attr(755,root,root) %{_libdir}/%{name}/ssl_client2
59cd7fbe 167%attr(755,root,root) %{_libdir}/%{name}/ssl_context_info
a3f8074d
JB
168%attr(755,root,root) %{_libdir}/%{name}/ssl_fork_server
169%attr(755,root,root) %{_libdir}/%{name}/ssl_mail_client
170%attr(755,root,root) %{_libdir}/%{name}/ssl_pthread_server
171%attr(755,root,root) %{_libdir}/%{name}/ssl_server
9874b67a 172%attr(755,root,root) %{_libdir}/%{name}/ssl_server2
a3f8074d 173%attr(755,root,root) %{_libdir}/%{name}/strerror
64c8d752 174%attr(755,root,root) %{_libdir}/%{name}/udp_proxy
59cd7fbe 175%attr(755,root,root) %{_libdir}/%{name}/zeroize
a3f8074d
JB
176
177%files devel
178%defattr(644,root,root,755)
64c8d752 179%attr(755,root,root) %{_libdir}/libmbedcrypto.so
a3f8074d 180%attr(755,root,root) %{_libdir}/libmbedtls.so
64c8d752
JB
181%attr(755,root,root) %{_libdir}/libmbedx509.so
182%{_includedir}/mbedtls
59cd7fbe 183%{_includedir}/psa
a3f8074d
JB
184
185%files static
186%defattr(644,root,root,755)
95cbb035 187%{_libdir}/libmbedcrypto.a
a3f8074d 188%{_libdir}/libmbedtls.a
64c8d752 189%{_libdir}/libmbedx509.a
875e57b3
JB
190
191%files apidocs
192%defattr(644,root,root,755)
193%doc apidoc/*
This page took 0.297879 seconds and 4 git commands to generate.