]> git.pld-linux.org Git - packages/mate-panel.git/blobdiff - mate-panel.spec
up to 1.18.1
[packages/mate-panel.git] / mate-panel.spec
index 540145d30ef9a2c2198a334e297914c017abf3ab..df30e33fd0b07fa7598ee6b6fa84380c9f7e61e7 100644 (file)
-# TODO
-# - docs broken, like mate-desktop
-#   fix gtk-doc building (probably missing some dtd's)
-#xsltproc -o mate-applet-clock-C.omf --stringparam db2omf.basename mate-applet-clock --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/mate/help" --stringparam db2omf.omf_in "/home/users/glen/rpm/packages/BUILD.i686-linux/mate-panel-1.5.3/help/clock/mate-applet-clock.omf.in"  `/usr/bin/pkg-config --variable db2omf mate-doc-utils` C/mate-applet-clock.xml || { rm -f "mate-applet-clock-C.omf"; exit 1; }
-#if ! test -d ar/; then mkdir ar/; fi
-#if [ -f "C/mate-applet-clock.xml" ]; then d="../"; else d="/home/users/glen/rpm/packages/BUILD.i686-linux/mate-panel-1.5.3/help/clock/"; fi; \
-#mo="ar/ar.mo"; \
-#if [ -f "${mo}" ]; then mo="../${mo}"; else mo="/home/users/glen/rpm/packages/BUILD.i686-linux/mate-panel-1.5.3/help/clock/${mo}"; fi; \
-#(cd ar/ && \
-#  `which xml2po` -m docbook -e -t "${mo}" \
-#    "${d}C/mate-applet-clock.xml" > mate-applet-clock.xml.tmp && \
-#    cp mate-applet-clock.xml.tmp mate-applet-clock.xml && rm -f mate-applet-clock.xml.tmp)
-#runtime error
-#xsltApplyStylesheet: saving to mate-applet-clock-C.omf may not be possible
-#make[3]: *** [mate-applet-clock-C.omf] Error 1
-#make[3]: *** Waiting for unfinished jobs....
-#Making all in mate-panel-applet
-#make[4]: Entering directory `/home/users/glen/rpm/BUILD/i686-linux/mate-panel-1.5.3/doc/reference/mate-panel-applet'
-#  DOC   Scanning header files
-#  DOC   Introspecting gobjects
-#libtool: link: cannot find the library `../../../libmate-panel-applet/libmate-panel-applet-3.la' or unhandled argument `../../../libmate-panel-applet/libmate-panel-applet-3.la'
-#Linking of scanner failed:
-#make[4]: *** [scan-build.stamp] Error 1
-#make[4]: Leaving directory `/home/users/
-# - check direct deps:
-#mate-panel-1.5.3-0.1.i686 marks mate-menus-libs-1.5.0-1.i686 (cap libmate-menu.so.2)
-#mate-panel-1.5.3-0.1.i686 marks mate-panel-libs-1.5.3-0.1.i686 (cap libmate-panel-applet-4.so.1)
-#mate-panel-1.5.3-0.1.i686 marks libmateweather-1.5.0-1.i686 (cap libmateweather.so.1)
-#mate-panel-1.5.3-0.1.i686 marks libmatewnck-1.5.0-1.i686 (cap libmatewnck.so.0)
-# - panel does not start:
-#(mate-panel:7862): GLib-GIO-ERROR **: Settings schema 'org.mate.caja.desktop' is not installed
-
+#
 # Conditional build:
-%bcond_with    apidocs         # disable gtk-doc
+%bcond_without apidocs         # disable gtk-doc
 
 Summary:       MATE Desktop panel applets
+Summary(pl.UTF-8):     Aplety panelu dla środowiska MATE Desktop
 Name:          mate-panel
-Version:       1.5.3
-Release:       0.2
-# libs are LGPLv2+ applications GPLv2+
-License:       GPL v2+
+Version:       1.18.1
+Release:       1
+License:       LGPL v2+ (library), GPL v2+ (applets)
 Group:         X11/Applications
-Source0:       http://pub.mate-desktop.org/releases/1.5/%{name}-%{version}.tar.xz
-# Source0-md5: 72029cbcd38bee447df92c8774452bf3
-URL:           http://mate-desktop.org/
+Source0:       http://pub.mate-desktop.org/releases/1.18/%{name}-%{version}.tar.xz
+# Source0-md5: b01c3d72183b1a1e0ff627f17833c223
+Patch0:                no-xdg-menu-prefix.patch
+URL:           http://wiki.mate-desktop.org/mate-panel
+BuildRequires: NetworkManager-devel >= 0.6
+BuildRequires: autoconf >= 2.53
+BuildRequires: automake >= 1:1.9
+BuildRequires: cairo-devel >= 1.0.0
+BuildRequires: dbus-devel >= 1.1.2
+BuildRequires: dbus-glib-devel >= 0.80
+BuildRequires: dconf-devel >= 0.13.4
 BuildRequires: desktop-file-utils
-BuildRequires: icon-naming-utils
+BuildRequires: docbook-dtd412-xml
+BuildRequires: gdk-pixbuf2-devel >= 2.7.1
+BuildRequires: gettext-tools >= 0.12
+BuildRequires: glib2-devel >= 1:2.36
+BuildRequires: gobject-introspection-devel >= 0.6.7
+BuildRequires: gtk+3-devel >= 3.14
+BuildRequires: gtk-doc >= 1.0
+BuildRequires: intltool >= 0.50.1
+BuildRequires: libcanberra-gtk3-devel
+BuildRequires: libmateweather-devel >= 1.17.0
+BuildRequires: librsvg-devel >= 2.36.2
+BuildRequires: libtool >= 1:1.4.3
+BuildRequires: libwnck-devel >= 3.0.0
 BuildRequires: mate-common
-BuildRequires: pkgconfig(dbus-glib-1)
-BuildRequires: pkgconfig(dconf)
-BuildRequires: pkgconfig(gobject-introspection-1.0)
-BuildRequires: pkgconfig(gsettings-desktop-schemas)
-BuildRequires: pkgconfig(gtk+-2.0)
-BuildRequires: pkgconfig(libcanberra)
-BuildRequires: pkgconfig(libmate-menu)
-BuildRequires: pkgconfig(libmatewnck)
-BuildRequires: pkgconfig(libnm-gtk)
-BuildRequires: pkgconfig(librsvg-2.0)
-BuildRequires: pkgconfig(mate-desktop-2.0)
-%{?with_apidoc:BuildRequires:  pkgconfig(mate-doc-utils)}
-BuildRequires: pkgconfig(mateweather)
-BuildRequires: pkgconfig(pango)
-BuildRequires: pkgconfig(sm)
-BuildRequires: pkgconfig(x11)
-BuildRequires: popt-devel
+BuildRequires: mate-desktop-devel >= 1.17.0
+BuildRequires: mate-menus-devel >= 1.10.0
+BuildRequires: pango-devel >= 1:1.15.4
+BuildRequires: pkgconfig
+BuildRequires: python >= 2
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(find_lang) >= 1.36
 BuildRequires: tar >= 1:1.22
+BuildRequires: xorg-lib-libICE-devel
+BuildRequires: xorg-lib-libSM-devel
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXau-devel
+BuildRequires: xorg-lib-libXrandr-devel >= 1.3.0
 BuildRequires: xz
+BuildRequires: yelp-tools
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      glib2 >= 1:2.26.0
-Requires:      gsettings-desktop-schemas
-# needed as nothing else requires it
+Requires:      dbus >= 1.1.2
+Requires:      dbus-glib >= 0.80
+Requires:      dconf >= 0.13.4
 Requires:      desktop-file-utils
+Requires:      gsettings-desktop-schemas
 Requires:      gtk-update-icon-cache
-Requires:      mate-session-manager
+Requires:      libmateweather >= 1.17.0
+Requires:      librsvg >= 2.36.2
+Requires:      libwnck >= 3.0.0
+Requires:      marco
+Requires:      mate-desktop >= 1.17.0
+Requires:      mate-menus >= 1.10.0
 Suggests:      mate-settings-daemon
 # for fish
 Requires:      fortune-mod
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-MATE Desktop panel applets
+MATE Desktop panel applets.
+
+%description -l pl.UTF-8
+Aplety panelu dla środowiska MATE Desktop.
 
 %package libs
-Summary:       Shared libraries for mate-panel
+Summary:       Shared library for MATE panel applets
+Summary(pl.UTF-8):     Biblitoteka współdzielona dla apletów panelu MATE
 License:       LGPL v2+
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      cairo >= 1.0.0
+Requires:      gdk-pixbuf2 >= 2.7.1
+Requires:      glib2 >= 1:2.36
+Requires:      gtk+3 >= 3.14
+Requires:      pango >= 1:1.15.4
+Requires:      xorg-lib-libXrandr >= 1.3.0
 
 %description libs
-Shared libraries for libmate-desktop
+Shared library for MATE panel applets.
+
+%description libs -l pl.UTF-8
+Biblitoteka współdzielona dla apletów panelu MATE.
 
 %package devel
-Summary:       Development files for mate-panel
+Summary:       Development files for libmate-panel-applet library
+Summary(pl.UTF-8):     Pliki programistyczne biblioteki libmate-panel-applet
+License:       LGPL v2+
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      glib2-devel >= 1:2.36
+Requires:      gtk+3-devel >= 3.14
 
 %description devel
-Development files for mate-panel
+Development files for libmate-panel-applet library.
+
+%description devel -l pl.UTF-8
+Pliki programistyczne biblioteki libmate-panel-applet.
 
 %package apidocs
-Summary:       mate-panel API documentation
-Summary(pl.UTF-8):     Dokumentacja API mate-panel
+Summary:       API documentation for libmate-panel-applet library
+Summary(pl.UTF-8):     Dokumentacja API biblioteki libmate-panel-applet
 Group:         Documentation
 Requires:      gtk-doc-common
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description apidocs
-mate-panel API documentation.
+API documentation for libmate-panel-applet library.
 
 %description apidocs -l pl.UTF-8
-Dokumentacja API mate-panel.
+Dokumentacja API biblioteki libmate-panel-applet.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
-NOCONFIGURE=1 ./autogen.sh
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 # libexecdir needed for gnome conflicts
 %configure \
-       --disable-scrollkeeper \
-       --disable-static \
-       --disable-schemas-compile \
-       --with-x \
+       --libexecdir=%{_libdir}/%{name} \
        --enable-network-manager \
-       --libexecdir=%{_libexecdir}/mate-panel \
-       %{?with_apidocs:--enable-gtk-doc --with-html-dir=%{_gtkdocdir}} \
+       --disable-schemas-compile \
+       --disable-silent-rules \
+       --disable-static \
+       --with-html-dir=%{_gtkdocdir} \
+       --with-x
 
-%{__make} \
-       V=1
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -138,9 +155,11 @@ desktop-file-install \
         --remove-category="MATE" \
         --add-category="X-Mate" \
         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
-$RPM_BUILD_ROOT%{_desktopdir}/mate-panel.desktop
+       $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
 
-%find_lang %{name}
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{frp,jv,ku_IQ,pms}
+
+%find_lang %{name} --with-mate --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -160,33 +179,33 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING README
+%doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/mate-desktop-item-edit
 %attr(755,root,root) %{_bindir}/mate-panel
 %attr(755,root,root) %{_bindir}/mate-panel-test-applets
-%{_mandir}/man1/*
-%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
-%{_libexecdir}/mate-panel
+%{_mandir}/man1/mate-desktop-item-edit.1*
+%{_mandir}/man1/mate-panel-test-applets.1*
+%{_mandir}/man1/mate-panel.1*
+%dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/clock-applet
+%attr(755,root,root) %{_libdir}/%{name}/fish-applet
+%attr(755,root,root) %{_libdir}/%{name}/notification-area-applet
+%attr(755,root,root) %{_libdir}/%{name}/wnck-applet
+%{_datadir}/%{name}
 %{_datadir}/glib-2.0/schemas/org.mate.panel.*.xml
-%{_desktopdir}/mate-panel.desktop
 %{_datadir}/dbus-1/services/org.mate.panel.*.service
-%{_datadir}/omf/mate-applet-fish
-%{_datadir}/omf/mate-applet-clock
-%{_iconsdir}/hicolor/*/*/*
-%{_datadir}/mate/help/mate-applet-clock
-%{_datadir}/mate/help/mate-applet-fish
-%{_datadir}/mate-panel
-%{_datadir}/mate-panelrc
+%{_desktopdir}/%{name}.desktop
+%{_iconsdir}/hicolor/*/apps/mate-panel*.*
 
 %files libs
 %defattr(644,root,root,755)
-%doc COPYING.LIB
 %attr(755,root,root) %{_libdir}/libmate-panel-applet-4.so.*.*.*
-%ghost %{_libdir}/libmate-panel-applet-4.so.1
+%attr(755,root,root) %ghost %{_libdir}/libmate-panel-applet-4.so.1
+%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
 
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/libmate-panel-applet-4.so
+%attr(755,root,root) %{_libdir}/libmate-panel-applet-4.so
 %{_includedir}/mate-panel-4.0
 %{_pkgconfigdir}/libmatepanelapplet-4.0.pc
 %{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
This page took 0.14486 seconds and 4 git commands to generate.