]> git.pld-linux.org Git - packages/mame.git/blob - mame.spec
up to 0.247
[packages/mame.git] / mame.spec
1 # TODO: is qt optional? (either as bcond, or qt-less version)
2 %define         fver    %(echo %{version} | tr -d .)
3 Summary:        MAME - Multiple Arcade Machine Emulator
4 Summary(pl.UTF-8):      MAME (Multiple Arcade Machine Emulator) - emulator wielu automatów do gier
5 Name:           mame
6 Version:        0.247
7 Release:        1
8 License:        GPL v2+ (BSD for core part, LGPL v2.1+/GPL v2+ for some drivers)
9 Group:          X11/Applications/Games
10 #Source0Download: http://www.mamedev.org/release.html
11 Source0:        https://github.com/mamedev/mame/archive/mame%{fver}/%{name}-%{version}.tar.gz
12 # Source0-md5:  ecacc3c2e0cb63432fc22510dc7bedef
13 URL:            http://www.mamedev.org/
14 BuildRequires:  OpenGL-GLU-devel
15 BuildRequires:  SDL2-devel >= 2
16 BuildRequires:  SDL2_ttf-devel >= 2
17 BuildRequires:  expat-devel >= 1.95
18 BuildRequires:  flac-devel
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  lua53-devel >= 5.3
21 BuildRequires:  pkgconfig
22 BuildRequires:  portaudio-devel
23 BuildRequires:  portmidi-devel
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  sqlite3-devel >= 3
26 BuildRequires:  unzip
27 BuildRequires:  xorg-lib-libX11-devel
28 BuildRequires:  xorg-lib-libXinerama-devel
29 BuildRequires:  zlib-devel
30 Suggests:       gmameui
31 Obsoletes:      sdlhazemd
32 Obsoletes:      sdlmame
33 Obsoletes:      xmame
34 Obsoletes:      xmame-SDL
35 Obsoletes:      xmame-qtmame
36 Obsoletes:      xmame-svgalib
37 Obsoletes:      xmame-x11
38 Obsoletes:      xmame-xmess-SDL
39 Obsoletes:      xmame-xmess-svgalib
40 Obsoletes:      xmame-xmess-x11
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %ifarch %{ix86} x32
44 # linker memory exhausted on 32-bit x86
45 %define         _enable_debug_packages  0
46 %endif
47
48 %description
49 MAME stands for Multiple Arcade Machine Emulator.
50
51 MAME's purpose is to preserve decades of video-game history. As gaming
52 technology continues to rush forward, MAME prevents these important
53 "vintage" games from being lost and forgotten. This is achieved by
54 documenting the hardware and how it functions. The source code to MAME
55 serves as this documentation. The fact that the games are playable
56 serves primarily to validate the accuracy of the documentation (how
57 else can you prove that you have recreated the hardware faithfully?).
58
59 %description -l pl.UTF-8
60 MAME to skrót od Multiple Arcade Machine Emulator - emulatora wielu
61 automatów do gier.
62
63 Celem MAME jest zachowanie dziesięcioleci historii gier wideo.
64 Jakkolwiek techonologia gier cały czas szybko się posuwa, MAME chroni
65 te ważne, "starodawne" gry od zapomnienia. Można to osiągnąć poprzez
66 dokumentowanie sprzętu i sposobu jego funkcjonowania. Kod źródłowy
67 MAME służy jako ta dokumentacja. Fakt, że w gry da się grać, służy
68 głównie sprawdzeniu dokładności dokumentacji (bo jak inaczej można
69 udowodnić wierne odtworzenie sprzętu?).
70
71 %prep
72 %setup -q -n %{name}-%{name}%{fver}
73
74 %{__sed} -i -e 's/"lua"/"lua5.3"/' scripts/src/main.lua
75
76 %build
77 %{__make} \
78 %ifarch arm ppc ppc64 s390 s390x sparc sparcv9 sparc64
79         BIGENDIAN=1 \
80 %endif
81 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
82         PTR64=1 \
83 %endif
84 %ifarch x32
85         PTR64=0 \
86         ARCHITECTURE= \
87 %endif
88         CC="%{__cc}" \
89         CXX="%{__cxx}" \
90         LD="%{__cxx}" \
91         OPT_FLAGS="%{rpmcflags} $(pkg-config --cflags lua5.3)" \
92         LDFLAGS="%{rpmldflags}" \
93         CPP11=1 \
94         OSD=sdl \
95         USE_SYSTEM_LIB_EXPAT=1 \
96         USE_SYSTEM_LIB_FLAC=1 \
97         USE_SYSTEM_LIB_JPEG=1 \
98         USE_SYSTEM_LIB_LUA=1 \
99         USE_SYSTEM_LIB_PORTAUDIO=1 \
100         USE_SYSTEM_LIB_PORTMIDI=1 \
101         USE_SYSTEM_LIB_SQLITE3=1 \
102         USE_SYSTEM_LIB_ZLIB=1 \
103         VERBOSE=1
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT%{_bindir}
108
109 install mame $RPM_BUILD_ROOT%{_bindir}/mame
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc README.md
117 %attr(755,root,root) %{_bindir}/mame
This page took 0.083317 seconds and 3 git commands to generate.