]> git.pld-linux.org Git - packages/mame.git/blame - mame.spec
- release 1
[packages/mame.git] / mame.spec
CommitLineData
3fe9f974
JB
1# TODO: is qt optional? (either as bcond, or qt-less version)
2%define fver %(echo %{version} | tr -d .)
3Summary: MAME - Multiple Arcade Machine Emulator
4Summary(pl.UTF-8): MAME (Multiple Arcade Machine Emulator) - emulator wielu automatów do gier
5Name: mame
6Version: 0.167s
572e4ceb 7Release: 1
3fe9f974
JB
8License: GPL v2+ (BSD for core part, LGPL v2.1+/GPL v2+ for some drivers)
9Group: X11/Applications/Games
10#Source0Download: http://www.mamedev.org/release.html
11Source0: http://www.mamedev.org/downloader.php?file=mame0167/%{name}%{fver}.zip
12# Source0-md5: cb2ab1cac87e6a5187d5c631d58ee3fa
13Patch0: %{name}-system-jsoncpp.patch
c4887c66 14Patch1: %{name}-c++11.patch
3fe9f974
JB
15URL: http://www.mamedev.org/
16BuildRequires: OpenGL-GLU-devel
17BuildRequires: SDL2-devel >= 2
18BuildRequires: SDL2_ttf-devel >= 2
19BuildRequires: expat-devel >= 1.95
20BuildRequires: flac-devel
21BuildRequires: libjpeg-devel
22BuildRequires: lua53-devel >= 5.3
23BuildRequires: pkgconfig
24BuildRequires: portaudio-devel
25BuildRequires: portmidi-devel
26BuildRequires: sed >= 4.0
27BuildRequires: sqlite3-devel >= 3
28BuildRequires: unzip
29BuildRequires: xorg-lib-libX11-devel
30BuildRequires: xorg-lib-libXinerama-devel
31BuildRequires: zlib-devel
32Suggests: gmameui
33Obsoletes: sdlhazemd
34Obsoletes: sdlmame
35Obsoletes: xmame
36Obsoletes: xmame-SDL
37Obsoletes: xmame-qtmame
38Obsoletes: xmame-svgalib
39Obsoletes: xmame-x11
40Obsoletes: xmame-xmess-SDL
41Obsoletes: xmame-xmess-svgalib
42Obsoletes: xmame-xmess-x11
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
18f4a813
JB
45%ifarch %{ix86} x32
46# linker memory exhausted on 32-bit x86
47%define _enable_debug_packages 0
48%endif
49
3fe9f974
JB
50%description
51MAME stands for Multiple Arcade Machine Emulator.
52
53MAME's purpose is to preserve decades of video-game history. As gaming
54technology continues to rush forward, MAME prevents these important
55"vintage" games from being lost and forgotten. This is achieved by
56documenting the hardware and how it functions. The source code to MAME
57serves as this documentation. The fact that the games are playable
58serves primarily to validate the accuracy of the documentation (how
59else can you prove that you have recreated the hardware faithfully?).
60
61%description -l pl.UTF-8
62MAME to skrót od Multiple Arcade Machine Emulator - emulatora wielu
63automatów do gier.
64
65Celem MAME jest zachowanie dziesięcioleci historii gier wideo.
66Jakkolwiek techonologia gier cały czas szybko się posuwa, MAME chroni
67te ważne, "starodawne" gry od zapomnienia. Można to osiągnąć poprzez
68dokumentowanie sprzętu i sposobu jego funkcjonowania. Kod źródłowy
69MAME służy jako ta dokumentacja. Fakt, że w gry da się grać, służy
70głównie sprawdzeniu dokładności dokumentacji (bo jak inaczej można
71udowodnić wierne odtworzenie sprzętu?).
72
73%prep
74%setup -q -c
75%{__unzip} -q mame.zip
76%patch0 -p1
c4887c66 77%patch1 -p1
3fe9f974
JB
78
79%{__sed} -i -e 's/"lua"/"lua5.3"/' scripts/src/main.lua
80
81%build
3fe9f974 82%{__make} \
3fe9f974
JB
83%ifarch arm ppc ppc64 s390 s390x sparc sparcv9 sparc64
84 BIGENDIAN=1 \
85%endif
86%ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
87 PTR64=1 \
18f4a813
JB
88%endif
89%ifarch x32
90 PTR64=0 \
91 ARCHITECTURE= \
3fe9f974
JB
92%endif
93 CC="%{__cc}" \
94 CXX="%{__cxx}" \
95 LD="%{__cxx}" \
96 OPT_FLAGS="%{rpmcflags} $(pkg-config --cflags lua5.3)" \
97 LDFLAGS="%{rpmldflags}" \
c4887c66 98 CPP11=1 \
3fe9f974
JB
99 OSD=sdl \
100 USE_SYSTEM_LIB_EXPAT=1 \
101 USE_SYSTEM_LIB_FLAC=1 \
102 USE_SYSTEM_LIB_JPEG=1 \
103 USE_SYSTEM_LIB_LUA=1 \
104 USE_SYSTEM_LIB_PORTAUDIO=1 \
105 USE_SYSTEM_LIB_PORTMIDI=1 \
106 USE_SYSTEM_LIB_SQLITE3=1 \
107 USE_SYSTEM_LIB_ZLIB=1 \
108 VERBOSE=1
3fe9f974
JB
109
110%install
111rm -rf $RPM_BUILD_ROOT
112install -d $RPM_BUILD_ROOT%{_bindir}
113
18f4a813 114%ifarch %{x8664} ppc64
c4887c66
JB
115install mame64 $RPM_BUILD_ROOT%{_bindir}/mame
116%else
117install mame $RPM_BUILD_ROOT%{_bindir}/mame
118%endif
3fe9f974
JB
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%files
124%defattr(644,root,root,755)
125%doc README.md docs/{SDL,config,floppy,hlsl,imgtool,m6502,mamelicense,newvideo,nscsi}.txt docs/luaengine.md
126%attr(755,root,root) %{_bindir}/mame
This page took 0.106206 seconds and 4 git commands to generate.