]> git.pld-linux.org Git - packages/mame.git/blame - mame.spec
disable -Werror
[packages/mame.git] / mame.spec
CommitLineData
3fe9f974
JB
1# TODO: is qt optional? (either as bcond, or qt-less version)
2%define fver %(echo %{version} | tr -d .)
3Summary: MAME - Multiple Arcade Machine Emulator
4Summary(pl.UTF-8): MAME (Multiple Arcade Machine Emulator) - emulator wielu automatów do gier
5Name: mame
c0417229 6Version: 0.247
3b04840e 7Release: 1
3fe9f974
JB
8License: GPL v2+ (BSD for core part, LGPL v2.1+/GPL v2+ for some drivers)
9Group: X11/Applications/Games
10#Source0Download: http://www.mamedev.org/release.html
3b04840e 11Source0: https://github.com/mamedev/mame/archive/mame%{fver}/%{name}-%{version}.tar.gz
c0417229 12# Source0-md5: ecacc3c2e0cb63432fc22510dc7bedef
3fe9f974
JB
13URL: http://www.mamedev.org/
14BuildRequires: OpenGL-GLU-devel
15BuildRequires: SDL2-devel >= 2
16BuildRequires: SDL2_ttf-devel >= 2
17BuildRequires: expat-devel >= 1.95
18BuildRequires: flac-devel
19BuildRequires: libjpeg-devel
20BuildRequires: lua53-devel >= 5.3
21BuildRequires: pkgconfig
22BuildRequires: portaudio-devel
23BuildRequires: portmidi-devel
24BuildRequires: sed >= 4.0
25BuildRequires: sqlite3-devel >= 3
26BuildRequires: unzip
27BuildRequires: xorg-lib-libX11-devel
28BuildRequires: xorg-lib-libXinerama-devel
29BuildRequires: zlib-devel
30Suggests: gmameui
31Obsoletes: sdlhazemd
32Obsoletes: sdlmame
33Obsoletes: xmame
34Obsoletes: xmame-SDL
35Obsoletes: xmame-qtmame
36Obsoletes: xmame-svgalib
37Obsoletes: xmame-x11
38Obsoletes: xmame-xmess-SDL
39Obsoletes: xmame-xmess-svgalib
40Obsoletes: xmame-xmess-x11
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
e44ecf82 43# linker memory exhausted on x86_64 after reaching 23GB of virt mem
18f4a813 44%define _enable_debug_packages 0
18f4a813 45
3fe9f974
JB
46%description
47MAME stands for Multiple Arcade Machine Emulator.
48
49MAME's purpose is to preserve decades of video-game history. As gaming
50technology continues to rush forward, MAME prevents these important
51"vintage" games from being lost and forgotten. This is achieved by
52documenting the hardware and how it functions. The source code to MAME
53serves as this documentation. The fact that the games are playable
54serves primarily to validate the accuracy of the documentation (how
55else can you prove that you have recreated the hardware faithfully?).
56
57%description -l pl.UTF-8
58MAME to skrót od Multiple Arcade Machine Emulator - emulatora wielu
59automatów do gier.
60
61Celem MAME jest zachowanie dziesięcioleci historii gier wideo.
62Jakkolwiek techonologia gier cały czas szybko się posuwa, MAME chroni
63te ważne, "starodawne" gry od zapomnienia. Można to osiągnąć poprzez
64dokumentowanie sprzętu i sposobu jego funkcjonowania. Kod źródłowy
65MAME służy jako ta dokumentacja. Fakt, że w gry da się grać, służy
66głównie sprawdzeniu dokładności dokumentacji (bo jak inaczej można
67udowodnić wierne odtworzenie sprzętu?).
68
69%prep
3b04840e 70%setup -q -n %{name}-%{name}%{fver}
3fe9f974
JB
71
72%{__sed} -i -e 's/"lua"/"lua5.3"/' scripts/src/main.lua
73
74%build
3fe9f974 75%{__make} \
3fe9f974
JB
76%ifarch arm ppc ppc64 s390 s390x sparc sparcv9 sparc64
77 BIGENDIAN=1 \
78%endif
79%ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
80 PTR64=1 \
18f4a813
JB
81%endif
82%ifarch x32
83 PTR64=0 \
84 ARCHITECTURE= \
3fe9f974
JB
85%endif
86 CC="%{__cc}" \
87 CXX="%{__cxx}" \
88 LD="%{__cxx}" \
89 OPT_FLAGS="%{rpmcflags} $(pkg-config --cflags lua5.3)" \
90 LDFLAGS="%{rpmldflags}" \
c4887c66 91 CPP11=1 \
d3cd3f23 92 NOWERROR=1 \
3fe9f974
JB
93 OSD=sdl \
94 USE_SYSTEM_LIB_EXPAT=1 \
95 USE_SYSTEM_LIB_FLAC=1 \
96 USE_SYSTEM_LIB_JPEG=1 \
97 USE_SYSTEM_LIB_LUA=1 \
98 USE_SYSTEM_LIB_PORTAUDIO=1 \
99 USE_SYSTEM_LIB_PORTMIDI=1 \
100 USE_SYSTEM_LIB_SQLITE3=1 \
101 USE_SYSTEM_LIB_ZLIB=1 \
102 VERBOSE=1
3fe9f974
JB
103
104%install
105rm -rf $RPM_BUILD_ROOT
106install -d $RPM_BUILD_ROOT%{_bindir}
107
c4887c66 108install mame $RPM_BUILD_ROOT%{_bindir}/mame
3fe9f974
JB
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(644,root,root,755)
3b04840e 115%doc README.md
3fe9f974 116%attr(755,root,root) %{_bindir}/mame
This page took 0.235536 seconds and 4 git commands to generate.