]> git.pld-linux.org Git - packages/luakit.git/blame - luakit.spec
- %bcond_with git: ugly hack to build the newest git version
[packages/luakit.git] / luakit.spec
CommitLineData
6299949c 1
2%bcond_with git # fetch the newest version from git
3
4%if %{with git}
5%define git_url %{?luakit_git_url}%{!?luakit_git_url:git://github.com/mason-larobina/luakit}
6%define git_branch %{?luakit_git_branch}%{!?luakit_git_branch:develop}
7%endif
8
9%define rel 1
f3205533 10Summary: WebKitGTK+ based browser
0836801b 11Summary(hu.UTF-8): WebKitGTK+ alapú böngésző
f3205533 12Name: luakit
f3b8d5b4 13Version: 2010.09.24
6299949c 14Release: %{rel}%{?with_git:.git.%(date +%s)}
d58785c7 15License: GPL v3
f3205533 16Group: Applications
17Source0: http://github.com/mason-larobina/luakit/tarball/%{version}/%{name}-%{version}.tar.gz
f3b8d5b4 18# Source0-md5: 1cf30b806f4758a1def0eabe4c86c1e2
f3205533 19Patch0: %{name}-make.patch
f3b8d5b4 20Patch1: %{name}-shebang.patch
f3205533 21URL: http://luakit.org
6299949c 22%{?with_git:BuildRequires: git-core}
f3205533 23BuildRequires: glib-devel
24BuildRequires: gtk+2-devel
25BuildRequires: gtk-webkit-devel
3734c566 26BuildRequires: help2man
27BuildRequires: libsoup-devel
f3b8d5b4 28BuildRequires: lua51
f3205533 29BuildRequires: lua51-devel
c18c77db 30Requires: dmenu
3734c566 31Requires: wget
afe787a6 32Suggests: ca-certificates
f3205533 33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36luakit is a highly configurable, micro-browser framework based on the
37WebKit web content engine and the GTK+ toolkit. It is very fast,
ac76fd81 38extensible by Lua.
f3205533 39
0836801b
ZU
40%description -l hu.UTF-8
41luakit egy magas szinten konfigurálható, micro-böngésző keretrendszer
42WebKit motorral és GTK+ grafikus felületettel. Nagyon gyors, és Lua
43nyelven bővíthető.
44
f3205533 45%prep
6299949c 46%if %{without git}
f3205533 47%setup -qc
48mv mason-larobina-%{name}-*/* .
6299949c 49%else
50%setup -Tc
51git clone %{git_url} luakit.git
52cd luakit.git; git checkout %{git_branch}; cd -
53mv luakit.git/* .
54%endif
f3205533 55
6299949c 56%if 0%{!?luakit_patched:1}
f3205533 57%patch0 -p1
f3b8d5b4 58%patch1 -p1
6299949c 59%endif
f3205533 60
61%build
62CFLAGS='%{rpmcflags}' \
63LDFLAGS='%{rpmldflags}' \
6299949c 64%{__make} \
65 PREFIX=%{_prefix}
f3205533 66
67%install
68rm -rf $RPM_BUILD_ROOT
f3205533 69%{__make} install \
6299949c 70 PREFIX=%{_prefix} \
f3205533 71 DESTDIR=$RPM_BUILD_ROOT
72
73find $RPM_BUILD_ROOT
74rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(644,root,root,755)
81%doc AUTHORS COPYING PATCHES README.md
82
83%dir %{_sysconfdir}/xdg/luakit
b3a30aad 84%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/luakit/*.lua
8ea19bd5 85%attr(755,root,root) %{_bindir}/luakit
f3205533 86%{_datadir}/luakit
b3a30aad 87%{_pixmapsdir}/luakit.png
88%{_mandir}/man1/luakit.1*
89%{_desktopdir}/luakit.desktop
This page took 1.023717 seconds and 4 git commands to generate.