]> git.pld-linux.org Git - packages/lttng-modules.git/commitdiff
- updated to 2.5.1, removed obsolete Update patches
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 23 Oct 2014 15:32:56 +0000 (17:32 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 23 Oct 2014 15:32:56 +0000 (17:32 +0200)
Update-compaction-instrumentation-to-3.16-kernel.patch [deleted file]
Update-vmscan-instrumentation-to-3.16-kernel.patch [deleted file]
lttng-modules.spec

diff --git a/Update-compaction-instrumentation-to-3.16-kernel.patch b/Update-compaction-instrumentation-to-3.16-kernel.patch
deleted file mode 100644 (file)
index 0a056a9..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-From 0007344741ef65259bc52dea72259173dfbf96c0 Mon Sep 17 00:00:00 2001
-From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
-Date: Sun, 13 Jul 2014 13:33:21 -0400
-Subject: [PATCH 2/2] Update compaction instrumentation to 3.16 kernel
-
-Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
----
- instrumentation/events/lttng-module/compaction.h | 45 +++++++++++++++++++++++-
- 1 file changed, 44 insertions(+), 1 deletion(-)
-
-diff --git a/instrumentation/events/lttng-module/compaction.h b/instrumentation/events/lttng-module/compaction.h
-index 1b237fa45ab0..22024e9ee582 100644
---- a/instrumentation/events/lttng-module/compaction.h
-+++ b/instrumentation/events/lttng-module/compaction.h
-@@ -6,6 +6,7 @@
- #include <linux/types.h>
- #include <linux/tracepoint.h>
-+#include <linux/version.h>
- #include <trace/events/gfpflags.h>
- DECLARE_EVENT_CLASS(mm_compaction_isolate_template,
-@@ -45,6 +46,48 @@ DEFINE_EVENT(mm_compaction_isolate_template, mm_compaction_isolate_freepages,
-       TP_ARGS(nr_scanned, nr_taken)
- )
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,16,0))
-+TRACE_EVENT(mm_compaction_migratepages,
-+
-+      TP_PROTO(unsigned long nr_all,
-+              int migrate_rc,
-+              struct list_head *migratepages),
-+
-+      TP_ARGS(nr_all, migrate_rc, migratepages),
-+
-+      TP_STRUCT__entry(
-+              __field(unsigned long, nr_migrated)
-+              __field(unsigned long, nr_failed)
-+      ),
-+
-+      TP_fast_assign(
-+              tp_assign(nr_migrated,
-+                      nr_all -
-+                      (migrate_rc >= 0 ? migrate_rc :
-+                              ({
-+                                      unsigned long nr_failed = 0;
-+                                      struct list_head *page_lru;
-+
-+                                      list_for_each(page_lru, migratepages)
-+                                              nr_failed++;
-+                                      nr_failed;
-+                              })))
-+              tp_assign(nr_failed,
-+                              ({
-+                                      unsigned long nr_failed = 0;
-+                                      struct list_head *page_lru;
-+
-+                                      list_for_each(page_lru, migratepages)
-+                                              nr_failed++;
-+                                      nr_failed;
-+                              }))
-+      ),
-+
-+      TP_printk("nr_migrated=%lu nr_failed=%lu",
-+              __entry->nr_migrated,
-+              __entry->nr_failed)
-+)
-+#else /* #if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,16,0)) */
- TRACE_EVENT(mm_compaction_migratepages,
-       TP_PROTO(unsigned long nr_migrated,
-@@ -66,7 +109,7 @@ TRACE_EVENT(mm_compaction_migratepages,
-               __entry->nr_migrated,
-               __entry->nr_failed)
- )
--
-+#endif /* #else #if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,16,0)) */
- #endif /* _TRACE_COMPACTION_H */
--- 
-1.8.1.2
-
diff --git a/Update-vmscan-instrumentation-to-3.16-kernel.patch b/Update-vmscan-instrumentation-to-3.16-kernel.patch
deleted file mode 100644 (file)
index 5f02270..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-From 5defe623568273e9b87da1b817e373ff087fd862 Mon Sep 17 00:00:00 2001
-From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
-Date: Sun, 13 Jul 2014 13:27:01 -0400
-Subject: [PATCH 1/2] Update vmscan instrumentation to 3.16 kernel
-
-Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
----
- instrumentation/events/lttng-module/vmscan.h | 39 ++++++++++++++++++++++++++++
- 1 file changed, 39 insertions(+)
-
-diff --git a/instrumentation/events/lttng-module/vmscan.h b/instrumentation/events/lttng-module/vmscan.h
-index 1fd50ba7c235..0b4aa56761dc 100644
---- a/instrumentation/events/lttng-module/vmscan.h
-+++ b/instrumentation/events/lttng-module/vmscan.h
-@@ -238,6 +238,44 @@ TRACE_EVENT(mm_shrink_slab_start,
-               __entry->total_scan)
- )
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,16,0))
-+TRACE_EVENT(mm_shrink_slab_end,
-+      TP_PROTO(struct shrinker *shr, int nid, int shrinker_retval,
-+              long unused_scan_cnt, long new_scan_cnt, long total_scan),
-+
-+      TP_ARGS(shr, nid, shrinker_retval, unused_scan_cnt, new_scan_cnt,
-+              total_scan),
-+
-+      TP_STRUCT__entry(
-+              __field(struct shrinker *, shr)
-+              __field(int, nid)
-+              __field(void *, shrink)
-+              __field(long, unused_scan)
-+              __field(long, new_scan)
-+              __field(int, retval)
-+              __field(long, total_scan)
-+      ),
-+
-+      TP_fast_assign(
-+              tp_assign(shr, shr)
-+              tp_assign(nid, nid)
-+              tp_assign(shrink, shr->scan_objects)
-+              tp_assign(unused_scan, unused_scan_cnt)
-+              tp_assign(new_scan, new_scan_cnt)
-+              tp_assign(retval, shrinker_retval)
-+              tp_assign(total_scan, total_scan)
-+      ),
-+
-+      TP_printk("%pF %p: nid %d unused scan count %ld new scan count %ld total_scan %ld last shrinker return val %d",
-+              __entry->shrink,
-+              __entry->shr,
-+              __entry->nid,
-+              __entry->unused_scan,
-+              __entry->new_scan,
-+              __entry->total_scan,
-+              __entry->retval)
-+)
-+#else /* #if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,16,0)) */
- TRACE_EVENT(mm_shrink_slab_end,
-       TP_PROTO(struct shrinker *shr, int shrinker_retval,
-               long unused_scan_cnt, long new_scan_cnt),
-@@ -274,6 +312,7 @@ TRACE_EVENT(mm_shrink_slab_end,
-               __entry->total_scan,
-               __entry->retval)
- )
-+#endif /* #else #if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,16,0)) */
- #endif
- DECLARE_EVENT_CLASS(mm_vmscan_lru_isolate_template,
--- 
-1.8.1.2
-
index c387fa153062ad8809a8e64ae60d135903f54cf9..637b40150c28d12c352208988ae5f5c90d4b5cbe 100644 (file)
@@ -20,19 +20,17 @@ exit 1
 %define                kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; done)
 %define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
 
-%define                rel     2
+%define                rel     1
 %define                pname   lttng-modules
 Summary:       LTTng 2.x kernel modules
 Summary(pl.UTF-8):     Moduły jądra LTTng 2.x
 Name:          %{pname}%{_alt_kernel}
-Version:       2.5.0
+Version:       2.5.1
 Release:       %{rel}@%{_kernel_ver_str}
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://lttng.org/files/lttng-modules/%{pname}-%{version}.tar.bz2
-# Source0-md5: 81e59ff62489d7a9e2a08587d3363e46
-Patch0:                Update-vmscan-instrumentation-to-3.16-kernel.patch
-Patch1:                Update-compaction-instrumentation-to-3.16-kernel.patch
+# Source0-md5: 2d99bb7311ba92e82e3b675f0b8dee7d
 URL:           http://lttng.org/
 %if %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.38
@@ -102,8 +100,6 @@ p=`pwd`\
 
 %prep
 %setup -q -n %{pname}-%{version}
-%patch0 -p1
-%patch1 -p1
 
 %build
 %{expand:%bkpkg}
This page took 0.057418 seconds and 4 git commands to generate.