]> git.pld-linux.org Git - packages/lsvpd.git/commitdiff
- added patch to allow partial functionality on unknown (non-POWER) platform master auto/th/lsvpd-1.7.15-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 24 Dec 2023 10:32:14 +0000 (11:32 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 24 Dec 2023 10:32:14 +0000 (11:32 +0100)
lsvpd-unknown-platform.patch [new file with mode: 0644]
lsvpd.spec

diff --git a/lsvpd-unknown-platform.patch b/lsvpd-unknown-platform.patch
new file mode 100644 (file)
index 0000000..5d11f1c
--- /dev/null
@@ -0,0 +1,71 @@
+--- lsvpd-1.7.15/src/internal/sys_interface/platformcollector.cpp.orig 2023-09-28 16:02:21.000000000 +0200
++++ lsvpd-1.7.15/src/internal/sys_interface/platformcollector.cpp      2023-12-24 10:49:56.027693044 +0100
+@@ -111,9 +111,6 @@ error:
+                       }
+               }
+-              if (platform_type == PF_NULL)
+-                      platform_type = PF_ERROR;
+-
+               ifs.close();
+               /* Get Service processor type */
+--- lsvpd-1.7.15/src/output/lscfg.cpp.orig     2023-09-28 16:02:21.000000000 +0200
++++ lsvpd-1.7.15/src/output/lscfg.cpp  2023-12-24 11:23:14.750198369 +0100
+@@ -754,11 +754,11 @@ int main( int argc, char** argv )
+       switch (PlatformCollector::platform_type) {
+       case PF_PSERIES_KVM_GUEST: /* Fall through */
+               rc = 0;
+-      case PF_NULL:   /* Fall through */
+       case PF_ERROR:
+               cout<< argv[0] << " is not supported on the "
+                       << platform << " platform" << endl;
+               return rc;
++      case PF_NULL:   /* Fall through */
+       default:
+               ;
+       }
+--- lsvpd-1.7.15/src/output/lsmcode.cpp.orig   2023-09-28 16:02:21.000000000 +0200
++++ lsvpd-1.7.15/src/output/lsmcode.cpp        2023-12-24 11:23:43.206710874 +0100
+@@ -579,11 +579,11 @@ int main( int argc, char** argv )
+       switch (PlatformCollector::platform_type) {
+       case PF_PSERIES_KVM_GUEST:      /* Fall through */
+               rc = 0;
+-      case PF_NULL:   /* Fall through */
+       case PF_ERROR:
+               cout<< "lsmcode is not supported on the "
+                       << platform << " platform" << endl;
+               return rc;
++      case PF_NULL:   /* Fall through */
+       default:
+               ;
+       }
+--- lsvpd-1.7.15/src/output/lsvio.cpp.orig     2023-09-28 16:02:21.000000000 +0200
++++ lsvpd-1.7.15/src/output/lsvio.cpp  2023-12-24 11:24:09.633234376 +0100
+@@ -222,11 +222,11 @@ int main( int argc, char** argv )
+       case PF_PSERIES_KVM_GUEST:      /* Fall through */
+       case PF_OPAL:           /* Fall through */
+               rc = 0;
+-      case PF_NULL:   /* Fall through */
+       case PF_ERROR:
+               cout<< "lsvio is not supported on the "
+                       << platform << " platform" << endl;
+               return rc;
++      case PF_NULL:   /* Fall through */
+       default:
+               ;
+       }
+--- lsvpd-1.7.15/src/output/lsvpd.cpp.orig     2023-09-28 16:02:21.000000000 +0200
++++ lsvpd-1.7.15/src/output/lsvpd.cpp  2023-12-24 11:22:31.047101795 +0100
+@@ -390,10 +390,10 @@ int main( int argc, char** argv )
+       switch (PlatformCollector::platform_type) {
+       case PF_PSERIES_KVM_GUEST:      /* Fall through */
+               rc = 0;
+-      case PF_NULL:   /* Fall through */
+       case PF_ERROR:
+               cout<< "lsvpd is not supported on the " << platform << " platform" << endl;
+               return rc;
++      case PF_NULL:   /* Fall through */
+       default:
+               ;
+       }
index 17e7f695d27a9fe751ced7a84dbf783da1f9dcfd..61edb87d5f60c18642e86668513bc71805daab26 100644 (file)
@@ -20,6 +20,7 @@ Source2:      vpdupdater.sysconfig
 # from libvpd sources
 Source3:       90-vpdupdate.rules
 Patch0:                %{name}-nortas.patch
+Patch1:                %{name}-unknown-platform.patch
 URL:           https://github.com/power-ras/lsvpd
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
@@ -62,6 +63,7 @@ wypisuje poziomy mikrokodu i firmware'u.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.143602 seconds and 4 git commands to generate.