]> git.pld-linux.org Git - packages/lsvpd.git/blob - lsvpd.spec
- up to 0.15.0, but doesn't build with current libsysfs
[packages/lsvpd.git] / lsvpd.spec
1 Summary:        VPD/hardware inventory utilities for Linux
2 Summary(pl):    Narzêdzia do inwentaryzacji VPD/sprzêtu dla Linuksa
3 Name:           lsvpd
4 Version:        0.15.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        http://dl.sourceforge.net/linux-diag/%{name}-%{version}.tar.gz
9 # Source0-md5:  1019318fa4d81c080153682c36bd5831
10 URL:            http://linux-diag.sourceforge.net/Lsvpd.html
11 BuildRequires:  perl-base
12 BuildRequires:  rpmbuild(macros) >= 1.268
13 BuildRequires:  sed >= 4.0
14 BuildRequires:  sg3_utils-devel >= 1.01
15 BuildRequires:  sysfsutils-devel >= 1.3.0-3
16 BuildRequires:  sysfsutils-devel < 2.0.0
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       /bin/bash
19 Requires:       /bin/sed
20 Requires:       /bin/sh
21 Requires:       rc-scripts
22 Requires:       sg3_utils >= 1.01
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The lsvpd package contains both the lsvpd, lscfg and lsmcode commands.
27 These commands, along with a boot-time scanning script called
28 update-device-tree, constitute a simple hardware inventory system. The
29 lsvpd command provides Vital Product Data (VPD) about hardware
30 components to higher-level serviceability tools. The lscfg command
31 provides a more human-readable format of the VPD, as well as some
32 system-specific information. lsmcode lists microcode and firmware
33 levels.
34
35 %description -l pl
36 Pakiet lsvpd zawiera polecenia lsvpd, lscfg i lsmcode. Tworz± one,
37 wraz z uruchamianym przy starcie systemu skryptem update-device-tree,
38 prosty system inwentaryzacji sprzêtu. Polecenie lsvpd dostarcza VPD
39 (Vital Product Data) o podzespo³ach sprzêtowych dla narzêdzi wy¿szego
40 poziomu. Polecenie lscfg dostarcza bardziej czyteln± dla cz³owieka
41 postaæ VPD oraz trochê informacji specyficznych dla systemu. lsmcode
42 wypisuje poziomy mikrokodu i firmware'u.
43
44 %prep
45 %setup -q
46 sed -i -e "s,#!/bin/sh,#!/bin/bash," scripts/lsvpd.in
47
48 %build
49 # disable unit-at-a-time - see src/init.h
50 %{__make} \
51         CC="%{__cc}" \
52         CFLAGS="%{rpmcflags} -fstrict-aliasing -fno-unit-at-a-time -Wall -Werror -I../lib" \
53         LDLIBS="-lsysfs -lsgutils"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
62 install debian/init.d $RPM_BUILD_ROOT/etc/rc.d/init.d/lsvpd
63 # don't install this right now.  It can crash systems.
64 rm -f $RPM_BUILD_ROOT/lib/lsvpd/pci_vpd_rom_grab
65
66 install -d $RPM_BUILD_ROOT/etc/cron.daily
67 install scripts/lsvpd.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/lsvpd
68
69 ln -sf /usr/bin/find $RPM_BUILD_ROOT/lib/lsvpd/find
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 /sbin/chkconfig --add lsvpd
76 %service lsvpd restart
77
78 %preun
79 if [ "$1" = "0" ] ; then
80         %service lsvpd stop
81         /sbin/chkconfig --del lsvpd
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 %doc NEWS README TODO docs/*.html
87 %attr(755,root,root) /sbin/lsvpd
88 %attr(755,root,root) /sbin/lscfg
89 %attr(755,root,root) /sbin/lsmcode
90 %attr(755,root,root) /sbin/lsvio
91 %attr(755,root,root) /sbin/update-lsvpd-db
92 %dir /lib/lsvpd
93 /lib/lsvpd/common.d
94 /lib/lsvpd/common-post.d
95 /lib/lsvpd/debug.bash
96 /lib/lsvpd/ide_mf.map
97 /lib/lsvpd/lscfg.d
98 /lib/lsvpd/lsmcode.d
99 /lib/lsvpd/lsvio.d
100 /lib/lsvpd/lsvpd-functions.bash
101 /lib/lsvpd/lsvpd.d
102 /lib/lsvpd/pci.ids
103 /lib/lsvpd/query.d
104 /lib/lsvpd/scan.d
105 /lib/lsvpd/scsivpd.conf
106 %attr(755,root,root) /lib/lsvpd/adapter_pci_map
107 %attr(755,root,root) /lib/lsvpd/device_handler
108 %attr(755,root,root) /lib/lsvpd/ibm_vpd_render
109 %attr(755,root,root) /lib/lsvpd/lsvpd_test
110 %attr(755,root,root) /lib/lsvpd/pci_lookup
111 %attr(755,root,root) /lib/lsvpd/pci_vpd_cap_grab
112 %attr(755,root,root) /lib/lsvpd/tdump
113 %attr(755,root,root) /lib/lsvpd/tidy_lsvpd_dbs
114 %attr(755,root,root) /lib/lsvpd/tidy_subdirs
115 %attr(755,root,root) /lib/lsvpd/update-vpd.hotplug
116 %attr(755,root,root) /lib/lsvpd/vpd-name-crosslink.hotplug
117 %attr(754,root,root) /etc/rc.d/init.d/lsvpd
118 %attr(755,root,root) /etc/cron.daily/lsvpd
119 %{_mandir}/man8/*
This page took 0.092791 seconds and 4 git commands to generate.