]> git.pld-linux.org Git - packages/lsvpd.git/blob - lsvpd.spec
- updated usb.ids path in make patch
[packages/lsvpd.git] / lsvpd.spec
1 #
2 # Conditional build:
3 %bcond_with     rtas    # RTAS support (PowerPC)
4 #
5 %ifarch ppc ppc64
6 %define with_rtas       1
7 %endif
8 Summary:        VPD/hardware inventory utilities for Linux
9 Summary(pl.UTF-8):      Narzędzia do inwentaryzacji VPD/sprzętu dla Linuksa
10 Name:           lsvpd
11 Version:        1.6.10
12 Release:        1
13 License:        GPL v2+
14 Group:          Applications/System
15 Source0:        http://downloads.sourceforge.net/linux-diag/%{name}-%{version}.tar.gz
16 # Source0-md5:  36b6378586c9566c18175d7612069e41
17 Source1:        vpdupdater.init
18 Source2:        vpdupdater.sysconfig
19 Patch0:         %{name}-make.patch
20 URL:            http://linux-diag.sourceforge.net/Lsvpd.html
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 %{?with_rtas:BuildRequires:     librtas-devel}
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:2.0
26 BuildRequires:  rpmbuild(macros) >= 1.268
27 BuildRequires:  sg3_utils-devel
28 BuildRequires:  zlib-devel
29 Requires(post,preun):   /sbin/chkconfig
30 Requires(post): /sbin/ldconfig
31 Requires:       /etc/pci.ids
32 Requires:       /etc/usb.ids
33 Requires:       rc-scripts
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The lsvpd package contains both the lsvpd, lscfg and lsmcode commands.
38 These commands, along with a boot-time scanning script called
39 update-device-tree, constitute a simple hardware inventory system. The
40 lsvpd command provides Vital Product Data (VPD) about hardware
41 components to higher-level serviceability tools. The lscfg command
42 provides a more human-readable format of the VPD, as well as some
43 system-specific information. lsmcode lists microcode and firmware
44 levels.
45
46 %description -l pl.UTF-8
47 Pakiet lsvpd zawiera polecenia lsvpd, lscfg i lsmcode. Tworzą one,
48 wraz z uruchamianym przy starcie systemu skryptem update-device-tree,
49 prosty system inwentaryzacji sprzętu. Polecenie lsvpd dostarcza VPD
50 (Vital Product Data) o podzespołach sprzętowych dla narzędzi wyższego
51 poziomu. Polecenie lscfg dostarcza bardziej czytelną dla człowieka
52 postać VPD oraz trochę informacji specyficznych dla systemu. lsmcode
53 wypisuje poziomy mikrokodu i firmware'u.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         %{!?with_rtas:ac_cv_lib_rtas_rtas_get_vpd=no}
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 install -D -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/vpdupdater
76 install -D -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/vpdupdater
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post
82 /sbin/chkconfig --add vpdupdater
83
84 %postun -p /sbin/ldconfig
85
86 %preun
87 if [ "$1" = "0" ] ; then
88         /sbin/chkconfig --del vpdupdater
89 fi
90
91 %triggerpostun -- lsvpd < 1.0.0
92 /sbin/chkconfig --del lsvpd
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS NEWS README TODO docs/*.html
97 %attr(755,root,root) %{_sbindir}/lscfg
98 %attr(755,root,root) %{_sbindir}/lsmcode
99 %attr(755,root,root) %{_sbindir}/lsvio
100 %attr(755,root,root) %{_sbindir}/lsvpd
101 %attr(755,root,root) %{_sbindir}/vpdupdate
102 %dir %{_sysconfdir}/lsvpd
103 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lsvpd/cpu_mod_conv.conf
104 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lsvpd/scsi_templates.conf
105 %attr(754,root,root) /etc/rc.d/init.d/vpdupdater
106 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vpdupdater
107 %{_mandir}/man8/lscfg.8*
108 %{_mandir}/man8/lsmcode.8*
109 %{_mandir}/man8/lsvio.8*
110 %{_mandir}/man8/lsvpd.8*
111 %{_mandir}/man8/vpdupdate.8*
This page took 0.064154 seconds and 3 git commands to generate.