]> git.pld-linux.org Git - packages/lsvpd.git/blame - lsvpd.spec
- updated to 1.7.9
[packages/lsvpd.git] / lsvpd.spec
CommitLineData
7a8d4c54
JB
1#
2# Conditional build:
3%bcond_with rtas # RTAS support (PowerPC)
4#
5%ifarch ppc ppc64
6%define with_rtas 1
7%endif
a6b33d7b 8Summary: VPD/hardware inventory utilities for Linux
40312222 9Summary(pl.UTF-8): Narzędzia do inwentaryzacji VPD/sprzętu dla Linuksa
a6b33d7b 10Name: lsvpd
efb060d6 11Version: 1.7.9
7a8d4c54 12Release: 1
c411a5ee 13License: GPL v2+ with librtas exception
a6b33d7b 14Group: Applications/System
7a8d4c54 15Source0: http://downloads.sourceforge.net/linux-diag/%{name}-%{version}.tar.gz
efb060d6 16# Source0-md5: 57b237df3f30de06d8c9fc81ecb92ca6
7a8d4c54
JB
17Source1: vpdupdater.init
18Source2: vpdupdater.sysconfig
c411a5ee
JB
19# from libvpd sources
20Source3: 90-vpdupdate.rules
21Patch0: %{name}-nortas.patch
27f7840e 22URL: http://linux-diag.sourceforge.net/Lsvpd.html
c411a5ee 23BuildRequires: autoconf >= 2.69
3ff35f2f 24BuildRequires: automake
7a8d4c54 25%{?with_rtas:BuildRequires: librtas-devel}
3ff35f2f 26BuildRequires: libstdc++-devel
7a8d4c54 27BuildRequires: libtool >= 2:2.0
efb060d6 28BuildRequires: libvpd-cxx-devel >= 2.2.6
11297fa9 29BuildRequires: rpmbuild(macros) >= 1.268
3ff35f2f 30BuildRequires: sg3_utils-devel
c411a5ee 31BuildRequires: sqlite3-devel >= 3
3ff35f2f 32BuildRequires: zlib-devel
a6b33d7b 33Requires(post,preun): /sbin/chkconfig
3ff35f2f 34Requires(post): /sbin/ldconfig
4cdb445c
JB
35Requires: /lib/hwdata/pci.ids
36Requires: /lib/hwdata/usb.ids
37Requires: hwdata >= 0.243-5
00f47270 38Requires: rc-scripts
a6b33d7b
JB
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42The lsvpd package contains both the lsvpd, lscfg and lsmcode commands.
43These commands, along with a boot-time scanning script called
44update-device-tree, constitute a simple hardware inventory system. The
45lsvpd command provides Vital Product Data (VPD) about hardware
46components to higher-level serviceability tools. The lscfg command
47provides a more human-readable format of the VPD, as well as some
48system-specific information. lsmcode lists microcode and firmware
49levels.
50
a018b7aa
JR
51%description -l pl.UTF-8
52Pakiet lsvpd zawiera polecenia lsvpd, lscfg i lsmcode. Tworzą one,
a6b33d7b 53wraz z uruchamianym przy starcie systemu skryptem update-device-tree,
a018b7aa
JR
54prosty system inwentaryzacji sprzętu. Polecenie lsvpd dostarcza VPD
55(Vital Product Data) o podzespołach sprzętowych dla narzędzi wyższego
56poziomu. Polecenie lscfg dostarcza bardziej czytelną dla człowieka
57postać VPD oraz trochę informacji specyficznych dla systemu. lsmcode
a6b33d7b
JB
58wypisuje poziomy mikrokodu i firmware'u.
59
60%prep
61%setup -q
30c21f0a 62%patch0 -p1
a6b33d7b
JB
63
64%build
3ff35f2f
JB
65%{__libtoolize}
66%{__aclocal}
67%{__autoconf}
68%{__autoheader}
69%{__automake}
7a8d4c54
JB
70%configure \
71 %{!?with_rtas:ac_cv_lib_rtas_rtas_get_vpd=no}
72%{__make}
a6b33d7b
JB
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77%{__make} install \
78 DESTDIR=$RPM_BUILD_ROOT
79
7a8d4c54
JB
80install -D -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/vpdupdater
81install -D -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/vpdupdater
c411a5ee
JB
82install -D -p %{SOURCE3} $RPM_BUILD_ROOT/lib/udev/rules.d/90-vpdupdate.rules
83
84install -d $RPM_BUILD_ROOT/var/lib/lsvpd
a6b33d7b 85
8706ca9d
JB
86%clean
87rm -rf $RPM_BUILD_ROOT
88
a6b33d7b 89%post
3ff35f2f
JB
90/sbin/chkconfig --add vpdupdater
91
92%postun -p /sbin/ldconfig
a6b33d7b
JB
93
94%preun
95if [ "$1" = "0" ] ; then
3ff35f2f 96 /sbin/chkconfig --del vpdupdater
a6b33d7b
JB
97fi
98
3ff35f2f
JB
99%triggerpostun -- lsvpd < 1.0.0
100/sbin/chkconfig --del lsvpd
101
a6b33d7b
JB
102%files
103%defattr(644,root,root,755)
c411a5ee 104%doc AUTHORS COPYING ChangeLog NEWS README
7a8d4c54
JB
105%attr(755,root,root) %{_sbindir}/lscfg
106%attr(755,root,root) %{_sbindir}/lsmcode
107%attr(755,root,root) %{_sbindir}/lsvio
108%attr(755,root,root) %{_sbindir}/lsvpd
109%attr(755,root,root) %{_sbindir}/vpdupdate
110%dir %{_sysconfdir}/lsvpd
111%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lsvpd/cpu_mod_conv.conf
112%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lsvpd/scsi_templates.conf
3ff35f2f 113%attr(754,root,root) /etc/rc.d/init.d/vpdupdater
7a8d4c54 114%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vpdupdater
c411a5ee
JB
115/lib/udev/rules.d/90-vpdupdate.rules
116%dir /var/lib/lsvpd
3ff35f2f
JB
117%{_mandir}/man8/lscfg.8*
118%{_mandir}/man8/lsmcode.8*
119%{_mandir}/man8/lsvio.8*
120%{_mandir}/man8/lsvpd.8*
121%{_mandir}/man8/vpdupdate.8*
This page took 0.104075 seconds and 4 git commands to generate.