]> git.pld-linux.org Git - packages/lsvpd.git/blame - lsvpd.spec
- does not build with C++17 standard, downgrade, rel 4
[packages/lsvpd.git] / lsvpd.spec
CommitLineData
7a8d4c54
JB
1#
2# Conditional build:
3%bcond_with rtas # RTAS support (PowerPC)
4#
5%ifarch ppc ppc64
6%define with_rtas 1
7%endif
a6b33d7b 8Summary: VPD/hardware inventory utilities for Linux
40312222 9Summary(pl.UTF-8): Narzędzia do inwentaryzacji VPD/sprzętu dla Linuksa
a6b33d7b 10Name: lsvpd
e4a77fcf 11Version: 1.7.10
c874c7a4 12Release: 4
c411a5ee 13License: GPL v2+ with librtas exception
a6b33d7b 14Group: Applications/System
7a8d4c54 15Source0: http://downloads.sourceforge.net/linux-diag/%{name}-%{version}.tar.gz
e4a77fcf 16# Source0-md5: 11c59a64c8c2d9ed691f900af32f3879
7a8d4c54
JB
17Source1: vpdupdater.init
18Source2: vpdupdater.sysconfig
c411a5ee
JB
19# from libvpd sources
20Source3: 90-vpdupdate.rules
21Patch0: %{name}-nortas.patch
27f7840e 22URL: http://linux-diag.sourceforge.net/Lsvpd.html
c411a5ee 23BuildRequires: autoconf >= 2.69
3ff35f2f 24BuildRequires: automake
7a8d4c54 25%{?with_rtas:BuildRequires: librtas-devel}
3ff35f2f 26BuildRequires: libstdc++-devel
7a8d4c54 27BuildRequires: libtool >= 2:2.0
efb060d6 28BuildRequires: libvpd-cxx-devel >= 2.2.6
11297fa9 29BuildRequires: rpmbuild(macros) >= 1.268
3ff35f2f 30BuildRequires: sg3_utils-devel
c411a5ee 31BuildRequires: sqlite3-devel >= 3
3ff35f2f 32BuildRequires: zlib-devel
a6b33d7b 33Requires(post,preun): /sbin/chkconfig
3ff35f2f 34Requires(post): /sbin/ldconfig
4cdb445c
JB
35Requires: /lib/hwdata/pci.ids
36Requires: /lib/hwdata/usb.ids
37Requires: hwdata >= 0.243-5
00f47270 38Requires: rc-scripts
a6b33d7b
JB
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42The lsvpd package contains both the lsvpd, lscfg and lsmcode commands.
43These commands, along with a boot-time scanning script called
44update-device-tree, constitute a simple hardware inventory system. The
45lsvpd command provides Vital Product Data (VPD) about hardware
46components to higher-level serviceability tools. The lscfg command
47provides a more human-readable format of the VPD, as well as some
48system-specific information. lsmcode lists microcode and firmware
49levels.
50
a018b7aa
JR
51%description -l pl.UTF-8
52Pakiet lsvpd zawiera polecenia lsvpd, lscfg i lsmcode. Tworzą one,
a6b33d7b 53wraz z uruchamianym przy starcie systemu skryptem update-device-tree,
a018b7aa
JR
54prosty system inwentaryzacji sprzętu. Polecenie lsvpd dostarcza VPD
55(Vital Product Data) o podzespołach sprzętowych dla narzędzi wyższego
56poziomu. Polecenie lscfg dostarcza bardziej czytelną dla człowieka
57postać VPD oraz trochę informacji specyficznych dla systemu. lsmcode
a6b33d7b
JB
58wypisuje poziomy mikrokodu i firmware'u.
59
60%prep
61%setup -q
30c21f0a 62%patch0 -p1
a6b33d7b
JB
63
64%build
3ff35f2f
JB
65%{__libtoolize}
66%{__aclocal}
67%{__autoconf}
68%{__autoheader}
69%{__automake}
c874c7a4 70export CXXFLAGS="%{rpmcxxflags} -std=c++11"
7a8d4c54
JB
71%configure \
72 %{!?with_rtas:ac_cv_lib_rtas_rtas_get_vpd=no}
73%{__make}
a6b33d7b
JB
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78%{__make} install \
79 DESTDIR=$RPM_BUILD_ROOT
80
7a8d4c54
JB
81install -D -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/vpdupdater
82install -D -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/vpdupdater
c411a5ee
JB
83install -D -p %{SOURCE3} $RPM_BUILD_ROOT/lib/udev/rules.d/90-vpdupdate.rules
84
85install -d $RPM_BUILD_ROOT/var/lib/lsvpd
a6b33d7b 86
8706ca9d
JB
87%clean
88rm -rf $RPM_BUILD_ROOT
89
a6b33d7b 90%post
3ff35f2f
JB
91/sbin/chkconfig --add vpdupdater
92
93%postun -p /sbin/ldconfig
a6b33d7b
JB
94
95%preun
96if [ "$1" = "0" ] ; then
3ff35f2f 97 /sbin/chkconfig --del vpdupdater
a6b33d7b
JB
98fi
99
3ff35f2f
JB
100%triggerpostun -- lsvpd < 1.0.0
101/sbin/chkconfig --del lsvpd
102
a6b33d7b
JB
103%files
104%defattr(644,root,root,755)
c411a5ee 105%doc AUTHORS COPYING ChangeLog NEWS README
7a8d4c54
JB
106%attr(755,root,root) %{_sbindir}/lscfg
107%attr(755,root,root) %{_sbindir}/lsmcode
108%attr(755,root,root) %{_sbindir}/lsvio
109%attr(755,root,root) %{_sbindir}/lsvpd
110%attr(755,root,root) %{_sbindir}/vpdupdate
111%dir %{_sysconfdir}/lsvpd
112%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lsvpd/cpu_mod_conv.conf
e4a77fcf 113%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lsvpd/nvme_templates.conf
7a8d4c54 114%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lsvpd/scsi_templates.conf
3ff35f2f 115%attr(754,root,root) /etc/rc.d/init.d/vpdupdater
7a8d4c54 116%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vpdupdater
c411a5ee
JB
117/lib/udev/rules.d/90-vpdupdate.rules
118%dir /var/lib/lsvpd
3ff35f2f
JB
119%{_mandir}/man8/lscfg.8*
120%{_mandir}/man8/lsmcode.8*
121%{_mandir}/man8/lsvio.8*
122%{_mandir}/man8/lsvpd.8*
123%{_mandir}/man8/vpdupdate.8*
This page took 0.092973 seconds and 4 git commands to generate.