]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
- pl for -opt-viewer and vim-plugin-clang
[packages/llvm.git] / llvm.spec
index b42bc1483d62817ca826414c6ad94b5ea600ec1e..f930a3047efaee2fe7adde247e048b00cbadc789 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -1,53 +1,58 @@
+# TODO:
+# - move and package:
+#      %{_datadir}/clang/bash-autocomplete.sh
+#      %{_datadir}/clang/clang-format-sublime.py - sublime plugin
+#      %{_datadir}/clang/clang-format.el - clang tools emacs integration
+#      %{_datadir}/clang/clang-include-fixer.el
+#      %{_datadir}/clang/clang-rename.el
+# - no content in doc package (it used to contain parts of clang apidocs and some examples)
+# - system isl in polly?
 #
 # Conditional build:
-%bcond_without lldb    # LLDB debugger
-%bcond_without polly   # Polly cache-locality optimization, auto-parallelism and vectorization
-%bcond_without rt      # compiler-rt libraries
-%bcond_without ocaml   # OCaml binding
-%bcond_without doc     # HTML docs and man pages
-%bcond_with    apidocs # doxygen docs (HUGE, so they are not built by default)
-%bcond_with    tests   # run tests
+%bcond_without lldb            # LLDB debugger
+%bcond_without polly           # Polly cache-locality optimization, auto-parallelism and vectorization
+%bcond_without rt              # compiler-rt libraries
+%bcond_without multilib        # compiler-rt multilib libraries
+%bcond_without ocaml           # OCaml binding
+%bcond_without doc             # HTML docs and man pages
+%bcond_with    apidocs         # doxygen docs (HUGE, so they are not built by default)
+%bcond_with    tests           # run tests
 
 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
-%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9 
+%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
 %undefine      with_ocaml
 %endif
 
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       3.6.2
-Release:       0.1
+Version:       6.0.0
+Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
-#Source0Download: http://llvm.org/releases/download.html
-Source0:       http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: 0c1ee3597d75280dee603bae9cbf5cc2
-Source1:       http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
-# Source1-md5: ff862793682f714bb7862325b9c06e20
-Source2:       http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: e3bc4eb7ba8c39a6fe90d6c988927f3c
-Source3:       http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: 51e5eb552f777b950bb0ff326e60d5f0
-Source4:       http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 09dd91d06cc0832095379d00206bc3a1
-Source5:       http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: 3ebc1dc41659fcec3db1b47d81575e06
-Source6:       http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: 7143cc4fa88851a9f9b9a03621fbb387
-Patch0:                %{name}-config.patch
-# Data files should be installed with timestamps preserved
-Patch1:                %{name}-2.6-timestamp.patch
-Patch2:                %{name}-pld.patch
-Patch3:                %{name}-use-ocamlfind-for-ocamldoc.patch
-Patch4:                %{name}-lldb.patch
-Patch5:                %{name}-lldb-atomic.patch
-Patch6:                %{name}-lld-link.patch
+#Source0Download: http://releases.llvm.org/download.html
+Source0:       http://releases.llvm.org/%{version}/%{name}-%{version}.src.tar.xz
+# Source0-md5: 788a11a35fa62eb008019b37187d09d2
+Source1:       http://releases.llvm.org/%{version}/cfe-%{version}.src.tar.xz
+# Source1-md5: 121b3896cb0c7765d690acc5d9495d24
+Source2:       http://releases.llvm.org/%{version}/compiler-rt-%{version}.src.tar.xz
+# Source2-md5: ba6368e894b5528e527d86a69d8533c6
+Source3:       http://releases.llvm.org/%{version}/lldb-%{version}.src.tar.xz
+# Source3-md5: 1ec6498066e273b7261270f344b68121
+Source4:       http://releases.llvm.org/%{version}/polly-%{version}.src.tar.xz
+# Source4-md5: e5808a3a1ed1c23f56dd1854b86689d0
+Source5:       http://releases.llvm.org/%{version}/clang-tools-extra-%{version}.src.tar.xz
+# Source5-md5: 6b1d543116dab5a3caba10091d983743
+Source6:       http://releases.llvm.org/%{version}/lld-%{version}.src.tar.xz
+# Source6-md5: 7ab2612417477b03538f11cd8b5e12f8
+Patch1:                %{name}-pld.patch
+Patch3:                x32-gcc-toolchain.patch
+Patch4:                cmake-buildtype.patch
+Patch5:                %{name}-ocaml-shared.patch
 URL:           http://llvm.org/
-BuildRequires: autoconf >= 2.60
-BuildRequires: automake >= 1:1.9.6
 BuildRequires: bash
 BuildRequires: bison
+BuildRequires: cmake >= 3.4.3
 BuildRequires: flex
 BuildRequires: gcc >= 5:3.4
 # gcc4 might be installed, but not current __cc
@@ -58,48 +63,63 @@ BuildRequires:      __cc >= 3.4
 BuildRequires: glibc-devel(x86_64)
 %endif
 BuildRequires: groff
+BuildRequires: libedit-devel
 BuildRequires: libltdl-devel
-BuildRequires: libtool >= 2:1.5.22
 BuildRequires: libstdc++-devel >= 5:3.4
+BuildRequires: ncurses-devel
 %if %{with ocaml}
-BuildRequires: ocaml-ctypes-devel
+BuildRequires: ocaml >= 4.00.0
+BuildRequires: ocaml-ctypes-devel >= 0.4
 BuildRequires: ocaml-findlib
 BuildRequires: ocaml-ocamldoc
-BuildRequires: ocaml-ounit
+BuildRequires: ocaml-ounit >= 2
 %endif
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: perl-tools-pod
+BuildRequires: python >= 1:2.7
 BuildRequires: rpm-pythonprov
 %{?with_doc:BuildRequires:     sphinx-pdg}
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+BuildRequires: zlib-devel
 %if %{with apidocs}
 BuildRequires: doxygen
 BuildRequires: graphviz
 %endif
 %if %{with tests}
 BuildRequires: dejagnu
-BuildRequires: python
 BuildRequires: tcl-devel
 %endif
+%if %{with rt} && %{with multilib}
+%ifarch %{x8664}
+BuildRequires: gcc-c++-multilib-32
+BuildRequires: libstdc++-multilib-32-devel
+%endif
+%ifarch x32
+BuildRequires: gcc-c++-multilib-32
+BuildRequires: libstdc++-multilib-32-devel
+BuildRequires: gcc-c++-multilib-64
+BuildRequires: libstdc++-multilib-64-devel
+%endif
+%endif
 %if %{with lldb}
+BuildRequires: epydoc
 %ifarch i386 i486
 BuildRequires: libatomic-devel
 %endif
-BuildRequires: libedit-devel
 BuildRequires: libxml2-devel >= 2
 BuildRequires: ncurses-ext-devel
 BuildRequires: python-devel >= 2
+BuildRequires: swig-python >= 3.0.11
 %endif
 %if %{with polly}
-BuildRequires: cloog-isl-devel
-# >= 0.18.2-2
-BuildRequires: gmp-devel
-BuildRequires: isl-devel >= 0.14
-# optional
-BuildRequires: pluto-devel
-BuildRequires: scoplib-devel >= 0.2.1-2
-#cuda-devel
+#BuildRequires:        gmp-devel or imath-devel (private copy in polly/lib/External/isl/imath)
+# private copy in polly/lib/External/isl
+#BuildRequires:        isl-devel >= 0.18
+#TODO (bcond): cuda-devel (with POLLY_ENABLE_GPGPU_CODEGEN=ON)
+%endif
+%if %{with ocaml}
+BuildConflicts:        llvm-ocaml
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
 # LLVM is not supported on PPC64
@@ -107,13 +127,31 @@ Requires: %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                abi     6.0
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
+# ix86 and x32 - the same issue as https://llvm.org/bugs/show_bug.cgi?id=27237
+# use -gsplit-dwarf only when building packages with debuginfo
+# to avoid excessive disk space usage
+%if 0%{?_enable_debug_packages}
+%define                specflags_ia32  -gsplit-dwarf
+%define                specflags_x32   -gsplit-dwarf
+%endif
 
 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
 %define                _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
 
+# clang doesn't know -fvar-tracking-assignments, and leaving it here would pollute llvm-config
+# -Werror=format-security is for swig
+# TODO: add - -Werror=format-security to tools/lldb/scripts/LLDBWrapPython.cpp
+%define                filterout_c     -fvar-tracking-assignments
+%define                filterout_cxx   -fvar-tracking-assignments -Werror=format-security
+%define                filterout_ccpp  -fvar-tracking-assignments
+
+# std::__once_call, std::__once_callable non-function symbols
+%define                skip_post_check_so      libclang.so.* liblldb.so.*
+
 %description
 LLVM is a compiler infrastructure designed for compile-time,
 link-time, runtime, and idle-time optimization of programs from
@@ -130,16 +168,16 @@ roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
 kompilację programów w C i C++ przy użyciu frontendu clang.
 
 %package libs
-Summary:       LLVM shared library
-Summary(pl.UTF-8):     Biblioteka współdzielona LLVM-a
+Summary:       LLVM shared libraries
+Summary(pl.UTF-8):     Biblioteki współdzielone LLVM-a
 Group:         Libraries
 Conflicts:     llvm < 3.2
 
 %description libs
-LLVM shared library.
+LLVM shared libraries.
 
 %description libs -l pl.UTF-8
-Biblioteka współdzielona LLVM-a.
+Biblioteki współdzielone LLVM-a.
 
 %package devel
 Summary:       Static libraries and header files for LLVM
@@ -220,6 +258,7 @@ Summary(pl.UTF-8):  Frontend LLVM-a do języków z rodziny C
 License:       NCSA
 Group:         Development/Languages
 Requires:      %{name} = %{version}-%{release}
+Requires:      clang-libs = %{version}-%{release}
 
 %description -n clang
 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
@@ -239,6 +278,48 @@ LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
 i rozszerzaniu.
 
+%package -n clang-libs
+Summary:       Clang shared libraries
+Summary(pl.UTF-8):     Biblioteki współdzielone Clanga
+Group:         Libraries
+
+%description -n clang-libs
+Clang shared libraries.
+
+%description -n clang-libs -l pl.UTF-8
+Biblioteki współdzielone Clanga.
+
+%package -n clang-multilib
+Summary:       A C language family frontend for LLVM - 32-bit support
+Summary(pl.UTF-8):     Frontend LLVM-a do języków z rodziny C - obsługa binariów 32-bitowych
+License:       NCSA
+Group:         Development/Languages
+Requires:      clang = %{version}-%{release}
+
+%description -n clang-multilib
+clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
+of a crane or goose. 3. C-language family front-end toolkit.
+
+The goal of the Clang project is to create a new C, C++, Objective C
+and Objective C++ front-end for the LLVM compiler. Its tools are built
+as libraries and designed to be loosely-coupled and extendable.
+
+This package contains the C compiler support for producing 32-bit
+programs on 64-bit host.
+
+%description -n clang-multilib -l pl.UTF-8
+clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
+piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
+z rodziny C.
+
+Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
+LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
+budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
+i rozszerzaniu.
+
+Ten pakiet zawiera rozszerzenie kompilatora C o obsługę tworzenia
+programów 32-bitowych na maszynie 64-bitowej.
+
 %package -n clang-analyzer
 Summary:       A source code analysis framework
 Summary(pl.UTF-8):     Szkielet do analizy kodu źródłowego
@@ -344,6 +425,7 @@ Summary(pl.UTF-8):  Wydajny debugger nowej generacji
 Group:         Development/Debuggers
 URL:           http://lldb.llvm.org/
 Requires:      %{name} = %{version}-%{release}
+Requires:      python-six
 
 %description -n lldb
 LLDB is a next generation, high-performance debugger. It is built as a
@@ -377,7 +459,9 @@ Summary:    OCaml binding for LLVM
 Summary(pl.UTF-8):     Wiązanie OCamla do LLVM-a
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
+%if %{with ocaml}
 %requires_eq   ocaml-runtime
+%endif
 
 %description ocaml
 OCaml binding for LLVM.
@@ -412,85 +496,87 @@ HTML documentation for LLVM's OCaml binding.
 %description ocaml-doc -l pl.UTF-8
 Dokumentacja HTML wiązania OCamla do LLVM-a.
 
+%package opt-viewer
+Summary:       Optimization records visualization tools
+Summary(pl.UTF-8):     Narzędzia do wizualizacji rekordów optymalizacji
+Group:         Development/Tools
+Requires:      %{name} = %{version}
+BuildArch:     noarch
+
+%description opt-viewer
+Optimization records visualization tools.
+
+%description opt-viewer -l pl.UTF-8
+Narzędzia do wizualizacji rekordów optymalizacji.
+
+%package -n vim-plugin-clang
+Summary:       Clang format and rename integration for Vim
+Summary(pl.UTF-8):     Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem
+Group:         Applications/Editors/Vim
+Requires:      vim-rt >= 4:7.0
+BuildArch:     noarch
+
+%description -n vim-plugin-clang
+Clang format and rename integration for Vim.
+
+%description -n vim-plugin-clang -l pl.UTF-8
+Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
+
 %prep
 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
-mv cfe-%{version}.src tools/clang
-%{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
-%{?with_lldb:mv lldb-%{version}.src tools/lldb}
-%{?with_polly:mv polly-%{version}.src tools/polly}
-mv clang-tools-extra-%{version}.src tools/clang/tools/extra
-mv lld-%{version}.src tools/lld
-
-#%patch0 -p1
+%{__mv} cfe-%{version}.src tools/clang
+%{?with_rt:%{__mv} compiler-rt-%{version}.src projects/compiler-rt}
+%{?with_lldb:%{__mv} lldb-%{version}.src tools/lldb}
+%{?with_polly:%{__mv} polly-%{version}.src tools/polly}
+%{__mv} clang-tools-extra-%{version}.src tools/clang/tools/extra
+%{__mv} lld-%{version}.src tools/lld
+
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
-%if %{with lldb}
 %patch4 -p1
-%ifarch i386 i486
 %patch5 -p1
-%endif
-%endif
-%patch6 -p1
-
-## configure does not properly specify libdir
-#%{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
-## clang resources
-#%{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
-#%{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
 
 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python},
        s,^#!.*bin/env perl,#!%{__perl},
 }'
 
+find -name '*.py' -print0 | xargs -0 sed -i -e '1{
+       s,^#!.*bin/python.*,#!%{__python},
+}'
+
 %build
-install -d obj
-%if "%{_lib}" != "lib"
-# workaround for clang relative search paths building
-install -d obj/Release
-ln -snf lib obj/Release/%{_lib}
-%endif
-
-cd autoconf
-%{__aclocal} -I m4
-%{__autoconf} -o ../configure configure.ac
-cd ..
-%{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
-%if %{with polly}
-cd tools/polly/autoconf
-%{__aclocal} -I m4 -I ../../../autoconf/m4
-%{__autoconf} -o ../configure configure.ac
-cd ..
-%{__autoheader} -I autoconf -I autoconf/m4 -I ../../../autoconf/m4 autoconf/configure.ac
-cd ../..
-%endif
+install -d build
 
 # Disabling assertions now, rec. by pure and needed for OpenGTL
 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
-#
-# bash specific 'test a < b'
-cd obj
+cd build
 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 
-bash ../%configure \
-       --datadir=%{_datadir}/%{name}-%{version} \
-       --disable-assertions \
-       --enable-cxx11 \
-%ifarch %{ix86}
-       --disable-pic \
+%cmake \
+%if "%{_lib}" == "lib64"
+       -DLLVM_LIBDIR_SUFFIX:STRING=64 \
+%endif
+%if "%{_lib}" == "libx32"
+       -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
 %endif
-       --disable-static \
-       --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
-       --enable-debug-runtime \
 %if %{with apidocs}
-       --enable-doxygen \
+       -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
+%endif
+%if %{with doc}
+       -DLLVM_ENABLE_SPHINX:BOOL=ON \
+       -DSPHINX_WARNINGS_AS_ERRORS=OFF \
 %endif
-       --enable-experimental-targets=R600 \
-       --enable-jit \
-       --enable-optimized \
-       --enable-shared \
-       --with-pic
+       -DLLVM_ENABLE_PIC:BOOL=ON \
+       -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
+       -DLLVM_ENABLE_CXX1Y:BOOL=ON \
+       -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
+       -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
+       -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
+       -DBUILD_SHARED_LIBS:BOOL=OFF \
+       -DENABLE_LINKER_BUILD_ID:BOOL=ON \
+       -DLLVM_BINUTILS_INCDIR:STRING=%{_includedir} \
+       ../
 
 %{__make} \
        VERBOSE=1 \
@@ -502,38 +588,45 @@ bash ../%configure \
 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
 %endif
 
-cd ..
-
 %if %{with doc}
-%{__make} -C docs -f Makefile.sphinx man
-%{__make} -C tools/clang/tools/extra/docs html
+%{__make} -C docs docs-llvm-html
+%{__make} -C docs docs-llvm-man
+%if %{with ocaml}
+%{__make} -C docs ocaml_doc
+%endif
+%{__make} -C tools/clang/docs docs-clang-html
+%{__make} -C tools/clang/docs docs-clang-man
+%{__make} -C tools/lld/docs docs-lld-html
+%{__make} \
+       LD_LIBRARY_PATH=$(pwd)/%{_lib} \
+       -C tools/lldb/docs lldb-python-doc
+%{__make} -C tools/lldb/docs lldb-cpp-doc
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -C obj -j1 install \
-       PROJ_docsdir=/moredocs \
-       VERBOSE=1 \
+
+%{__make} -j1 -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# Static analyzer not installed by default:
+# only some .pyc files are created by make install
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+
+# Adjust static analyzer installation
 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
-install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
-# create launchers
-for f in scan-{build,view}; do
-       ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
-       cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
-done
-%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
-%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
-%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
-%py_postclean %{_libdir}/clang-analyzer/scan-view
-# not this OS
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/*.bat
+install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
+%{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
+%{__sed} -i -e 's,/\.\./libexec/,/../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
+%py_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
+%py_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
+%py_postclean %{_datadir}/scan-view
+
+# not installed by cmake buildsystem
+install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
 
 %if %{with doc}
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
-cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
+cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 # these tools are not installed
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
 # make links
@@ -541,18 +634,15 @@ echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
 %endif
 
 # Move documentation back to build directory
-rm -rf moredocs
-mv $RPM_BUILD_ROOT/moredocs .
-%{__rm} -v moredocs/*.tar.gz
 %if %{with ocaml}
-%{__rm} -v moredocs/ocamldoc/html/*.tar.gz
+rm -rf ocamldocs
+%{__mv} $RPM_BUILD_ROOT%{_docdir}/llvm/ocaml-html ocamldocs
 %endif
 
 # and separate the apidoc
 %if %{with apidocs}
-rm -rf apidoc clang-apidoc
-mv moredocs/html/doxygen apidoc
-cp -a tools/clang/docs/doxygen/html clang-apidoc
+rm -rf clang-apidoc
+cp -a build/tools/clang/docs/html clang-apidoc
 %endif
 
 # And prepare Clang documentation
@@ -563,16 +653,15 @@ for f in LICENSE.TXT NOTES.txt README.txt; do
 done
 
 # Get rid of erroneously installed example files.
-%{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
-# parts of test suite
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/{FileCheck,count,not}
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/linker-script-test
-
-# remove documentation makefiles:
-# they require the build directory to work
-rm -rf moredocs/examples
-cp -a examples moredocs/examples
-find moredocs/examples -name Makefile | xargs -0r rm -f
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
+# test?
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/{c-index-test,llvm-c-test}
+# not this OS
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
+# use system six
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/six.py*
+# it seems it is used internally by an extra clang tool
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -580,8 +669,8 @@ rm -rf $RPM_BUILD_ROOT
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
-%post  -n clang -p /sbin/ldconfig
-%postun        -n clang -p /sbin/ldconfig
+%post  -n clang-libs -p /sbin/ldconfig
+%postun        -n clang-libs -p /sbin/ldconfig
 
 %post  -n lldb -p /sbin/ldconfig
 %postun        -n lldb -p /sbin/ldconfig
@@ -592,37 +681,57 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/bugpoint
 %attr(755,root,root) %{_bindir}/llc
 %attr(755,root,root) %{_bindir}/lli
-%attr(755,root,root) %{_bindir}/lli-child-target
 %attr(755,root,root) %{_bindir}/llvm-ar
 %attr(755,root,root) %{_bindir}/llvm-as
 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
+%attr(755,root,root) %{_bindir}/llvm-cat
+%attr(755,root,root) %{_bindir}/llvm-cfi-verify
 %attr(755,root,root) %{_bindir}/llvm-cov
+%attr(755,root,root) %{_bindir}/llvm-cvtres
+%attr(755,root,root) %{_bindir}/llvm-cxxdump
+%attr(755,root,root) %{_bindir}/llvm-cxxfilt
 %attr(755,root,root) %{_bindir}/llvm-diff
 %attr(755,root,root) %{_bindir}/llvm-dis
+%attr(755,root,root) %{_bindir}/llvm-dlltool
 %attr(755,root,root) %{_bindir}/llvm-dsymutil
 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
+%attr(755,root,root) %{_bindir}/llvm-dwp
 %attr(755,root,root) %{_bindir}/llvm-extract
+%attr(755,root,root) %{_bindir}/llvm-lib
 %attr(755,root,root) %{_bindir}/llvm-link
+%attr(755,root,root) %{_bindir}/llvm-lto
+%attr(755,root,root) %{_bindir}/llvm-lto2
 %attr(755,root,root) %{_bindir}/llvm-mc
 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
+%attr(755,root,root) %{_bindir}/llvm-modextract
+%attr(755,root,root) %{_bindir}/llvm-mt
 %attr(755,root,root) %{_bindir}/llvm-nm
+%attr(755,root,root) %{_bindir}/llvm-objcopy
 %attr(755,root,root) %{_bindir}/llvm-objdump
+%attr(755,root,root) %{_bindir}/llvm-opt-report
+%attr(755,root,root) %{_bindir}/llvm-pdbutil
 %attr(755,root,root) %{_bindir}/llvm-profdata
 %attr(755,root,root) %{_bindir}/llvm-ranlib
+%attr(755,root,root) %{_bindir}/llvm-rc
+%attr(755,root,root) %{_bindir}/llvm-readelf
 %attr(755,root,root) %{_bindir}/llvm-readobj
 %attr(755,root,root) %{_bindir}/llvm-rtdyld
 %attr(755,root,root) %{_bindir}/llvm-size
+%attr(755,root,root) %{_bindir}/llvm-split
 %attr(755,root,root) %{_bindir}/llvm-stress
+%attr(755,root,root) %{_bindir}/llvm-strings
 %attr(755,root,root) %{_bindir}/llvm-symbolizer
 %attr(755,root,root) %{_bindir}/llvm-tblgen
-%attr(755,root,root) %{_bindir}/llvm-vtabledump
-%attr(755,root,root) %{_bindir}/macho-dump
+%attr(755,root,root) %{_bindir}/llvm-xray
 %attr(755,root,root) %{_bindir}/obj2yaml
 %attr(755,root,root) %{_bindir}/opt
+%attr(755,root,root) %{_bindir}/sancov
+%attr(755,root,root) %{_bindir}/sanstats
 %attr(755,root,root) %{_bindir}/verify-uselistorder
 %attr(755,root,root) %{_bindir}/yaml2obj
 %if %{with doc}
 %{_mandir}/man1/bugpoint.1*
+%{_mandir}/man1/dsymutil.1*
 %{_mandir}/man1/lit.1*
 %{_mandir}/man1/llc.1*
 %{_mandir}/man1/lli.1*
@@ -634,8 +743,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-dis.1*
 %{_mandir}/man1/llvm-dwarfdump.1*
 %{_mandir}/man1/llvm-extract.1*
+%{_mandir}/man1/llvm-lib.1*
 %{_mandir}/man1/llvm-link.1*
 %{_mandir}/man1/llvm-nm.1*
+%{_mandir}/man1/llvm-pdbutil.1*
 %{_mandir}/man1/llvm-profdata.1*
 %{_mandir}/man1/llvm-ranlib.1*
 %{_mandir}/man1/llvm-readobj.1*
@@ -647,29 +758,29 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libs
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
+# non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %{_libdir}/libLLVM-3.6.so
+%attr(755,root,root) %{_libdir}/libLTO.so.%{version}
+%attr(755,root,root) %ghost %{_libdir}/libLTO.so.6
+%attr(755,root,root) %{_libdir}/LLVMgold.so
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/llvm-config
-%{_libdir}/libLLVM*.a
-%ifarch %{x8664}
-%attr(755,root,root) %{_libdir}/BugpointPasses.so
+%attr(755,root,root) %{_libdir}/libLLVM.so
 %attr(755,root,root) %{_libdir}/libLTO.so
-%{_libdir}/libLTO.a
-%endif
+%attr(755,root,root) %{_libdir}/BugpointPasses.so
+%{_libdir}/libLLVM*.a
 %{_includedir}/llvm
 %{_includedir}/llvm-c
-%dir %{_datadir}/llvm
-%{_datadir}/llvm/cmake
+%{_libdir}/cmake/llvm
 %if %{with doc}
 %{_mandir}/man1/llvm-config.1*
 %endif
 
-%files doc
-%defattr(644,root,root,755)
-%doc moredocs/examples moredocs/html
+#%files doc
+#%defattr(644,root,root,755)
 
 %if %{with apidocs}
 %files apidocs
@@ -680,59 +791,103 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with polly}
 %files polly
 %defattr(644,root,root,755)
-%doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
+%doc tools/polly/{CREDITS.txt,LICENSE.txt,README} tools/polly/www/{bugs,changelog,contributors}.html
 %attr(755,root,root) %{_libdir}/LLVMPolly.so
 
 %files polly-devel
 %defattr(644,root,root,755)
+%{_libdir}/libPolly.a
+%{_libdir}/libPollyISL.a
+%{_libdir}/libPollyPPCG.a
 %{_includedir}/polly
+%{_libdir}/cmake/polly
 %endif
 
 %files -n clang
 %defattr(644,root,root,755)
 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
-%attr(755,root,root) %{_bindir}/c-index-test
 %attr(755,root,root) %{_bindir}/clang
 %attr(755,root,root) %{_bindir}/clang++
+%attr(755,root,root) %{_bindir}/clang-%{abi}
 %attr(755,root,root) %{_bindir}/clang-check
+%attr(755,root,root) %{_bindir}/clang-cl
+%attr(755,root,root) %{_bindir}/clang-cpp
 %attr(755,root,root) %{_bindir}/clang-format
-%attr(755,root,root) %{_bindir}/clang-tblgen
-%attr(755,root,root) %{_libdir}/libclang.so
+%attr(755,root,root) %{_bindir}/clang-import-test
+%attr(755,root,root) %{_bindir}/clang-offload-bundler
+%attr(755,root,root) %{_bindir}/git-clang-format
 %dir %{_libdir}/clang
 %dir %{_libdir}/clang/%{version}
 %{_libdir}/clang/%{version}/include
 %if %{with rt}
-%{_libdir}/clang/%{version}/lib
+%ifarch %{ix86} %{x8664} x32
+%dir %{_libdir}/clang/%{version}/lib
+%dir %{_libdir}/clang/%{version}/lib/linux
+%endif
+%ifarch %{ix86}
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.a
+%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
+%endif
+%ifarch %{x8664}
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
+%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
+%endif
+%ifarch %{ix86} %{x8664} x32 %{arm} aarch64 mips mips64 ppc64
+%{_libdir}/clang/%{version}/asan_blacklist.txt
+%endif
+%ifarch %{ix86} %{x8664} x32 mips64
+%{_libdir}/clang/%{version}/cfi_blacklist.txt
+%endif
+%ifarch %{x8664} x32 aarch64 mips64
+%{_libdir}/clang/%{version}/dfsan_abilist.txt
+%{_libdir}/clang/%{version}/msan_blacklist.txt
+%endif
+%endif
+%dir %{_datadir}/clang
+%{_datadir}/clang/clang-format-diff.py
+
+%files -n clang-libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libclang.so.%{abi}
+%attr(755,root,root) %ghost %{_libdir}/libclang.so.6
+
+%if %{with rt} && %{with multilib}
+%ifarch %{x8664} x32
+%files -n clang-multilib
+%defattr(644,root,root,755)
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
+%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
+%endif
+%ifarch x32
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
+%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
+%endif
 %endif
-%{_mandir}/man1/clang.1*
 
 %files -n clang-analyzer
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/scan-build
 %attr(755,root,root) %{_bindir}/scan-view
+%{_datadir}/scan-build
+%{_datadir}/scan-view
 %{_mandir}/man1/scan-build.1*
-%dir %{_libdir}/clang-analyzer
-
-%dir %{_libdir}/clang-analyzer/scan-build
-%{_libdir}/clang-analyzer/scan-build/*.css
-%{_libdir}/clang-analyzer/scan-build/*.js
-%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
-%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
-
-%dir %{_libdir}/clang-analyzer/scan-view
-%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
-%{_libdir}/clang-analyzer/scan-view/Resources
-%{_libdir}/clang-analyzer/scan-view/*.py[co]
+%dir %{_libdir}/scan-build
+%attr(755,root,root) %{_libdir}/scan-build/c++-analyzer
+%attr(755,root,root) %{_libdir}/scan-build/ccc-analyzer
 
 %files -n clang-devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libclang.so
 %{_libdir}/libclang*.a
 %{_includedir}/clang
 %{_includedir}/clang-c
+%{_libdir}/cmake/clang
 
 %files -n clang-doc
 %defattr(644,root,root,755)
-%doc tools/clang/docs/*.{css,html,png,txt}
+%doc tools/clang/docs/*.{html,png,txt}
 
 %if %{with apidocs}
 %files -n clang-apidocs
@@ -742,49 +897,65 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n clang-tools-extra
 %defattr(644,root,root,755)
-%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt,docs/_build/html/{*.html,*.js,_static}}
+%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt}
 %attr(755,root,root) %{_bindir}/clang-apply-replacements
-%attr(755,root,root) %{_bindir}/clang-modernize
+%attr(755,root,root) %{_bindir}/clang-change-namespace
+%attr(755,root,root) %{_bindir}/clang-func-mapping
+%attr(755,root,root) %{_bindir}/clang-include-fixer
 %attr(755,root,root) %{_bindir}/clang-query
+%attr(755,root,root) %{_bindir}/clang-refactor
 %attr(755,root,root) %{_bindir}/clang-rename
+%attr(755,root,root) %{_bindir}/clang-reorder-fields
 %attr(755,root,root) %{_bindir}/clang-tidy
+%attr(755,root,root) %{_bindir}/clangd
+%attr(755,root,root) %{_bindir}/find-all-symbols
+%attr(755,root,root) %{_bindir}/modularize
 %attr(755,root,root) %{_bindir}/pp-trace
-%{_libdir}/libmodernizeCore.a
+%{_datadir}/clang/clang-include-fixer.py
+%{_datadir}/clang/clang-tidy-diff.py
+%{_datadir}/clang/run-clang-tidy.py
+%{_datadir}/clang/run-find-all-symbols.py
 
 %files -n lld
 %defattr(644,root,root,755)
 %doc tools/lld/{LICENSE.TXT,README.md}
+%attr(755,root,root) %{_bindir}/ld.lld
+%attr(755,root,root) %{_bindir}/ld64.lld
 %attr(755,root,root) %{_bindir}/lld
+%attr(755,root,root) %{_bindir}/lld-link
+%attr(755,root,root) %{_bindir}/wasm-ld
 
 %files -n lld-devel
 %defattr(644,root,root,755)
-%{_libdir}/liblldConfig.a
-%{_libdir}/liblldCore.a
-%{_libdir}/liblldDriver.a
-%{_libdir}/liblldELF.a
-%{_libdir}/liblldMachO.a
-%{_libdir}/liblldNative.a
-%{_libdir}/liblldPECOFF.a
-%{_libdir}/liblldPasses.a
-%{_libdir}/liblldReaderWriter.a
-%{_libdir}/liblldYAML.a
-%{_libdir}/liblld*ELFTarget.a
+%{_libdir}/liblld[ACDEHMRWXY]*.a
 %{_includedir}/lld
 
 %if %{with lldb}
 %files -n lldb
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/lldb
-%attr(755,root,root) %{_bindir}/lldb-gdbserver
+%attr(755,root,root) %{_bindir}/lldb-argdumper
 %attr(755,root,root) %{_bindir}/lldb-mi
-%attr(755,root,root) %{_bindir}/lldb-platform
-%attr(755,root,root) %{_libdir}/liblldb.so
+%attr(755,root,root) %{_bindir}/lldb-server
+%attr(755,root,root) %{_bindir}/lldb-test
+%attr(755,root,root) %{_libdir}/liblldb.so.%{version}
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.6
+%attr(755,root,root) %{_libdir}/liblldbIntelFeatures.so.%{version}
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.6
 %dir %{py_sitedir}/lldb
+%attr(755,root,root) %{py_sitedir}/lldb/lldb-argdumper
+%{py_sitedir}/lldb/formatters
+%{py_sitedir}/lldb/runtime
+%{py_sitedir}/lldb/utils
+%{py_sitedir}/lldb/__init__.py[co]
+%{py_sitedir}/lldb/embedded_interpreter.py[co]
 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
 %attr(755,root,root) %{py_sitedir}/readline.so
 
 %files -n lldb-devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/liblldb.so
+%attr(755,root,root) %{_libdir}/liblldbIntelFeatures.so
 %{_libdir}/liblldb*.a
 %{_includedir}/lldb
 %endif
@@ -792,20 +963,30 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with ocaml}
 %files ocaml
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllllvm*.so
+%dir %{_libdir}/ocaml/llvm
+%{_libdir}/ocaml/llvm/llvm*.cma
+%{_libdir}/ocaml/llvm/llvm*.cmi
 %{_libdir}/ocaml/META.llvm*
-%attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
-%{_libdir}/ocaml/llvm*.cma
-%{_libdir}/ocaml/llvm*.cmi
 
 %files ocaml-devel
 %defattr(644,root,root,755)
-%{_libdir}/ocaml/libLLVM*.a
-%{_libdir}/ocaml/libllvm*.a
-%{_libdir}/ocaml/llvm*.a
-%{_libdir}/ocaml/llvm*.cmx*
-%{_libdir}/ocaml/llvm*.mli
+%{_libdir}/ocaml/llvm/libllvm*.a
+%{_libdir}/ocaml/llvm/llvm*.a
+%{_libdir}/ocaml/llvm/llvm*.cmx
+%{_libdir}/ocaml/llvm/llvm*.cmxa
+%{_libdir}/ocaml/llvm/llvm*.mli
 
 %files ocaml-doc
 %defattr(644,root,root,755)
-%doc moredocs/ocamldoc/html/*
+%doc ocamldocs/*
 %endif
+
+%files opt-viewer
+%defattr(644,root,root,755)
+%{_datadir}/opt-viewer
+
+%files -n vim-plugin-clang
+%defattr(644,root,root,755)
+%{_datadir}/clang/clang-format.py
+%{_datadir}/clang/clang-rename.py
This page took 0.147251 seconds and 4 git commands to generate.