]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
- package missing files
[packages/llvm.git] / llvm.spec
index d19853a41395dc764f5e1423cfacbb195b5762d9..ed9c3483d09650553de382448136c22f3885e924 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
 # - system isl in polly?
 #
 # Conditional build:
-%bcond_without lldb            # LLDB debugger
-%bcond_without polly           # Polly cache-locality optimization, auto-parallelism and vectorization
-%bcond_without rt              # compiler-rt libraries
-%bcond_without multilib        # compiler-rt multilib libraries
-%bcond_without ocaml           # OCaml binding
-%bcond_without z3              # Z3 constraint solver support in Clang Static Analyzer
-%bcond_without doc             # HTML docs and man pages
-%bcond_with    flang           # flang (Fortran18) compiler (broken as of 11.0.1)
-%bcond_with    cxxmodules      # C++20 modules (requires support in bootstrap compiler)
-%bcond_with    apidocs         # doxygen docs (HUGE, so they are not built by default)
-%bcond_with    tests           # run tests
-%bcond_with    lowmem          # lower memory requirements
+%bcond_without lldb                    # LLDB debugger
+%bcond_without polly                   # Polly cache-locality optimization, auto-parallelism and vectorization
+%bcond_without rt                      # compiler-rt libraries
+%bcond_without multilib                # compiler-rt multilib libraries
+%bcond_without ocaml                   # OCaml binding
+%bcond_without z3                      # Z3 constraint solver support in Clang Static Analyzer
+%bcond_without doc                     # HTML docs and man pages
+%bcond_without target_aarch64          # AArch64 target support
+%bcond_without target_amdgpu           # AMDGPU target support
+%bcond_without target_arm              # ARM target support
+%bcond_without target_avr              # AVR target support
+%bcond_without target_bpf              # BPF target support
+%bcond_without target_hexagon          # Hexagon target support
+%bcond_without target_lanai            # Lanai target support
+%bcond_without target_mips             # Mips target support
+%bcond_without target_msp430           # MSP430 target support
+%bcond_without target_nvptx            # NVPTX target support
+%bcond_without target_powerpc          # PowerPC target support
+%bcond_without target_riscv            # RISCV target support
+%bcond_without target_sparc            # Sparc target support
+%bcond_without target_systemz          # SystemZ target support
+%bcond_without target_webassembly      # WebAssembly target support
+%bcond_without target_x86              # X86 target support
+%bcond_without target_xcore            # XCore target support
+%bcond_with    flang                   # flang (Fortran18) compiler (broken as of 11.0.1)
+%bcond_with    cxxmodules              # C++20 modules (requires support in bootstrap compiler)
+%bcond_with    apidocs                 # doxygen docs (HUGE, so they are not built by default)
+%bcond_with    tests                   # run tests
+%bcond_with    lowmem                  # lower memory requirements
 
 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
 %define                with_lowmem             1
 %endif
 
+%define                targets_to_build        %{?with_target_aarch64:AArch64;}%{?with_target_amdgpu:AMDGPU;}%{?with_target_arm:ARM;}%{?with_target_avr:AVR;}%{?with_target_bpf:BPF;}%{?with_target_hexagon:Hexagon;}%{?with_target_lanai:Lanai;}%{?with_target_mips:Mips;}%{?with_target_msp430:MSP430;}%{?with_target_nvptx:NVPTX;}%{?with_target_powerpc:PowerPC;}%{?with_target_riscv:RISCV;}%{?with_target_sparc:Sparc;}%{?with_target_systemz:SystemZ;}%{?with_target_webassembly:WebAssembly;}%{?with_target_x86:X86;}%{?with_target_xcore:XCore;}
+
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       12.0.0
-Release:       2
+Version:       13.0.0
+Release:       3
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
 #Source0Download: https://github.com/llvm/llvm-project/releases/
 Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: ceab21c9081e122a88d82216a80d0dc0
+# Source0-md5: 8c24626dce3ee9d87d1079ebf0897db5
 Source1:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
-# Source1-md5: 877200cc072ece1a52c27677ab26e3ee
+# Source1-md5: 020cbac6e5786094fe4f96f72e290763
 Source2:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: 313e9b1caf33195cbece3ba3174115a1
+# Source2-md5: e2e136656d27d60c5f40e20260f63c07
 Source3:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: 6e1b19f825fe8535aeb740b44d815c81
+# Source3-md5: 0956c6078d1fd3bee22d064e2addd784
 Source4:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: c9b362f89ed8f2d6f9563648ecb7af66
+# Source4-md5: 4bde9e5c4d739576cf2d804d50c822d6
 Source5:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: 640967530560f7ff96e487b6d64aa6e4
+# Source5-md5: f86778fc0d97508b4d7c244d93ebf944
 Source6:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: 7368ec545a26d67dbc487706970827c1
+# Source6-md5: e4f95d6cb895ebedf2c3224585682159
 Source7:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/flang-%{version}.src.tar.xz
-# Source7-md5: 28e7993b76258a04b3eabdcd2f4eae45
-# "mlir" subdir extracted from https://github.com/llvm/llvm-project/releases/download/llvmorg-12.0.0/llvm-project-12.0.0.src.tar.xz
+# Source7-md5: 4125a570905dd2755748e6f33442b74d
+# "mlir" subdir extracted from https://github.com/llvm/llvm-project/releases/download/llvmorg-13.0.0/llvm-project-13.0.0.src.tar.xz
 Source8:       mlir-%{version}.tar.xz
-# Source8-md5: 6ec5402ada1f8b60cb8e8c023a267901
+# Source8-md5: de6a9476ef2a52b59d7c29a8bb786719
 Patch1:                %{name}-pld.patch
 Patch2:                %{name}-python-modules.patch
 Patch3:                x32-gcc-toolchain.patch
@@ -73,11 +92,13 @@ Patch4:             cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
 Patch6:                %{name}-flang.patch
 Patch7:                llvm12-build_fixes.patch
+Patch8:                %{name}-selective_bindings.patch
+Patch9:                %{name}-libexecdir.patch
 URL:           http://llvm.org/
 BuildRequires: bash
 BuildRequires: binutils-devel
 BuildRequires: bison
-BuildRequires: cmake >= 3.4.3
+BuildRequires: cmake >= 3.13.4
 BuildRequires: flex
 BuildRequires: groff
 BuildRequires: libedit-devel
@@ -95,14 +116,14 @@ BuildRequires:     ocaml-ocamldoc
 %endif
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: perl-tools-pod
-BuildRequires: python3
+BuildRequires: python3 >= 1:3
 BuildRequires: python3-PyYAML
 BuildRequires: python3-pygments >= 2.0
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.734
+BuildRequires: rpmbuild(macros) >= 1.742
 %{?with_doc:BuildRequires:     sphinx-pdg}
 BuildRequires: tar >= 1:1.22
-BuildRequires: xar-devel
+BuildRequires: xar-devel >= 1.6
 BuildRequires: xz
 %{?with_z3:BuildRequires:      z3-devel >= 4.7.1}
 BuildRequires: zlib-devel
@@ -135,7 +156,7 @@ BuildRequires:      libatomic-devel
 BuildRequires: libxml2-devel >= 2
 BuildRequires: lua-devel
 BuildRequires: ncurses-ext-devel
-BuildRequires: python3-devel
+BuildRequires: python3-devel >= 1:3.2
 %{?with_doc:BuildRequires:     python3-recommonmark}
 BuildRequires: swig-python >= 3.0.11
 BuildRequires: xz-devel
@@ -145,6 +166,7 @@ BuildRequires:      xz-devel
 # private copy in polly/lib/External/isl
 #BuildRequires:        isl-devel >= 0.22.1
 #TODO (bcond): cuda-devel (with POLLY_ENABLE_GPGPU_CODEGEN=ON)
+%{?with_target_nvptx:BuildRequires:    ocl-icd-libOpenCL-devel}
 %endif
 %if %{with ocaml}
 BuildConflicts:        llvm-ocaml
@@ -155,7 +177,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                abi     12
+%define                abi     13
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
@@ -444,6 +466,7 @@ Summary(pl.UTF-8):  Pliki programistyczne narzędzi konsolidujących LLD
 Group:         Development/Tools
 URL:           http://lld.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
+Requires:      xar-devel >= 1.6
 
 %description -n lld-devel
 Development files for LLD linker tools.
@@ -576,6 +599,8 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %patch6 -p1
 %endif
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 grep -rl /usr/bin/env projects tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python3},
@@ -627,6 +652,10 @@ export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
        -DLLVM_DEFAULT_TARGET_TRIPLE:STRING=%{_target_platform} \
 %if %{with lowmem}
        -DLLVM_PARALLEL_LINK_JOBS:STRING=1 \
+%endif
+       -DLLVM_TARGETS_TO_BUILD="%{targets_to_build}" \
+%if %{with polly}
+       %{cmake_on_off target_nvptx POLLY_ENABLE_GPGPU_CODEGEN} \
 %endif
        -DSPHINX_WARNINGS_AS_ERRORS=OFF
 
@@ -666,11 +695,10 @@ rm -rf $RPM_BUILD_ROOT
 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
 
-# Adjust static analyzer installation
-# http://clang-analyzer.llvm.org/installation#OtherPlatforms
-install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
-%{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
-%{__sed} -i -e 's,/\.\./libexec/,/../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
+# Adjust static analyzer installation (see -libexecdir patch)
+abs_ca_libexecdir="%{_libexecdir}/clang-analyzer"
+rel_ca_libexecdir="${abs_ca_libexecdir#%{_prefix}}"
+%{__sed} -i -e "s,/\.\./libexec/,/..${rel_ca_libexecdir}/," $RPM_BUILD_ROOT%{_bindir}/scan-build
 %py3_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
 %py3_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
 
@@ -680,7 +708,7 @@ install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
 %if %{with doc}
 cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 # these tools are not installed
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/FileCheck.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,clang-tblgen,lldb-tblgen}.1
 # make links
 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
 %endif
@@ -751,7 +779,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-dlltool
 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
 %attr(755,root,root) %{_bindir}/llvm-dwp
-%attr(755,root,root) %{_bindir}/llvm-elfabi
 %attr(755,root,root) %{_bindir}/llvm-exegesis
 %attr(755,root,root) %{_bindir}/llvm-extract
 %attr(755,root,root) %{_bindir}/llvm-gsymutil
@@ -773,6 +800,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-objcopy
 %attr(755,root,root) %{_bindir}/llvm-objdump
 %attr(755,root,root) %{_bindir}/llvm-opt-report
+%attr(755,root,root) %{_bindir}/llvm-otool
 %attr(755,root,root) %{_bindir}/llvm-pdbutil
 %attr(755,root,root) %{_bindir}/llvm-profdata
 %attr(755,root,root) %{_bindir}/llvm-profgen
@@ -782,14 +810,17 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-readobj
 %attr(755,root,root) %{_bindir}/llvm-reduce
 %attr(755,root,root) %{_bindir}/llvm-rtdyld
+%attr(755,root,root) %{_bindir}/llvm-sim
 %attr(755,root,root) %{_bindir}/llvm-size
 %attr(755,root,root) %{_bindir}/llvm-split
 %attr(755,root,root) %{_bindir}/llvm-strip
 %attr(755,root,root) %{_bindir}/llvm-stress
 %attr(755,root,root) %{_bindir}/llvm-strings
 %attr(755,root,root) %{_bindir}/llvm-symbolizer
+%attr(755,root,root) %{_bindir}/llvm-tapi-diff
 %attr(755,root,root) %{_bindir}/llvm-tblgen
 %attr(755,root,root) %{_bindir}/llvm-undname
+%attr(755,root,root) %{_bindir}/llvm-windres
 %attr(755,root,root) %{_bindir}/llvm-xray
 %attr(755,root,root) %{_bindir}/opt
 %attr(755,root,root) %{_bindir}/sancov
@@ -824,6 +855,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-nm.1*
 %{_mandir}/man1/llvm-objcopy.1*
 %{_mandir}/man1/llvm-objdump.1*
+%{_mandir}/man1/llvm-otool.1*
 %{_mandir}/man1/llvm-pdbutil.1*
 %{_mandir}/man1/llvm-profdata.1*
 %{_mandir}/man1/llvm-profgen.1*
@@ -835,19 +867,20 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-strings.1*
 %{_mandir}/man1/llvm-strip.1*
 %{_mandir}/man1/llvm-symbolizer.1*
+%{_mandir}/man1/llvm-tblgen.1*
 %{_mandir}/man1/opt.1*
-%{_mandir}/man1/xxx-tblgen.1*
+%{_mandir}/man1/tblgen.1*
 %endif
 
 %files libs
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/LLVMgold.so
 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
 # non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %ghost %{_libdir}/libLTO.so.12
-%attr(755,root,root) %{_libdir}/LLVMgold.so
-%attr(755,root,root) %{_libdir}/libRemarks.so.12
-%attr(755,root,root) %{_libdir}/libclang-cpp.so.12
+%attr(755,root,root) %{_libdir}/libLTO.so.13
+%attr(755,root,root) %{_libdir}/libRemarks.so.13
+%attr(755,root,root) %{_libdir}/libclang-cpp.so.13
 
 %files devel
 %defattr(644,root,root,755)
@@ -876,14 +909,15 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with polly}
 %files polly
 %defattr(644,root,root,755)
-%doc tools/polly/{CREDITS.txt,LICENSE.txt,README} tools/polly/www/{bugs,changelog,contributors}.html
+%doc tools/polly/{CREDITS.txt,LICENSE.TXT,README} tools/polly/www/{bugs,changelog,contributors}.html
 %attr(755,root,root) %{_libdir}/LLVMPolly.so
+%{?with_target_nvptx:%attr(755,root,root) %{_libdir}/libGPURuntime.so}
 
 %files polly-devel
 %defattr(644,root,root,755)
 %{_libdir}/libPolly.a
 %{_libdir}/libPollyISL.a
-%{_libdir}/libPollyPPCG.a
+%{?with_target_nvptx:%{_libdir}/libPollyPPCG.a}
 %{_includedir}/polly
 %{_libdir}/cmake/polly
 %endif
@@ -901,6 +935,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang-format
 %attr(755,root,root) %{_bindir}/clang-offload-bundler
 %attr(755,root,root) %{_bindir}/clang-offload-wrapper
+%attr(755,root,root) %{_bindir}/clang-repl
 %attr(755,root,root) %{_bindir}/git-clang-format
 %dir %{_libdir}/clang
 %dir %{_libdir}/clang/%{version}
@@ -910,7 +945,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/clang/%{version}/bin
 %attr(755,root,root) %{_libdir}/clang/%{version}/bin/hwasan_symbolize
 %endif
-%ifarch %{ix86} %{x8664} aarch64
+%ifarch %{ix86} %{x8664} aarch64 armv7hl armv7hnl
 %dir %{_libdir}/clang/%{version}/lib
 %dir %{_libdir}/clang/%{version}/lib/linux
 %dir %{_libdir}/clang/%{version}/share
@@ -939,26 +974,32 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.so
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.a.syms
 %endif
+%ifarch armv7hl armv7hnl
+%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-armhf.o
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a
+%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.so
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a.syms
+%endif
 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
-%{_libdir}/clang/%{version}/share/asan_blacklist.txt
+%{_libdir}/clang/%{version}/share/asan_ignorelist.txt
 %endif
-%ifarch %{ix86} %{x8664} mips64 aarch64
-%{_libdir}/clang/%{version}/share/cfi_blacklist.txt
+%ifarch %{ix86} %{x8664} mips64 aarch64 armv7hl armv7hnl
+%{_libdir}/clang/%{version}/share/cfi_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64 mips64
 %{_libdir}/clang/%{version}/share/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/share/msan_blacklist.txt
+%{_libdir}/clang/%{version}/share/msan_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64
-%{_libdir}/clang/%{version}/share/hwasan_blacklist.txt
+%{_libdir}/clang/%{version}/share/hwasan_ignorelist.txt
 %endif
 %ifarch x32
 %if %{with multilib}
-%{_libdir}/clang/%{version}/share/asan_blacklist.txt
-%{_libdir}/clang/%{version}/share/cfi_blacklist.txt
+%{_libdir}/clang/%{version}/share/asan_ignorelist.txt
+%{_libdir}/clang/%{version}/share/cfi_ignorelist.txt
 %{_libdir}/clang/%{version}/share/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/share/msan_blacklist.txt
-%{_libdir}/clang/%{version}/share/hwasan_blacklist.txt
+%{_libdir}/clang/%{version}/share/msan_ignorelist.txt
+%{_libdir}/clang/%{version}/share/hwasan_ignorelist.txt
 %endif
 %endif
 %endif
@@ -968,6 +1009,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n clang-libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libclang.so.%{abi}
+%attr(755,root,root) %{_libdir}/libclang.so.*.*.*
 
 %if %{with rt} && %{with multilib}
 %ifarch %{x8664} x32
@@ -987,14 +1029,25 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n clang-analyzer
 %defattr(644,root,root,755)
+%dir %{_libexecdir}/clang-analyzer
+# perl tools
 %attr(755,root,root) %{_bindir}/scan-build
-%attr(755,root,root) %{_bindir}/scan-view
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/c++-analyzer
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/ccc-analyzer
 %{_datadir}/scan-build
-%{_datadir}/scan-view
 %{_mandir}/man1/scan-build.1*
-%dir %{_libdir}/scan-build
-%attr(755,root,root) %{_libdir}/scan-build/c++-analyzer
-%attr(755,root,root) %{_libdir}/scan-build/ccc-analyzer
+# python tools
+%attr(755,root,root) %{_bindir}/analyze-build
+%attr(755,root,root) %{_bindir}/intercept-build
+%attr(755,root,root) %{_bindir}/scan-build-py
+%attr(755,root,root) %{_bindir}/scan-view
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/analyze-c++
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/analyze-cc
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-c++
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-cc
+%{_prefix}/lib/libear
+%{_prefix}/lib/libscanbuild
+%{_datadir}/scan-view
 
 %files -n clang-devel
 %defattr(644,root,root,755)
@@ -1035,9 +1088,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/hmaptool
 %attr(755,root,root) %{_bindir}/modularize
 %attr(755,root,root) %{_bindir}/pp-trace
+%attr(755,root,root) %{_bindir}/run-clang-tidy
 %{_datadir}/clang/clang-include-fixer.py
 %{_datadir}/clang/clang-tidy-diff.py
-%{_datadir}/clang/run-clang-tidy.py
 %{_datadir}/clang/run-find-all-symbols.py
 
 %files -n lld
@@ -1046,6 +1099,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ld.lld
 %attr(755,root,root) %{_bindir}/ld64.lld
 %attr(755,root,root) %{_bindir}/ld64.lld.darwinnew
+%attr(755,root,root) %{_bindir}/ld64.lld.darwinold
 %attr(755,root,root) %{_bindir}/lld
 %attr(755,root,root) %{_bindir}/lld-link
 %attr(755,root,root) %{_bindir}/wasm-ld
@@ -1065,8 +1119,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lldb-server
 %attr(755,root,root) %{_bindir}/lldb-vscode
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblldb.so.12
-%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.12
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.13
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.13
 %dir %{py3_sitedir}/lldb
 %attr(755,root,root) %{py3_sitedir}/lldb/lldb-argdumper
 %{py3_sitedir}/lldb/formatters
@@ -1074,6 +1128,10 @@ rm -rf $RPM_BUILD_ROOT
 %{py3_sitedir}/lldb/__init__.py
 %{py3_sitedir}/lldb/__pycache__
 %{py3_sitedir}/lldb/embedded_interpreter.py
+%dir %{py3_sitedir}/lldb/plugins
+%{py3_sitedir}/lldb/plugins/__pycache__
+%{py3_sitedir}/lldb/plugins/__init__.py
+%{py3_sitedir}/lldb/plugins/scripted_process.py
 %attr(755,root,root) %{py3_sitedir}/lldb/_lldb.so
 
 %files -n lldb-devel
This page took 0.093914 seconds and 4 git commands to generate.