]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
- packaged bash completion file
[packages/llvm.git] / llvm.spec
index 949611c8e536a4e8a02c8ae71334cf7082964abc..ad879d39a2aa449294e71fa2f38ffce9a5f6dc95 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -4,7 +4,6 @@
 #
 # TODO:
 # - move and package:
-#      %{_datadir}/clang/bash-autocomplete.sh
 #      %{_datadir}/clang/clang-format-sublime.py - sublime plugin
 #      %{_datadir}/clang/clang-format.el - clang tools emacs integration
 #      %{_datadir}/clang/clang-include-fixer.el
@@ -14,6 +13,8 @@
 #
 # Conditional build:
 %bcond_without lldb                    # LLDB debugger
+%bcond_without mlir                    # MLIR libraries and tools (required for Flang)
+%bcond_without flang                   # Flang (Fortran18) compiler
 %bcond_without polly                   # Polly cache-locality optimization, auto-parallelism and vectorization
 %bcond_without rt                      # compiler-rt libraries
 %bcond_without multilib                # compiler-rt multilib libraries
@@ -37,7 +38,6 @@
 %bcond_without target_webassembly      # WebAssembly target support
 %bcond_without target_x86              # X86 target support
 %bcond_without target_xcore            # XCore target support
-%bcond_with    flang                   # flang (Fortran18) compiler (broken as of 11.0.1)
 %bcond_with    cxxmodules              # C++20 modules (requires support in bootstrap compiler)
 %bcond_with    apidocs                 # doxygen docs (HUGE, so they are not built by default)
 %bcond_with    tests                   # run tests
 
 %define                targets_to_build        %{?with_target_aarch64:AArch64;}%{?with_target_amdgpu:AMDGPU;}%{?with_target_arm:ARM;}%{?with_target_avr:AVR;}%{?with_target_bpf:BPF;}%{?with_target_hexagon:Hexagon;}%{?with_target_lanai:Lanai;}%{?with_target_mips:Mips;}%{?with_target_msp430:MSP430;}%{?with_target_nvptx:NVPTX;}%{?with_target_powerpc:PowerPC;}%{?with_target_riscv:RISCV;}%{?with_target_sparc:Sparc;}%{?with_target_systemz:SystemZ;}%{?with_target_webassembly:WebAssembly;}%{?with_target_x86:X86;}%{?with_target_xcore:XCore;}
 
+%if %{without mlir}
+%undefine      with_flang
+%endif
+
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       12.0.1
-Release:       2
-License:       University of Illinois/NCSA Open Source License
+Version:       13.0.0
+Release:       3
+License:       Apache 2.0 with LLVM exceptions
 Group:         Development/Languages
 #Source0Download: https://github.com/llvm/llvm-project/releases/
 Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: 72a257604efa1d32ef85a37cd9c66873
+# Source0-md5: 8c24626dce3ee9d87d1079ebf0897db5
 Source1:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
-# Source1-md5: 03d77af27fcbeeae4414fb4713b9fd7e
+# Source1-md5: 020cbac6e5786094fe4f96f72e290763
 Source2:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: 40095daa9070b20eef9bdd32fdc53db5
+# Source2-md5: e2e136656d27d60c5f40e20260f63c07
 Source3:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: e5727e0caf947dfc5575db22d1186b9a
+# Source3-md5: 0956c6078d1fd3bee22d064e2addd784
 Source4:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 6932b855535c97283b21c07f0e9cfd79
+# Source4-md5: 4bde9e5c4d739576cf2d804d50c822d6
 Source5:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: befc3b0dbd926378f9e863b6817d4fb8
+# Source5-md5: f86778fc0d97508b4d7c244d93ebf944
 Source6:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: bb29dcdebead37a8738986d4ef616e69
+# Source6-md5: e4f95d6cb895ebedf2c3224585682159
 Source7:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/flang-%{version}.src.tar.xz
-# Source7-md5: 2cbf2687297f20467b3bd9a8a490b4be
-# "mlir" subdir extracted from https://github.com/llvm/llvm-project/releases/download/llvmorg-12.0.0/llvm-project-12.0.0.src.tar.xz
+# Source7-md5: 4125a570905dd2755748e6f33442b74d
+# "mlir" subdir extracted from https://github.com/llvm/llvm-project/releases/download/llvmorg-13.0.0/llvm-project-13.0.0.src.tar.xz
 Source8:       mlir-%{version}.tar.xz
-# Source8-md5: fca8ea96f3e3278a0e5d8c1d5d5c821e
+# Source8-md5: de6a9476ef2a52b59d7c29a8bb786719
 Patch1:                %{name}-pld.patch
 Patch2:                %{name}-python-modules.patch
 Patch3:                x32-gcc-toolchain.patch
@@ -92,7 +96,9 @@ Patch4:               cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
 Patch6:                %{name}-flang.patch
 Patch7:                llvm12-build_fixes.patch
-URL:           http://llvm.org/
+Patch8:                %{name}-selective_bindings.patch
+Patch9:                %{name}-libexecdir.patch
+URL:           https://llvm.org/
 BuildRequires: bash
 BuildRequires: binutils-devel
 BuildRequires: bison
@@ -118,10 +124,10 @@ BuildRequires:    python3 >= 1:3
 BuildRequires: python3-PyYAML
 BuildRequires: python3-pygments >= 2.0
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.734
+BuildRequires: rpmbuild(macros) >= 1.742
 %{?with_doc:BuildRequires:     sphinx-pdg}
 BuildRequires: tar >= 1:1.22
-BuildRequires: xar-devel
+BuildRequires: xar-devel >= 1.6
 BuildRequires: xz
 %{?with_z3:BuildRequires:      z3-devel >= 4.7.1}
 BuildRequires: zlib-devel
@@ -164,6 +170,7 @@ BuildRequires:      xz-devel
 # private copy in polly/lib/External/isl
 #BuildRequires:        isl-devel >= 0.22.1
 #TODO (bcond): cuda-devel (with POLLY_ENABLE_GPGPU_CODEGEN=ON)
+%{?with_target_nvptx:BuildRequires:    ocl-icd-libOpenCL-devel}
 %endif
 %if %{with ocaml}
 BuildConflicts:        llvm-ocaml
@@ -174,7 +181,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                abi     12
+%define                abi     13
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
@@ -269,11 +276,39 @@ API documentation for the LLVM compiler infrastructure.
 %description apidocs -l pl.UTF-8
 Dokumentacja API infrastruktury kompilatorów LLVM.
 
+%package mlir
+Summary:       LLVM Multi-Level Intermediate Representation libraries and tools
+Summary(pl.UTF-8):     Biblioteki i narzędzia wielopoziomowej reprezentacji pośredniej LLVM
+Group:         Development/Tools
+URL:           https://mlir.llvm.org/
+Requires:      %{name} = %{version}-%{release}
+
+%description mlir
+LLVM Multi-Level Intermediate Representation libraries and tools.
+
+%description mlir -l pl.UTF-8
+Biblioteki i narzędzia wielopoziomowej reprezentacji pośredniej LLVM.
+
+%package mlir-devel
+Summary:       LLVM Multi-Level Intermediate Representation development files
+Summary(pl.UTF-8):     Pliki do programowania z użyciem wielopoziomowej reprezentacji pośredniej LLVM
+Group:         Development/Tools
+URL:           https://mlir.llvm.org/
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-mlir = %{version}-%{release}
+
+%description mlir-devel
+LLVM Multi-Level Intermediate Representation development files.
+
+%description mlir-devel -l pl.UTF-8
+Pliki do programowania z użyciem wielopoziomowej reprezentacji
+pośredniej LLVM.
+
 %package polly
 Summary:       Polyhedral optimizations for LLVM
 Summary(pl.UTF-8):     Optymalizacje wielościanowe dla LLVM-a
 Group:         Development/Tools
-URL:           http://polly.llvm.org/
+URL:           https://polly.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 
 %description polly
@@ -292,7 +327,7 @@ do analizy i optymalizacji wzorców dostępu do pamięci przez program.
 Summary:       Header files for LLVM Polly optimization infrastructure
 Summary(pl.UTF-8):     Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
 Group:         Development/Libraries
-URL:           http://polly.llvm.org/
+URL:           https://polly.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      %{name}-polly = %{version}-%{release}
 
@@ -305,8 +340,8 @@ Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
 %package -n clang
 Summary:       A C language family frontend for LLVM
 Summary(pl.UTF-8):     Frontend LLVM-a do języków z rodziny C
-License:       NCSA
 Group:         Development/Languages
+URL:           https://clang.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 Requires:      clang-libs = %{version}-%{release}
 
@@ -328,22 +363,11 @@ LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
 i rozszerzaniu.
 
-%package -n clang-libs
-Summary:       Clang shared libraries
-Summary(pl.UTF-8):     Biblioteki współdzielone Clanga
-Group:         Libraries
-
-%description -n clang-libs
-Clang shared libraries.
-
-%description -n clang-libs -l pl.UTF-8
-Biblioteki współdzielone Clanga.
-
 %package -n clang-multilib
 Summary:       A C language family frontend for LLVM - 32-bit support
 Summary(pl.UTF-8):     Frontend LLVM-a do języków z rodziny C - obsługa binariów 32-bitowych
-License:       NCSA
 Group:         Development/Languages
+URL:           https://clang.llvm.org/
 Requires:      clang = %{version}-%{release}
 
 %description -n clang-multilib
@@ -370,32 +394,23 @@ i rozszerzaniu.
 Ten pakiet zawiera rozszerzenie kompilatora C o obsługę tworzenia
 programów 32-bitowych na maszynie 64-bitowej.
 
-%package -n clang-analyzer
-Summary:       A source code analysis framework
-Summary(pl.UTF-8):     Szkielet do analizy kodu źródłowego
-License:       NCSA
-Group:         Development/Languages
-Requires:      clang = %{version}-%{release}
-# not picked up automatically since files are currently not instaled
-# in standard Python hierarchies yet
-Requires:      python3
+%package -n clang-libs
+Summary:       Clang shared libraries
+Summary(pl.UTF-8):     Biblioteki współdzielone Clanga
+Group:         Libraries
+URL:           https://clang.llvm.org/
 
-%description -n clang-analyzer
-The Clang Static Analyzer consists of both a source code analysis
-framework and a standalone tool that finds bugs in C and Objective-C
-programs. The standalone tool is invoked from the command-line, and is
-intended to run in tandem with a build of a project or code base.
+%description -n clang-libs
+Clang shared libraries.
 
-%description -n clang-analyzer -l pl.UTF-8
-Clang Static Analyzer składa się ze szkieletu do analizy kodu
-źródłowego oraz samodzielnego narzędzia znajdującego błędy w
-programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
-myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
+%description -n clang-libs -l pl.UTF-8
+Biblioteki współdzielone Clanga.
 
 %package -n clang-devel
 Summary:       Header files for Clang
 Summary(pl.UTF-8):     Pliki nagłówkowe Clanga
 Group:         Development/Languages
+URL:           https://clang.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      clang = %{version}-%{release}
 %{?with_polly:Requires:        llvm-polly-devel = %{version}-%{release}}
@@ -409,6 +424,7 @@ Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
 %package -n clang-doc
 Summary:       Documentation for Clang
 Summary(pl.UTF-8):     Dokumentacja do Clanga
+URL:           https://clang.llvm.org/
 Group:         Documentation
 Requires:      %{name} = %{version}-%{release}
 
@@ -421,6 +437,7 @@ Dokumentacja do frontendu kompilatora Clang.
 %package -n clang-apidocs
 Summary:       API documentation for Clang
 Summary(pl.UTF-8):     Dokumentacja API Clanga
+URL:           https://clang.llvm.org/
 Group:         Development/Languages
 Requires:      clang-doc = %{version}-%{release}
 
@@ -430,11 +447,33 @@ API documentation for the Clang compiler.
 %description -n clang-apidocs -l pl.UTF-8
 Dokumentacja API kompilatora Clang.
 
+%package -n clang-analyzer
+Summary:       A source code analysis framework
+Summary(pl.UTF-8):     Szkielet do analizy kodu źródłowego
+Group:         Development/Languages
+URL:           https://clang-analyzer.llvm.org/
+Requires:      clang = %{version}-%{release}
+# not picked up automatically since files are currently not instaled
+# in standard Python hierarchies yet
+Requires:      python3
+
+%description -n clang-analyzer
+The Clang Static Analyzer consists of both a source code analysis
+framework and a standalone tool that finds bugs in C and Objective-C
+programs. The standalone tool is invoked from the command-line, and is
+intended to run in tandem with a build of a project or code base.
+
+%description -n clang-analyzer -l pl.UTF-8
+Clang Static Analyzer składa się ze szkieletu do analizy kodu
+źródłowego oraz samodzielnego narzędzia znajdującego błędy w
+programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
+myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
+
 %package -n clang-tools-extra
 Summary:       Extra tools for Clang
 Summary(pl.UTF-8):     Dodatkowe narzędzia do kompilatora Clang
 Group:         Development/Tools
-URL:           http://clang.llvm.org/docs/ClangTools.html
+URL:           https://clang.llvm.org/docs/ClangTools.html
 Requires:      clang = %{version}-%{release}
 
 %description -n clang-tools-extra
@@ -443,11 +482,53 @@ Extra tools for Clang.
 %description -n clang-tools-extra -l pl.UTF-8
 Dodatkowe narzędzia do kompilatora Clang.
 
+%package -n bash-completion-clang
+Summary:       Bash completion for clang command
+Summary(pl.UTF-8):     Bashowe dopełnianie składni polecenia clang
+Group:         Applications/Shells
+Requires:      bash-completion >= 2.0
+Requires:      clang = %{version}-%{release}
+
+%description -n bash-completion-clang
+Bash completion for clang command.
+
+%description -n bash-completion-clang -l pl.UTF-8
+Bashowe dopełnianie składni polecenia clang.
+
+%package -n flang
+Summary:       Fortran frontend for LLVM
+Summary(pl.UTF-8):     Frontend LLVM-a do Fortranu
+Group:         Development/Languages
+URL:           http://flang.llvm.org/
+Requires:      %{name}-mlir = %{version}-%{release}
+
+%description -n flang
+Flang is a ground-up implementation of a Fortran front end written in
+modern C++.
+
+%description -n flang -l pl.UTF-8
+Flang to napisana od podstaw we współczesnym C++ implementacja
+frontendu do Fortranu.
+
+%package -n flang-devel
+Summary:       Fortran frontend for LLVM - development files
+Summary(pl.UTF-8):     Frontend LLVM-a do Fortranu - pliki programistyczne
+Group:         Development/Languages
+URL:           http://flang.llvm.org/
+Requires:      %{name}-mlir-devel = %{version}-%{release}
+Requires:      flang-devel = %{version}-%{release}
+
+%description -n flang-devel
+Development files for LLVM Fortran frontend.
+
+%description -n flang-devel -l pl.UTF-8
+Pliki prosramistyczne frontendu LLVM do Fortranu.
+
 %package -n lld
 Summary:       The LLVM linker
 Summary(pl.UTF-8):     Konsolidator z projektu LLVM
 Group:         Development/Libraries
-URL:           http://lld.llvm.org/
+URL:           https://lld.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 
 %description -n lld
@@ -461,8 +542,9 @@ konsolidujących.
 Summary:       Development files for LLD linker tools
 Summary(pl.UTF-8):     Pliki programistyczne narzędzi konsolidujących LLD
 Group:         Development/Tools
-URL:           http://lld.llvm.org/
+URL:           https://lld.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
+Requires:      xar-devel >= 1.6
 
 %description -n lld-devel
 Development files for LLD linker tools.
@@ -474,7 +556,7 @@ Pliki programistyczne narzędzi konsolidujących LLD.
 Summary:       Next generation high-performance debugger
 Summary(pl.UTF-8):     Wydajny debugger nowej generacji
 Group:         Development/Debuggers
-URL:           http://lldb.llvm.org/
+URL:           https://lldb.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 Requires:      python3-six
 
@@ -494,7 +576,7 @@ disasembler LLVM.
 Summary:       Development files for LLDB debugger
 Summary(pl.UTF-8):     Pliki programistyczne debuggera LLDB
 Group:         Development/Libraries
-URL:           http://lldb.llvm.org/
+URL:           https://lldb.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      clang-devel = %{version}-%{release}
 Requires:      lldb = %{version}-%{release}
@@ -574,7 +656,7 @@ Clang format and rename integration for Vim.
 Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 
 %prep
-%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6 %{?with_flang:-a7 -a8}
+%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6 %{?with_flang:-a7} %{?with_mlir:-a8}
 %{__mv} clang-%{version}.src tools/clang
 %{?with_rt:%{__mv} compiler-rt-%{version}.src projects/compiler-rt}
 %{?with_lldb:%{__mv} lldb-%{version}.src tools/lldb}
@@ -583,6 +665,8 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %{__mv} lld-%{version}.src tools/lld
 %if %{with flang}
 %{__mv} flang-%{version}.src tools/flang
+%endif
+%if %{with mlir}
 %{__mv} mlir tools/mlir
 %endif
 
@@ -595,6 +679,8 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %patch6 -p1
 %endif
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 grep -rl /usr/bin/env projects tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python3},
@@ -605,6 +691,10 @@ find -name '*.py' -print0 | xargs -0 sed -i -e '1{
        s,^#!.*bin/python.*,#!%{__python3},
 }'
 
+%if %{with flang}
+%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' tools/flang/tools/f18/flang.in
+%endif
+
 %build
 install -d build
 
@@ -648,6 +738,9 @@ export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
        -DLLVM_PARALLEL_LINK_JOBS:STRING=1 \
 %endif
        -DLLVM_TARGETS_TO_BUILD="%{targets_to_build}" \
+%if %{with polly}
+       %{cmake_on_off target_nvptx POLLY_ENABLE_GPGPU_CODEGEN} \
+%endif
        -DSPHINX_WARNINGS_AS_ERRORS=OFF
 
 %{__make} \
@@ -686,11 +779,10 @@ rm -rf $RPM_BUILD_ROOT
 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
 
-# Adjust static analyzer installation
-# http://clang-analyzer.llvm.org/installation#OtherPlatforms
-install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
-%{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
-%{__sed} -i -e 's,/\.\./libexec/,/../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
+# Adjust static analyzer installation (see -libexecdir patch)
+abs_ca_libexecdir="%{_libexecdir}/clang-analyzer"
+rel_ca_libexecdir="${abs_ca_libexecdir#%{_prefix}}"
+%{__sed} -i -e "s,/\.\./libexec/,/..${rel_ca_libexecdir}/," $RPM_BUILD_ROOT%{_bindir}/scan-build
 %py3_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
 %py3_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
 
@@ -700,7 +792,7 @@ install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
 %if %{with doc}
 cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 # these tools are not installed
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/FileCheck.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,clang-tblgen,lldb-tblgen}.1
 # make links
 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
 %endif
@@ -724,6 +816,9 @@ for f in LICENSE.TXT NOTES.txt README.txt; do
        ln tools/clang/$f clang-docs
 done
 
+install -d $RPM_BUILD_ROOT%{bash_compdir}
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/clang/bash-autocomplete.sh $RPM_BUILD_ROOT%{bash_compdir}/clang
+
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{c-index-test,llvm-c-test}
 # not this OS
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
@@ -733,7 +828,16 @@ done
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
 
 # disable completeness check incompatible with split packaging
-%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_libdir}/cmake/llvm/LLVMExports.cmake
+%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' \
+       $RPM_BUILD_ROOT%{_libdir}/cmake/clang/ClangTargets.cmake \
+%if %{with flang}
+       $RPM_BUILD_ROOT%{_libdir}/cmake/flang/FlangTargets.cmake \
+%endif
+       $RPM_BUILD_ROOT%{_libdir}/cmake/lld/LLDTargets.cmake \
+       $RPM_BUILD_ROOT%{_libdir}/cmake/llvm/LLVMExports.cmake \
+%if %{with mlir}
+       $RPM_BUILD_ROOT%{_libdir}/cmake/mlir/MLIRTargets.cmake
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -741,6 +845,9 @@ rm -rf $RPM_BUILD_ROOT
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
+%post  mlir -p /sbin/ldconfig
+%postun        mlir -p /sbin/ldconfig
+
 %post  -n clang-libs -p /sbin/ldconfig
 %postun        -n clang-libs -p /sbin/ldconfig
 
@@ -771,7 +878,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-dlltool
 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
 %attr(755,root,root) %{_bindir}/llvm-dwp
-%attr(755,root,root) %{_bindir}/llvm-elfabi
 %attr(755,root,root) %{_bindir}/llvm-exegesis
 %attr(755,root,root) %{_bindir}/llvm-extract
 %attr(755,root,root) %{_bindir}/llvm-gsymutil
@@ -793,6 +899,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-objcopy
 %attr(755,root,root) %{_bindir}/llvm-objdump
 %attr(755,root,root) %{_bindir}/llvm-opt-report
+%attr(755,root,root) %{_bindir}/llvm-otool
 %attr(755,root,root) %{_bindir}/llvm-pdbutil
 %attr(755,root,root) %{_bindir}/llvm-profdata
 %attr(755,root,root) %{_bindir}/llvm-profgen
@@ -802,14 +909,17 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-readobj
 %attr(755,root,root) %{_bindir}/llvm-reduce
 %attr(755,root,root) %{_bindir}/llvm-rtdyld
+%attr(755,root,root) %{_bindir}/llvm-sim
 %attr(755,root,root) %{_bindir}/llvm-size
 %attr(755,root,root) %{_bindir}/llvm-split
 %attr(755,root,root) %{_bindir}/llvm-strip
 %attr(755,root,root) %{_bindir}/llvm-stress
 %attr(755,root,root) %{_bindir}/llvm-strings
 %attr(755,root,root) %{_bindir}/llvm-symbolizer
+%attr(755,root,root) %{_bindir}/llvm-tapi-diff
 %attr(755,root,root) %{_bindir}/llvm-tblgen
 %attr(755,root,root) %{_bindir}/llvm-undname
+%attr(755,root,root) %{_bindir}/llvm-windres
 %attr(755,root,root) %{_bindir}/llvm-xray
 %attr(755,root,root) %{_bindir}/opt
 %attr(755,root,root) %{_bindir}/sancov
@@ -844,6 +954,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-nm.1*
 %{_mandir}/man1/llvm-objcopy.1*
 %{_mandir}/man1/llvm-objdump.1*
+%{_mandir}/man1/llvm-otool.1*
 %{_mandir}/man1/llvm-pdbutil.1*
 %{_mandir}/man1/llvm-profdata.1*
 %{_mandir}/man1/llvm-profgen.1*
@@ -855,19 +966,20 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-strings.1*
 %{_mandir}/man1/llvm-strip.1*
 %{_mandir}/man1/llvm-symbolizer.1*
+%{_mandir}/man1/llvm-tblgen.1*
 %{_mandir}/man1/opt.1*
-%{_mandir}/man1/xxx-tblgen.1*
+%{_mandir}/man1/tblgen.1*
 %endif
 
 %files libs
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/LLVMgold.so
 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
 # non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %ghost %{_libdir}/libLTO.so.12
-%attr(755,root,root) %{_libdir}/LLVMgold.so
-%attr(755,root,root) %{_libdir}/libRemarks.so.12
-%attr(755,root,root) %{_libdir}/libclang-cpp.so.12
+%attr(755,root,root) %{_libdir}/libLTO.so.13
+%attr(755,root,root) %{_libdir}/libRemarks.so.13
+%attr(755,root,root) %{_libdir}/libclang-cpp.so.13
 
 %files devel
 %defattr(644,root,root,755)
@@ -893,17 +1005,47 @@ rm -rf $RPM_BUILD_ROOT
 %doc apidoc/*
 %endif
 
+%if %{with mlir}
+%files mlir
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/mlir-cpu-runner
+%attr(755,root,root) %{_bindir}/mlir-linalg-ods-gen
+%attr(755,root,root) %{_bindir}/mlir-linalg-ods-yaml-gen
+%attr(755,root,root) %{_bindir}/mlir-lsp-server
+%attr(755,root,root) %{_bindir}/mlir-opt
+%attr(755,root,root) %{_bindir}/mlir-reduce
+%attr(755,root,root) %{_bindir}/mlir-tblgen
+%attr(755,root,root) %{_bindir}/mlir-translate
+%attr(755,root,root) %{_libdir}/libMLIR.so.13
+%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.13
+%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.13
+%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.13
+%{_mandir}/man1/mlir-tblgen.1*
+
+%files mlir-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libMLIR.so
+%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so
+%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so
+%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so
+%{_libdir}/libMLIR*.a
+%{_includedir}/mlir
+%{_includedir}/mlir-c
+%{_libdir}/cmake/mlir
+%endif
+
 %if %{with polly}
 %files polly
 %defattr(644,root,root,755)
-%doc tools/polly/{CREDITS.txt,LICENSE.txt,README} tools/polly/www/{bugs,changelog,contributors}.html
+%doc tools/polly/{CREDITS.txt,LICENSE.TXT,README} tools/polly/www/{bugs,changelog,contributors}.html
 %attr(755,root,root) %{_libdir}/LLVMPolly.so
+%{?with_target_nvptx:%attr(755,root,root) %{_libdir}/libGPURuntime.so}
 
 %files polly-devel
 %defattr(644,root,root,755)
 %{_libdir}/libPolly.a
 %{_libdir}/libPollyISL.a
-%{_libdir}/libPollyPPCG.a
+%{?with_target_nvptx:%{_libdir}/libPollyPPCG.a}
 %{_includedir}/polly
 %{_libdir}/cmake/polly
 %endif
@@ -921,6 +1063,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang-format
 %attr(755,root,root) %{_bindir}/clang-offload-bundler
 %attr(755,root,root) %{_bindir}/clang-offload-wrapper
+%attr(755,root,root) %{_bindir}/clang-repl
 %attr(755,root,root) %{_bindir}/git-clang-format
 %dir %{_libdir}/clang
 %dir %{_libdir}/clang/%{version}
@@ -930,7 +1073,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/clang/%{version}/bin
 %attr(755,root,root) %{_libdir}/clang/%{version}/bin/hwasan_symbolize
 %endif
-%ifarch %{ix86} %{x8664} aarch64
+%ifarch %{ix86} %{x8664} aarch64 armv7hl armv7hnl
 %dir %{_libdir}/clang/%{version}/lib
 %dir %{_libdir}/clang/%{version}/lib/linux
 %dir %{_libdir}/clang/%{version}/share
@@ -959,36 +1102,38 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.so
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.a.syms
 %endif
+%ifarch armv7hl armv7hnl
+%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-armhf.o
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a
+%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.so
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a.syms
+%endif
 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
-%{_libdir}/clang/%{version}/share/asan_blacklist.txt
+%{_libdir}/clang/%{version}/share/asan_ignorelist.txt
 %endif
-%ifarch %{ix86} %{x8664} mips64 aarch64
-%{_libdir}/clang/%{version}/share/cfi_blacklist.txt
+%ifarch %{ix86} %{x8664} mips64 aarch64 armv7hl armv7hnl
+%{_libdir}/clang/%{version}/share/cfi_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64 mips64
 %{_libdir}/clang/%{version}/share/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/share/msan_blacklist.txt
+%{_libdir}/clang/%{version}/share/msan_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64
-%{_libdir}/clang/%{version}/share/hwasan_blacklist.txt
+%{_libdir}/clang/%{version}/share/hwasan_ignorelist.txt
 %endif
 %ifarch x32
 %if %{with multilib}
-%{_libdir}/clang/%{version}/share/asan_blacklist.txt
-%{_libdir}/clang/%{version}/share/cfi_blacklist.txt
+%{_libdir}/clang/%{version}/share/asan_ignorelist.txt
+%{_libdir}/clang/%{version}/share/cfi_ignorelist.txt
 %{_libdir}/clang/%{version}/share/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/share/msan_blacklist.txt
-%{_libdir}/clang/%{version}/share/hwasan_blacklist.txt
+%{_libdir}/clang/%{version}/share/msan_ignorelist.txt
+%{_libdir}/clang/%{version}/share/hwasan_ignorelist.txt
 %endif
 %endif
 %endif
 %dir %{_datadir}/clang
 %{_datadir}/clang/clang-format-diff.py
 
-%files -n clang-libs
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libclang.so.%{abi}
-
 %if %{with rt} && %{with multilib}
 %ifarch %{x8664} x32
 %files -n clang-multilib
@@ -1005,16 +1150,10 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %endif
 
-%files -n clang-analyzer
+%files -n clang-libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/scan-build
-%attr(755,root,root) %{_bindir}/scan-view
-%{_datadir}/scan-build
-%{_datadir}/scan-view
-%{_mandir}/man1/scan-build.1*
-%dir %{_libdir}/scan-build
-%attr(755,root,root) %{_libdir}/scan-build/c++-analyzer
-%attr(755,root,root) %{_libdir}/scan-build/ccc-analyzer
+%attr(755,root,root) %{_libdir}/libclang.so.%{abi}
+%attr(755,root,root) %{_libdir}/libclang.so.*.*.*
 
 %files -n clang-devel
 %defattr(644,root,root,755)
@@ -1035,6 +1174,28 @@ rm -rf $RPM_BUILD_ROOT
 %doc clang-apidoc/*
 %endif
 
+%files -n clang-analyzer
+%defattr(644,root,root,755)
+%dir %{_libexecdir}/clang-analyzer
+# perl tools
+%attr(755,root,root) %{_bindir}/scan-build
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/c++-analyzer
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/ccc-analyzer
+%{_datadir}/scan-build
+%{_mandir}/man1/scan-build.1*
+# python tools
+%attr(755,root,root) %{_bindir}/analyze-build
+%attr(755,root,root) %{_bindir}/intercept-build
+%attr(755,root,root) %{_bindir}/scan-build-py
+%attr(755,root,root) %{_bindir}/scan-view
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/analyze-c++
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/analyze-cc
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-c++
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-cc
+%{_prefix}/lib/libear
+%{_prefix}/lib/libscanbuild
+%{_datadir}/scan-view
+
 %files -n clang-tools-extra
 %defattr(644,root,root,755)
 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt}
@@ -1055,17 +1216,55 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/hmaptool
 %attr(755,root,root) %{_bindir}/modularize
 %attr(755,root,root) %{_bindir}/pp-trace
+%attr(755,root,root) %{_bindir}/run-clang-tidy
 %{_datadir}/clang/clang-include-fixer.py
 %{_datadir}/clang/clang-tidy-diff.py
-%{_datadir}/clang/run-clang-tidy.py
 %{_datadir}/clang/run-find-all-symbols.py
 
+%files -n bash-completion-clang
+%defattr(644,root,root,755)
+%{bash_compdir}/clang
+
+%if %{with flang}
+%files -n flang
+%defattr(644,root,root,755)
+%doc tools/flang/{LICENSE.TXT,README.md}
+%attr(755,root,root) %{_bindir}/f18
+%attr(755,root,root) %{_bindir}/f18-parse-demo
+%attr(755,root,root) %{_bindir}/fir-opt
+%attr(755,root,root) %{_bindir}/flang
+%attr(755,root,root) %{_bindir}/tco
+%dir %{_includedir}/flang
+%{_includedir}/flang/Version.inc
+%{_includedir}/flang/__fortran_*.mod
+%{_includedir}/flang/ieee_*.mod
+%{_includedir}/flang/iso_*.mod
+%{_includedir}/flang/omp_lib*.mod
+
+%files -n flang-devel
+%defattr(644,root,root,755)
+%{_libdir}/libFIROptimizer.a
+%{_libdir}/libFortran*.a
+%{_includedir}/flang/Common
+%{_includedir}/flang/Decimal
+%{_includedir}/flang/Evaluate
+%{_includedir}/flang/Frontend
+%{_includedir}/flang/FrontendTool
+%{_includedir}/flang/Lower
+%{_includedir}/flang/Optimizer
+%{_includedir}/flang/Parser
+%{_includedir}/flang/Semantics
+%{_includedir}/flang/ISO_Fortran_binding.h
+%{_libdir}/cmake/flang
+%endif
+
 %files -n lld
 %defattr(644,root,root,755)
 %doc tools/lld/{LICENSE.TXT,README.md}
 %attr(755,root,root) %{_bindir}/ld.lld
 %attr(755,root,root) %{_bindir}/ld64.lld
 %attr(755,root,root) %{_bindir}/ld64.lld.darwinnew
+%attr(755,root,root) %{_bindir}/ld64.lld.darwinold
 %attr(755,root,root) %{_bindir}/lld
 %attr(755,root,root) %{_bindir}/lld-link
 %attr(755,root,root) %{_bindir}/wasm-ld
@@ -1085,8 +1284,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lldb-server
 %attr(755,root,root) %{_bindir}/lldb-vscode
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblldb.so.12
-%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.12
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.13
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.13
 %dir %{py3_sitedir}/lldb
 %attr(755,root,root) %{py3_sitedir}/lldb/lldb-argdumper
 %{py3_sitedir}/lldb/formatters
@@ -1094,6 +1293,10 @@ rm -rf $RPM_BUILD_ROOT
 %{py3_sitedir}/lldb/__init__.py
 %{py3_sitedir}/lldb/__pycache__
 %{py3_sitedir}/lldb/embedded_interpreter.py
+%dir %{py3_sitedir}/lldb/plugins
+%{py3_sitedir}/lldb/plugins/__pycache__
+%{py3_sitedir}/lldb/plugins/__init__.py
+%{py3_sitedir}/lldb/plugins/scripted_process.py
 %attr(755,root,root) %{py3_sitedir}/lldb/_lldb.so
 
 %files -n lldb-devel
This page took 0.127891 seconds and 4 git commands to generate.