]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
- packaged bash completion file
[packages/llvm.git] / llvm.spec
index 313fc1b4ff3527c246ec9341d43bef5ef2f43294..ad879d39a2aa449294e71fa2f38ffce9a5f6dc95 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -4,7 +4,6 @@
 #
 # TODO:
 # - move and package:
-#      %{_datadir}/clang/bash-autocomplete.sh
 #      %{_datadir}/clang/clang-format-sublime.py - sublime plugin
 #      %{_datadir}/clang/clang-format.el - clang tools emacs integration
 #      %{_datadir}/clang/clang-include-fixer.el
@@ -14,6 +13,8 @@
 #
 # Conditional build:
 %bcond_without lldb                    # LLDB debugger
+%bcond_without mlir                    # MLIR libraries and tools (required for Flang)
+%bcond_without flang                   # Flang (Fortran18) compiler
 %bcond_without polly                   # Polly cache-locality optimization, auto-parallelism and vectorization
 %bcond_without rt                      # compiler-rt libraries
 %bcond_without multilib                # compiler-rt multilib libraries
@@ -37,7 +38,6 @@
 %bcond_without target_webassembly      # WebAssembly target support
 %bcond_without target_x86              # X86 target support
 %bcond_without target_xcore            # XCore target support
-%bcond_with    flang                   # flang (Fortran18) compiler (broken as of 11.0.1)
 %bcond_with    cxxmodules              # C++20 modules (requires support in bootstrap compiler)
 %bcond_with    apidocs                 # doxygen docs (HUGE, so they are not built by default)
 %bcond_with    tests                   # run tests
 
 %define                targets_to_build        %{?with_target_aarch64:AArch64;}%{?with_target_amdgpu:AMDGPU;}%{?with_target_arm:ARM;}%{?with_target_avr:AVR;}%{?with_target_bpf:BPF;}%{?with_target_hexagon:Hexagon;}%{?with_target_lanai:Lanai;}%{?with_target_mips:Mips;}%{?with_target_msp430:MSP430;}%{?with_target_nvptx:NVPTX;}%{?with_target_powerpc:PowerPC;}%{?with_target_riscv:RISCV;}%{?with_target_sparc:Sparc;}%{?with_target_systemz:SystemZ;}%{?with_target_webassembly:WebAssembly;}%{?with_target_x86:X86;}%{?with_target_xcore:XCore;}
 
+%if %{without mlir}
+%undefine      with_flang
+%endif
+
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
 Version:       13.0.0
-Release:       2
-License:       University of Illinois/NCSA Open Source License
+Release:       3
+License:       Apache 2.0 with LLVM exceptions
 Group:         Development/Languages
 #Source0Download: https://github.com/llvm/llvm-project/releases/
 Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
@@ -93,7 +97,8 @@ Patch5:               %{name}-ocaml-shared.patch
 Patch6:                %{name}-flang.patch
 Patch7:                llvm12-build_fixes.patch
 Patch8:                %{name}-selective_bindings.patch
-URL:           http://llvm.org/
+Patch9:                %{name}-libexecdir.patch
+URL:           https://llvm.org/
 BuildRequires: bash
 BuildRequires: binutils-devel
 BuildRequires: bison
@@ -122,7 +127,7 @@ BuildRequires:      rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.742
 %{?with_doc:BuildRequires:     sphinx-pdg}
 BuildRequires: tar >= 1:1.22
-BuildRequires: xar-devel
+BuildRequires: xar-devel >= 1.6
 BuildRequires: xz
 %{?with_z3:BuildRequires:      z3-devel >= 4.7.1}
 BuildRequires: zlib-devel
@@ -165,10 +170,9 @@ BuildRequires:     xz-devel
 # private copy in polly/lib/External/isl
 #BuildRequires:        isl-devel >= 0.22.1
 #TODO (bcond): cuda-devel (with POLLY_ENABLE_GPGPU_CODEGEN=ON)
-BuildRequires: ocl-icd-libOpenCL-devel
+%{?with_target_nvptx:BuildRequires:    ocl-icd-libOpenCL-devel}
 %endif
 %if %{with ocaml}
-BuildConflicts:        llvm-libs
 BuildConflicts:        llvm-ocaml
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
@@ -272,11 +276,39 @@ API documentation for the LLVM compiler infrastructure.
 %description apidocs -l pl.UTF-8
 Dokumentacja API infrastruktury kompilatorów LLVM.
 
+%package mlir
+Summary:       LLVM Multi-Level Intermediate Representation libraries and tools
+Summary(pl.UTF-8):     Biblioteki i narzędzia wielopoziomowej reprezentacji pośredniej LLVM
+Group:         Development/Tools
+URL:           https://mlir.llvm.org/
+Requires:      %{name} = %{version}-%{release}
+
+%description mlir
+LLVM Multi-Level Intermediate Representation libraries and tools.
+
+%description mlir -l pl.UTF-8
+Biblioteki i narzędzia wielopoziomowej reprezentacji pośredniej LLVM.
+
+%package mlir-devel
+Summary:       LLVM Multi-Level Intermediate Representation development files
+Summary(pl.UTF-8):     Pliki do programowania z użyciem wielopoziomowej reprezentacji pośredniej LLVM
+Group:         Development/Tools
+URL:           https://mlir.llvm.org/
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-mlir = %{version}-%{release}
+
+%description mlir-devel
+LLVM Multi-Level Intermediate Representation development files.
+
+%description mlir-devel -l pl.UTF-8
+Pliki do programowania z użyciem wielopoziomowej reprezentacji
+pośredniej LLVM.
+
 %package polly
 Summary:       Polyhedral optimizations for LLVM
 Summary(pl.UTF-8):     Optymalizacje wielościanowe dla LLVM-a
 Group:         Development/Tools
-URL:           http://polly.llvm.org/
+URL:           https://polly.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 
 %description polly
@@ -295,7 +327,7 @@ do analizy i optymalizacji wzorców dostępu do pamięci przez program.
 Summary:       Header files for LLVM Polly optimization infrastructure
 Summary(pl.UTF-8):     Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
 Group:         Development/Libraries
-URL:           http://polly.llvm.org/
+URL:           https://polly.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      %{name}-polly = %{version}-%{release}
 
@@ -308,8 +340,8 @@ Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
 %package -n clang
 Summary:       A C language family frontend for LLVM
 Summary(pl.UTF-8):     Frontend LLVM-a do języków z rodziny C
-License:       NCSA
 Group:         Development/Languages
+URL:           https://clang.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 Requires:      clang-libs = %{version}-%{release}
 
@@ -331,22 +363,11 @@ LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
 i rozszerzaniu.
 
-%package -n clang-libs
-Summary:       Clang shared libraries
-Summary(pl.UTF-8):     Biblioteki współdzielone Clanga
-Group:         Libraries
-
-%description -n clang-libs
-Clang shared libraries.
-
-%description -n clang-libs -l pl.UTF-8
-Biblioteki współdzielone Clanga.
-
 %package -n clang-multilib
 Summary:       A C language family frontend for LLVM - 32-bit support
 Summary(pl.UTF-8):     Frontend LLVM-a do języków z rodziny C - obsługa binariów 32-bitowych
-License:       NCSA
 Group:         Development/Languages
+URL:           https://clang.llvm.org/
 Requires:      clang = %{version}-%{release}
 
 %description -n clang-multilib
@@ -373,32 +394,23 @@ i rozszerzaniu.
 Ten pakiet zawiera rozszerzenie kompilatora C o obsługę tworzenia
 programów 32-bitowych na maszynie 64-bitowej.
 
-%package -n clang-analyzer
-Summary:       A source code analysis framework
-Summary(pl.UTF-8):     Szkielet do analizy kodu źródłowego
-License:       NCSA
-Group:         Development/Languages
-Requires:      clang = %{version}-%{release}
-# not picked up automatically since files are currently not instaled
-# in standard Python hierarchies yet
-Requires:      python3
+%package -n clang-libs
+Summary:       Clang shared libraries
+Summary(pl.UTF-8):     Biblioteki współdzielone Clanga
+Group:         Libraries
+URL:           https://clang.llvm.org/
 
-%description -n clang-analyzer
-The Clang Static Analyzer consists of both a source code analysis
-framework and a standalone tool that finds bugs in C and Objective-C
-programs. The standalone tool is invoked from the command-line, and is
-intended to run in tandem with a build of a project or code base.
+%description -n clang-libs
+Clang shared libraries.
 
-%description -n clang-analyzer -l pl.UTF-8
-Clang Static Analyzer składa się ze szkieletu do analizy kodu
-źródłowego oraz samodzielnego narzędzia znajdującego błędy w
-programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
-myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
+%description -n clang-libs -l pl.UTF-8
+Biblioteki współdzielone Clanga.
 
 %package -n clang-devel
 Summary:       Header files for Clang
 Summary(pl.UTF-8):     Pliki nagłówkowe Clanga
 Group:         Development/Languages
+URL:           https://clang.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      clang = %{version}-%{release}
 %{?with_polly:Requires:        llvm-polly-devel = %{version}-%{release}}
@@ -412,6 +424,7 @@ Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
 %package -n clang-doc
 Summary:       Documentation for Clang
 Summary(pl.UTF-8):     Dokumentacja do Clanga
+URL:           https://clang.llvm.org/
 Group:         Documentation
 Requires:      %{name} = %{version}-%{release}
 
@@ -424,6 +437,7 @@ Dokumentacja do frontendu kompilatora Clang.
 %package -n clang-apidocs
 Summary:       API documentation for Clang
 Summary(pl.UTF-8):     Dokumentacja API Clanga
+URL:           https://clang.llvm.org/
 Group:         Development/Languages
 Requires:      clang-doc = %{version}-%{release}
 
@@ -433,11 +447,33 @@ API documentation for the Clang compiler.
 %description -n clang-apidocs -l pl.UTF-8
 Dokumentacja API kompilatora Clang.
 
+%package -n clang-analyzer
+Summary:       A source code analysis framework
+Summary(pl.UTF-8):     Szkielet do analizy kodu źródłowego
+Group:         Development/Languages
+URL:           https://clang-analyzer.llvm.org/
+Requires:      clang = %{version}-%{release}
+# not picked up automatically since files are currently not instaled
+# in standard Python hierarchies yet
+Requires:      python3
+
+%description -n clang-analyzer
+The Clang Static Analyzer consists of both a source code analysis
+framework and a standalone tool that finds bugs in C and Objective-C
+programs. The standalone tool is invoked from the command-line, and is
+intended to run in tandem with a build of a project or code base.
+
+%description -n clang-analyzer -l pl.UTF-8
+Clang Static Analyzer składa się ze szkieletu do analizy kodu
+źródłowego oraz samodzielnego narzędzia znajdującego błędy w
+programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
+myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
+
 %package -n clang-tools-extra
 Summary:       Extra tools for Clang
 Summary(pl.UTF-8):     Dodatkowe narzędzia do kompilatora Clang
 Group:         Development/Tools
-URL:           http://clang.llvm.org/docs/ClangTools.html
+URL:           https://clang.llvm.org/docs/ClangTools.html
 Requires:      clang = %{version}-%{release}
 
 %description -n clang-tools-extra
@@ -446,11 +482,53 @@ Extra tools for Clang.
 %description -n clang-tools-extra -l pl.UTF-8
 Dodatkowe narzędzia do kompilatora Clang.
 
+%package -n bash-completion-clang
+Summary:       Bash completion for clang command
+Summary(pl.UTF-8):     Bashowe dopełnianie składni polecenia clang
+Group:         Applications/Shells
+Requires:      bash-completion >= 2.0
+Requires:      clang = %{version}-%{release}
+
+%description -n bash-completion-clang
+Bash completion for clang command.
+
+%description -n bash-completion-clang -l pl.UTF-8
+Bashowe dopełnianie składni polecenia clang.
+
+%package -n flang
+Summary:       Fortran frontend for LLVM
+Summary(pl.UTF-8):     Frontend LLVM-a do Fortranu
+Group:         Development/Languages
+URL:           http://flang.llvm.org/
+Requires:      %{name}-mlir = %{version}-%{release}
+
+%description -n flang
+Flang is a ground-up implementation of a Fortran front end written in
+modern C++.
+
+%description -n flang -l pl.UTF-8
+Flang to napisana od podstaw we współczesnym C++ implementacja
+frontendu do Fortranu.
+
+%package -n flang-devel
+Summary:       Fortran frontend for LLVM - development files
+Summary(pl.UTF-8):     Frontend LLVM-a do Fortranu - pliki programistyczne
+Group:         Development/Languages
+URL:           http://flang.llvm.org/
+Requires:      %{name}-mlir-devel = %{version}-%{release}
+Requires:      flang-devel = %{version}-%{release}
+
+%description -n flang-devel
+Development files for LLVM Fortran frontend.
+
+%description -n flang-devel -l pl.UTF-8
+Pliki prosramistyczne frontendu LLVM do Fortranu.
+
 %package -n lld
 Summary:       The LLVM linker
 Summary(pl.UTF-8):     Konsolidator z projektu LLVM
 Group:         Development/Libraries
-URL:           http://lld.llvm.org/
+URL:           https://lld.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 
 %description -n lld
@@ -464,8 +542,9 @@ konsolidujących.
 Summary:       Development files for LLD linker tools
 Summary(pl.UTF-8):     Pliki programistyczne narzędzi konsolidujących LLD
 Group:         Development/Tools
-URL:           http://lld.llvm.org/
+URL:           https://lld.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
+Requires:      xar-devel >= 1.6
 
 %description -n lld-devel
 Development files for LLD linker tools.
@@ -477,7 +556,7 @@ Pliki programistyczne narzędzi konsolidujących LLD.
 Summary:       Next generation high-performance debugger
 Summary(pl.UTF-8):     Wydajny debugger nowej generacji
 Group:         Development/Debuggers
-URL:           http://lldb.llvm.org/
+URL:           https://lldb.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 Requires:      python3-six
 
@@ -497,7 +576,7 @@ disasembler LLVM.
 Summary:       Development files for LLDB debugger
 Summary(pl.UTF-8):     Pliki programistyczne debuggera LLDB
 Group:         Development/Libraries
-URL:           http://lldb.llvm.org/
+URL:           https://lldb.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      clang-devel = %{version}-%{release}
 Requires:      lldb = %{version}-%{release}
@@ -577,7 +656,7 @@ Clang format and rename integration for Vim.
 Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 
 %prep
-%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6 %{?with_flang:-a7 -a8}
+%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6 %{?with_flang:-a7} %{?with_mlir:-a8}
 %{__mv} clang-%{version}.src tools/clang
 %{?with_rt:%{__mv} compiler-rt-%{version}.src projects/compiler-rt}
 %{?with_lldb:%{__mv} lldb-%{version}.src tools/lldb}
@@ -586,6 +665,8 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %{__mv} lld-%{version}.src tools/lld
 %if %{with flang}
 %{__mv} flang-%{version}.src tools/flang
+%endif
+%if %{with mlir}
 %{__mv} mlir tools/mlir
 %endif
 
@@ -599,6 +680,7 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %endif
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 grep -rl /usr/bin/env projects tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python3},
@@ -609,6 +691,10 @@ find -name '*.py' -print0 | xargs -0 sed -i -e '1{
        s,^#!.*bin/python.*,#!%{__python3},
 }'
 
+%if %{with flang}
+%{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' tools/flang/tools/f18/flang.in
+%endif
+
 %build
 install -d build
 
@@ -693,11 +779,10 @@ rm -rf $RPM_BUILD_ROOT
 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
 
-# Adjust static analyzer installation
-# http://clang-analyzer.llvm.org/installation#OtherPlatforms
-install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
-%{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
-%{__sed} -i -e 's,/\.\./libexec/,/../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
+# Adjust static analyzer installation (see -libexecdir patch)
+abs_ca_libexecdir="%{_libexecdir}/clang-analyzer"
+rel_ca_libexecdir="${abs_ca_libexecdir#%{_prefix}}"
+%{__sed} -i -e "s,/\.\./libexec/,/..${rel_ca_libexecdir}/," $RPM_BUILD_ROOT%{_bindir}/scan-build
 %py3_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
 %py3_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
 
@@ -707,7 +792,7 @@ install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
 %if %{with doc}
 cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 # these tools are not installed
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/FileCheck.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,clang-tblgen,lldb-tblgen}.1
 # make links
 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
 %endif
@@ -731,6 +816,9 @@ for f in LICENSE.TXT NOTES.txt README.txt; do
        ln tools/clang/$f clang-docs
 done
 
+install -d $RPM_BUILD_ROOT%{bash_compdir}
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/clang/bash-autocomplete.sh $RPM_BUILD_ROOT%{bash_compdir}/clang
+
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{c-index-test,llvm-c-test}
 # not this OS
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
@@ -740,7 +828,16 @@ done
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
 
 # disable completeness check incompatible with split packaging
-%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_libdir}/cmake/llvm/LLVMExports.cmake
+%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' \
+       $RPM_BUILD_ROOT%{_libdir}/cmake/clang/ClangTargets.cmake \
+%if %{with flang}
+       $RPM_BUILD_ROOT%{_libdir}/cmake/flang/FlangTargets.cmake \
+%endif
+       $RPM_BUILD_ROOT%{_libdir}/cmake/lld/LLDTargets.cmake \
+       $RPM_BUILD_ROOT%{_libdir}/cmake/llvm/LLVMExports.cmake \
+%if %{with mlir}
+       $RPM_BUILD_ROOT%{_libdir}/cmake/mlir/MLIRTargets.cmake
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -748,6 +845,9 @@ rm -rf $RPM_BUILD_ROOT
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
+%post  mlir -p /sbin/ldconfig
+%postun        mlir -p /sbin/ldconfig
+
 %post  -n clang-libs -p /sbin/ldconfig
 %postun        -n clang-libs -p /sbin/ldconfig
 
@@ -868,6 +968,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-symbolizer.1*
 %{_mandir}/man1/llvm-tblgen.1*
 %{_mandir}/man1/opt.1*
+%{_mandir}/man1/tblgen.1*
 %endif
 
 %files libs
@@ -904,6 +1005,35 @@ rm -rf $RPM_BUILD_ROOT
 %doc apidoc/*
 %endif
 
+%if %{with mlir}
+%files mlir
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/mlir-cpu-runner
+%attr(755,root,root) %{_bindir}/mlir-linalg-ods-gen
+%attr(755,root,root) %{_bindir}/mlir-linalg-ods-yaml-gen
+%attr(755,root,root) %{_bindir}/mlir-lsp-server
+%attr(755,root,root) %{_bindir}/mlir-opt
+%attr(755,root,root) %{_bindir}/mlir-reduce
+%attr(755,root,root) %{_bindir}/mlir-tblgen
+%attr(755,root,root) %{_bindir}/mlir-translate
+%attr(755,root,root) %{_libdir}/libMLIR.so.13
+%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.13
+%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.13
+%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.13
+%{_mandir}/man1/mlir-tblgen.1*
+
+%files mlir-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libMLIR.so
+%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so
+%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so
+%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so
+%{_libdir}/libMLIR*.a
+%{_includedir}/mlir
+%{_includedir}/mlir-c
+%{_libdir}/cmake/mlir
+%endif
+
 %if %{with polly}
 %files polly
 %defattr(644,root,root,755)
@@ -943,7 +1073,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/clang/%{version}/bin
 %attr(755,root,root) %{_libdir}/clang/%{version}/bin/hwasan_symbolize
 %endif
-%ifarch %{ix86} %{x8664} aarch64
+%ifarch %{ix86} %{x8664} aarch64 armv7hl armv7hnl
 %dir %{_libdir}/clang/%{version}/lib
 %dir %{_libdir}/clang/%{version}/lib/linux
 %dir %{_libdir}/clang/%{version}/share
@@ -972,10 +1102,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.so
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.a.syms
 %endif
+%ifarch armv7hl armv7hnl
+%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-armhf.o
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a
+%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.so
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a.syms
+%endif
 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
 %{_libdir}/clang/%{version}/share/asan_ignorelist.txt
 %endif
-%ifarch %{ix86} %{x8664} mips64 aarch64
+%ifarch %{ix86} %{x8664} mips64 aarch64 armv7hl armv7hnl
 %{_libdir}/clang/%{version}/share/cfi_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64 mips64
@@ -998,11 +1134,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/clang
 %{_datadir}/clang/clang-format-diff.py
 
-%files -n clang-libs
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libclang.so.%{abi}
-%attr(755,root,root) %{_libdir}/libclang.so.*.*.*
-
 %if %{with rt} && %{with multilib}
 %ifarch %{x8664} x32
 %files -n clang-multilib
@@ -1019,25 +1150,10 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %endif
 
-%files -n clang-analyzer
+%files -n clang-libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/analyze-build
-%attr(755,root,root) %{_bindir}/intercept-build
-%attr(755,root,root) %{_bindir}/scan-build
-%attr(755,root,root) %{_bindir}/scan-build-py
-%attr(755,root,root) %{_bindir}/scan-view
-%attr(755,root,root) %{_libexecdir}/analyze-c++
-%attr(755,root,root) %{_libexecdir}/analyze-cc
-%attr(755,root,root) %{_libexecdir}/intercept-c++
-%attr(755,root,root) %{_libexecdir}/intercept-cc
-%{_prefix}/lib/libear
-%{_prefix}/lib/libscanbuild
-%{_datadir}/scan-build
-%{_datadir}/scan-view
-%{_mandir}/man1/scan-build.1*
-%dir %{_libdir}/scan-build
-%attr(755,root,root) %{_libdir}/scan-build/c++-analyzer
-%attr(755,root,root) %{_libdir}/scan-build/ccc-analyzer
+%attr(755,root,root) %{_libdir}/libclang.so.%{abi}
+%attr(755,root,root) %{_libdir}/libclang.so.*.*.*
 
 %files -n clang-devel
 %defattr(644,root,root,755)
@@ -1058,6 +1174,28 @@ rm -rf $RPM_BUILD_ROOT
 %doc clang-apidoc/*
 %endif
 
+%files -n clang-analyzer
+%defattr(644,root,root,755)
+%dir %{_libexecdir}/clang-analyzer
+# perl tools
+%attr(755,root,root) %{_bindir}/scan-build
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/c++-analyzer
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/ccc-analyzer
+%{_datadir}/scan-build
+%{_mandir}/man1/scan-build.1*
+# python tools
+%attr(755,root,root) %{_bindir}/analyze-build
+%attr(755,root,root) %{_bindir}/intercept-build
+%attr(755,root,root) %{_bindir}/scan-build-py
+%attr(755,root,root) %{_bindir}/scan-view
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/analyze-c++
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/analyze-cc
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-c++
+%attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-cc
+%{_prefix}/lib/libear
+%{_prefix}/lib/libscanbuild
+%{_datadir}/scan-view
+
 %files -n clang-tools-extra
 %defattr(644,root,root,755)
 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt}
@@ -1083,12 +1221,50 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/clang/clang-tidy-diff.py
 %{_datadir}/clang/run-find-all-symbols.py
 
+%files -n bash-completion-clang
+%defattr(644,root,root,755)
+%{bash_compdir}/clang
+
+%if %{with flang}
+%files -n flang
+%defattr(644,root,root,755)
+%doc tools/flang/{LICENSE.TXT,README.md}
+%attr(755,root,root) %{_bindir}/f18
+%attr(755,root,root) %{_bindir}/f18-parse-demo
+%attr(755,root,root) %{_bindir}/fir-opt
+%attr(755,root,root) %{_bindir}/flang
+%attr(755,root,root) %{_bindir}/tco
+%dir %{_includedir}/flang
+%{_includedir}/flang/Version.inc
+%{_includedir}/flang/__fortran_*.mod
+%{_includedir}/flang/ieee_*.mod
+%{_includedir}/flang/iso_*.mod
+%{_includedir}/flang/omp_lib*.mod
+
+%files -n flang-devel
+%defattr(644,root,root,755)
+%{_libdir}/libFIROptimizer.a
+%{_libdir}/libFortran*.a
+%{_includedir}/flang/Common
+%{_includedir}/flang/Decimal
+%{_includedir}/flang/Evaluate
+%{_includedir}/flang/Frontend
+%{_includedir}/flang/FrontendTool
+%{_includedir}/flang/Lower
+%{_includedir}/flang/Optimizer
+%{_includedir}/flang/Parser
+%{_includedir}/flang/Semantics
+%{_includedir}/flang/ISO_Fortran_binding.h
+%{_libdir}/cmake/flang
+%endif
+
 %files -n lld
 %defattr(644,root,root,755)
 %doc tools/lld/{LICENSE.TXT,README.md}
 %attr(755,root,root) %{_bindir}/ld.lld
 %attr(755,root,root) %{_bindir}/ld64.lld
 %attr(755,root,root) %{_bindir}/ld64.lld.darwinnew
+%attr(755,root,root) %{_bindir}/ld64.lld.darwinold
 %attr(755,root,root) %{_bindir}/lld
 %attr(755,root,root) %{_bindir}/lld-link
 %attr(755,root,root) %{_bindir}/wasm-ld
This page took 0.155085 seconds and 4 git commands to generate.