]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
add R: llvm-polly-devel to clang-devel
[packages/llvm.git] / llvm.spec
index f0d3cc4101688594412c0439117e6e467968dfad..a5964adfb67d14dea411c2c27b2b51f1eb88c178 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -1,8 +1,14 @@
+#
+# NOTE:
+#  - normal build (x86_64) requires about 80 GB of disk space
+#
 # TODO:
 # - move and package:
+#      %{_datadir}/clang/bash-autocomplete.sh
 #      %{_datadir}/clang/clang-format-sublime.py - sublime plugin
-#      %{_datadir}/clang/clang-format.el - emacs mode
-#      %{_datadir}/clang/clang-format.py - vim plugin
+#      %{_datadir}/clang/clang-format.el - clang tools emacs integration
+#      %{_datadir}/clang/clang-include-fixer.el
+#      %{_datadir}/clang/clang-rename.el
 # - no content in doc package (it used to contain parts of clang apidocs and some examples)
 # - system isl in polly?
 #
 %bcond_without rt              # compiler-rt libraries
 %bcond_without multilib        # compiler-rt multilib libraries
 %bcond_without ocaml           # OCaml binding
+%bcond_without z3              # Z3 constraint solver support in Clang Static Analyzer
 %bcond_without doc             # HTML docs and man pages
+%bcond_with    cxxmodules      # C++20 modules (requires support in bootstrap compiler)
 %bcond_with    apidocs         # doxygen docs (HUGE, so they are not built by default)
 %bcond_with    tests           # run tests
 
 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
-%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
+%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
 %undefine      with_ocaml
 %endif
 
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       3.8.1
-Release:       0.1
+Version:       10.0.0
+Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
-#Source0Download: http://llvm.org/releases/download.html
-Source0:       http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: 538467e6028bbc9259b1e6e015d25845
-Source1:       http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
-# Source1-md5: 4ff2f8844a786edb0220f490f7896080
-Source2:       http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: f140db073d2453f854fbe01cc46f3110
-Source3:       http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: 9e4787b71be8e432fffd31e13ac87623
-Source4:       http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 8a40e697a4ba1c8b640b85d074bd6e25
-Source5:       http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: 6e49f285d0b366cc3cab782d8c92d382
-Source6:       http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: 68cd069bf99c71ebcfbe01d557c0e14d
-Patch0:                %{name}-lld-link.patch
+#Source0Download: https://github.com/llvm/llvm-project/releases/
+Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
+# Source0-md5: 693cefdc49d618f828144486a18b473f
+Source1:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
+# Source1-md5: 717ef92318fed4dbe1ee058368cfb552
+Source2:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
+# Source2-md5: 3a8477233f69600f3e2ca997405c29db
+Source3:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
+# Source3-md5: 9828da982f3088cece20e0db9e76e06d
+Source4:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/polly-%{version}.src.tar.xz
+# Source4-md5: f71e6f808676c211338ad10b3ad5c10d
+Source5:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
+# Source5-md5: 19adb2918e88d682ba2f97ac7280a25d
+Source6:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
+# Source6-md5: 481ab4e01c8c5549c8aff5ef1bd25425
 Patch1:                %{name}-pld.patch
-Patch2:                libdir.patch
+Patch2:                %{name}-python-modules.patch
 Patch3:                x32-gcc-toolchain.patch
 Patch4:                cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
 URL:           http://llvm.org/
 BuildRequires: bash
 BuildRequires: bison
-BuildRequires: cmake >= 2.8.12.2
+BuildRequires: cmake >= 3.4.3
 BuildRequires: flex
 BuildRequires: gcc >= 5:3.4
 # gcc4 might be installed, but not current __cc
 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
 BuildRequires: __cc >= 3.4
 %endif
-%ifarch x32
-BuildRequires: glibc-devel(x86_64)
-%endif
 BuildRequires: groff
 BuildRequires: libedit-devel
 BuildRequires: libltdl-devel
+BuildRequires: libpfm-devel
 BuildRequires: libstdc++-devel >= 5:3.4
+BuildRequires: libxml2-devel >= 2
 BuildRequires: ncurses-devel
 %if %{with ocaml}
+BuildRequires: ocaml >= 4.00.0
 BuildRequires: ocaml-ctypes-devel >= 0.4
 BuildRequires: ocaml-findlib
 BuildRequires: ocaml-ocamldoc
-BuildRequires: ocaml-ounit
+BuildRequires: ocaml-ounit >= 2
 %endif
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: perl-tools-pod
 BuildRequires: python >= 1:2.7
+BuildRequires: python-PyYAML
+BuildRequires: python-pygments >= 2.0
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.734
 %{?with_doc:BuildRequires:     sphinx-pdg}
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+%{?with_z3:BuildRequires:      z3-devel >= 4.7.1}
 BuildRequires: zlib-devel
 %if %{with apidocs}
 BuildRequires: doxygen
@@ -94,6 +105,13 @@ BuildRequires:      tcl-devel
 BuildRequires: gcc-c++-multilib-32
 BuildRequires: libstdc++-multilib-32-devel
 %endif
+%ifarch x32
+BuildRequires: gcc-c++-multilib-32
+BuildRequires: gcc-c++-multilib-64
+BuildRequires: glibc-devel(x86_64)
+BuildRequires: libstdc++-multilib-32-devel
+BuildRequires: libstdc++-multilib-64-devel
+%endif
 %endif
 %if %{with lldb}
 BuildRequires: epydoc
@@ -102,13 +120,14 @@ BuildRequires:    libatomic-devel
 %endif
 BuildRequires: libxml2-devel >= 2
 BuildRequires: ncurses-ext-devel
-BuildRequires: python-devel >= 2
-BuildRequires: swig-python
+BuildRequires: python-devel >= 1:2.7
+%{?with_doc:BuildRequires:     python3-recommonmark}
+BuildRequires: swig-python >= 3.0.11
 %endif
 %if %{with polly}
 #BuildRequires:        gmp-devel or imath-devel (private copy in polly/lib/External/isl/imath)
 # private copy in polly/lib/External/isl
-#BuildRequires:        isl-devel >= 0.15
+#BuildRequires:        isl-devel >= 0.18
 #TODO (bcond): cuda-devel (with POLLY_ENABLE_GPGPU_CODEGEN=ON)
 %endif
 %if %{with ocaml}
@@ -120,11 +139,24 @@ Requires: %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                abi     3.8
+%define                abi     10
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
 
+# objcopy: BFD (GNU Binutils) 2.32 assertion fail format.c:459
+# objcopy: error: .../libLLVM-8.so(.debug_gnu_pubtypes) is too large (0x1ceee347 bytes)
+# objcopy: .../libLLVM-8.so[.debug_gnu_pubtypes]: memory exhausted
+%ifarch x32
+%define                _enable_debug_packages  0
+%endif
+# ix86 and x32 - the same issue as https://llvm.org/bugs/show_bug.cgi?id=27237
+# use -gsplit-dwarf only when building packages with debuginfo
+# to avoid excessive disk space usage
+%if 0%{?_enable_debug_packages}
+%define                specflags       -gsplit-dwarf
+%endif
+
 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
 %define                _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
 
@@ -135,9 +167,6 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                filterout_cxx   -fvar-tracking-assignments -Werror=format-security
 %define                filterout_ccpp  -fvar-tracking-assignments
 
-# std::__once_call, std::__once_callable non-function symbols
-%define                skip_post_check_so      liblldb.so.*
-
 %description
 LLVM is a compiler infrastructure designed for compile-time,
 link-time, runtime, and idle-time optimization of programs from
@@ -334,6 +363,7 @@ Summary(pl.UTF-8):  Pliki nagłówkowe Clanga
 Group:         Development/Languages
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      clang = %{version}-%{release}
+%{?with_polly:Requires:        llvm-polly-devel = %{version}-%{release}}
 
 %description -n clang-devel
 This package contains header files for the Clang compiler.
@@ -482,27 +512,56 @@ HTML documentation for LLVM's OCaml binding.
 %description ocaml-doc -l pl.UTF-8
 Dokumentacja HTML wiązania OCamla do LLVM-a.
 
+%package opt-viewer
+Summary:       Optimization records visualization tools
+Summary(pl.UTF-8):     Narzędzia do wizualizacji rekordów optymalizacji
+Group:         Development/Tools
+Requires:      %{name} = %{version}
+BuildArch:     noarch
+
+%description opt-viewer
+Optimization records visualization tools.
+
+%description opt-viewer -l pl.UTF-8
+Narzędzia do wizualizacji rekordów optymalizacji.
+
+%package -n vim-plugin-clang
+Summary:       Clang format and rename integration for Vim
+Summary(pl.UTF-8):     Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem
+Group:         Applications/Editors/Vim
+Requires:      vim-rt >= 4:7.0
+BuildArch:     noarch
+
+%description -n vim-plugin-clang
+Clang format and rename integration for Vim.
+
+%description -n vim-plugin-clang -l pl.UTF-8
+Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
+
 %prep
 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
-%{__mv} cfe-%{version}.src tools/clang
-%{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
-%{?with_lldb:mv lldb-%{version}.src tools/lldb}
-%{?with_polly:mv polly-%{version}.src tools/polly}
+%{__mv} clang-%{version}.src tools/clang
+%{?with_rt:%{__mv} compiler-rt-%{version}.src projects/compiler-rt}
+%{?with_lldb:%{__mv} lldb-%{version}.src tools/lldb}
+%{?with_polly:%{__mv} polly-%{version}.src tools/polly}
 %{__mv} clang-tools-extra-%{version}.src tools/clang/tools/extra
 %{__mv} lld-%{version}.src tools/lld
 
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
 
-grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
+grep -rl /usr/bin/env projects tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python},
        s,^#!.*bin/env perl,#!%{__perl},
 }'
 
+find -name '*.py' -print0 | xargs -0 sed -i -e '1{
+       s,^#!.*bin/python.*,#!%{__python},
+}'
+
 %build
 install -d build
 
@@ -511,32 +570,35 @@ install -d build
 cd build
 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 
-%cmake \
-%ifarch %{x8664}
-       -DLLVM_LIBDIR_SUFFIX:STRING=64 \
-%endif
-%ifarch x32
-       -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
-%endif
+%cmake .. \
+       -DBUILD_SHARED_LIBS:BOOL=OFF \
+       -DENABLE_LINKER_BUILD_ID:BOOL=ON \
+       -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
+       -DLLVM_BINUTILS_INCDIR:STRING=%{_includedir} \
+       -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
+       -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
+       -DLLVM_ENABLE_CXX1Y:BOOL=ON \
 %if %{with apidocs}
        -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
 %endif
+       %{?with_cxxmodules:-DLLVM_ENABLE_MODULES:BOOL=ON} \
+       -DLLVM_ENABLE_PIC:BOOL=ON \
+       -DLLVM_ENABLE_RTTI:BOOL=ON \
 %if %{with doc}
        -DLLVM_ENABLE_SPHINX:BOOL=ON \
-       -DSPHINX_WARNINGS_AS_ERRORS=OFF \
 %endif
-       -DLLVM_ENABLE_PIC:BOOL=ON \
-       -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
-       -DLLVM_ENABLE_CXX1Y:BOOL=ON \
-       -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
-       -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
+       %{!?with_z3:-DLLVM_ENABLE_Z3_SOLVER:BOOL=OFF} \
+%if "%{_lib}" == "lib64"
+       -DLLVM_LIBDIR_SUFFIX:STRING=64 \
+%endif
+%if "%{_lib}" == "libx32"
+       -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
+%endif
        -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
-       -DBUILD_SHARED_LIBS:BOOL=OFF \
-       ../
+       -DSPHINX_WARNINGS_AS_ERRORS=OFF
 
 %{__make} \
        VERBOSE=1 \
-       REQUIRES_RTTI=1 \
        OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
 
 %if %{with tests}
@@ -553,14 +615,18 @@ CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 %{__make} -C tools/clang/docs docs-clang-html
 %{__make} -C tools/clang/docs docs-clang-man
 %{__make} -C tools/lld/docs docs-lld-html
-%{__make} -C tools/lldb/docs lldb-python-doc
+# workaround failed import of _lldb
+cp -pnL %{_lib}/python%{py_ver}/site-packages/lldb/_lldb.so tools/lldb/docs/lldb
+%{__make} \
+       LD_LIBRARY_PATH=$(pwd)/%{_lib} \
+       -C tools/lldb/docs lldb-python-doc
 %{__make} -C tools/lldb/docs lldb-cpp-doc
-%{__make} -C ../tools/clang/tools/extra/docs html
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -C build install \
+
+%{__make} -j1 -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 # only some .pyc files are created by make install
@@ -571,7 +637,7 @@ rm -rf $RPM_BUILD_ROOT
 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
 install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
 %{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
-%{__sed} -i -e 's,/\.\./libexec/,../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
+%{__sed} -i -e 's,/\.\./libexec/,/../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
 %py_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
 %py_postclean %{_datadir}/scan-view
@@ -590,7 +656,7 @@ echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
 # Move documentation back to build directory
 %if %{with ocaml}
 rm -rf ocamldocs
-%{__mv} $RPM_BUILD_ROOT%{_prefix}/docs/ocaml/html/html ocamldocs
+%{__mv} $RPM_BUILD_ROOT%{_docdir}/llvm/ocaml-html ocamldocs
 %endif
 
 # and separate the apidoc
@@ -606,14 +672,16 @@ for f in LICENSE.TXT NOTES.txt README.txt; do
        ln tools/clang/$f clang-docs
 done
 
-# Get rid of erroneously installed example files.
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
-# test?
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{c-index-test,llvm-c-test}
 # not this OS
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
 # use system six
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/six.py*
+# it seems it is used internally by an extra clang tool
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
+
+# disable completeness check incompatible with split packaging
+%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_libdir}/cmake/llvm/LLVMExports.cmake
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -621,8 +689,8 @@ rm -rf $RPM_BUILD_ROOT
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
-%post  -n clang -p /sbin/ldconfig
-%postun        -n clang -p /sbin/ldconfig
+%post  -n clang-libs -p /sbin/ldconfig
+%postun        -n clang-libs -p /sbin/ldconfig
 
 %post  -n lldb -p /sbin/ldconfig
 %postun        -n lldb -p /sbin/ldconfig
@@ -631,61 +699,102 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
 %attr(755,root,root) %{_bindir}/bugpoint
+%attr(755,root,root) %{_bindir}/dsymutil
 %attr(755,root,root) %{_bindir}/llc
 %attr(755,root,root) %{_bindir}/lli
+%attr(755,root,root) %{_bindir}/llvm-addr2line
 %attr(755,root,root) %{_bindir}/llvm-ar
 %attr(755,root,root) %{_bindir}/llvm-as
 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
+%attr(755,root,root) %{_bindir}/llvm-cat
+%attr(755,root,root) %{_bindir}/llvm-cfi-verify
 %attr(755,root,root) %{_bindir}/llvm-cov
+%attr(755,root,root) %{_bindir}/llvm-cvtres
+%attr(755,root,root) %{_bindir}/llvm-cxxdump
+%attr(755,root,root) %{_bindir}/llvm-cxxfilt
+%attr(755,root,root) %{_bindir}/llvm-cxxmap
 %attr(755,root,root) %{_bindir}/llvm-diff
 %attr(755,root,root) %{_bindir}/llvm-dis
-%attr(755,root,root) %{_bindir}/llvm-dsymutil
+%attr(755,root,root) %{_bindir}/llvm-dlltool
 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
 %attr(755,root,root) %{_bindir}/llvm-dwp
+%attr(755,root,root) %{_bindir}/llvm-elfabi
+%attr(755,root,root) %{_bindir}/llvm-exegesis
 %attr(755,root,root) %{_bindir}/llvm-extract
+%attr(755,root,root) %{_bindir}/llvm-ifs
+%attr(755,root,root) %{_bindir}/llvm-install-name-tool
+%attr(755,root,root) %{_bindir}/llvm-jitlink
 %attr(755,root,root) %{_bindir}/llvm-lib
 %attr(755,root,root) %{_bindir}/llvm-link
+%attr(755,root,root) %{_bindir}/llvm-lipo
 %attr(755,root,root) %{_bindir}/llvm-lto
+%attr(755,root,root) %{_bindir}/llvm-lto2
 %attr(755,root,root) %{_bindir}/llvm-mc
-%attr(755,root,root) %{_bindir}/llvm-mcmarkup
+%attr(755,root,root) %{_bindir}/llvm-mca
+%attr(755,root,root) %{_bindir}/llvm-modextract
+%attr(755,root,root) %{_bindir}/llvm-mt
 %attr(755,root,root) %{_bindir}/llvm-nm
+%attr(755,root,root) %{_bindir}/llvm-objcopy
 %attr(755,root,root) %{_bindir}/llvm-objdump
+%attr(755,root,root) %{_bindir}/llvm-opt-report
+%attr(755,root,root) %{_bindir}/llvm-pdbutil
 %attr(755,root,root) %{_bindir}/llvm-profdata
 %attr(755,root,root) %{_bindir}/llvm-ranlib
+%attr(755,root,root) %{_bindir}/llvm-rc
+%attr(755,root,root) %{_bindir}/llvm-readelf
 %attr(755,root,root) %{_bindir}/llvm-readobj
+%attr(755,root,root) %{_bindir}/llvm-reduce
 %attr(755,root,root) %{_bindir}/llvm-rtdyld
 %attr(755,root,root) %{_bindir}/llvm-size
 %attr(755,root,root) %{_bindir}/llvm-split
+%attr(755,root,root) %{_bindir}/llvm-strip
 %attr(755,root,root) %{_bindir}/llvm-stress
+%attr(755,root,root) %{_bindir}/llvm-strings
 %attr(755,root,root) %{_bindir}/llvm-symbolizer
 %attr(755,root,root) %{_bindir}/llvm-tblgen
-%attr(755,root,root) %{_bindir}/llvm-cxxdump
-%attr(755,root,root) %{_bindir}/llvm-pdbdump
+%attr(755,root,root) %{_bindir}/llvm-undname
+%attr(755,root,root) %{_bindir}/llvm-xray
 %attr(755,root,root) %{_bindir}/obj2yaml
 %attr(755,root,root) %{_bindir}/opt
 %attr(755,root,root) %{_bindir}/sancov
+%attr(755,root,root) %{_bindir}/sanstats
 %attr(755,root,root) %{_bindir}/verify-uselistorder
 %attr(755,root,root) %{_bindir}/yaml2obj
 %if %{with doc}
 %{_mandir}/man1/bugpoint.1*
+%{_mandir}/man1/dsymutil.1*
 %{_mandir}/man1/lit.1*
 %{_mandir}/man1/llc.1*
 %{_mandir}/man1/lli.1*
+%{_mandir}/man1/llvm-addr2line.1*
 %{_mandir}/man1/llvm-ar.1*
 %{_mandir}/man1/llvm-as.1*
 %{_mandir}/man1/llvm-bcanalyzer.1*
 %{_mandir}/man1/llvm-cov.1*
+%{_mandir}/man1/llvm-cxxfilt.1*
+%{_mandir}/man1/llvm-cxxmap.1*
 %{_mandir}/man1/llvm-diff.1*
 %{_mandir}/man1/llvm-dis.1*
 %{_mandir}/man1/llvm-dwarfdump.1*
+%{_mandir}/man1/llvm-exegesis.1*
 %{_mandir}/man1/llvm-extract.1*
 %{_mandir}/man1/llvm-lib.1*
 %{_mandir}/man1/llvm-link.1*
+%{_mandir}/man1/llvm-lipo.1*
+%{_mandir}/man1/llvm-locstats.1*
+%{_mandir}/man1/llvm-mca.1*
 %{_mandir}/man1/llvm-nm.1*
+%{_mandir}/man1/llvm-objcopy.1*
+%{_mandir}/man1/llvm-objdump.1*
+%{_mandir}/man1/llvm-pdbutil.1*
 %{_mandir}/man1/llvm-profdata.1*
 %{_mandir}/man1/llvm-ranlib.1*
+%{_mandir}/man1/llvm-readelf.1*
 %{_mandir}/man1/llvm-readobj.1*
+%{_mandir}/man1/llvm-size.1*
 %{_mandir}/man1/llvm-stress.1*
+%{_mandir}/man1/llvm-strings.1*
+%{_mandir}/man1/llvm-strip.1*
 %{_mandir}/man1/llvm-symbolizer.1*
 %{_mandir}/man1/opt.1*
 %{_mandir}/man1/tblgen.1*
@@ -696,18 +805,22 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
 # non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %{_libdir}/libLTO.so
+%attr(755,root,root) %ghost %{_libdir}/libLTO.so.10
+%attr(755,root,root) %{_libdir}/LLVMgold.so
+%attr(755,root,root) %{_libdir}/libRemarks.so.10
+%attr(755,root,root) %{_libdir}/libclang-cpp.so.10
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/llvm-config
 %attr(755,root,root) %{_libdir}/libLLVM.so
-%attr(755,root,root) %{_libdir}/BugpointPasses.so
+%attr(755,root,root) %{_libdir}/libLTO.so
+%attr(755,root,root) %{_libdir}/libRemarks.so
+%attr(755,root,root) %{_libdir}/libclang-cpp.so
 %{_libdir}/libLLVM*.a
 %{_includedir}/llvm
 %{_includedir}/llvm-c
-%dir %{_datadir}/llvm
-%{_datadir}/llvm/cmake
+%{_libdir}/cmake/llvm
 %if %{with doc}
 %{_mandir}/man1/llvm-config.1*
 %endif
@@ -731,7 +844,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libPolly.a
 %{_libdir}/libPollyISL.a
+%{_libdir}/libPollyPPCG.a
 %{_includedir}/polly
+%{_libdir}/cmake/polly
 %endif
 
 %files -n clang
@@ -742,34 +857,63 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang-%{abi}
 %attr(755,root,root) %{_bindir}/clang-check
 %attr(755,root,root) %{_bindir}/clang-cl
+%attr(755,root,root) %{_bindir}/clang-cpp
+%attr(755,root,root) %{_bindir}/clang-doc
 %attr(755,root,root) %{_bindir}/clang-format
+%attr(755,root,root) %{_bindir}/clang-import-test
+%attr(755,root,root) %{_bindir}/clang-offload-bundler
+%attr(755,root,root) %{_bindir}/clang-offload-wrapper
 %attr(755,root,root) %{_bindir}/git-clang-format
 %dir %{_libdir}/clang
 %dir %{_libdir}/clang/%{version}
 %{_libdir}/clang/%{version}/include
 %if %{with rt}
-%ifarch %{ix86} %{x8664} x32
+%dir %{_libdir}/clang/%{version}/bin
+%attr(755,root,root) %{_libdir}/clang/%{version}/bin/hwasan_symbolize
+%ifarch %{ix86} %{x8664}
+%dir %{_libdir}/clang/%{version}/lib
+%dir %{_libdir}/clang/%{version}/lib/linux
+%dir %{_libdir}/clang/%{version}/share
+%endif
+%ifarch x32
+%if %{with multilib}
 %dir %{_libdir}/clang/%{version}/lib
 %dir %{_libdir}/clang/%{version}/lib/linux
+%dir %{_libdir}/clang/%{version}/share
+%endif
 %endif
 %ifarch %{ix86}
+%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-i*86.o
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.a
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
 %endif
 %ifarch %{x8664}
+%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-x86_64.o
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
 %endif
-%ifarch %{ix86} %{x8664} x32 %{arm} aarch64 mips mips64 ppc64
-%{_libdir}/clang/%{version}/asan_blacklist.txt
+%ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
+%{_libdir}/clang/%{version}/share/asan_blacklist.txt
 %endif
-%ifarch %{ix86} %{x8664} x32 mips64
-%{_libdir}/clang/%{version}/cfi_blacklist.txt
+%ifarch %{ix86} %{x8664} mips64
+%{_libdir}/clang/%{version}/share/cfi_blacklist.txt
+%endif
+%ifarch %{x8664} aarch64 mips64
+%{_libdir}/clang/%{version}/share/dfsan_abilist.txt
+%{_libdir}/clang/%{version}/share/msan_blacklist.txt
+%endif
+%ifarch %{x8664} aarch64
+%{_libdir}/clang/%{version}/share/hwasan_blacklist.txt
+%endif
+%ifarch x32
+%if %{with multilib}
+%{_libdir}/clang/%{version}/share/asan_blacklist.txt
+%{_libdir}/clang/%{version}/share/cfi_blacklist.txt
+%{_libdir}/clang/%{version}/share/dfsan_abilist.txt
+%{_libdir}/clang/%{version}/share/msan_blacklist.txt
+%{_libdir}/clang/%{version}/share/hwasan_blacklist.txt
 %endif
-%ifarch %{x8664} x32 aarch64 mips64
-%{_libdir}/clang/%{version}/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/msan_blacklist.txt
 %endif
 %endif
 %dir %{_datadir}/clang
@@ -783,10 +927,12 @@ rm -rf $RPM_BUILD_ROOT
 %ifarch %{x8664} x32
 %files -n clang-multilib
 %defattr(644,root,root,755)
+%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-i386.o
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
 %endif
 %ifarch x32
+%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-x86_64.o
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
@@ -810,7 +956,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libclang*.a
 %{_includedir}/clang
 %{_includedir}/clang-c
-%{_datadir}/clang/cmake
+%{_libdir}/cmake/clang
 
 %files -n clang-doc
 %defattr(644,root,root,755)
@@ -824,71 +970,96 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n clang-tools-extra
 %defattr(644,root,root,755)
-%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt} tools/clang/tools/extra/docs/_build/html/{*.html,*.js,_static}
+%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt}
 %attr(755,root,root) %{_bindir}/clang-apply-replacements
+%attr(755,root,root) %{_bindir}/clang-change-namespace
+%attr(755,root,root) %{_bindir}/clang-extdef-mapping
+%attr(755,root,root) %{_bindir}/clang-include-fixer
+%attr(755,root,root) %{_bindir}/clang-move
 %attr(755,root,root) %{_bindir}/clang-query
+%attr(755,root,root) %{_bindir}/clang-refactor
 %attr(755,root,root) %{_bindir}/clang-rename
+%attr(755,root,root) %{_bindir}/clang-reorder-fields
+%attr(755,root,root) %{_bindir}/clang-scan-deps
 %attr(755,root,root) %{_bindir}/clang-tidy
+%attr(755,root,root) %{_bindir}/clangd
+%attr(755,root,root) %{_bindir}/diagtool
+%attr(755,root,root) %{_bindir}/find-all-symbols
+%attr(755,root,root) %{_bindir}/hmaptool
 %attr(755,root,root) %{_bindir}/modularize
 %attr(755,root,root) %{_bindir}/pp-trace
+%{_datadir}/clang/clang-include-fixer.py
 %{_datadir}/clang/clang-tidy-diff.py
 %{_datadir}/clang/run-clang-tidy.py
+%{_datadir}/clang/run-find-all-symbols.py
 
 %files -n lld
 %defattr(644,root,root,755)
 %doc tools/lld/{LICENSE.TXT,README.md}
 %attr(755,root,root) %{_bindir}/ld.lld
+%attr(755,root,root) %{_bindir}/ld64.lld
 %attr(755,root,root) %{_bindir}/lld
 %attr(755,root,root) %{_bindir}/lld-link
+%attr(755,root,root) %{_bindir}/wasm-ld
 
 %files -n lld-devel
 %defattr(644,root,root,755)
-%{_libdir}/liblld[ACDEHMRXY]*.a
+%{_libdir}/liblld[ACDEHMRWXY]*.a
 %{_includedir}/lld
 
 %if %{with lldb}
 %files -n lldb
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/lldb
-%attr(755,root,root) %{_bindir}/lldb-%{version}
 %attr(755,root,root) %{_bindir}/lldb-argdumper
-%attr(755,root,root) %{_bindir}/lldb-mi
-%attr(755,root,root) %{_bindir}/lldb-mi-%{version}
+%attr(755,root,root) %{_bindir}/lldb-instr
 %attr(755,root,root) %{_bindir}/lldb-server
-%attr(755,root,root) %{_bindir}/lldb-server-%{version}
+%attr(755,root,root) %{_bindir}/lldb-vscode
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.10
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.10
 %dir %{py_sitedir}/lldb
 %attr(755,root,root) %{py_sitedir}/lldb/lldb-argdumper
 %{py_sitedir}/lldb/formatters
-%{py_sitedir}/lldb/runtime
 %{py_sitedir}/lldb/utils
 %{py_sitedir}/lldb/__init__.py[co]
 %{py_sitedir}/lldb/embedded_interpreter.py[co]
 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
-%attr(755,root,root) %{py_sitedir}/readline.so
 
 %files -n lldb-devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/liblldb.so
-%{_libdir}/liblldb*.a
+%attr(755,root,root) %{_libdir}/liblldbIntelFeatures.so
 %{_includedir}/lldb
 %endif
 
 %if %{with ocaml}
 %files ocaml
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllllvm*.so
+%dir %{_libdir}/ocaml/llvm
+%{_libdir}/ocaml/llvm/llvm*.cma
+%{_libdir}/ocaml/llvm/llvm*.cmi
 %{_libdir}/ocaml/META.llvm*
-%attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
-%{_libdir}/ocaml/llvm*.cma
-%{_libdir}/ocaml/llvm*.cmi
 
 %files ocaml-devel
 %defattr(644,root,root,755)
-%{_libdir}/ocaml/libllvm*.a
-%{_libdir}/ocaml/llvm*.a
-%{_libdir}/ocaml/llvm*.cmx*
+%{_libdir}/ocaml/llvm/libllvm*.a
+%{_libdir}/ocaml/llvm/llvm*.a
+%{_libdir}/ocaml/llvm/llvm*.cmx
+%{_libdir}/ocaml/llvm/llvm*.cmxa
+%{_libdir}/ocaml/llvm/llvm*.mli
 
 %files ocaml-doc
 %defattr(644,root,root,755)
 %doc ocamldocs/*
 %endif
+
+%files opt-viewer
+%defattr(644,root,root,755)
+%{_datadir}/opt-viewer
+
+%files -n vim-plugin-clang
+%defattr(644,root,root,755)
+%{_datadir}/clang/clang-format.py
+%{_datadir}/clang/clang-rename.py
This page took 0.097337 seconds and 4 git commands to generate.