]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
Release 2 (by relup.sh)
[packages/llvm.git] / llvm.spec
index f0d4ccfb22bf2d393d35a57fd1c4ef86f3b48998..949611c8e536a4e8a02c8ae71334cf7082964abc 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
 # - system isl in polly?
 #
 # Conditional build:
-%bcond_without lldb            # LLDB debugger
-%bcond_without polly           # Polly cache-locality optimization, auto-parallelism and vectorization
-%bcond_without rt              # compiler-rt libraries
-%bcond_without multilib        # compiler-rt multilib libraries
-%bcond_without ocaml           # OCaml binding
-%bcond_without z3              # Z3 constraint solver support in Clang Static Analyzer
-%bcond_without doc             # HTML docs and man pages
-%bcond_with    cxxmodules      # C++20 modules (requires support in bootstrap compiler)
-%bcond_with    apidocs         # doxygen docs (HUGE, so they are not built by default)
-%bcond_with    tests           # run tests
+%bcond_without lldb                    # LLDB debugger
+%bcond_without polly                   # Polly cache-locality optimization, auto-parallelism and vectorization
+%bcond_without rt                      # compiler-rt libraries
+%bcond_without multilib                # compiler-rt multilib libraries
+%bcond_without ocaml                   # OCaml binding
+%bcond_without z3                      # Z3 constraint solver support in Clang Static Analyzer
+%bcond_without doc                     # HTML docs and man pages
+%bcond_without target_aarch64          # AArch64 target support
+%bcond_without target_amdgpu           # AMDGPU target support
+%bcond_without target_arm              # ARM target support
+%bcond_without target_avr              # AVR target support
+%bcond_without target_bpf              # BPF target support
+%bcond_without target_hexagon          # Hexagon target support
+%bcond_without target_lanai            # Lanai target support
+%bcond_without target_mips             # Mips target support
+%bcond_without target_msp430           # MSP430 target support
+%bcond_without target_nvptx            # NVPTX target support
+%bcond_without target_powerpc          # PowerPC target support
+%bcond_without target_riscv            # RISCV target support
+%bcond_without target_sparc            # Sparc target support
+%bcond_without target_systemz          # SystemZ target support
+%bcond_without target_webassembly      # WebAssembly target support
+%bcond_without target_x86              # X86 target support
+%bcond_without target_xcore            # XCore target support
+%bcond_with    flang                   # flang (Fortran18) compiler (broken as of 11.0.1)
+%bcond_with    cxxmodules              # C++20 modules (requires support in bootstrap compiler)
+%bcond_with    apidocs                 # doxygen docs (HUGE, so they are not built by default)
+%bcond_with    tests                   # run tests
+%bcond_with    lowmem                  # lower memory requirements
 
 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
 %undefine      with_ocaml
 %endif
 
+%ifarch armv3l armv4b armv4l armv4tl armv5tl armv5tel armv5tejl armv6l armv6hl
+%undefine      with_rt
+%endif
+
+%ifarch %{arm} aarch64
+%define                with_lowmem             1
+%endif
+
+%define                targets_to_build        %{?with_target_aarch64:AArch64;}%{?with_target_amdgpu:AMDGPU;}%{?with_target_arm:ARM;}%{?with_target_avr:AVR;}%{?with_target_bpf:BPF;}%{?with_target_hexagon:Hexagon;}%{?with_target_lanai:Lanai;}%{?with_target_mips:Mips;}%{?with_target_msp430:MSP430;}%{?with_target_nvptx:NVPTX;}%{?with_target_powerpc:PowerPC;}%{?with_target_riscv:RISCV;}%{?with_target_sparc:Sparc;}%{?with_target_systemz:SystemZ;}%{?with_target_webassembly:WebAssembly;}%{?with_target_x86:X86;}%{?with_target_xcore:XCore;}
+
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       10.0.1
-Release:       1
+Version:       12.0.1
+Release:       2
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
 #Source0Download: https://github.com/llvm/llvm-project/releases/
 Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: 71c68c526cbbf1674b5aafc5542b336c
+# Source0-md5: 72a257604efa1d32ef85a37cd9c66873
 Source1:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
-# Source1-md5: 6c8b56f531876fd24e06257a2d8ce422
+# Source1-md5: 03d77af27fcbeeae4414fb4713b9fd7e
 Source2:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: 970835d14e9c08a68c4b2ff3931bada7
+# Source2-md5: 40095daa9070b20eef9bdd32fdc53db5
 Source3:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: 0dddd62dd96ba97ccf075fc3ca086024
+# Source3-md5: e5727e0caf947dfc5575db22d1186b9a
 Source4:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 263ad3980c19012719b14333b69c108e
+# Source4-md5: 6932b855535c97283b21c07f0e9cfd79
 Source5:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: 251388aa2f5fbd472acc9735b3386e59
+# Source5-md5: befc3b0dbd926378f9e863b6817d4fb8
 Source6:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: c8f364fbb129e47ef2793c317561449a
+# Source6-md5: bb29dcdebead37a8738986d4ef616e69
+Source7:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/flang-%{version}.src.tar.xz
+# Source7-md5: 2cbf2687297f20467b3bd9a8a490b4be
+# "mlir" subdir extracted from https://github.com/llvm/llvm-project/releases/download/llvmorg-12.0.0/llvm-project-12.0.0.src.tar.xz
+Source8:       mlir-%{version}.tar.xz
+# Source8-md5: fca8ea96f3e3278a0e5d8c1d5d5c821e
 Patch1:                %{name}-pld.patch
 Patch2:                %{name}-python-modules.patch
 Patch3:                x32-gcc-toolchain.patch
 Patch4:                cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
-Patch6:                lld-sphinx2.patch
+Patch6:                %{name}-flang.patch
+Patch7:                llvm12-build_fixes.patch
 URL:           http://llvm.org/
 BuildRequires: bash
+BuildRequires: binutils-devel
 BuildRequires: bison
-BuildRequires: cmake >= 3.4.3
+BuildRequires: cmake >= 3.13.4
 BuildRequires: flex
-BuildRequires: gcc >= 5:3.4
-# gcc4 might be installed, but not current __cc
-%if %(rpmvercmp %{cc_version} 3.4 > /dev/null; test $? = 2 && echo 1 || echo 0)
-BuildRequires: __cc >= 3.4
-%endif
 BuildRequires: groff
 BuildRequires: libedit-devel
 BuildRequires: libltdl-devel
 BuildRequires: libpfm-devel
-BuildRequires: libstdc++-devel >= 5:3.4
+BuildRequires: libstdc++-devel >= 6:5
 BuildRequires: libxml2-devel >= 2
 BuildRequires: ncurses-devel
 %if %{with ocaml}
@@ -79,17 +110,18 @@ BuildRequires:     ocaml >= 4.00.0
 BuildRequires: ocaml-ctypes-devel >= 0.4
 BuildRequires: ocaml-findlib
 BuildRequires: ocaml-ocamldoc
-BuildRequires: ocaml-ounit >= 2
+%{?with_tests:BuildRequires:   ocaml-ounit >= 2}
 %endif
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: perl-tools-pod
-BuildRequires: python >= 1:2.7
-BuildRequires: python-PyYAML
-BuildRequires: python-pygments >= 2.0
+BuildRequires: python3 >= 1:3
+BuildRequires: python3-PyYAML
+BuildRequires: python3-pygments >= 2.0
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.734
 %{?with_doc:BuildRequires:     sphinx-pdg}
 BuildRequires: tar >= 1:1.22
+BuildRequires: xar-devel
 BuildRequires: xz
 %{?with_z3:BuildRequires:      z3-devel >= 4.7.1}
 BuildRequires: zlib-devel
@@ -116,19 +148,21 @@ BuildRequires:    libstdc++-multilib-64-devel
 %endif
 %if %{with lldb}
 BuildRequires: epydoc
-%ifarch i386 i486
+%ifarch i386 i486 %{arm}
 BuildRequires: libatomic-devel
 %endif
 BuildRequires: libxml2-devel >= 2
+BuildRequires: lua-devel
 BuildRequires: ncurses-ext-devel
-BuildRequires: python-devel >= 1:2.7
+BuildRequires: python3-devel >= 1:3.2
 %{?with_doc:BuildRequires:     python3-recommonmark}
 BuildRequires: swig-python >= 3.0.11
+BuildRequires: xz-devel
 %endif
 %if %{with polly}
 #BuildRequires:        gmp-devel or imath-devel (private copy in polly/lib/External/isl/imath)
 # private copy in polly/lib/External/isl
-#BuildRequires:        isl-devel >= 0.18
+#BuildRequires:        isl-devel >= 0.22.1
 #TODO (bcond): cuda-devel (with POLLY_ENABLE_GPGPU_CODEGEN=ON)
 %endif
 %if %{with ocaml}
@@ -140,7 +174,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                abi     10
+%define                abi     12
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
@@ -344,7 +378,7 @@ Group:              Development/Languages
 Requires:      clang = %{version}-%{release}
 # not picked up automatically since files are currently not instaled
 # in standard Python hierarchies yet
-Requires:      python
+Requires:      python3
 
 %description -n clang-analyzer
 The Clang Static Analyzer consists of both a source code analysis
@@ -442,7 +476,7 @@ Summary(pl.UTF-8):  Wydajny debugger nowej generacji
 Group:         Development/Debuggers
 URL:           http://lldb.llvm.org/
 Requires:      %{name} = %{version}-%{release}
-Requires:      python-six
+Requires:      python3-six
 
 %description -n lldb
 LLDB is a next generation, high-performance debugger. It is built as a
@@ -540,28 +574,35 @@ Clang format and rename integration for Vim.
 Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 
 %prep
-%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
+%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6 %{?with_flang:-a7 -a8}
 %{__mv} clang-%{version}.src tools/clang
 %{?with_rt:%{__mv} compiler-rt-%{version}.src projects/compiler-rt}
 %{?with_lldb:%{__mv} lldb-%{version}.src tools/lldb}
 %{?with_polly:%{__mv} polly-%{version}.src tools/polly}
 %{__mv} clang-tools-extra-%{version}.src tools/clang/tools/extra
 %{__mv} lld-%{version}.src tools/lld
+%if %{with flang}
+%{__mv} flang-%{version}.src tools/flang
+%{__mv} mlir tools/mlir
+%endif
 
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%if %{with flang}
 %patch6 -p1
+%endif
+%patch7 -p1
 
 grep -rl /usr/bin/env projects tools utils | xargs sed -i -e '1{
-       s,^#!.*bin/env python,#!%{__python},
+       s,^#!.*bin/env python,#!%{__python3},
        s,^#!.*bin/env perl,#!%{__perl},
 }'
 
 find -name '*.py' -print0 | xargs -0 sed -i -e '1{
-       s,^#!.*bin/python.*,#!%{__python},
+       s,^#!.*bin/python.*,#!%{__python3},
 }'
 
 %build
@@ -572,6 +613,12 @@ install -d build
 cd build
 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 
+%if %{with lowmem}
+export CFLAGS="%{rpmcflags} -g0"
+export CXXFLAGS="%{rpmcxxflags} -g0"
+export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
+%endif
+
 %cmake .. \
        -DBUILD_SHARED_LIBS:BOOL=OFF \
        -DENABLE_LINKER_BUILD_ID:BOOL=ON \
@@ -579,7 +626,6 @@ CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
        -DLLVM_BINUTILS_INCDIR:STRING=%{_includedir} \
        -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
        -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
-       -DLLVM_ENABLE_CXX1Y:BOOL=ON \
 %if %{with apidocs}
        -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
 %endif
@@ -589,7 +635,7 @@ CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 %if %{with doc}
        -DLLVM_ENABLE_SPHINX:BOOL=ON \
 %endif
-       %{!?with_z3:-DLLVM_ENABLE_Z3_SOLVER:BOOL=OFF} \
+       %{?with_z3:-DLLVM_ENABLE_Z3_SOLVER:BOOL=ON} \
 %if "%{_lib}" == "lib64"
        -DLLVM_LIBDIR_SUFFIX:STRING=64 \
 %endif
@@ -597,6 +643,11 @@ CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
        -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
 %endif
        -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
+       -DLLVM_DEFAULT_TARGET_TRIPLE:STRING=%{_target_platform} \
+%if %{with lowmem}
+       -DLLVM_PARALLEL_LINK_JOBS:STRING=1 \
+%endif
+       -DLLVM_TARGETS_TO_BUILD="%{targets_to_build}" \
        -DSPHINX_WARNINGS_AS_ERRORS=OFF
 
 %{__make} \
@@ -618,10 +669,10 @@ CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 %{__make} -C tools/clang/docs docs-clang-man
 %{__make} -C tools/lld/docs docs-lld-html
 # workaround failed import of _lldb
-cp -pnL %{_lib}/python%{py_ver}/site-packages/lldb/_lldb.so tools/lldb/docs/lldb
+cp -pnL %{_lib}/python%{py3_ver}/site-packages/lldb/_lldb.so tools/lldb/docs/lldb
 %{__make} \
        LD_LIBRARY_PATH=$(pwd)/%{_lib} \
-       -C tools/lldb/docs lldb-python-doc
+       -C tools/lldb/docs lldb-python-doc-package
 %{__make} -C tools/lldb/docs lldb-cpp-doc
 %endif
 
@@ -632,17 +683,16 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # only some .pyc files are created by make install
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
+%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
 
 # Adjust static analyzer installation
 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
 install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
 %{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
 %{__sed} -i -e 's,/\.\./libexec/,/../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
-%py_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
-%py_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
-%py_postclean %{_datadir}/scan-view
+%py3_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
+%py3_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
 
 # not installed by cmake buildsystem
 install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
@@ -650,7 +700,7 @@ install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
 %if %{with doc}
 cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 # these tools are not installed
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/FileCheck.1
 # make links
 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
 %endif
@@ -678,7 +728,7 @@ done
 # not this OS
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
 # use system six
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/six.py*
+%{?with_lldb:%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/{,__pycache__/}six*.py*}
 # it seems it is used internally by an extra clang tool
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
 
@@ -708,6 +758,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-ar
 %attr(755,root,root) %{_bindir}/llvm-as
 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
+%attr(755,root,root) %{_bindir}/llvm-bitcode-strip
 %attr(755,root,root) %{_bindir}/llvm-cat
 %attr(755,root,root) %{_bindir}/llvm-cfi-verify
 %attr(755,root,root) %{_bindir}/llvm-cov
@@ -723,16 +774,19 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-elfabi
 %attr(755,root,root) %{_bindir}/llvm-exegesis
 %attr(755,root,root) %{_bindir}/llvm-extract
+%attr(755,root,root) %{_bindir}/llvm-gsymutil
 %attr(755,root,root) %{_bindir}/llvm-ifs
 %attr(755,root,root) %{_bindir}/llvm-install-name-tool
 %attr(755,root,root) %{_bindir}/llvm-jitlink
 %attr(755,root,root) %{_bindir}/llvm-lib
+%attr(755,root,root) %{_bindir}/llvm-libtool-darwin
 %attr(755,root,root) %{_bindir}/llvm-link
 %attr(755,root,root) %{_bindir}/llvm-lipo
 %attr(755,root,root) %{_bindir}/llvm-lto
 %attr(755,root,root) %{_bindir}/llvm-lto2
 %attr(755,root,root) %{_bindir}/llvm-mc
 %attr(755,root,root) %{_bindir}/llvm-mca
+%attr(755,root,root) %{_bindir}/llvm-ml
 %attr(755,root,root) %{_bindir}/llvm-modextract
 %attr(755,root,root) %{_bindir}/llvm-mt
 %attr(755,root,root) %{_bindir}/llvm-nm
@@ -741,6 +795,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-opt-report
 %attr(755,root,root) %{_bindir}/llvm-pdbutil
 %attr(755,root,root) %{_bindir}/llvm-profdata
+%attr(755,root,root) %{_bindir}/llvm-profgen
 %attr(755,root,root) %{_bindir}/llvm-ranlib
 %attr(755,root,root) %{_bindir}/llvm-rc
 %attr(755,root,root) %{_bindir}/llvm-readelf
@@ -756,12 +811,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-tblgen
 %attr(755,root,root) %{_bindir}/llvm-undname
 %attr(755,root,root) %{_bindir}/llvm-xray
-%attr(755,root,root) %{_bindir}/obj2yaml
 %attr(755,root,root) %{_bindir}/opt
 %attr(755,root,root) %{_bindir}/sancov
 %attr(755,root,root) %{_bindir}/sanstats
+%attr(755,root,root) %{_bindir}/split-file
 %attr(755,root,root) %{_bindir}/verify-uselistorder
-%attr(755,root,root) %{_bindir}/yaml2obj
 %if %{with doc}
 %{_mandir}/man1/bugpoint.1*
 %{_mandir}/man1/dsymutil.1*
@@ -780,7 +834,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-dwarfdump.1*
 %{_mandir}/man1/llvm-exegesis.1*
 %{_mandir}/man1/llvm-extract.1*
+%{_mandir}/man1/llvm-install-name-tool.1*
 %{_mandir}/man1/llvm-lib.1*
+%{_mandir}/man1/llvm-libtool-darwin.1*
 %{_mandir}/man1/llvm-link.1*
 %{_mandir}/man1/llvm-lipo.1*
 %{_mandir}/man1/llvm-locstats.1*
@@ -790,6 +846,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-objdump.1*
 %{_mandir}/man1/llvm-pdbutil.1*
 %{_mandir}/man1/llvm-profdata.1*
+%{_mandir}/man1/llvm-profgen.1*
 %{_mandir}/man1/llvm-ranlib.1*
 %{_mandir}/man1/llvm-readelf.1*
 %{_mandir}/man1/llvm-readobj.1*
@@ -799,7 +856,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-strip.1*
 %{_mandir}/man1/llvm-symbolizer.1*
 %{_mandir}/man1/opt.1*
-%{_mandir}/man1/tblgen.1*
+%{_mandir}/man1/xxx-tblgen.1*
 %endif
 
 %files libs
@@ -807,10 +864,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
 # non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %ghost %{_libdir}/libLTO.so.10
+%attr(755,root,root) %ghost %{_libdir}/libLTO.so.12
 %attr(755,root,root) %{_libdir}/LLVMgold.so
-%attr(755,root,root) %{_libdir}/libRemarks.so.10
-%attr(755,root,root) %{_libdir}/libclang-cpp.so.10
+%attr(755,root,root) %{_libdir}/libRemarks.so.12
+%attr(755,root,root) %{_libdir}/libclang-cpp.so.12
 
 %files devel
 %defattr(644,root,root,755)
@@ -862,7 +919,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang-cpp
 %attr(755,root,root) %{_bindir}/clang-doc
 %attr(755,root,root) %{_bindir}/clang-format
-%attr(755,root,root) %{_bindir}/clang-import-test
 %attr(755,root,root) %{_bindir}/clang-offload-bundler
 %attr(755,root,root) %{_bindir}/clang-offload-wrapper
 %attr(755,root,root) %{_bindir}/git-clang-format
@@ -966,6 +1022,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libclang*.a
 %{_includedir}/clang
 %{_includedir}/clang-c
+%{_includedir}/clang-tidy
 %{_libdir}/cmake/clang
 
 %files -n clang-doc
@@ -1008,6 +1065,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc tools/lld/{LICENSE.TXT,README.md}
 %attr(755,root,root) %{_bindir}/ld.lld
 %attr(755,root,root) %{_bindir}/ld64.lld
+%attr(755,root,root) %{_bindir}/ld64.lld.darwinnew
 %attr(755,root,root) %{_bindir}/lld
 %attr(755,root,root) %{_bindir}/lld-link
 %attr(755,root,root) %{_bindir}/wasm-ld
@@ -1016,6 +1074,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/liblld[ACDEHMRWXY]*.a
 %{_includedir}/lld
+%{_libdir}/cmake/lld
 
 %if %{with lldb}
 %files -n lldb
@@ -1026,15 +1085,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lldb-server
 %attr(755,root,root) %{_bindir}/lldb-vscode
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblldb.so.10
-%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.10
-%dir %{py_sitedir}/lldb
-%attr(755,root,root) %{py_sitedir}/lldb/lldb-argdumper
-%{py_sitedir}/lldb/formatters
-%{py_sitedir}/lldb/utils
-%{py_sitedir}/lldb/__init__.py[co]
-%{py_sitedir}/lldb/embedded_interpreter.py[co]
-%attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.12
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.12
+%dir %{py3_sitedir}/lldb
+%attr(755,root,root) %{py3_sitedir}/lldb/lldb-argdumper
+%{py3_sitedir}/lldb/formatters
+%{py3_sitedir}/lldb/utils
+%{py3_sitedir}/lldb/__init__.py
+%{py3_sitedir}/lldb/__pycache__
+%{py3_sitedir}/lldb/embedded_interpreter.py
+%attr(755,root,root) %{py3_sitedir}/lldb/_lldb.so
 
 %files -n lldb-devel
 %defattr(644,root,root,755)
This page took 0.131406 seconds and 4 git commands to generate.