]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
BR: python3-modules for %py3_*comp
[packages/llvm.git] / llvm.spec
index ad879d39a2aa449294e71fa2f38ffce9a5f6dc95..8f8dc07d71fa9350ff16d4e75abad2fca45395a6 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
 #      %{_datadir}/clang/clang-rename.el
 # - no content in doc package (it used to contain parts of clang apidocs and some examples)
 # - system isl in polly?
+# - dependencies and files for lua module
+#      %{_libdir}/lua/5.3/lldb.so
+# - figure out whether we need obj.MLIRCAPIIR files
+# - cmake dependencies mess (LLVMExports.cmake appears to require all -devels):
+#   with llvm-devel and spirv-tools-devel installed but without llvm-mlir (or other packages):
+#   $ cat CMakeLists.txt
+#   find_package(LLVM)
+#   find_package(SPIRV-Tools)
+#   $ cmake -B build
+#   ...
+#   The imported target "mlir-tblgen" references the file
+#
+#      "/usr/bin/mlir-tblgen"
+#
+#   but this file does not exist.  Possible reasons include:
+#   ...
 #
 # Conditional build:
 %bcond_without lldb                    # LLDB debugger
 %bcond_without mlir                    # MLIR libraries and tools (required for Flang)
-%bcond_without flang                   # Flang (Fortran18) compiler
+%bcond_with    flang                   # Flang (Fortran18) compiler (heavy memory requirements during build)
 %bcond_without polly                   # Polly cache-locality optimization, auto-parallelism and vectorization
 %bcond_without rt                      # compiler-rt libraries
 %bcond_without multilib                # compiler-rt multilib libraries
@@ -28,6 +44,7 @@
 %bcond_without target_bpf              # BPF target support
 %bcond_without target_hexagon          # Hexagon target support
 %bcond_without target_lanai            # Lanai target support
+%bcond_without target_loongarch        # LoongArch target support
 %bcond_without target_mips             # Mips target support
 %bcond_without target_msp430           # MSP430 target support
 %bcond_without target_nvptx            # NVPTX target support
@@ -35,6 +52,7 @@
 %bcond_without target_riscv            # RISCV target support
 %bcond_without target_sparc            # Sparc target support
 %bcond_without target_systemz          # SystemZ target support
+%bcond_without target_ve               # VE target support
 %bcond_without target_webassembly      # WebAssembly target support
 %bcond_without target_x86              # X86 target support
 %bcond_without target_xcore            # XCore target support
@@ -56,7 +74,7 @@
 %define                with_lowmem             1
 %endif
 
-%define                targets_to_build        %{?with_target_aarch64:AArch64;}%{?with_target_amdgpu:AMDGPU;}%{?with_target_arm:ARM;}%{?with_target_avr:AVR;}%{?with_target_bpf:BPF;}%{?with_target_hexagon:Hexagon;}%{?with_target_lanai:Lanai;}%{?with_target_mips:Mips;}%{?with_target_msp430:MSP430;}%{?with_target_nvptx:NVPTX;}%{?with_target_powerpc:PowerPC;}%{?with_target_riscv:RISCV;}%{?with_target_sparc:Sparc;}%{?with_target_systemz:SystemZ;}%{?with_target_webassembly:WebAssembly;}%{?with_target_x86:X86;}%{?with_target_xcore:XCore;}
+%define                targets_to_build        %{?with_target_aarch64:AArch64;}%{?with_target_amdgpu:AMDGPU;}%{?with_target_arm:ARM;}%{?with_target_avr:AVR;}%{?with_target_bpf:BPF;}%{?with_target_hexagon:Hexagon;}%{?with_target_lanai:Lanai;}%{?with_target_loongarch:LoongArch;}%{?with_target_mips:Mips;}%{?with_target_msp430:MSP430;}%{?with_target_nvptx:NVPTX;}%{?with_target_powerpc:PowerPC;}%{?with_target_riscv:RISCV;}%{?with_target_sparc:Sparc;}%{?with_target_systemz:SystemZ;}%{?with_target_ve:VE;}%{?with_target_webassembly:WebAssembly;}%{?with_target_x86:X86;}%{?with_target_xcore:XCore;}
 
 %if %{without mlir}
 %undefine      with_flang
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       13.0.0
-Release:       3
+Version:       16.0.0
+Release:       0.1
 License:       Apache 2.0 with LLVM exceptions
 Group:         Development/Languages
 #Source0Download: https://github.com/llvm/llvm-project/releases/
 Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: 8c24626dce3ee9d87d1079ebf0897db5
+# Source0-md5: c465413aa9ab18837f40cc5750d39a33
 Source1:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
-# Source1-md5: 020cbac6e5786094fe4f96f72e290763
+# Source1-md5: d38fd3897a0fd6dc396c973ba08662aa
 Source2:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: e2e136656d27d60c5f40e20260f63c07
+# Source2-md5: 5f0633ec762fed4f1e2c450b3654caa6
 Source3:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: 0956c6078d1fd3bee22d064e2addd784
+# Source3-md5: ad78eb12a144c7e5eb7ae235af8d6dfd
 Source4:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 4bde9e5c4d739576cf2d804d50c822d6
+# Source4-md5: 4ede663c676600ed63e4d7d840ff480b
 Source5:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: f86778fc0d97508b4d7c244d93ebf944
+# Source5-md5: 9c21e090e61e0dda6c7a044207af38e3
 Source6:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: e4f95d6cb895ebedf2c3224585682159
+# Source6-md5: 4c031fc367188d0a45b7ab8838dd9b49
 Source7:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/flang-%{version}.src.tar.xz
-# Source7-md5: 4125a570905dd2755748e6f33442b74d
-# "mlir" subdir extracted from https://github.com/llvm/llvm-project/releases/download/llvmorg-13.0.0/llvm-project-13.0.0.src.tar.xz
+# Source7-md5: b895740c1fd1c69bd28d03f93fa3eea1
+# "mlir" subdir extracted from https://github.com/llvm/llvm-project/releases/download/llvmorg-16.0.0/llvm-project-16.0.0.src.tar.xz
 Source8:       mlir-%{version}.tar.xz
-# Source8-md5: de6a9476ef2a52b59d7c29a8bb786719
+# Source8-md5: 9596f341d62129b9c7204305c111d5be
+Source9:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/cmake-%{version}.src.tar.xz
+# Source9-md5: b2103df1421f7bcc271fcacec27a24bb
 Patch1:                %{name}-pld.patch
-Patch2:                %{name}-python-modules.patch
 Patch3:                x32-gcc-toolchain.patch
 Patch4:                cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
@@ -98,6 +117,10 @@ Patch6:             %{name}-flang.patch
 Patch7:                llvm12-build_fixes.patch
 Patch8:                %{name}-selective_bindings.patch
 Patch9:                %{name}-libexecdir.patch
+Patch10:       compiler-rt-paths.patch
+Patch11:       cmake-utils-path-override.patch
+Patch12:       x32-compiler-rt.patch
+Patch13:       atomic.patch
 URL:           https://llvm.org/
 BuildRequires: bash
 BuildRequires: binutils-devel
@@ -122,7 +145,9 @@ BuildRequires:      perl-base >= 1:5.6
 BuildRequires: perl-tools-pod
 BuildRequires: python3 >= 1:3
 BuildRequires: python3-PyYAML
+BuildRequires: python3-modules
 BuildRequires: python3-pygments >= 2.0
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.742
 %{?with_doc:BuildRequires:     sphinx-pdg}
@@ -142,12 +167,14 @@ BuildRequires:    tcl-devel
 %if %{with rt} && %{with multilib}
 %ifarch %{x8664}
 BuildRequires: gcc-c++-multilib-32
+BuildRequires: glibc-devel(ix86)
 BuildRequires: libstdc++-multilib-32-devel
 %endif
 %ifarch x32
 BuildRequires: gcc-c++-multilib-32
 BuildRequires: gcc-c++-multilib-64
 BuildRequires: glibc-devel(x86_64)
+BuildRequires: glibc-devel(ix86)
 BuildRequires: libstdc++-multilib-32-devel
 BuildRequires: libstdc++-multilib-64-devel
 %endif
@@ -181,7 +208,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                abi     13
+%define                abi     16
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
@@ -269,6 +296,7 @@ Summary:    API documentation for LLVM
 Summary(pl.UTF-8):     Dokumentacja API LLVM-a
 Group:         Development/Languages
 Requires:      %{name}-doc = %{version}-%{release}
+BuildArch:     noarch
 
 %description apidocs
 API documentation for the LLVM compiler infrastructure.
@@ -427,6 +455,7 @@ Summary(pl.UTF-8):  Dokumentacja do Clanga
 URL:           https://clang.llvm.org/
 Group:         Documentation
 Requires:      %{name} = %{version}-%{release}
+BuildArch:     noarch
 
 %description -n clang-doc
 Documentation for the Clang compiler front-end.
@@ -440,6 +469,7 @@ Summary(pl.UTF-8):  Dokumentacja API Clanga
 URL:           https://clang.llvm.org/
 Group:         Development/Languages
 Requires:      clang-doc = %{version}-%{release}
+BuildArch:     noarch
 
 %description -n clang-apidocs
 API documentation for the Clang compiler.
@@ -486,8 +516,9 @@ Dodatkowe narzędzia do kompilatora Clang.
 Summary:       Bash completion for clang command
 Summary(pl.UTF-8):     Bashowe dopełnianie składni polecenia clang
 Group:         Applications/Shells
-Requires:      bash-completion >= 2.0
+Requires:      bash-completion >= 1:2.0
 Requires:      clang = %{version}-%{release}
+BuildArch:     noarch
 
 %description -n bash-completion-clang
 Bash completion for clang command.
@@ -622,6 +653,7 @@ Summary:    Documentation for LLVM's OCaml binding
 Summary(pl.UTF-8):     Dokumentacja wiązania OCamla do LLVM-a
 Group:         Documentation
 Requires:      %{name}-ocaml = %{version}-%{release}
+BuildArch:     noarch
 
 %description ocaml-doc
 HTML documentation for LLVM's OCaml binding.
@@ -656,7 +688,7 @@ Clang format and rename integration for Vim.
 Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 
 %prep
-%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6 %{?with_flang:-a7} %{?with_mlir:-a8}
+%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6 %{?with_flang:-a7} %{?with_mlir:-a8} -a9
 %{__mv} clang-%{version}.src tools/clang
 %{?with_rt:%{__mv} compiler-rt-%{version}.src projects/compiler-rt}
 %{?with_lldb:%{__mv} lldb-%{version}.src tools/lldb}
@@ -669,9 +701,9 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %if %{with mlir}
 %{__mv} mlir tools/mlir
 %endif
+%{__mv} cmake-%{version}.src cmake-utils
 
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
@@ -681,9 +713,15 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%if %{with rt}
+%patch10 -p1
+%patch12 -p1
+%endif
+%patch11 -p1
+%patch13 -p1
 
 grep -rl /usr/bin/env projects tools utils | xargs sed -i -e '1{
-       s,^#!.*bin/env python,#!%{__python3},
+       s,^#!.*bin/env python3\?,#!%{__python3},
        s,^#!.*bin/env perl,#!%{__perl},
 }'
 
@@ -706,16 +744,21 @@ CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 %if %{with lowmem}
 export CFLAGS="%{rpmcflags} -g0"
 export CXXFLAGS="%{rpmcxxflags} -g0"
+if echo 'int main(){}' | %{__cc} -x c %{rpmldflags} -Wl,--reduce-memory-overheads -o /dev/null - > /dev/null 2>&1; then
 export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
+fi
 %endif
 
 %cmake .. \
        -DBUILD_SHARED_LIBS:BOOL=OFF \
        -DENABLE_LINKER_BUILD_ID:BOOL=ON \
+       -DLLVM_COMMON_CMAKE_UTILS="%{_builddir}/%{buildsubdir}/cmake-utils" \
        -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
        -DLLVM_BINUTILS_INCDIR:STRING=%{_includedir} \
        -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
        -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
+       -DLLVM_INSTALL_PACKAGE_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_libdir}/cmake/llvm") \
+       -DLLVM_TOOLS_INSTALL_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_bindir}") \
 %if %{with apidocs}
        -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
 %endif
@@ -725,6 +768,7 @@ export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
 %if %{with doc}
        -DLLVM_ENABLE_SPHINX:BOOL=ON \
 %endif
+       -DLLVM_INCLUDE_BENCHMARKS:BOOL=OFF \
        %{?with_z3:-DLLVM_ENABLE_Z3_SOLVER:BOOL=ON} \
 %if "%{_lib}" == "lib64"
        -DLLVM_LIBDIR_SUFFIX:STRING=64 \
@@ -733,15 +777,23 @@ export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
        -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
 %endif
        -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
+       -DLLVM_TARGET_ARCH:STRING=%{_target_base_arch} \
        -DLLVM_DEFAULT_TARGET_TRIPLE:STRING=%{_target_platform} \
 %if %{with lowmem}
        -DLLVM_PARALLEL_LINK_JOBS:STRING=1 \
 %endif
        -DLLVM_TARGETS_TO_BUILD="%{targets_to_build}" \
+       -DLLVM_INCLUDE_TESTS:BOOL=OFF \
 %if %{with polly}
        %{cmake_on_off target_nvptx POLLY_ENABLE_GPGPU_CODEGEN} \
 %endif
-       -DSPHINX_WARNINGS_AS_ERRORS=OFF
+       -DSPHINX_WARNINGS_AS_ERRORS=OFF \
+%if %{with rt}
+       -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF \
+%ifarch x32
+       -DCOMPILER_RT_BUILD_MEMPROF:BOOL=OFF
+%endif
+%endif
 
 %{__make} \
        VERBOSE=1 \
@@ -762,7 +814,7 @@ export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
 %{__make} -C tools/clang/docs docs-clang-man
 %{__make} -C tools/lld/docs docs-lld-html
 # workaround failed import of _lldb
-cp -pnL %{_lib}/python%{py3_ver}/site-packages/lldb/_lldb.so tools/lldb/docs/lldb
+cp -pnL %{_lib}/liblldb.so tools/lldb/docs/lldb/_lldb.so
 %{__make} \
        LD_LIBRARY_PATH=$(pwd)/%{_lib} \
        -C tools/lldb/docs lldb-python-doc-package
@@ -819,11 +871,9 @@ done
 install -d $RPM_BUILD_ROOT%{bash_compdir}
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/clang/bash-autocomplete.sh $RPM_BUILD_ROOT%{bash_compdir}/clang
 
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/{c-index-test,llvm-c-test}
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/c-index-test
 # not this OS
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
-# use system six
-%{?with_lldb:%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/{,__pycache__/}six*.py*}
 # it seems it is used internally by an extra clang tool
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
 
@@ -866,6 +916,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-as
 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
 %attr(755,root,root) %{_bindir}/llvm-bitcode-strip
+%attr(755,root,root) %{_bindir}/llvm-c-test
 %attr(755,root,root) %{_bindir}/llvm-cat
 %attr(755,root,root) %{_bindir}/llvm-cfi-verify
 %attr(755,root,root) %{_bindir}/llvm-cov
@@ -873,10 +924,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-cxxdump
 %attr(755,root,root) %{_bindir}/llvm-cxxfilt
 %attr(755,root,root) %{_bindir}/llvm-cxxmap
+%attr(755,root,root) %{_bindir}/llvm-debuginfo-analyzer
+%attr(755,root,root) %{_bindir}/llvm-debuginfod
+%attr(755,root,root) %{_bindir}/llvm-debuginfod-find
 %attr(755,root,root) %{_bindir}/llvm-diff
 %attr(755,root,root) %{_bindir}/llvm-dis
 %attr(755,root,root) %{_bindir}/llvm-dlltool
 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
+%attr(755,root,root) %{_bindir}/llvm-dwarfutil
 %attr(755,root,root) %{_bindir}/llvm-dwp
 %attr(755,root,root) %{_bindir}/llvm-exegesis
 %attr(755,root,root) %{_bindir}/llvm-extract
@@ -908,6 +963,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-readelf
 %attr(755,root,root) %{_bindir}/llvm-readobj
 %attr(755,root,root) %{_bindir}/llvm-reduce
+%attr(755,root,root) %{_bindir}/llvm-remark-size-diff
+%attr(755,root,root) %{_bindir}/llvm-remarkutil
 %attr(755,root,root) %{_bindir}/llvm-rtdyld
 %attr(755,root,root) %{_bindir}/llvm-sim
 %attr(755,root,root) %{_bindir}/llvm-size
@@ -918,13 +975,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-symbolizer
 %attr(755,root,root) %{_bindir}/llvm-tapi-diff
 %attr(755,root,root) %{_bindir}/llvm-tblgen
+%attr(755,root,root) %{_bindir}/llvm-tli-checker
 %attr(755,root,root) %{_bindir}/llvm-undname
 %attr(755,root,root) %{_bindir}/llvm-windres
 %attr(755,root,root) %{_bindir}/llvm-xray
 %attr(755,root,root) %{_bindir}/opt
 %attr(755,root,root) %{_bindir}/sancov
 %attr(755,root,root) %{_bindir}/sanstats
-%attr(755,root,root) %{_bindir}/split-file
+#%%attr(755,root,root) %{_bindir}/split-file
+%attr(755,root,root) %{_bindir}/tblgen-lsp-server
 %attr(755,root,root) %{_bindir}/verify-uselistorder
 %if %{with doc}
 %{_mandir}/man1/bugpoint.1*
@@ -942,8 +1001,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-diff.1*
 %{_mandir}/man1/llvm-dis.1*
 %{_mandir}/man1/llvm-dwarfdump.1*
+%{_mandir}/man1/llvm-dwarfutil.1*
 %{_mandir}/man1/llvm-exegesis.1*
 %{_mandir}/man1/llvm-extract.1*
+%{_mandir}/man1/llvm-ifs.1*
 %{_mandir}/man1/llvm-install-name-tool.1*
 %{_mandir}/man1/llvm-lib.1*
 %{_mandir}/man1/llvm-libtool-darwin.1*
@@ -961,12 +1022,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-ranlib.1*
 %{_mandir}/man1/llvm-readelf.1*
 %{_mandir}/man1/llvm-readobj.1*
+%{_mandir}/man1/llvm-remark-size-diff.1*
 %{_mandir}/man1/llvm-size.1*
 %{_mandir}/man1/llvm-stress.1*
 %{_mandir}/man1/llvm-strings.1*
 %{_mandir}/man1/llvm-strip.1*
 %{_mandir}/man1/llvm-symbolizer.1*
 %{_mandir}/man1/llvm-tblgen.1*
+%{_mandir}/man1/llvm-tli-checker.1*
 %{_mandir}/man1/opt.1*
 %{_mandir}/man1/tblgen.1*
 %endif
@@ -977,9 +1040,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
 # non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %{_libdir}/libLTO.so.13
-%attr(755,root,root) %{_libdir}/libRemarks.so.13
-%attr(755,root,root) %{_libdir}/libclang-cpp.so.13
+%attr(755,root,root) %{_libdir}/libLTO.so.16
+%attr(755,root,root) %{_libdir}/libRemarks.so.16
+%attr(755,root,root) %{_libdir}/libclang-cpp.so.16
 
 %files devel
 %defattr(644,root,root,755)
@@ -1009,24 +1072,29 @@ rm -rf $RPM_BUILD_ROOT
 %files mlir
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/mlir-cpu-runner
-%attr(755,root,root) %{_bindir}/mlir-linalg-ods-gen
 %attr(755,root,root) %{_bindir}/mlir-linalg-ods-yaml-gen
 %attr(755,root,root) %{_bindir}/mlir-lsp-server
 %attr(755,root,root) %{_bindir}/mlir-opt
+%attr(755,root,root) %{_bindir}/mlir-pdll
+%attr(755,root,root) %{_bindir}/mlir-pdll-lsp-server*
 %attr(755,root,root) %{_bindir}/mlir-reduce
 %attr(755,root,root) %{_bindir}/mlir-tblgen
 %attr(755,root,root) %{_bindir}/mlir-translate
-%attr(755,root,root) %{_libdir}/libMLIR.so.13
-%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.13
-%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.13
-%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.13
+%attr(755,root,root) %{_libdir}/libMLIR.so.16
+%attr(755,root,root) %{_libdir}/libmlir_async_runtime.so.16
+%attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so.16
+%attr(755,root,root) %{_libdir}/libmlir_float16_utils.so.16
+%attr(755,root,root) %{_libdir}/libmlir_runner_utils.so.16
+%if %{with doc}
 %{_mandir}/man1/mlir-tblgen.1*
+%endif
 
 %files mlir-devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libMLIR.so
 %attr(755,root,root) %{_libdir}/libmlir_async_runtime.so
 %attr(755,root,root) %{_libdir}/libmlir_c_runner_utils.so
+%attr(755,root,root) %{_libdir}/libmlir_float16_utils.so
 %attr(755,root,root) %{_libdir}/libmlir_runner_utils.so
 %{_libdir}/libMLIR*.a
 %{_includedir}/mlir
@@ -1053,6 +1121,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n clang
 %defattr(644,root,root,755)
 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
+%attr(755,root,root) %{_bindir}/amdgpu-arch
 %attr(755,root,root) %{_bindir}/clang
 %attr(755,root,root) %{_bindir}/clang++
 %attr(755,root,root) %{_bindir}/clang-%{abi}
@@ -1061,73 +1130,81 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang-cpp
 %attr(755,root,root) %{_bindir}/clang-doc
 %attr(755,root,root) %{_bindir}/clang-format
+%attr(755,root,root) %{_bindir}/clang-linker-wrapper
 %attr(755,root,root) %{_bindir}/clang-offload-bundler
-%attr(755,root,root) %{_bindir}/clang-offload-wrapper
+%attr(755,root,root) %{_bindir}/clang-offload-packager
+%attr(755,root,root) %{_bindir}/clang-pseudo
 %attr(755,root,root) %{_bindir}/clang-repl
+%attr(755,root,root) %{_bindir}/clang-tblgen
 %attr(755,root,root) %{_bindir}/git-clang-format
+%attr(755,root,root) %{_bindir}/nvptx-arch
 %dir %{_libdir}/clang
-%dir %{_libdir}/clang/%{version}
-%{_libdir}/clang/%{version}/include
+%dir %{_libdir}/clang/%{abi}
+%{_libdir}/clang/%{abi}/include
 %if %{with rt}
-%ifarch %{x8664} aarch64
-%dir %{_libdir}/clang/%{version}/bin
-%attr(755,root,root) %{_libdir}/clang/%{version}/bin/hwasan_symbolize
+%ifarch %{x8664} x32 aarch64
+%dir %{_libdir}/clang/%{abi}/bin
+%attr(755,root,root) %{_libdir}/clang/%{abi}/bin/hwasan_symbolize
 %endif
 %ifarch %{ix86} %{x8664} aarch64 armv7hl armv7hnl
-%dir %{_libdir}/clang/%{version}/lib
-%dir %{_libdir}/clang/%{version}/lib/linux
-%dir %{_libdir}/clang/%{version}/share
+%dir %{_libdir}/clang/%{abi}/lib
+%dir %{_libdir}/clang/%{abi}/lib/*-linux*
+%dir %{_libdir}/clang/%{abi}/share
 %endif
 %ifarch x32
 %if %{with multilib}
-%dir %{_libdir}/clang/%{version}/lib
-%dir %{_libdir}/clang/%{version}/lib/linux
-%dir %{_libdir}/clang/%{version}/share
+%dir %{_libdir}/clang/%{abi}/lib
+%dir %{_libdir}/clang/%{abi}/lib/*-linux*
+%dir %{_libdir}/clang/%{abi}/share
 %endif
 %endif
 %ifarch %{ix86}
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-i*86.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
+%{_libdir}/clang/%{abi}/lib/i*86-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/i*86-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/i*86-*linux/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/i*86-*linux/liborc_rt.a
 %endif
 %ifarch %{x8664}
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-x86_64.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/liborc_rt.a
 %endif
 %ifarch aarch64
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-aarch64.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.so
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-aarch64.a.syms
+%{_libdir}/clang/%{abi}/lib/aarch64-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/aarch64-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/aarch64-*linux/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/aarch64-*linux/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/aarch64-*linux/liborc_rt.a
 %endif
 %ifarch armv7hl armv7hnl
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-armhf.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.so
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-armhf.a.syms
+%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/armhf-*linux%{_gnu}/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/armhf-*linux/liborc_rt.a
 %endif
 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
-%{_libdir}/clang/%{version}/share/asan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/asan_ignorelist.txt
 %endif
 %ifarch %{ix86} %{x8664} mips64 aarch64 armv7hl armv7hnl
-%{_libdir}/clang/%{version}/share/cfi_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/cfi_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64 mips64
-%{_libdir}/clang/%{version}/share/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/share/msan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/dfsan_abilist.txt
+%{_libdir}/clang/%{abi}/share/msan_ignorelist.txt
 %endif
 %ifarch %{x8664} aarch64
-%{_libdir}/clang/%{version}/share/hwasan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/hwasan_ignorelist.txt
 %endif
 %ifarch x32
 %if %{with multilib}
-%{_libdir}/clang/%{version}/share/asan_ignorelist.txt
-%{_libdir}/clang/%{version}/share/cfi_ignorelist.txt
-%{_libdir}/clang/%{version}/share/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/share/msan_ignorelist.txt
-%{_libdir}/clang/%{version}/share/hwasan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/asan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/cfi_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/dfsan_abilist.txt
+%{_libdir}/clang/%{abi}/share/msan_ignorelist.txt
+%{_libdir}/clang/%{abi}/share/hwasan_ignorelist.txt
 %endif
 %endif
 %endif
@@ -1138,21 +1215,23 @@ rm -rf $RPM_BUILD_ROOT
 %ifarch %{x8664} x32
 %files -n clang-multilib
 %defattr(644,root,root,755)
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-i386.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
+%{_libdir}/clang/%{abi}/lib/i386-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/i386-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/i386-*linux/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/i386-*linux/liborc_rt.a
 %endif
 %ifarch x32
-%{_libdir}/clang/%{version}/lib/linux/clang_rt.*-x86_64.o
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
-%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
-%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/clang_rt.*.o
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.a
+%attr(755,root,root) %{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.so
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/libclang_rt.*.a.syms
+%{_libdir}/clang/%{abi}/lib/x86_64-*linux/liborc_rt.a
 %endif
 %endif
 
 %files -n clang-libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libclang.so.%{abi}
+%attr(755,root,root) %{_libdir}/libclang.so.16
 %attr(755,root,root) %{_libdir}/libclang.so.*.*.*
 
 %files -n clang-devel
@@ -1192,8 +1271,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libexecdir}/clang-analyzer/analyze-cc
 %attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-c++
 %attr(755,root,root) %{_libexecdir}/clang-analyzer/intercept-cc
-%{_prefix}/lib/libear
-%{_prefix}/lib/libscanbuild
+%{_prefix}/%{_lib}/libear
+%{_prefix}/%{_lib}/libscanbuild
 %{_datadir}/scan-view
 
 %files -n clang-tools-extra
@@ -1202,6 +1281,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang-apply-replacements
 %attr(755,root,root) %{_bindir}/clang-change-namespace
 %attr(755,root,root) %{_bindir}/clang-extdef-mapping
+%attr(755,root,root) %{_bindir}/clang-include-cleaner
 %attr(755,root,root) %{_bindir}/clang-include-fixer
 %attr(755,root,root) %{_bindir}/clang-move
 %attr(755,root,root) %{_bindir}/clang-query
@@ -1263,8 +1343,6 @@ rm -rf $RPM_BUILD_ROOT
 %doc tools/lld/{LICENSE.TXT,README.md}
 %attr(755,root,root) %{_bindir}/ld.lld
 %attr(755,root,root) %{_bindir}/ld64.lld
-%attr(755,root,root) %{_bindir}/ld64.lld.darwinnew
-%attr(755,root,root) %{_bindir}/ld64.lld.darwinold
 %attr(755,root,root) %{_bindir}/lld
 %attr(755,root,root) %{_bindir}/lld-link
 %attr(755,root,root) %{_bindir}/wasm-ld
@@ -1284,8 +1362,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lldb-server
 %attr(755,root,root) %{_bindir}/lldb-vscode
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblldb.so.13
-%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.13
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.16
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.16
 %dir %{py3_sitedir}/lldb
 %attr(755,root,root) %{py3_sitedir}/lldb/lldb-argdumper
 %{py3_sitedir}/lldb/formatters
@@ -1296,8 +1374,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/lldb/plugins
 %{py3_sitedir}/lldb/plugins/__pycache__
 %{py3_sitedir}/lldb/plugins/__init__.py
+%{py3_sitedir}/lldb/plugins/scripted_platform.py
 %{py3_sitedir}/lldb/plugins/scripted_process.py
-%attr(755,root,root) %{py3_sitedir}/lldb/_lldb.so
+%attr(755,root,root) %{py3_sitedir}/lldb/_lldb.cpython-*.so
 
 %files -n lldb-devel
 %defattr(644,root,root,755)
@@ -1319,6 +1398,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/ocaml/llvm/libllvm*.a
 %{_libdir}/ocaml/llvm/llvm*.a
+%{_libdir}/ocaml/llvm/llvm*.cmt
+%{_libdir}/ocaml/llvm/llvm*.cmti
 %{_libdir}/ocaml/llvm/llvm*.cmx
 %{_libdir}/ocaml/llvm/llvm*.cmxa
 %{_libdir}/ocaml/llvm/llvm*.mli
This page took 0.79908 seconds and 4 git commands to generate.