]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
- rebuild with ocaml 4.02
[packages/llvm.git] / llvm.spec
index 8d90fb000b3115aedb5b89b9da4a4619a167cfee..51cf2f4d56ef89f9bb9a279a009cfa091159055b 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -1,4 +1,3 @@
-# TODO: dragonegg, lld, openmp?
 #
 # Conditional build:
 %bcond_without lldb    # LLDB debugger
@@ -18,7 +17,7 @@ Summary:      The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
 Version:       3.5.0
-Release:       1
+Release:       2
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
 #Source0Download: http://llvm.org/releases/download.html
@@ -34,12 +33,16 @@ Source4:    http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
 # Source4-md5: 2ee0167c7ed7c85026cdb18ad6f4ade8
 Source5:       http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
 # Source5-md5: 6e2830316638ec0de9534b98361dfbec
+Source6:       http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
+# Source6-md5: 946404d534a51f1806d1ee955885d927
 Patch0:                %{name}-config.patch
 # Data files should be installed with timestamps preserved
 Patch1:                %{name}-2.6-timestamp.patch
 Patch2:                %{name}-pld.patch
 Patch3:                %{name}-polly-update.patch
 Patch4:                %{name}-lldb.patch
+Patch5:                %{name}-lldb-atomic.patch
+Patch6:                %{name}-lld-link.patch
 URL:           http://llvm.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.9.6
@@ -72,6 +75,9 @@ BuildRequires:        python
 BuildRequires: tcl-devel
 %endif
 %if %{with lldb}
+%ifarch i386 i486
+BuildRequires: libatomic-devel
+%endif
 BuildRequires: libedit-devel
 BuildRequires: libxml2-devel >= 2
 BuildRequires: ncurses-ext-devel
@@ -83,9 +89,8 @@ BuildRequires:        cloog-isl-devel
 BuildRequires: gmp-devel
 BuildRequires: isl-devel >= 0.13
 # optional
+BuildRequires: pluto-devel
 BuildRequires: scoplib-devel >= 0.2.1-2
-# optional
-#BuildRequires:        libpluto-devel
 #cuda-devel
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
@@ -298,10 +303,38 @@ Extra tools for Clang.
 %description -n clang-tools-extra -l pl.UTF-8
 Dodatkowe narzędzia do kompilatora Clang.
 
+%package -n lld
+Summary:       The LLVM linker
+Summary(pl.UTF-8):     Konsolidator z projektu LLVM
+Group:         Development/Libraries
+URL:           http://lld.llvm.org/
+Requires:      %{name} = %{version}-%{release}
+
+%description -n lld
+lld is a new set of modular code for creating linker tools.
+
+%description -n lld -l pl.UTF-8
+lld to nowy zbiór modularnego kodu do tworzenia narzędzi
+konsolidujących.
+
+%package -n lld-devel
+Summary:       Development files for LLD linker tools
+Summary(pl.UTF-8):     Pliki programistyczne narzędzi konsolidujących LLD
+Group:         Development/Tools
+URL:           http://lld.llvm.org/
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description -n lld-devel
+Development files for LLD linker tools.
+
+%description -n lld-devel -l pl.UTF-8
+Pliki programistyczne narzędzi konsolidujących LLD.
+
 %package -n lldb
 Summary:       Next generation high-performance debugger
 Summary(pl.UTF-8):     Wydajny debugger nowej generacji
 Group:         Development/Debuggers
+URL:           http://lldb.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 
 %description -n lldb
@@ -317,18 +350,19 @@ w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
 disasembler LLVM.
 
 %package -n lldb-devel
-Summary:       Header files for LLDB
-Summary(pl.UTF-8):     Pliki nagłówkowe LLDB
+Summary:       Development files for LLDB debugger
+Summary(pl.UTF-8):     Pliki programistyczne debuggera LLDB
 Group:         Development/Libraries
+URL:           http://lldb.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      clang-devel = %{version}-%{release}
 Requires:      lldb = %{version}-%{release}
 
 %description -n lldb-devel
-Header files for LLDB.
+Development files for LLDB debugger.
 
 %description -n lldb-devel -l pl.UTF-8
-Pliki nagłówkowe LLDB.
+Pliki programistyczne debuggera LLDB.
 
 %package ocaml
 Summary:       OCaml binding for LLVM
@@ -371,18 +405,25 @@ HTML documentation for LLVM's OCaml binding.
 Dokumentacja HTML wiązania OCamla do LLVM-a.
 
 %prep
-%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5
+%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
 mv cfe-%{version}.src tools/clang
 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
 %{?with_polly:mv polly-%{version}.src tools/polly}
 mv clang-tools-extra-%{version}.src tools/clang/tools/extra
+mv lld-%{version}.src tools/lld
 
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+%{?with_polly:%patch3 -p1}
+%if %{with lldb}
 %patch4 -p1
+%ifarch i386 i486
+%patch5 -p1
+%endif
+%endif
+%patch6 -p1
 
 # configure does not properly specify libdir
 %{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
@@ -395,20 +436,34 @@ grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env perl,#!%{__perl},
 }'
 
+%build
 install -d obj
+%if "%{_lib}" != "lib"
+# workaround for clang relative search paths building
+install -d obj/Release
+ln -snf lib obj/Release/%{_lib}
+%endif
 
-%build
 cd autoconf
 %{__aclocal} -I m4
 %{__autoconf} -o ../configure configure.ac
 cd ..
 %{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
+%if %{with polly}
+cd tools/polly/autoconf
+%{__aclocal} -I m4 -I ../../../autoconf/m4
+%{__autoconf} -o ../configure configure.ac
+cd ..
+%{__autoheader} -I autoconf -I autoconf/m4 -I ../../../autoconf/m4 autoconf/configure.ac
+cd ../..
+%endif
 
 # Disabling assertions now, rec. by pure and needed for OpenGTL
 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
 #
 # bash specific 'test a < b'
 cd obj
+CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 bash ../%configure \
        --datadir=%{_datadir}/%{name}-%{version} \
        --disable-assertions \
@@ -497,6 +552,7 @@ done
 %{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
 # parts of test suite
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{FileCheck,count,not}
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/linker-script-test
 
 # remove documentation makefiles:
 # they require the build directory to work
@@ -675,6 +731,25 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/pp-trace
 %{_libdir}/libmodernizeCore.a
 
+%files -n lld
+%defattr(644,root,root,755)
+%doc tools/lld/{LICENSE.TXT,README.md}
+%attr(755,root,root) %{_bindir}/lld
+
+%files -n lld-devel
+%defattr(644,root,root,755)
+%{_libdir}/liblldCore.a
+%{_libdir}/liblldDriver.a
+%{_libdir}/liblldELF.a
+%{_libdir}/liblldMachO.a
+%{_libdir}/liblldNative.a
+%{_libdir}/liblldPECOFF.a
+%{_libdir}/liblldPasses.a
+%{_libdir}/liblldReaderWriter.a
+%{_libdir}/liblldYAML.a
+%{_libdir}/liblld*ELFTarget.a
+%{_includedir}/lld
+
 %if %{with lldb}
 %files -n lldb
 %defattr(644,root,root,755)
This page took 0.050723 seconds and 4 git commands to generate.