]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
- rebuild with ocaml 4.02
[packages/llvm.git] / llvm.spec
index 50f40f21da724d8a4c3f617e3e7073190fe06f6a..51cf2f4d56ef89f9bb9a279a009cfa091159055b 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       3.4.2
-Release:       1
+Version:       3.5.0
+Release:       2
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
 #Source0Download: http://llvm.org/releases/download.html
-Source0:       http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.gz
-# Source0-md5: a20669f75967440de949ac3b1bad439c
-Source1:       http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.gz
-# Source1-md5: 87945973b7c73038871c5f849a818588
-Source2:       http://llvm.org/releases/3.4/compiler-rt-3.4.src.tar.gz
-# Source2-md5: 7938353e3a3bda85733a165e7ac4bb84
-Source3:       http://llvm.org/releases/3.4/lldb-3.4.src.tar.gz
-# Source3-md5: 7ed60a0463f9fdfa20db7109d4624cee
-Source4:       http://llvm.org/releases/3.4/polly-3.4.src.tar.gz
-# Source4-md5: 5b2958c9076a584f710423bdca9e6d5d
-Source5:       http://llvm.org/releases/3.4/clang-tools-extra-3.4.src.tar.gz
-# Source5-md5: fc25c6b90eaf8a9b0702940c7c57183c
+Source0:       http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
+# Source0-md5: d6987305a1a0e58e128c1374cd3b8fef
+Source1:       http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
+# Source1-md5: 27718dd13c7df83e15f997116bbb4aef
+Source2:       http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
+# Source2-md5: 02624d2a9144278c3808c00dbbab56c8
+Source3:       http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
+# Source3-md5: 9597d5376309805ac586adfbd1e992f4
+Source4:       http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
+# Source4-md5: 2ee0167c7ed7c85026cdb18ad6f4ade8
+Source5:       http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
+# Source5-md5: 6e2830316638ec0de9534b98361dfbec
+Source6:       http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
+# Source6-md5: 946404d534a51f1806d1ee955885d927
 Patch0:                %{name}-config.patch
 # Data files should be installed with timestamps preserved
 Patch1:                %{name}-2.6-timestamp.patch
 Patch2:                %{name}-pld.patch
+Patch3:                %{name}-polly-update.patch
+Patch4:                %{name}-lldb.patch
+Patch5:                %{name}-lldb-atomic.patch
+Patch6:                %{name}-lld-link.patch
 URL:           http://llvm.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.9.6
@@ -57,6 +63,8 @@ BuildRequires:        perl-base >= 1:5.6
 BuildRequires: perl-tools-pod
 BuildRequires: rpm-pythonprov
 %{?with_doc:BuildRequires:     sphinx-pdg}
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 %if %{with apidocs}
 BuildRequires: doxygen
 BuildRequires: graphviz
@@ -66,14 +74,23 @@ BuildRequires:      dejagnu
 BuildRequires: python
 BuildRequires: tcl-devel
 %endif
+%if %{with lldb}
+%ifarch i386 i486
+BuildRequires: libatomic-devel
+%endif
+BuildRequires: libedit-devel
+BuildRequires: libxml2-devel >= 2
+BuildRequires: ncurses-ext-devel
+BuildRequires: python-devel >= 2
+%endif
 %if %{with polly}
 BuildRequires: cloog-isl-devel
+# >= 0.18.2-2
 BuildRequires: gmp-devel
-BuildRequires: isl-devel
+BuildRequires: isl-devel >= 0.13
 # optional
-#BuildRequires:        libpluto-devel
-#BuildRequires:        openscop-devel
-#BuildRequires:        scoplib-devel
+BuildRequires: pluto-devel
+BuildRequires: scoplib-devel >= 0.2.1-2
 #cuda-devel
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
@@ -286,10 +303,38 @@ Extra tools for Clang.
 %description -n clang-tools-extra -l pl.UTF-8
 Dodatkowe narzędzia do kompilatora Clang.
 
+%package -n lld
+Summary:       The LLVM linker
+Summary(pl.UTF-8):     Konsolidator z projektu LLVM
+Group:         Development/Libraries
+URL:           http://lld.llvm.org/
+Requires:      %{name} = %{version}-%{release}
+
+%description -n lld
+lld is a new set of modular code for creating linker tools.
+
+%description -n lld -l pl.UTF-8
+lld to nowy zbiór modularnego kodu do tworzenia narzędzi
+konsolidujących.
+
+%package -n lld-devel
+Summary:       Development files for LLD linker tools
+Summary(pl.UTF-8):     Pliki programistyczne narzędzi konsolidujących LLD
+Group:         Development/Tools
+URL:           http://lld.llvm.org/
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description -n lld-devel
+Development files for LLD linker tools.
+
+%description -n lld-devel -l pl.UTF-8
+Pliki programistyczne narzędzi konsolidujących LLD.
+
 %package -n lldb
 Summary:       Next generation high-performance debugger
 Summary(pl.UTF-8):     Wydajny debugger nowej generacji
 Group:         Development/Debuggers
+URL:           http://lldb.llvm.org/
 Requires:      %{name} = %{version}-%{release}
 
 %description -n lldb
@@ -305,18 +350,19 @@ w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
 disasembler LLVM.
 
 %package -n lldb-devel
-Summary:       Header files for LLDB
-Summary(pl.UTF-8):     Pliki nagłówkowe LLDB
+Summary:       Development files for LLDB debugger
+Summary(pl.UTF-8):     Pliki programistyczne debuggera LLDB
 Group:         Development/Libraries
+URL:           http://lldb.llvm.org/
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      clang-devel = %{version}-%{release}
 Requires:      lldb = %{version}-%{release}
 
 %description -n lldb-devel
-Header files for LLDB.
+Development files for LLDB debugger.
 
 %description -n lldb-devel -l pl.UTF-8
-Pliki nagłówkowe LLDB.
+Pliki programistyczne debuggera LLDB.
 
 %package ocaml
 Summary:       OCaml binding for LLVM
@@ -359,16 +405,25 @@ HTML documentation for LLVM's OCaml binding.
 Dokumentacja HTML wiązania OCamla do LLVM-a.
 
 %prep
-%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5
+%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
 mv cfe-%{version}.src tools/clang
-%{?with_rt:mv compiler-rt-3.4 projects/compiler-rt}
-%{?with_lldb:mv lldb-3.4 tools/lldb}
-%{?with_polly:mv polly-3.4 tools/polly}
-mv clang-tools-extra-3.4 tools/clang/tools/extra
+%{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
+%{?with_lldb:mv lldb-%{version}.src tools/lldb}
+%{?with_polly:mv polly-%{version}.src tools/polly}
+mv clang-tools-extra-%{version}.src tools/clang/tools/extra
+mv lld-%{version}.src tools/lld
 
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%{?with_polly:%patch3 -p1}
+%if %{with lldb}
+%patch4 -p1
+%ifarch i386 i486
+%patch5 -p1
+%endif
+%endif
+%patch6 -p1
 
 # configure does not properly specify libdir
 %{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
@@ -381,20 +436,34 @@ grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env perl,#!%{__perl},
 }'
 
+%build
 install -d obj
+%if "%{_lib}" != "lib"
+# workaround for clang relative search paths building
+install -d obj/Release
+ln -snf lib obj/Release/%{_lib}
+%endif
 
-%build
 cd autoconf
 %{__aclocal} -I m4
 %{__autoconf} -o ../configure configure.ac
 cd ..
 %{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
+%if %{with polly}
+cd tools/polly/autoconf
+%{__aclocal} -I m4 -I ../../../autoconf/m4
+%{__autoconf} -o ../configure configure.ac
+cd ..
+%{__autoheader} -I autoconf -I autoconf/m4 -I ../../../autoconf/m4 autoconf/configure.ac
+cd ../..
+%endif
 
 # Disabling assertions now, rec. by pure and needed for OpenGTL
 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
 #
 # bash specific 'test a < b'
 cd obj
+CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 bash ../%configure \
        --datadir=%{_datadir}/%{name}-%{version} \
        --disable-assertions \
@@ -453,8 +522,8 @@ done
 %if %{with doc}
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
 cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
-# these tools are not installed (llvm-prof has been removed before LLVM 3.4)
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build,llvm-prof}.1
+# these tools are not installed
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
 # make links
 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
 %endif
@@ -481,6 +550,9 @@ done
 
 # Get rid of erroneously installed example files.
 %{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
+# parts of test suite
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/{FileCheck,count,not}
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/linker-script-test
 
 # remove documentation makefiles:
 # they require the build directory to work
@@ -520,6 +592,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
 %attr(755,root,root) %{_bindir}/llvm-nm
 %attr(755,root,root) %{_bindir}/llvm-objdump
+%attr(755,root,root) %{_bindir}/llvm-profdata
 %attr(755,root,root) %{_bindir}/llvm-ranlib
 %attr(755,root,root) %{_bindir}/llvm-readobj
 %attr(755,root,root) %{_bindir}/llvm-rtdyld
@@ -540,9 +613,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-cov.1*
 %{_mandir}/man1/llvm-diff.1*
 %{_mandir}/man1/llvm-dis.1*
+%{_mandir}/man1/llvm-dwarfdump.1*
 %{_mandir}/man1/llvm-extract.1*
 %{_mandir}/man1/llvm-link.1*
 %{_mandir}/man1/llvm-nm.1*
+%{_mandir}/man1/llvm-profdata.1*
 %{_mandir}/man1/llvm-ranlib.1*
 %{_mandir}/man1/llvm-readobj.1*
 %{_mandir}/man1/llvm-stress.1*
@@ -554,7 +629,7 @@ rm -rf $RPM_BUILD_ROOT
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %{_libdir}/libLLVM-3.4.so
+%attr(755,root,root) %{_libdir}/libLLVM-3.5.so
 
 %files devel
 %defattr(644,root,root,755)
@@ -567,6 +642,8 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %{_includedir}/llvm
 %{_includedir}/llvm-c
+%dir %{_datadir}/llvm
+%{_datadir}/llvm/cmake
 %if %{with doc}
 %{_mandir}/man1/llvm-config.1*
 %endif
@@ -589,7 +666,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files polly-devel
 %defattr(644,root,root,755)
-%{_libdir}/libpolly*.a
 %{_includedir}/polly
 %endif
 
@@ -650,16 +726,41 @@ rm -rf $RPM_BUILD_ROOT
 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt,docs/_build/html/{*.html,*.js,_static}}
 %attr(755,root,root) %{_bindir}/clang-apply-replacements
 %attr(755,root,root) %{_bindir}/clang-modernize
+%attr(755,root,root) %{_bindir}/clang-query
 %attr(755,root,root) %{_bindir}/clang-tidy
 %attr(755,root,root) %{_bindir}/pp-trace
 %{_libdir}/libmodernizeCore.a
 
+%files -n lld
+%defattr(644,root,root,755)
+%doc tools/lld/{LICENSE.TXT,README.md}
+%attr(755,root,root) %{_bindir}/lld
+
+%files -n lld-devel
+%defattr(644,root,root,755)
+%{_libdir}/liblldCore.a
+%{_libdir}/liblldDriver.a
+%{_libdir}/liblldELF.a
+%{_libdir}/liblldMachO.a
+%{_libdir}/liblldNative.a
+%{_libdir}/liblldPECOFF.a
+%{_libdir}/liblldPasses.a
+%{_libdir}/liblldReaderWriter.a
+%{_libdir}/liblldYAML.a
+%{_libdir}/liblld*ELFTarget.a
+%{_includedir}/lld
+
 %if %{with lldb}
 %files -n lldb
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/lldb
+%attr(755,root,root) %{_bindir}/lldb-gdbserver
+%attr(755,root,root) %{_bindir}/lldb-mi
 %attr(755,root,root) %{_bindir}/lldb-platform
 %attr(755,root,root) %{_libdir}/liblldb.so
+%dir %{py_sitedir}/lldb
+%attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
+%attr(755,root,root) %{py_sitedir}/readline.so
 
 %files -n lldb-devel
 %defattr(644,root,root,755)
This page took 0.034527 seconds and 4 git commands to generate.