]> git.pld-linux.org Git - packages/llvm.git/blame_incremental - llvm.spec
- more changes to fix lib64 related problems (config patch, lldb patch, spec)
[packages/llvm.git] / llvm.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without lldb # LLDB debugger
4%bcond_without polly # Polly cache-locality optimization, auto-parallelism and vectorization
5%bcond_without rt # compiler-rt libraries
6%bcond_without ocaml # OCaml binding
7%bcond_without doc # HTML docs and man pages
8%bcond_with apidocs # doxygen docs (HUGE, so they are not built by default)
9%bcond_with tests # run tests
10
11%ifarch s390 s390x sparc64
12# No ocaml on these arches
13%undefine with_ocaml
14%endif
15
16Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
17Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
18Name: llvm
19Version: 3.5.0
20Release: 1
21License: University of Illinois/NCSA Open Source License
22Group: Development/Languages
23#Source0Download: http://llvm.org/releases/download.html
24Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
25# Source0-md5: d6987305a1a0e58e128c1374cd3b8fef
26Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
27# Source1-md5: 27718dd13c7df83e15f997116bbb4aef
28Source2: http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
29# Source2-md5: 02624d2a9144278c3808c00dbbab56c8
30Source3: http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
31# Source3-md5: 9597d5376309805ac586adfbd1e992f4
32Source4: http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
33# Source4-md5: 2ee0167c7ed7c85026cdb18ad6f4ade8
34Source5: http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
35# Source5-md5: 6e2830316638ec0de9534b98361dfbec
36Source6: http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
37# Source6-md5: 946404d534a51f1806d1ee955885d927
38Patch0: %{name}-config.patch
39# Data files should be installed with timestamps preserved
40Patch1: %{name}-2.6-timestamp.patch
41Patch2: %{name}-pld.patch
42Patch3: %{name}-polly-update.patch
43Patch4: %{name}-lldb.patch
44Patch5: %{name}-lld-link.patch
45URL: http://llvm.org/
46BuildRequires: autoconf >= 2.60
47BuildRequires: automake >= 1:1.9.6
48BuildRequires: bash
49BuildRequires: bison
50BuildRequires: flex
51BuildRequires: gcc >= 5:3.4
52# gcc4 might be installed, but not current __cc
53%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
54BuildRequires: __cc >= 3.4
55%endif
56BuildRequires: groff
57BuildRequires: libltdl-devel
58BuildRequires: libtool >= 2:1.5.22
59BuildRequires: libstdc++-devel >= 5:3.4
60BuildRequires: ocaml-ocamldoc
61BuildRequires: perl-base >= 1:5.6
62BuildRequires: perl-tools-pod
63BuildRequires: rpm-pythonprov
64%{?with_doc:BuildRequires: sphinx-pdg}
65BuildRequires: tar >= 1:1.22
66BuildRequires: xz
67%if %{with apidocs}
68BuildRequires: doxygen
69BuildRequires: graphviz
70%endif
71%if %{with tests}
72BuildRequires: dejagnu
73BuildRequires: python
74BuildRequires: tcl-devel
75%endif
76%if %{with lldb}
77BuildRequires: libedit-devel
78BuildRequires: libxml2-devel >= 2
79BuildRequires: ncurses-ext-devel
80BuildRequires: python-devel >= 2
81%endif
82%if %{with polly}
83BuildRequires: cloog-isl-devel
84# >= 0.18.2-2
85BuildRequires: gmp-devel
86BuildRequires: isl-devel >= 0.13
87# optional
88BuildRequires: pluto-devel
89BuildRequires: scoplib-devel >= 0.2.1-2
90#cuda-devel
91%endif
92Requires: %{name}-libs = %{version}-%{release}
93# LLVM is not supported on PPC64
94# http://llvm.org/bugs/show_bug.cgi?id=3729
95ExcludeArch: ppc64
96BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98%define _sysconfdir /etc/%{name}
99
100%define specflags_ppc -fno-var-tracking-assignments
101
102# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
103%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
104
105%description
106LLVM is a compiler infrastructure designed for compile-time,
107link-time, runtime, and idle-time optimization of programs from
108arbitrary programming languages. LLVM is written in C++ and has been
109developed since 2000 at the University of Illinois and Apple. It
110currently supports compilation of C and C++ programs using clang
111frontend.
112
113%description -l pl.UTF-8
114LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
115czasu kompilowania, linkowania, działania i bezczynności programów w
116dowolnych językach programowania. Jest napisana w C++, rozwijana od
117roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
118kompilację programów w C i C++ przy użyciu frontendu clang.
119
120%package libs
121Summary: LLVM shared library
122Summary(pl.UTF-8): Biblioteka współdzielona LLVM-a
123Group: Libraries
124Conflicts: llvm < 3.2
125
126%description libs
127LLVM shared library.
128
129%description libs -l pl.UTF-8
130Biblioteka współdzielona LLVM-a.
131
132%package devel
133Summary: Static libraries and header files for LLVM
134Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
135Group: Development/Languages
136Requires: %{name}-libs = %{version}-%{release}
137Requires: libstdc++-devel >= 6:3.4
138
139%description devel
140This package contains static libraries and header files needed to
141develop new native programs that use the LLVM infrastructure.
142
143%description devel -l pl.UTF-8
144Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
145potrzebne do tworzenia nowych programów natywnych wykorzystujących
146infrastrukturę LLVM.
147
148%package doc
149Summary: Documentation for LLVM
150Summary(pl.UTF-8): Dokumentacja do LLVM-a
151Group: Documentation
152# does not require base
153
154%description doc
155Documentation for the LLVM compiler infrastructure.
156
157%description doc -l pl.UTF-8
158Dokumentacja do infrastruktury kompilatorów LLVM.
159
160%package apidocs
161Summary: API documentation for LLVM
162Summary(pl.UTF-8): Dokumentacja API LLVM-a
163Group: Development/Languages
164Requires: %{name}-doc = %{version}-%{release}
165
166%description apidocs
167API documentation for the LLVM compiler infrastructure.
168
169%description apidocs -l pl.UTF-8
170Dokumentacja API infrastruktury kompilatorów LLVM.
171
172%package polly
173Summary: Polyhedral optimizations for LLVM
174Summary(pl.UTF-8): Optymalizacje wielościanowe dla LLVM-a
175Group: Development/Tools
176URL: http://polly.llvm.org/
177Requires: %{name} = %{version}-%{release}
178
179%description polly
180Polly is a high-level loop and data-locality optimizer and
181optimization infrastructure for LLVM. It uses an abstract mathematical
182representation based on integer polyhedra to analyze and optimize the
183memory access pattern of a program.
184
185%description polly -l pl.UTF-8
186Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
187optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
188reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
189do analizy i optymalizacji wzorców dostępu do pamięci przez program.
190
191%package polly-devel
192Summary: Header files for LLVM Polly optimization infrastructure
193Summary(pl.UTF-8): Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
194Group: Development/Libraries
195URL: http://polly.llvm.org/
196Requires: %{name}-devel = %{version}-%{release}
197Requires: %{name}-polly = %{version}-%{release}
198
199%description polly-devel
200Header files for LLVM Polly optimization infrastructure.
201
202%description polly-devel -l pl.UTF-8
203Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
204
205%package -n clang
206Summary: A C language family frontend for LLVM
207Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
208License: NCSA
209Group: Development/Languages
210Requires: %{name} = %{version}-%{release}
211
212%description -n clang
213clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
214of a crane or goose. 3. C-language family front-end toolkit.
215
216The goal of the Clang project is to create a new C, C++, Objective C
217and Objective C++ front-end for the LLVM compiler. Its tools are built
218as libraries and designed to be loosely-coupled and extendable.
219
220%description -n clang -l pl.UTF-8
221clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
222piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
223z rodziny C.
224
225Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
226LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
227budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
228i rozszerzaniu.
229
230%package -n clang-analyzer
231Summary: A source code analysis framework
232Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
233License: NCSA
234Group: Development/Languages
235Requires: clang = %{version}-%{release}
236# not picked up automatically since files are currently not instaled
237# in standard Python hierarchies yet
238Requires: python
239
240%description -n clang-analyzer
241The Clang Static Analyzer consists of both a source code analysis
242framework and a standalone tool that finds bugs in C and Objective-C
243programs. The standalone tool is invoked from the command-line, and is
244intended to run in tandem with a build of a project or code base.
245
246%description -n clang-analyzer -l pl.UTF-8
247Clang Static Analyzer składa się ze szkieletu do analizy kodu
248źródłowego oraz samodzielnego narzędzia znajdującego błędy w
249programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
250myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
251
252%package -n clang-devel
253Summary: Header files for Clang
254Summary(pl.UTF-8): Pliki nagłówkowe Clanga
255Group: Development/Languages
256Requires: %{name}-devel = %{version}-%{release}
257Requires: clang = %{version}-%{release}
258
259%description -n clang-devel
260This package contains header files for the Clang compiler.
261
262%description -n clang-devel -l pl.UTF-8
263Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
264
265%package -n clang-doc
266Summary: Documentation for Clang
267Summary(pl.UTF-8): Dokumentacja do Clanga
268Group: Documentation
269Requires: %{name} = %{version}-%{release}
270
271%description -n clang-doc
272Documentation for the Clang compiler front-end.
273
274%description -n clang-doc -l pl.UTF-8
275Dokumentacja do frontendu kompilatora Clang.
276
277%package -n clang-apidocs
278Summary: API documentation for Clang
279Summary(pl.UTF-8): Dokumentacja API Clanga
280Group: Development/Languages
281Requires: clang-doc = %{version}-%{release}
282
283%description -n clang-apidocs
284API documentation for the Clang compiler.
285
286%description -n clang-apidocs -l pl.UTF-8
287Dokumentacja API kompilatora Clang.
288
289%package -n clang-tools-extra
290Summary: Extra tools for Clang
291Summary(pl.UTF-8): Dodatkowe narzędzia do kompilatora Clang
292Group: Development/Tools
293URL: http://clang.llvm.org/docs/ClangTools.html
294Requires: clang = %{version}-%{release}
295
296%description -n clang-tools-extra
297Extra tools for Clang.
298
299%description -n clang-tools-extra -l pl.UTF-8
300Dodatkowe narzędzia do kompilatora Clang.
301
302%package -n lld
303Summary: The LLVM linker
304Summary(pl.UTF-8): Konsolidator z projektu LLVM
305Group: Development/Libraries
306URL: http://lld.llvm.org/
307Requires: %{name} = %{version}-%{release}
308
309%description -n lld
310lld is a new set of modular code for creating linker tools.
311
312%description -n lld -l pl.UTF-8
313lld to nowy zbiór modularnego kodu do tworzenia narzędzi
314konsolidujących.
315
316%package -n lld-devel
317Summary: Development files for LLD linker tools
318Summary(pl.UTF-8): Pliki programistyczne narzędzi konsolidujących LLD
319Group: Development/Tools
320URL: http://lld.llvm.org/
321Requires: %{name}-devel = %{version}-%{release}
322
323%description -n lld-devel
324Development files for LLD linker tools.
325
326%description -n lld-devel -l pl.UTF-8
327Pliki programistyczne narzędzi konsolidujących LLD.
328
329%package -n lldb
330Summary: Next generation high-performance debugger
331Summary(pl.UTF-8): Wydajny debugger nowej generacji
332Group: Development/Debuggers
333URL: http://lldb.llvm.org/
334Requires: %{name} = %{version}-%{release}
335
336%description -n lldb
337LLDB is a next generation, high-performance debugger. It is built as a
338set of reusable components which highly leverage existing libraries in
339the larger LLVM Project, such as the Clang expression parser and LLVM
340disassembler.
341
342%description -n lldb -l pl.UTF-8
343LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
344komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
345w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
346disasembler LLVM.
347
348%package -n lldb-devel
349Summary: Development files for LLDB debugger
350Summary(pl.UTF-8): Pliki programistyczne debuggera LLDB
351Group: Development/Libraries
352URL: http://lldb.llvm.org/
353Requires: %{name}-devel = %{version}-%{release}
354Requires: clang-devel = %{version}-%{release}
355Requires: lldb = %{version}-%{release}
356
357%description -n lldb-devel
358Development files for LLDB debugger.
359
360%description -n lldb-devel -l pl.UTF-8
361Pliki programistyczne debuggera LLDB.
362
363%package ocaml
364Summary: OCaml binding for LLVM
365Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
366Group: Libraries
367Requires: %{name} = %{version}-%{release}
368%requires_eq ocaml-runtime
369
370%description ocaml
371OCaml binding for LLVM.
372
373%description ocaml -l pl.UTF-8
374Wiązanie OCamla do LLVM-a.
375
376%package ocaml-devel
377Summary: Development files for LLVM OCaml binding
378Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
379Group: Development/Libraries
380Requires: %{name}-devel = %{version}-%{release}
381Requires: %{name}-ocaml = %{version}-%{release}
382
383%description ocaml-devel
384The llvm-ocaml-devel package contains libraries and signature files
385for developing applications that use llvm-ocaml binding.
386
387%description ocaml-devel -l pl.UTF-8
388Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
389wykorzystujących wiązanie llvm-ocaml.
390
391%package ocaml-doc
392Summary: Documentation for LLVM's OCaml binding
393Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
394Group: Documentation
395Requires: %{name}-ocaml = %{version}-%{release}
396
397%description ocaml-doc
398HTML documentation for LLVM's OCaml binding.
399
400%description ocaml-doc -l pl.UTF-8
401Dokumentacja HTML wiązania OCamla do LLVM-a.
402
403%prep
404%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
405mv cfe-%{version}.src tools/clang
406%{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
407%{?with_lldb:mv lldb-%{version}.src tools/lldb}
408%{?with_polly:mv polly-%{version}.src tools/polly}
409mv clang-tools-extra-%{version}.src tools/clang/tools/extra
410mv lld-%{version}.src tools/lld
411
412%patch0 -p1
413%patch1 -p1
414%patch2 -p1
415%{?with_polly:%patch3 -p1}
416%{?with_lldb:%patch4 -p1}
417%patch5 -p1
418
419# configure does not properly specify libdir
420%{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
421# clang resources
422%{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
423%{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
424
425grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
426 s,^#!.*bin/env python,#!%{__python},
427 s,^#!.*bin/env perl,#!%{__perl},
428}'
429
430%build
431install -d obj
432%if "%{_lib}" != "lib"
433# workaround for clang relative search paths building
434install -d obj/Release
435ln -snf lib obj/Release/%{_lib}
436%endif
437
438cd autoconf
439%{__aclocal} -I m4
440%{__autoconf} -o ../configure configure.ac
441cd ..
442%{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
443%if %{with polly}
444cd tools/polly/autoconf
445%{__aclocal} -I m4 -I ../../../autoconf/m4
446%{__autoconf} -o ../configure configure.ac
447cd ..
448%{__autoheader} -I autoconf -I autoconf/m4 -I ../../../autoconf/m4 autoconf/configure.ac
449cd ../..
450%endif
451
452# Disabling assertions now, rec. by pure and needed for OpenGTL
453# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
454#
455# bash specific 'test a < b'
456cd obj
457CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
458bash ../%configure \
459 --datadir=%{_datadir}/%{name}-%{version} \
460 --disable-assertions \
461 --enable-cxx11 \
462%ifarch %{ix86}
463 --disable-pic \
464%endif
465 --disable-static \
466 --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
467 --enable-debug-runtime \
468%if %{with apidocs}
469 --enable-doxygen \
470%endif
471 --enable-experimental-targets=R600 \
472 --enable-jit \
473 --enable-optimized \
474 --enable-shared \
475 --with-pic
476
477%{__make} \
478 VERBOSE=1 \
479 REQUIRES_RTTI=1 \
480 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
481
482%if %{with tests}
483%{__make} check 2>&1 | tee llvm-testlog.txt
484%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
485%endif
486
487cd ..
488
489%if %{with doc}
490%{__make} -C docs -f Makefile.sphinx man
491%{__make} -C tools/clang/tools/extra/docs html
492%endif
493
494%install
495rm -rf $RPM_BUILD_ROOT
496%{__make} -C obj -j1 install \
497 PROJ_docsdir=/moredocs \
498 DESTDIR=$RPM_BUILD_ROOT
499
500# Static analyzer not installed by default:
501# http://clang-analyzer.llvm.org/installation#OtherPlatforms
502install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
503# create launchers
504for f in scan-{build,view}; do
505 ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
506 cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
507done
508%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
509%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
510%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
511%py_postclean %{_libdir}/clang-analyzer/scan-view
512
513%if %{with doc}
514install -d $RPM_BUILD_ROOT%{_mandir}/man1
515cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
516# these tools are not installed
517%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
518# make links
519echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
520%endif
521
522# Move documentation back to build directory
523rm -rf moredocs
524mv $RPM_BUILD_ROOT/moredocs .
525%{__rm} -v moredocs/*.tar.gz
526%{__rm} -v moredocs/ocamldoc/html/*.tar.gz
527
528# and separate the apidoc
529%if %{with apidocs}
530rm -rf apidoc clang-apidoc
531mv moredocs/html/doxygen apidoc
532cp -a tools/clang/docs/doxygen/html clang-apidoc
533%endif
534
535# And prepare Clang documentation
536rm -rf clang-docs
537install -d clang-docs
538for f in LICENSE.TXT NOTES.txt README.txt; do
539 ln tools/clang/$f clang-docs
540done
541
542# Get rid of erroneously installed example files.
543%{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
544# parts of test suite
545%{__rm} $RPM_BUILD_ROOT%{_bindir}/{FileCheck,count,not}
546%{__rm} $RPM_BUILD_ROOT%{_bindir}/linker-script-test
547
548# remove documentation makefiles:
549# they require the build directory to work
550rm -rf moredocs/examples
551cp -a examples moredocs/examples
552find moredocs/examples -name Makefile | xargs -0r rm -f
553
554%clean
555rm -rf $RPM_BUILD_ROOT
556
557%post libs -p /sbin/ldconfig
558%postun libs -p /sbin/ldconfig
559
560%post -n clang -p /sbin/ldconfig
561%postun -n clang -p /sbin/ldconfig
562
563%post -n lldb -p /sbin/ldconfig
564%postun -n lldb -p /sbin/ldconfig
565
566%files
567%defattr(644,root,root,755)
568%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
569%attr(755,root,root) %{_bindir}/bugpoint
570%attr(755,root,root) %{_bindir}/llc
571%attr(755,root,root) %{_bindir}/lli
572%attr(755,root,root) %{_bindir}/lli-child-target
573%attr(755,root,root) %{_bindir}/llvm-ar
574%attr(755,root,root) %{_bindir}/llvm-as
575%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
576%attr(755,root,root) %{_bindir}/llvm-cov
577%attr(755,root,root) %{_bindir}/llvm-diff
578%attr(755,root,root) %{_bindir}/llvm-dis
579%attr(755,root,root) %{_bindir}/llvm-dwarfdump
580%attr(755,root,root) %{_bindir}/llvm-extract
581%attr(755,root,root) %{_bindir}/llvm-link
582%attr(755,root,root) %{_bindir}/llvm-mc
583%attr(755,root,root) %{_bindir}/llvm-mcmarkup
584%attr(755,root,root) %{_bindir}/llvm-nm
585%attr(755,root,root) %{_bindir}/llvm-objdump
586%attr(755,root,root) %{_bindir}/llvm-profdata
587%attr(755,root,root) %{_bindir}/llvm-ranlib
588%attr(755,root,root) %{_bindir}/llvm-readobj
589%attr(755,root,root) %{_bindir}/llvm-rtdyld
590%attr(755,root,root) %{_bindir}/llvm-size
591%attr(755,root,root) %{_bindir}/llvm-stress
592%attr(755,root,root) %{_bindir}/llvm-symbolizer
593%attr(755,root,root) %{_bindir}/llvm-tblgen
594%attr(755,root,root) %{_bindir}/macho-dump
595%attr(755,root,root) %{_bindir}/opt
596%if %{with doc}
597%{_mandir}/man1/bugpoint.1*
598%{_mandir}/man1/lit.1*
599%{_mandir}/man1/llc.1*
600%{_mandir}/man1/lli.1*
601%{_mandir}/man1/llvm-ar.1*
602%{_mandir}/man1/llvm-as.1*
603%{_mandir}/man1/llvm-bcanalyzer.1*
604%{_mandir}/man1/llvm-cov.1*
605%{_mandir}/man1/llvm-diff.1*
606%{_mandir}/man1/llvm-dis.1*
607%{_mandir}/man1/llvm-dwarfdump.1*
608%{_mandir}/man1/llvm-extract.1*
609%{_mandir}/man1/llvm-link.1*
610%{_mandir}/man1/llvm-nm.1*
611%{_mandir}/man1/llvm-profdata.1*
612%{_mandir}/man1/llvm-ranlib.1*
613%{_mandir}/man1/llvm-readobj.1*
614%{_mandir}/man1/llvm-stress.1*
615%{_mandir}/man1/llvm-symbolizer.1*
616%{_mandir}/man1/opt.1*
617%{_mandir}/man1/tblgen.1*
618%endif
619
620%files libs
621%defattr(644,root,root,755)
622%attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
623%attr(755,root,root) %{_libdir}/libLLVM-3.5.so
624
625%files devel
626%defattr(644,root,root,755)
627%attr(755,root,root) %{_bindir}/llvm-config
628%{_libdir}/libLLVM*.a
629%ifarch %{x8664}
630%attr(755,root,root) %{_libdir}/BugpointPasses.so
631%attr(755,root,root) %{_libdir}/libLTO.so
632%{_libdir}/libLTO.a
633%endif
634%{_includedir}/llvm
635%{_includedir}/llvm-c
636%dir %{_datadir}/llvm
637%{_datadir}/llvm/cmake
638%if %{with doc}
639%{_mandir}/man1/llvm-config.1*
640%endif
641
642%files doc
643%defattr(644,root,root,755)
644%doc moredocs/examples moredocs/html
645
646%if %{with apidocs}
647%files apidocs
648%defattr(644,root,root,755)
649%doc apidoc/*
650%endif
651
652%if %{with polly}
653%files polly
654%defattr(644,root,root,755)
655%doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
656%attr(755,root,root) %{_libdir}/LLVMPolly.so
657
658%files polly-devel
659%defattr(644,root,root,755)
660%{_includedir}/polly
661%endif
662
663%files -n clang
664%defattr(644,root,root,755)
665%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
666%attr(755,root,root) %{_bindir}/c-index-test
667%attr(755,root,root) %{_bindir}/clang
668%attr(755,root,root) %{_bindir}/clang++
669%attr(755,root,root) %{_bindir}/clang-check
670%attr(755,root,root) %{_bindir}/clang-format
671%attr(755,root,root) %{_bindir}/clang-tblgen
672%attr(755,root,root) %{_libdir}/libclang.so
673%dir %{_libdir}/clang
674%dir %{_libdir}/clang/%{version}
675%{_libdir}/clang/%{version}/include
676%if %{with rt}
677%{_libdir}/clang/%{version}/lib
678%endif
679%{_mandir}/man1/clang.1*
680
681%files -n clang-analyzer
682%defattr(644,root,root,755)
683%attr(755,root,root) %{_bindir}/scan-build
684%attr(755,root,root) %{_bindir}/scan-view
685%{_mandir}/man1/scan-build.1*
686%dir %{_libdir}/clang-analyzer
687
688%dir %{_libdir}/clang-analyzer/scan-build
689%{_libdir}/clang-analyzer/scan-build/*.css
690%{_libdir}/clang-analyzer/scan-build/*.js
691%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
692%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
693
694%dir %{_libdir}/clang-analyzer/scan-view
695%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
696%{_libdir}/clang-analyzer/scan-view/Resources
697%{_libdir}/clang-analyzer/scan-view/*.py[co]
698
699%files -n clang-devel
700%defattr(644,root,root,755)
701%{_libdir}/libclang*.a
702%{_includedir}/clang
703%{_includedir}/clang-c
704
705%files -n clang-doc
706%defattr(644,root,root,755)
707%doc tools/clang/docs/*.{css,html,png,txt}
708
709%if %{with apidocs}
710%files -n clang-apidocs
711%defattr(644,root,root,755)
712%doc clang-apidoc/*
713%endif
714
715%files -n clang-tools-extra
716%defattr(644,root,root,755)
717%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt,docs/_build/html/{*.html,*.js,_static}}
718%attr(755,root,root) %{_bindir}/clang-apply-replacements
719%attr(755,root,root) %{_bindir}/clang-modernize
720%attr(755,root,root) %{_bindir}/clang-query
721%attr(755,root,root) %{_bindir}/clang-tidy
722%attr(755,root,root) %{_bindir}/pp-trace
723%{_libdir}/libmodernizeCore.a
724
725%files -n lld
726%defattr(644,root,root,755)
727%doc tools/lld/{LICENSE.TXT,README.md}
728%attr(755,root,root) %{_bindir}/lld
729
730%files -n lld-devel
731%defattr(644,root,root,755)
732%{_libdir}/liblldCore.a
733%{_libdir}/liblldDriver.a
734%{_libdir}/liblldELF.a
735%{_libdir}/liblldMachO.a
736%{_libdir}/liblldNative.a
737%{_libdir}/liblldPECOFF.a
738%{_libdir}/liblldPasses.a
739%{_libdir}/liblldReaderWriter.a
740%{_libdir}/liblldYAML.a
741%{_libdir}/liblld*ELFTarget.a
742%{_includedir}/lld
743
744%if %{with lldb}
745%files -n lldb
746%defattr(644,root,root,755)
747%attr(755,root,root) %{_bindir}/lldb
748%attr(755,root,root) %{_bindir}/lldb-gdbserver
749%attr(755,root,root) %{_bindir}/lldb-mi
750%attr(755,root,root) %{_bindir}/lldb-platform
751%attr(755,root,root) %{_libdir}/liblldb.so
752%dir %{py_sitedir}/lldb
753%attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
754%attr(755,root,root) %{py_sitedir}/readline.so
755
756%files -n lldb-devel
757%defattr(644,root,root,755)
758%{_libdir}/liblldb*.a
759%{_includedir}/lldb
760%endif
761
762%if %{with ocaml}
763%files ocaml
764%defattr(644,root,root,755)
765%{_libdir}/ocaml/META.llvm*
766%attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
767%{_libdir}/ocaml/llvm*.cma
768%{_libdir}/ocaml/llvm*.cmi
769
770%files ocaml-devel
771%defattr(644,root,root,755)
772%{_libdir}/libllvm*.a
773%{_libdir}/ocaml/libLLVM*.a
774%{_libdir}/ocaml/libllvm*.a
775%{_libdir}/ocaml/llvm*.a
776%{_libdir}/ocaml/llvm*.cmx*
777%{_libdir}/ocaml/llvm*.mli
778
779%files ocaml-doc
780%defattr(644,root,root,755)
781%doc moredocs/ocamldoc/html/*
782%endif
This page took 0.042324 seconds and 4 git commands to generate.