]> git.pld-linux.org Git - packages/llvm.git/blame_incremental - llvm.spec
- release 3
[packages/llvm.git] / llvm.spec
... / ...
CommitLineData
1#
2# NOTE:
3# - normal build (x86_64) requires about 80 GB of disk space
4#
5# TODO:
6# - move and package:
7# %{_datadir}/clang/bash-autocomplete.sh
8# %{_datadir}/clang/clang-format-sublime.py - sublime plugin
9# %{_datadir}/clang/clang-format.el - clang tools emacs integration
10# %{_datadir}/clang/clang-include-fixer.el
11# %{_datadir}/clang/clang-rename.el
12# - no content in doc package (it used to contain parts of clang apidocs and some examples)
13# - system isl in polly?
14#
15# Conditional build:
16%bcond_without lldb # LLDB debugger
17%bcond_without polly # Polly cache-locality optimization, auto-parallelism and vectorization
18%bcond_without rt # compiler-rt libraries
19%bcond_without multilib # compiler-rt multilib libraries
20%bcond_without ocaml # OCaml binding
21%bcond_without doc # HTML docs and man pages
22%bcond_with apidocs # doxygen docs (HUGE, so they are not built by default)
23%bcond_with tests # run tests
24
25# No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
26%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
27%undefine with_ocaml
28%endif
29
30Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
31Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
32Name: llvm
33Version: 7.0.0
34Release: 3
35License: University of Illinois/NCSA Open Source License
36Group: Development/Languages
37#Source0Download: http://releases.llvm.org/download.html
38Source0: http://releases.llvm.org/%{version}/%{name}-%{version}.src.tar.xz
39# Source0-md5: e0140354db83cdeb8668531b431398f0
40Source1: http://releases.llvm.org/%{version}/cfe-%{version}.src.tar.xz
41# Source1-md5: 2ac5d8d78be681e31611c5e546e11174
42Source2: http://releases.llvm.org/%{version}/compiler-rt-%{version}.src.tar.xz
43# Source2-md5: 3b759c47076298363f4443395e0e51c1
44Source3: http://releases.llvm.org/%{version}/lldb-%{version}.src.tar.xz
45# Source3-md5: 76338963b3ccc4f9dccc923716207310
46Source4: http://releases.llvm.org/%{version}/polly-%{version}.src.tar.xz
47# Source4-md5: ff689bbfdca3ea812d195f60e63d8346
48Source5: http://releases.llvm.org/%{version}/clang-tools-extra-%{version}.src.tar.xz
49# Source5-md5: e98b37a5911cd556775cba0868a56981
50Source6: http://releases.llvm.org/%{version}/lld-%{version}.src.tar.xz
51# Source6-md5: 5eb148c3064acff71d8e5856163c8323
52Patch1: %{name}-pld.patch
53Patch3: x32-gcc-toolchain.patch
54Patch4: cmake-buildtype.patch
55Patch5: %{name}-ocaml-shared.patch
56URL: http://llvm.org/
57BuildRequires: bash
58BuildRequires: bison
59BuildRequires: cmake >= 3.4.3
60BuildRequires: flex
61BuildRequires: gcc >= 5:3.4
62# gcc4 might be installed, but not current __cc
63%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
64BuildRequires: __cc >= 3.4
65%endif
66BuildRequires: groff
67BuildRequires: libedit-devel
68BuildRequires: libltdl-devel
69BuildRequires: libstdc++-devel >= 5:3.4
70BuildRequires: ncurses-devel
71%if %{with ocaml}
72BuildRequires: ocaml >= 4.00.0
73BuildRequires: ocaml-ctypes-devel >= 0.4
74BuildRequires: ocaml-findlib
75BuildRequires: ocaml-ocamldoc
76BuildRequires: ocaml-ounit >= 2
77%endif
78BuildRequires: perl-base >= 1:5.6
79BuildRequires: perl-tools-pod
80BuildRequires: python >= 1:2.7
81BuildRequires: rpm-pythonprov
82BuildRequires: rpmbuild(macros) >= 1.734
83%{?with_doc:BuildRequires: sphinx-pdg}
84BuildRequires: tar >= 1:1.22
85BuildRequires: xz
86BuildRequires: zlib-devel
87%if %{with apidocs}
88BuildRequires: doxygen
89BuildRequires: graphviz
90%endif
91%if %{with tests}
92BuildRequires: dejagnu
93BuildRequires: tcl-devel
94%endif
95%if %{with rt} && %{with multilib}
96%ifarch %{x8664}
97BuildRequires: gcc-c++-multilib-32
98BuildRequires: libstdc++-multilib-32-devel
99%endif
100%ifarch x32
101BuildRequires: gcc-c++-multilib-32
102BuildRequires: gcc-c++-multilib-64
103BuildRequires: glibc-devel(x86_64)
104BuildRequires: libstdc++-multilib-32-devel
105BuildRequires: libstdc++-multilib-64-devel
106%endif
107%endif
108%if %{with lldb}
109BuildRequires: epydoc
110%ifarch i386 i486
111BuildRequires: libatomic-devel
112%endif
113BuildRequires: libxml2-devel >= 2
114BuildRequires: ncurses-ext-devel
115BuildRequires: python-devel >= 2
116BuildRequires: swig-python >= 3.0.11
117%endif
118%if %{with polly}
119#BuildRequires: gmp-devel or imath-devel (private copy in polly/lib/External/isl/imath)
120# private copy in polly/lib/External/isl
121#BuildRequires: isl-devel >= 0.18
122#TODO (bcond): cuda-devel (with POLLY_ENABLE_GPGPU_CODEGEN=ON)
123%endif
124%if %{with ocaml}
125BuildConflicts: llvm-ocaml
126%endif
127Requires: %{name}-libs = %{version}-%{release}
128# LLVM is not supported on PPC64
129# http://llvm.org/bugs/show_bug.cgi?id=3729
130ExcludeArch: ppc64
131BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
132
133%define abi 7
134%define _sysconfdir /etc/%{name}
135
136%define specflags_ppc -fno-var-tracking-assignments
137# ix86 and x32 - the same issue as https://llvm.org/bugs/show_bug.cgi?id=27237
138# use -gsplit-dwarf only when building packages with debuginfo
139# to avoid excessive disk space usage
140%if 0%{?_enable_debug_packages}
141%define specflags -gsplit-dwarf
142%endif
143
144# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
145%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
146
147# clang doesn't know -fvar-tracking-assignments, and leaving it here would pollute llvm-config
148# -Werror=format-security is for swig
149# TODO: add - -Werror=format-security to tools/lldb/scripts/LLDBWrapPython.cpp
150%define filterout_c -fvar-tracking-assignments
151%define filterout_cxx -fvar-tracking-assignments -Werror=format-security
152%define filterout_ccpp -fvar-tracking-assignments
153
154%description
155LLVM is a compiler infrastructure designed for compile-time,
156link-time, runtime, and idle-time optimization of programs from
157arbitrary programming languages. LLVM is written in C++ and has been
158developed since 2000 at the University of Illinois and Apple. It
159currently supports compilation of C and C++ programs using clang
160frontend.
161
162%description -l pl.UTF-8
163LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
164czasu kompilowania, linkowania, działania i bezczynności programów w
165dowolnych językach programowania. Jest napisana w C++, rozwijana od
166roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
167kompilację programów w C i C++ przy użyciu frontendu clang.
168
169%package libs
170Summary: LLVM shared libraries
171Summary(pl.UTF-8): Biblioteki współdzielone LLVM-a
172Group: Libraries
173Conflicts: llvm < 3.2
174
175%description libs
176LLVM shared libraries.
177
178%description libs -l pl.UTF-8
179Biblioteki współdzielone LLVM-a.
180
181%package devel
182Summary: Static libraries and header files for LLVM
183Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
184Group: Development/Languages
185Requires: %{name}-libs = %{version}-%{release}
186Requires: libstdc++-devel >= 6:3.4
187
188%description devel
189This package contains static libraries and header files needed to
190develop new native programs that use the LLVM infrastructure.
191
192%description devel -l pl.UTF-8
193Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
194potrzebne do tworzenia nowych programów natywnych wykorzystujących
195infrastrukturę LLVM.
196
197%package doc
198Summary: Documentation for LLVM
199Summary(pl.UTF-8): Dokumentacja do LLVM-a
200Group: Documentation
201# does not require base
202
203%description doc
204Documentation for the LLVM compiler infrastructure.
205
206%description doc -l pl.UTF-8
207Dokumentacja do infrastruktury kompilatorów LLVM.
208
209%package apidocs
210Summary: API documentation for LLVM
211Summary(pl.UTF-8): Dokumentacja API LLVM-a
212Group: Development/Languages
213Requires: %{name}-doc = %{version}-%{release}
214
215%description apidocs
216API documentation for the LLVM compiler infrastructure.
217
218%description apidocs -l pl.UTF-8
219Dokumentacja API infrastruktury kompilatorów LLVM.
220
221%package polly
222Summary: Polyhedral optimizations for LLVM
223Summary(pl.UTF-8): Optymalizacje wielościanowe dla LLVM-a
224Group: Development/Tools
225URL: http://polly.llvm.org/
226Requires: %{name} = %{version}-%{release}
227
228%description polly
229Polly is a high-level loop and data-locality optimizer and
230optimization infrastructure for LLVM. It uses an abstract mathematical
231representation based on integer polyhedra to analyze and optimize the
232memory access pattern of a program.
233
234%description polly -l pl.UTF-8
235Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
236optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
237reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
238do analizy i optymalizacji wzorców dostępu do pamięci przez program.
239
240%package polly-devel
241Summary: Header files for LLVM Polly optimization infrastructure
242Summary(pl.UTF-8): Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
243Group: Development/Libraries
244URL: http://polly.llvm.org/
245Requires: %{name}-devel = %{version}-%{release}
246Requires: %{name}-polly = %{version}-%{release}
247
248%description polly-devel
249Header files for LLVM Polly optimization infrastructure.
250
251%description polly-devel -l pl.UTF-8
252Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
253
254%package -n clang
255Summary: A C language family frontend for LLVM
256Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
257License: NCSA
258Group: Development/Languages
259Requires: %{name} = %{version}-%{release}
260Requires: clang-libs = %{version}-%{release}
261
262%description -n clang
263clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
264of a crane or goose. 3. C-language family front-end toolkit.
265
266The goal of the Clang project is to create a new C, C++, Objective C
267and Objective C++ front-end for the LLVM compiler. Its tools are built
268as libraries and designed to be loosely-coupled and extendable.
269
270%description -n clang -l pl.UTF-8
271clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
272piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
273z rodziny C.
274
275Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
276LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
277budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
278i rozszerzaniu.
279
280%package -n clang-libs
281Summary: Clang shared libraries
282Summary(pl.UTF-8): Biblioteki współdzielone Clanga
283Group: Libraries
284
285%description -n clang-libs
286Clang shared libraries.
287
288%description -n clang-libs -l pl.UTF-8
289Biblioteki współdzielone Clanga.
290
291%package -n clang-multilib
292Summary: A C language family frontend for LLVM - 32-bit support
293Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C - obsługa binariów 32-bitowych
294License: NCSA
295Group: Development/Languages
296Requires: clang = %{version}-%{release}
297
298%description -n clang-multilib
299clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
300of a crane or goose. 3. C-language family front-end toolkit.
301
302The goal of the Clang project is to create a new C, C++, Objective C
303and Objective C++ front-end for the LLVM compiler. Its tools are built
304as libraries and designed to be loosely-coupled and extendable.
305
306This package contains the C compiler support for producing 32-bit
307programs on 64-bit host.
308
309%description -n clang-multilib -l pl.UTF-8
310clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
311piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
312z rodziny C.
313
314Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
315LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
316budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
317i rozszerzaniu.
318
319Ten pakiet zawiera rozszerzenie kompilatora C o obsługę tworzenia
320programów 32-bitowych na maszynie 64-bitowej.
321
322%package -n clang-analyzer
323Summary: A source code analysis framework
324Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
325License: NCSA
326Group: Development/Languages
327Requires: clang = %{version}-%{release}
328# not picked up automatically since files are currently not instaled
329# in standard Python hierarchies yet
330Requires: python
331
332%description -n clang-analyzer
333The Clang Static Analyzer consists of both a source code analysis
334framework and a standalone tool that finds bugs in C and Objective-C
335programs. The standalone tool is invoked from the command-line, and is
336intended to run in tandem with a build of a project or code base.
337
338%description -n clang-analyzer -l pl.UTF-8
339Clang Static Analyzer składa się ze szkieletu do analizy kodu
340źródłowego oraz samodzielnego narzędzia znajdującego błędy w
341programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
342myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
343
344%package -n clang-devel
345Summary: Header files for Clang
346Summary(pl.UTF-8): Pliki nagłówkowe Clanga
347Group: Development/Languages
348Requires: %{name}-devel = %{version}-%{release}
349Requires: clang = %{version}-%{release}
350
351%description -n clang-devel
352This package contains header files for the Clang compiler.
353
354%description -n clang-devel -l pl.UTF-8
355Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
356
357%package -n clang-doc
358Summary: Documentation for Clang
359Summary(pl.UTF-8): Dokumentacja do Clanga
360Group: Documentation
361Requires: %{name} = %{version}-%{release}
362
363%description -n clang-doc
364Documentation for the Clang compiler front-end.
365
366%description -n clang-doc -l pl.UTF-8
367Dokumentacja do frontendu kompilatora Clang.
368
369%package -n clang-apidocs
370Summary: API documentation for Clang
371Summary(pl.UTF-8): Dokumentacja API Clanga
372Group: Development/Languages
373Requires: clang-doc = %{version}-%{release}
374
375%description -n clang-apidocs
376API documentation for the Clang compiler.
377
378%description -n clang-apidocs -l pl.UTF-8
379Dokumentacja API kompilatora Clang.
380
381%package -n clang-tools-extra
382Summary: Extra tools for Clang
383Summary(pl.UTF-8): Dodatkowe narzędzia do kompilatora Clang
384Group: Development/Tools
385URL: http://clang.llvm.org/docs/ClangTools.html
386Requires: clang = %{version}-%{release}
387
388%description -n clang-tools-extra
389Extra tools for Clang.
390
391%description -n clang-tools-extra -l pl.UTF-8
392Dodatkowe narzędzia do kompilatora Clang.
393
394%package -n lld
395Summary: The LLVM linker
396Summary(pl.UTF-8): Konsolidator z projektu LLVM
397Group: Development/Libraries
398URL: http://lld.llvm.org/
399Requires: %{name} = %{version}-%{release}
400
401%description -n lld
402lld is a new set of modular code for creating linker tools.
403
404%description -n lld -l pl.UTF-8
405lld to nowy zbiór modularnego kodu do tworzenia narzędzi
406konsolidujących.
407
408%package -n lld-devel
409Summary: Development files for LLD linker tools
410Summary(pl.UTF-8): Pliki programistyczne narzędzi konsolidujących LLD
411Group: Development/Tools
412URL: http://lld.llvm.org/
413Requires: %{name}-devel = %{version}-%{release}
414
415%description -n lld-devel
416Development files for LLD linker tools.
417
418%description -n lld-devel -l pl.UTF-8
419Pliki programistyczne narzędzi konsolidujących LLD.
420
421%package -n lldb
422Summary: Next generation high-performance debugger
423Summary(pl.UTF-8): Wydajny debugger nowej generacji
424Group: Development/Debuggers
425URL: http://lldb.llvm.org/
426Requires: %{name} = %{version}-%{release}
427Requires: python-six
428
429%description -n lldb
430LLDB is a next generation, high-performance debugger. It is built as a
431set of reusable components which highly leverage existing libraries in
432the larger LLVM Project, such as the Clang expression parser and LLVM
433disassembler.
434
435%description -n lldb -l pl.UTF-8
436LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
437komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
438w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
439disasembler LLVM.
440
441%package -n lldb-devel
442Summary: Development files for LLDB debugger
443Summary(pl.UTF-8): Pliki programistyczne debuggera LLDB
444Group: Development/Libraries
445URL: http://lldb.llvm.org/
446Requires: %{name}-devel = %{version}-%{release}
447Requires: clang-devel = %{version}-%{release}
448Requires: lldb = %{version}-%{release}
449
450%description -n lldb-devel
451Development files for LLDB debugger.
452
453%description -n lldb-devel -l pl.UTF-8
454Pliki programistyczne debuggera LLDB.
455
456%package ocaml
457Summary: OCaml binding for LLVM
458Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
459Group: Libraries
460Requires: %{name} = %{version}-%{release}
461%if %{with ocaml}
462%requires_eq ocaml-runtime
463%endif
464
465%description ocaml
466OCaml binding for LLVM.
467
468%description ocaml -l pl.UTF-8
469Wiązanie OCamla do LLVM-a.
470
471%package ocaml-devel
472Summary: Development files for LLVM OCaml binding
473Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
474Group: Development/Libraries
475Requires: %{name}-devel = %{version}-%{release}
476Requires: %{name}-ocaml = %{version}-%{release}
477
478%description ocaml-devel
479The llvm-ocaml-devel package contains libraries and signature files
480for developing applications that use llvm-ocaml binding.
481
482%description ocaml-devel -l pl.UTF-8
483Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
484wykorzystujących wiązanie llvm-ocaml.
485
486%package ocaml-doc
487Summary: Documentation for LLVM's OCaml binding
488Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
489Group: Documentation
490Requires: %{name}-ocaml = %{version}-%{release}
491
492%description ocaml-doc
493HTML documentation for LLVM's OCaml binding.
494
495%description ocaml-doc -l pl.UTF-8
496Dokumentacja HTML wiązania OCamla do LLVM-a.
497
498%package opt-viewer
499Summary: Optimization records visualization tools
500Summary(pl.UTF-8): Narzędzia do wizualizacji rekordów optymalizacji
501Group: Development/Tools
502Requires: %{name} = %{version}
503BuildArch: noarch
504
505%description opt-viewer
506Optimization records visualization tools.
507
508%description opt-viewer -l pl.UTF-8
509Narzędzia do wizualizacji rekordów optymalizacji.
510
511%package -n vim-plugin-clang
512Summary: Clang format and rename integration for Vim
513Summary(pl.UTF-8): Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem
514Group: Applications/Editors/Vim
515Requires: vim-rt >= 4:7.0
516BuildArch: noarch
517
518%description -n vim-plugin-clang
519Clang format and rename integration for Vim.
520
521%description -n vim-plugin-clang -l pl.UTF-8
522Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
523
524%prep
525%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
526%{__mv} cfe-%{version}.src tools/clang
527%{?with_rt:%{__mv} compiler-rt-%{version}.src projects/compiler-rt}
528%{?with_lldb:%{__mv} lldb-%{version}.src tools/lldb}
529%{?with_polly:%{__mv} polly-%{version}.src tools/polly}
530%{__mv} clang-tools-extra-%{version}.src tools/clang/tools/extra
531%{__mv} lld-%{version}.src tools/lld
532
533%patch1 -p1
534%patch3 -p1
535%patch4 -p1
536%patch5 -p1
537
538grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
539 s,^#!.*bin/env python,#!%{__python},
540 s,^#!.*bin/env perl,#!%{__perl},
541}'
542
543find -name '*.py' -print0 | xargs -0 sed -i -e '1{
544 s,^#!.*bin/python.*,#!%{__python},
545}'
546
547%build
548install -d build
549
550# Disabling assertions now, rec. by pure and needed for OpenGTL
551# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
552cd build
553CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
554
555%cmake \
556%if "%{_lib}" == "lib64"
557 -DLLVM_LIBDIR_SUFFIX:STRING=64 \
558%endif
559%if "%{_lib}" == "libx32"
560 -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
561%endif
562%if %{with apidocs}
563 -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
564%endif
565%if %{with doc}
566 -DLLVM_ENABLE_SPHINX:BOOL=ON \
567 -DSPHINX_WARNINGS_AS_ERRORS=OFF \
568%endif
569 -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
570 -DLLVM_ENABLE_CXX1Y:BOOL=ON \
571 -DLLVM_ENABLE_RTTI:BOOL=ON \
572 -DLLVM_ENABLE_PIC:BOOL=ON \
573 -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
574 -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
575 -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
576 -DBUILD_SHARED_LIBS:BOOL=OFF \
577 -DENABLE_LINKER_BUILD_ID:BOOL=ON \
578 -DLLVM_BINUTILS_INCDIR:STRING=%{_includedir} \
579 ../
580
581%{__make} \
582 VERBOSE=1 \
583 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
584
585%if %{with tests}
586%{__make} check 2>&1 | tee llvm-testlog.txt
587%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
588%endif
589
590%if %{with doc}
591%{__make} -C docs docs-llvm-html
592%{__make} -C docs docs-llvm-man
593%if %{with ocaml}
594%{__make} -C docs ocaml_doc
595%endif
596%{__make} -C tools/clang/docs docs-clang-html
597%{__make} -C tools/clang/docs docs-clang-man
598%{__make} -C tools/lld/docs docs-lld-html
599%{__make} \
600 LD_LIBRARY_PATH=$(pwd)/%{_lib} \
601 -C tools/lldb/docs lldb-python-doc
602%{__make} -C tools/lldb/docs lldb-cpp-doc
603%endif
604
605%install
606rm -rf $RPM_BUILD_ROOT
607
608%{__make} -j1 -C build install \
609 DESTDIR=$RPM_BUILD_ROOT
610
611# only some .pyc files are created by make install
612%py_comp $RPM_BUILD_ROOT%{py_sitedir}
613%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
614
615# Adjust static analyzer installation
616# http://clang-analyzer.llvm.org/installation#OtherPlatforms
617install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
618%{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
619%{__sed} -i -e 's,/\.\./libexec/,/../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
620%py_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
621%py_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
622%py_postclean %{_datadir}/scan-view
623
624# not installed by cmake buildsystem
625install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
626
627%if %{with doc}
628cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
629# these tools are not installed
630%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
631# make links
632echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
633%endif
634
635# Move documentation back to build directory
636%if %{with ocaml}
637rm -rf ocamldocs
638%{__mv} $RPM_BUILD_ROOT%{_docdir}/llvm/ocaml-html ocamldocs
639%endif
640
641# and separate the apidoc
642%if %{with apidocs}
643rm -rf clang-apidoc
644cp -a build/tools/clang/docs/html clang-apidoc
645%endif
646
647# And prepare Clang documentation
648rm -rf clang-docs
649install -d clang-docs
650for f in LICENSE.TXT NOTES.txt README.txt; do
651 ln tools/clang/$f clang-docs
652done
653
654# Get rid of erroneously installed example files.
655%{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
656# test?
657%{__rm} $RPM_BUILD_ROOT%{_libdir}/TestPlugin.so
658%{__rm} $RPM_BUILD_ROOT%{_bindir}/{c-index-test,llvm-c-test}
659# not this OS
660%{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
661# use system six
662%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/six.py*
663# it seems it is used internally by an extra clang tool
664%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
665
666# disable completeness check incompatible with split packaging
667%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_libdir}/cmake/llvm/LLVMExports.cmake
668
669%clean
670rm -rf $RPM_BUILD_ROOT
671
672%post libs -p /sbin/ldconfig
673%postun libs -p /sbin/ldconfig
674
675%post -n clang-libs -p /sbin/ldconfig
676%postun -n clang-libs -p /sbin/ldconfig
677
678%post -n lldb -p /sbin/ldconfig
679%postun -n lldb -p /sbin/ldconfig
680
681%files
682%defattr(644,root,root,755)
683%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
684%attr(755,root,root) %{_bindir}/bugpoint
685%attr(755,root,root) %{_bindir}/dsymutil
686%attr(755,root,root) %{_bindir}/llc
687%attr(755,root,root) %{_bindir}/lli
688%attr(755,root,root) %{_bindir}/llvm-ar
689%attr(755,root,root) %{_bindir}/llvm-as
690%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
691%attr(755,root,root) %{_bindir}/llvm-cat
692%attr(755,root,root) %{_bindir}/llvm-cfi-verify
693%attr(755,root,root) %{_bindir}/llvm-cov
694%attr(755,root,root) %{_bindir}/llvm-cvtres
695%attr(755,root,root) %{_bindir}/llvm-cxxdump
696%attr(755,root,root) %{_bindir}/llvm-cxxfilt
697%attr(755,root,root) %{_bindir}/llvm-diff
698%attr(755,root,root) %{_bindir}/llvm-dis
699%attr(755,root,root) %{_bindir}/llvm-dlltool
700%attr(755,root,root) %{_bindir}/llvm-dwarfdump
701%attr(755,root,root) %{_bindir}/llvm-dwp
702%attr(755,root,root) %{_bindir}/llvm-exegesis
703%attr(755,root,root) %{_bindir}/llvm-extract
704%attr(755,root,root) %{_bindir}/llvm-lib
705%attr(755,root,root) %{_bindir}/llvm-link
706%attr(755,root,root) %{_bindir}/llvm-lto
707%attr(755,root,root) %{_bindir}/llvm-lto2
708%attr(755,root,root) %{_bindir}/llvm-mc
709%attr(755,root,root) %{_bindir}/llvm-mca
710%attr(755,root,root) %{_bindir}/llvm-modextract
711%attr(755,root,root) %{_bindir}/llvm-mt
712%attr(755,root,root) %{_bindir}/llvm-nm
713%attr(755,root,root) %{_bindir}/llvm-objcopy
714%attr(755,root,root) %{_bindir}/llvm-objdump
715%attr(755,root,root) %{_bindir}/llvm-opt-report
716%attr(755,root,root) %{_bindir}/llvm-pdbutil
717%attr(755,root,root) %{_bindir}/llvm-profdata
718%attr(755,root,root) %{_bindir}/llvm-ranlib
719%attr(755,root,root) %{_bindir}/llvm-rc
720%attr(755,root,root) %{_bindir}/llvm-readelf
721%attr(755,root,root) %{_bindir}/llvm-readobj
722%attr(755,root,root) %{_bindir}/llvm-rtdyld
723%attr(755,root,root) %{_bindir}/llvm-size
724%attr(755,root,root) %{_bindir}/llvm-split
725%attr(755,root,root) %{_bindir}/llvm-strip
726%attr(755,root,root) %{_bindir}/llvm-stress
727%attr(755,root,root) %{_bindir}/llvm-strings
728%attr(755,root,root) %{_bindir}/llvm-symbolizer
729%attr(755,root,root) %{_bindir}/llvm-tblgen
730%attr(755,root,root) %{_bindir}/llvm-undname
731%attr(755,root,root) %{_bindir}/llvm-xray
732%attr(755,root,root) %{_bindir}/obj2yaml
733%attr(755,root,root) %{_bindir}/opt
734%attr(755,root,root) %{_bindir}/sancov
735%attr(755,root,root) %{_bindir}/sanstats
736%attr(755,root,root) %{_bindir}/verify-uselistorder
737%attr(755,root,root) %{_bindir}/yaml2obj
738%if %{with doc}
739%{_mandir}/man1/bugpoint.1*
740%{_mandir}/man1/dsymutil.1*
741%{_mandir}/man1/lit.1*
742%{_mandir}/man1/llc.1*
743%{_mandir}/man1/lli.1*
744%{_mandir}/man1/llvm-ar.1*
745%{_mandir}/man1/llvm-as.1*
746%{_mandir}/man1/llvm-bcanalyzer.1*
747%{_mandir}/man1/llvm-cov.1*
748%{_mandir}/man1/llvm-diff.1*
749%{_mandir}/man1/llvm-dis.1*
750%{_mandir}/man1/llvm-dwarfdump.1*
751%{_mandir}/man1/llvm-exegesis.1*
752%{_mandir}/man1/llvm-extract.1*
753%{_mandir}/man1/llvm-lib.1*
754%{_mandir}/man1/llvm-link.1*
755%{_mandir}/man1/llvm-mca.1*
756%{_mandir}/man1/llvm-nm.1*
757%{_mandir}/man1/llvm-pdbutil.1*
758%{_mandir}/man1/llvm-profdata.1*
759%{_mandir}/man1/llvm-ranlib.1*
760%{_mandir}/man1/llvm-readobj.1*
761%{_mandir}/man1/llvm-stress.1*
762%{_mandir}/man1/llvm-symbolizer.1*
763%{_mandir}/man1/opt.1*
764%{_mandir}/man1/tblgen.1*
765%endif
766
767%files libs
768%defattr(644,root,root,755)
769%attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
770# non-soname symlink
771%attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
772%attr(755,root,root) %ghost %{_libdir}/libLTO.so.7
773%attr(755,root,root) %{_libdir}/LLVMgold.so
774
775%files devel
776%defattr(644,root,root,755)
777%attr(755,root,root) %{_bindir}/llvm-config
778%attr(755,root,root) %{_libdir}/libLLVM.so
779%attr(755,root,root) %{_libdir}/libLTO.so
780%attr(755,root,root) %{_libdir}/BugpointPasses.so
781%{_libdir}/libLLVM*.a
782%{_includedir}/llvm
783%{_includedir}/llvm-c
784%{_libdir}/cmake/llvm
785%if %{with doc}
786%{_mandir}/man1/llvm-config.1*
787%endif
788
789#%files doc
790#%defattr(644,root,root,755)
791
792%if %{with apidocs}
793%files apidocs
794%defattr(644,root,root,755)
795%doc apidoc/*
796%endif
797
798%if %{with polly}
799%files polly
800%defattr(644,root,root,755)
801%doc tools/polly/{CREDITS.txt,LICENSE.txt,README} tools/polly/www/{bugs,changelog,contributors}.html
802%attr(755,root,root) %{_libdir}/LLVMPolly.so
803
804%files polly-devel
805%defattr(644,root,root,755)
806%{_libdir}/libPolly.a
807%{_libdir}/libPollyISL.a
808%{_libdir}/libPollyPPCG.a
809%{_includedir}/polly
810%{_libdir}/cmake/polly
811%endif
812
813%files -n clang
814%defattr(644,root,root,755)
815%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
816%attr(755,root,root) %{_bindir}/clang
817%attr(755,root,root) %{_bindir}/clang++
818%attr(755,root,root) %{_bindir}/clang-%{abi}
819%attr(755,root,root) %{_bindir}/clang-check
820%attr(755,root,root) %{_bindir}/clang-cl
821%attr(755,root,root) %{_bindir}/clang-cpp
822%attr(755,root,root) %{_bindir}/clang-format
823%attr(755,root,root) %{_bindir}/clang-import-test
824%attr(755,root,root) %{_bindir}/clang-offload-bundler
825%attr(755,root,root) %{_bindir}/git-clang-format
826%dir %{_libdir}/clang
827%dir %{_libdir}/clang/%{version}
828%{_libdir}/clang/%{version}/include
829%if %{with rt}
830%ifarch %{ix86} %{x8664}
831%dir %{_libdir}/clang/%{version}/lib
832%dir %{_libdir}/clang/%{version}/lib/linux
833%dir %{_libdir}/clang/%{version}/share
834%endif
835%ifarch x32
836%if %{with multilib}
837%dir %{_libdir}/clang/%{version}/lib
838%dir %{_libdir}/clang/%{version}/lib/linux
839%dir %{_libdir}/clang/%{version}/share
840%endif
841%endif
842%ifarch %{ix86}
843%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.a
844%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
845%endif
846%ifarch %{x8664}
847%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
848%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
849%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
850%endif
851%ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
852%{_libdir}/clang/%{version}/share/asan_blacklist.txt
853%endif
854%ifarch %{ix86} %{x8664} mips64
855%{_libdir}/clang/%{version}/share/cfi_blacklist.txt
856%endif
857%ifarch %{x8664} aarch64 mips64
858%{_libdir}/clang/%{version}/share/dfsan_abilist.txt
859%{_libdir}/clang/%{version}/share/msan_blacklist.txt
860%endif
861%ifarch %{x8664} aarch64
862%{_libdir}/clang/%{version}/share/hwasan_blacklist.txt
863%endif
864%ifarch x32
865%if %{with multilib}
866%{_libdir}/clang/%{version}/share/asan_blacklist.txt
867%{_libdir}/clang/%{version}/share/cfi_blacklist.txt
868%{_libdir}/clang/%{version}/share/dfsan_abilist.txt
869%{_libdir}/clang/%{version}/share/msan_blacklist.txt
870%{_libdir}/clang/%{version}/share/hwasan_blacklist.txt
871%endif
872%endif
873%endif
874%dir %{_datadir}/clang
875%{_datadir}/clang/clang-format-diff.py
876
877%files -n clang-libs
878%defattr(644,root,root,755)
879%attr(755,root,root) %{_libdir}/libclang.so.%{abi}
880
881%if %{with rt} && %{with multilib}
882%ifarch %{x8664} x32
883%files -n clang-multilib
884%defattr(644,root,root,755)
885%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
886%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
887%endif
888%ifarch x32
889%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
890%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
891%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
892%endif
893%endif
894
895%files -n clang-analyzer
896%defattr(644,root,root,755)
897%attr(755,root,root) %{_bindir}/scan-build
898%attr(755,root,root) %{_bindir}/scan-view
899%{_datadir}/scan-build
900%{_datadir}/scan-view
901%{_mandir}/man1/scan-build.1*
902%dir %{_libdir}/scan-build
903%attr(755,root,root) %{_libdir}/scan-build/c++-analyzer
904%attr(755,root,root) %{_libdir}/scan-build/ccc-analyzer
905
906%files -n clang-devel
907%defattr(644,root,root,755)
908%attr(755,root,root) %{_libdir}/libclang.so
909%{_libdir}/libclang*.a
910%{_includedir}/clang
911%{_includedir}/clang-c
912%{_libdir}/cmake/clang
913
914%files -n clang-doc
915%defattr(644,root,root,755)
916%doc tools/clang/docs/*.{html,png,txt}
917
918%if %{with apidocs}
919%files -n clang-apidocs
920%defattr(644,root,root,755)
921%doc clang-apidoc/*
922%endif
923
924%files -n clang-tools-extra
925%defattr(644,root,root,755)
926%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt}
927%attr(755,root,root) %{_bindir}/clang-apply-replacements
928%attr(755,root,root) %{_bindir}/clang-change-namespace
929%attr(755,root,root) %{_bindir}/clang-func-mapping
930%attr(755,root,root) %{_bindir}/clang-include-fixer
931%attr(755,root,root) %{_bindir}/clang-query
932%attr(755,root,root) %{_bindir}/clang-refactor
933%attr(755,root,root) %{_bindir}/clang-rename
934%attr(755,root,root) %{_bindir}/clang-reorder-fields
935%attr(755,root,root) %{_bindir}/clang-tidy
936%attr(755,root,root) %{_bindir}/clangd
937%attr(755,root,root) %{_bindir}/diagtool
938%attr(755,root,root) %{_bindir}/find-all-symbols
939%attr(755,root,root) %{_bindir}/hmaptool
940%attr(755,root,root) %{_bindir}/modularize
941%attr(755,root,root) %{_bindir}/pp-trace
942%{_datadir}/clang/clang-include-fixer.py
943%{_datadir}/clang/clang-tidy-diff.py
944%{_datadir}/clang/run-clang-tidy.py
945%{_datadir}/clang/run-find-all-symbols.py
946
947%files -n lld
948%defattr(644,root,root,755)
949%doc tools/lld/{LICENSE.TXT,README.md}
950%attr(755,root,root) %{_bindir}/ld.lld
951%attr(755,root,root) %{_bindir}/ld64.lld
952%attr(755,root,root) %{_bindir}/lld
953%attr(755,root,root) %{_bindir}/lld-link
954%attr(755,root,root) %{_bindir}/wasm-ld
955
956%files -n lld-devel
957%defattr(644,root,root,755)
958%{_libdir}/liblld[ACDEHMRWXY]*.a
959%{_includedir}/lld
960
961%if %{with lldb}
962%files -n lldb
963%defattr(644,root,root,755)
964%attr(755,root,root) %{_bindir}/lldb
965%attr(755,root,root) %{_bindir}/lldb-argdumper
966%attr(755,root,root) %{_bindir}/lldb-mi
967%attr(755,root,root) %{_bindir}/lldb-server
968%attr(755,root,root) %{_bindir}/lldb-test
969%attr(755,root,root) %{_libdir}/liblldb.so.%{version}
970%attr(755,root,root) %ghost %{_libdir}/liblldb.so.7
971%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.7
972%dir %{py_sitedir}/lldb
973%attr(755,root,root) %{py_sitedir}/lldb/lldb-argdumper
974%{py_sitedir}/lldb/formatters
975%{py_sitedir}/lldb/runtime
976%{py_sitedir}/lldb/utils
977%{py_sitedir}/lldb/__init__.py[co]
978%{py_sitedir}/lldb/embedded_interpreter.py[co]
979%attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
980%attr(755,root,root) %{py_sitedir}/readline.so
981
982%files -n lldb-devel
983%defattr(644,root,root,755)
984%attr(755,root,root) %{_libdir}/liblldb.so
985%attr(755,root,root) %{_libdir}/liblldbIntelFeatures.so
986%{_libdir}/liblldb*.a
987%{_includedir}/lldb
988%endif
989
990%if %{with ocaml}
991%files ocaml
992%defattr(644,root,root,755)
993%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllllvm*.so
994%dir %{_libdir}/ocaml/llvm
995%{_libdir}/ocaml/llvm/llvm*.cma
996%{_libdir}/ocaml/llvm/llvm*.cmi
997%{_libdir}/ocaml/META.llvm*
998
999%files ocaml-devel
1000%defattr(644,root,root,755)
1001%{_libdir}/ocaml/llvm/libllvm*.a
1002%{_libdir}/ocaml/llvm/llvm*.a
1003%{_libdir}/ocaml/llvm/llvm*.cmx
1004%{_libdir}/ocaml/llvm/llvm*.cmxa
1005%{_libdir}/ocaml/llvm/llvm*.mli
1006
1007%files ocaml-doc
1008%defattr(644,root,root,755)
1009%doc ocamldocs/*
1010%endif
1011
1012%files opt-viewer
1013%defattr(644,root,root,755)
1014%{_datadir}/opt-viewer
1015
1016%files -n vim-plugin-clang
1017%defattr(644,root,root,755)
1018%{_datadir}/clang/clang-format.py
1019%{_datadir}/clang/clang-rename.py
This page took 0.046334 seconds and 4 git commands to generate.