]> git.pld-linux.org Git - packages/litecoin.git/commitdiff
- added univalue patch (fixes build with system libunivalue) auto/th/litecoin-0.18.1-2
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 22 Sep 2020 20:23:54 +0000 (22:23 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 22 Sep 2020 20:23:54 +0000 (22:23 +0200)
- release 2 (protobuf 3.13)

litecoin-univalue.patch [new file with mode: 0644]
litecoin.spec

diff --git a/litecoin-univalue.patch b/litecoin-univalue.patch
new file mode 100644 (file)
index 0000000..ec6e45b
--- /dev/null
@@ -0,0 +1,11 @@
+--- Feathercoin-0.19.1/src/rpc/blockchain.cpp.orig     2020-08-06 11:29:39.000000000 +0200
++++ Feathercoin-0.19.1/src/rpc/blockchain.cpp  2020-09-22 19:32:56.101427468 +0200
+@@ -2094,7 +2094,7 @@
+             // no scan in progress
+             return NullUniValue;
+         }
+-        result.pushKV("progress", g_scan_progress);
++        result.pushKV("progress", g_scan_progress.load());
+         return result;
+     } else if (request.params[0].get_str() == "abort") {
+         CoinsViewScanReserver reserver;
index cd200bf5fbbf503390247ddabdd94faf023e9d84..1b83145e9ecf1b2b92cf98d941a1f2d45c1f390f 100644 (file)
@@ -2,13 +2,14 @@ Summary:      Litecoin is a peer-to-peer currency
 Summary(pl.UTF-8):     Litecoin - waluta peer-to-peer
 Name:          litecoin
 Version:       0.18.1
-Release:       1
+Release:       2
 License:       MIT
 Group:         X11/Applications
 #Sourrce0Download: https://github.com/litecoin-project/litecoin/releases
 Source0:       https://download.litecoin.org/litecoin-%{version}/src/%{name}-%{version}.tar.gz
 # Source0-md5: 67af5786635639536e78993b1fc082d0
 Patch0:                qt-5.15.patch
+Patch1:                %{name}-univalue.patch
 URL:           http://www.litecoin.org/
 BuildRequires: Qt5Core-devel >= 5.4
 BuildRequires: Qt5DBus-devel >= 5.4
@@ -62,6 +63,7 @@ Portfel na litecoiny oparty na Qt.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -77,8 +79,11 @@ cd src/secp256k1
 %{__automake}
 cd ../..
 %configure \
+       --disable-bench \
+       --disable-gui-tests \
        --disable-shared \
        --disable-silent-rules \
+       --disable-tests \
        --with-boost \
        --with-incompatible-bdb \
        --with-miniupnpc \
This page took 0.2138 seconds and 4 git commands to generate.