]> git.pld-linux.org Git - packages/linux-gpib.git/commitdiff
- up to 4.0.4rc3 auto/th/linux-gpib-4.0.4-0.rc3.1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 16 Sep 2017 08:11:18 +0000 (10:11 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 16 Sep 2017 08:11:18 +0000 (10:11 +0200)
linux-gpib-php7.patch
linux-gpib.spec

index 045fbf0e429dcdf6a804def1c9df0f7b98740f6c..0d161b8c02f59696a264826f9e946d665edc0a20 100644 (file)
  #endif
  
 @@ -550,7 +558,11 @@
-         memset(p,0,len+1);
+       memset(p,0,len+1);
        r=ibrd(n,p,len);
-         p[ibcnt]='\0';
+       p[ibcnt]='\0';
 +#if PHP_MAJOR_VERSION >= 7
-+        ZVAL_STRING(z,p);
++      ZVAL_STRING(z,p);
 +#else
-         ZVAL_STRING(z,p,1);
+       ZVAL_STRING(z,p,1);
 +#endif
-       free(p);
+       efree(p);
        RETURN_LONG(r);
  }
index 916fbd90e214b0e978a78314da98448a2ef7fa4c..3f6bd2fd2a89a98698527d99ff93ec999027f581 100644 (file)
@@ -33,17 +33,18 @@ exit 1
 %include       /usr/lib/rpm/macros.perl
 %define                php_name        php%{?php_suffix}
 
-%define                rel     12
+%define                _rc     rc3
+%define                rel     0.%{_rc}.1
 %define                pname   linux-gpib
 Summary:       GPIB (IEEE 488) Linux support
 Summary(pl.UTF-8):     Obsługa GPIB (IEEE 488) dla Linuksa
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       4.0.3
+Version:       4.0.4
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2+
 Group:         Applications/System
-Source0:       http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
-# Source0-md5: 2d97191e538a57ba7350fcc011ee2596
+Source0:       http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}%{_rc}.tar.gz
+# Source0-md5: e12b4eeae623015c74f8ed01107e8f92
 Patch0:                %{pname}-include_file.patch
 Patch1:                %{pname}-destdir.patch
 Patch2:                %{pname}-python.patch
@@ -252,7 +253,7 @@ cd ../..\
 %{?with_kernel:%{expand:%create_kernel_packages}}
 
 %prep
-%setup -q -n %{pname}-%{version}
+%setup -q -n %{pname}-%{version}%{_rc}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -438,7 +439,7 @@ fi
 %if %{with guile}
 %files -n guile-gpib
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
+%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}%{_rc}.so
 %attr(755,root,root) %{_libdir}/libgpib-guile.so
 %endif
 
@@ -458,7 +459,7 @@ fi
 %files -n %{php_name}-gpib
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
-%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
+%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}%{_rc}.so
 %attr(755,root,root) %{php_extensiondir}/gpib_php.so
 %endif
 
@@ -475,7 +476,7 @@ fi
 %files -n tcl-gpib
 %defattr(644,root,root,755)
 %doc language/tcl/README
-%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
+%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}%{_rc}.so
 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
 %{_examplesdir}/tcl-gpib-%{version}
 %endif
This page took 0.166174 seconds and 4 git commands to generate.