]> git.pld-linux.org Git - packages/linux-gpib.git/blobdiff - linux-gpib.spec
- up to 4.3.0
[packages/linux-gpib.git] / linux-gpib.spec
index c90be4625bc92da0f623654cd5e60629f2bde57a..9748a0947e046a95ffc724b4adb1923603c01357 100644 (file)
@@ -38,21 +38,19 @@ exit 1
 Summary:       GPIB (IEEE 488) Linux support
 Summary(pl.UTF-8):     Obsługa GPIB (IEEE 488) dla Linuksa
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       4.1.0
+Version:       4.3.0
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2+
 Group:         Applications/System
 Source0:       http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
-# Source0-md5: 2614bb6dcfde4bf01f6047fdf0ea021f
-Patch0:                %{pname}-include_file.patch
-Patch1:                %{pname}-destdir.patch
+# Source0-md5: 3085422695baf210b866601db6108860
 Patch2:                %{pname}-python.patch
 Patch3:                %{pname}-perl.patch
 Patch4:                %{pname}-firmwaredir.patch
 Patch5:                %{pname}-guile2.patch
 Patch6:                %{pname}-php7.patch
-Patch7:                kernel-4.11.patch
-Patch8:                kernel-4.15.patch
+Patch7:                kernel-5.0.patch
+Patch8:                kernel-5.2.patch
 URL:           http://linux-gpib.sourceforge.net/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -240,10 +238,13 @@ Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
 %{nil}
 
 %define build_kernel_pkg()\
-TOPDIR=$(pwd)\
-%build_kernel_modules -C drivers/gpib -m gpib -- EARLYCPPFLAGS="-I$TOPDIR -I$TOPDIR/drivers/gpib/include -I$TOPDIR/include"\
+%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
 cd drivers/gpib\
+%ifarch %{ix86}\
+%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
+%else\
 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
+%endif\
 cd ../..\
 %{nil}
 
@@ -254,34 +255,44 @@ cd ../..\
 
 %prep
 %setup -q -n %{pname}-%{version}
-%patch0 -p1
-%patch1 -p1
+%if %{with userspace}
+tar xzf linux-gpib-user-%{version}.tar.gz
+cd linux-gpib-user-%{version}
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
-%patch7 -p1
-%patch8 -p1
+#%patch6 -p1
+cd ..
+%endif
 
-# disable modules build by default, just install userspace header
-echo 'SUBDIRS = gpib/include' > drivers/Makefile.am
+%if %{with kernel}
+tar xzf linux-gpib-kernel-%{version}.tar.gz
+cd linux-gpib-kernel-%{version}
+#%patch7 -p1
+#%ifarch %{ix86}
+#%patch8 -p1
+#%endif
 
 # need to inject -I options before $(LINUXINCLUDE), the simplest way is to override CC
-for f in drivers/gpib/*/Makefile ; do
-echo 'override CC += $(EARLYCPPFLAGS)' >> $f
-done
+#for f in drivers/gpib/*/Makefile ; do
+#echo 'override CC += $(EARLYCPPFLAGS)' >> $f
+#done
+%endif
 
 %build
+%if %{with userspace}
+cd linux-gpib-user-%{version}
 %{__libtoolize}
-%{__aclocal} -I m4
+%{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %if %{with guile}
-CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.0"
+CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
 %endif
 %configure \
+       --with-udev-libdir=/lib/udev \
        %{?with_drivers_isa:--enable-isa} \
        %{?with_drivers_pcmcia:--enable-pcmcia} \
        %{!?with_docs:--disable-documentation} \
@@ -290,14 +301,14 @@ CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.0"
        %{!?with_php:--disable-php-binding} \
        %{!?with_python:--disable-python-binding} \
        %{?with_static_libs:--enable-static} \
-       %{!?with_tcl:--disable-tcl-binding} \
-       --with-linux-srcdir=%{_kernelsrcdir}
+       %{!?with_tcl:--disable-tcl-binding}
 
-%if %{with userspace}
 %{__make}
+cd ..
 %endif
 
 %if %{with kernel}
+cd linux-gpib-kernel-%{version}
 %{expand:%build_kernel_packages}
 %endif
 
@@ -306,11 +317,14 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}
 
 %if %{with kernel}
+cd linux-gpib-kernel-%{version}
 %{expand:%install_kernel_packages}
 cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
+cd ..
 %endif
 
 %if %{with userspace}
+cd linux-gpib-user-%{version}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        HOTPLUG_USB_CONF_DIR=/lib/udev \
@@ -323,8 +337,6 @@ install -d $RPM_BUILD_ROOT/etc/hotplug/usb
 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
-%else
-%{__rm} $RPM_BUILD_ROOT/lib/udev/*.usermap
 %endif
 
 # obsoleted by pkg-config
@@ -374,7 +386,7 @@ cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
 
 %if %{with docs}
 # packaged as %doc
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib/html
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
 %endif
 %endif
 
@@ -401,14 +413,16 @@ fi
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
 %attr(755,root,root) %{_bindir}/ibterm
 %attr(755,root,root) %{_bindir}/ibtest
 %attr(755,root,root) %{_sbindir}/gpib_config
+/lib/udev/rules.d/98-gpib-generic.rules
 /lib/udev/rules.d/99-agilent_82357a.rules
-/lib/udev/rules.d/99-gpib-generic.rules
 /lib/udev/rules.d/99-ni_usb_gpib.rules
-%attr(755,root,root) /lib/udev/agilent_82357a
-%attr(755,root,root) /lib/udev/ni_usb_gpib
+%attr(755,root,root) /lib/udev/gpib_udev_config
+%attr(755,root,root) /lib/udev/gpib_udev_fxloader
+%attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
 
 %if %{with hotplug}
 %files hotplug
@@ -421,7 +435,7 @@ fi
 
 %files libs
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README README.HAMEG README.hp82335 TODO
+%doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
 %attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
 
@@ -447,7 +461,7 @@ fi
 %if %{with perl}
 %files -n perl-gpib
 %defattr(644,root,root,755)
-%doc language/perl/{Changes,README}
+%doc linux-gpib-user-%{version}/language/perl/{Changes,README}
 %{perl_vendorarch}/LinuxGpib.pm
 %dir %{perl_vendorarch}/auto/LinuxGpib
 %attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
@@ -467,7 +481,7 @@ fi
 %if %{with python}
 %files -n python-gpib
 %defattr(644,root,root,755)
-%doc language/python/README
+%doc linux-gpib-user-%{version}/language/python/README
 %attr(755,root,root) %{py_sitedir}/gpib.so
 %{py_sitedir}/Gpib.py[co]
 %{py_sitedir}/gpib-1.0-py*.egg-info
@@ -476,7 +490,7 @@ fi
 %if %{with tcl}
 %files -n tcl-gpib
 %defattr(644,root,root,755)
-%doc language/tcl/README
+%doc linux-gpib-user-%{version}/language/tcl/README
 %attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
 %{_examplesdir}/tcl-gpib-%{version}
@@ -485,6 +499,6 @@ fi
 %if %{with docs}
 %files doc
 %defattr(644,root,root,755)
-%doc doc/doc_html/*
+%doc linux-gpib-user-%{version}/doc/doc_html/*
 %endif
 %endif
This page took 0.102531 seconds and 4 git commands to generate.