]> git.pld-linux.org Git - packages/linux-gpib.git/blob - linux-gpib.spec
f53cfef9fcc06d0904ef2f93aa706d9d65fd7e5e
[packages/linux-gpib.git] / linux-gpib.spec
1 #
2 # Conditional build:
3 %bcond_without  kernel          # kernel modules
4 %bcond_without  drivers_isa     # ISA kernel drivers [ix86 only]
5 %bcond_without  drivers_usb     # USB kernel drivers
6 %bcond_without  userspace       # userspace packages
7 %bcond_without  verbose         # verbose modules build (V=1)
8
9 %bcond_without  doc             # documentation build
10 %bcond_with     hotplug         # legacy hotplug support
11 %bcond_without  static_libs     # static library
12 %bcond_without  guile           # guile binding
13 %bcond_without  perl            # Perl binding
14 %bcond_with     php             # PHP binding
15 %bcond_without  python          # Python (any) binding
16 %bcond_without  python2         # Python 2.x binding
17 %bcond_without  tcl             # Tcl binding
18
19 # The goal here is to have main, userspace, package built once with
20 # simple release number, and only rebuild kernel packages with kernel
21 # version as part of release number, without the need to bump release
22 # with every kernel change.
23 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24 %{error:kernel and userspace cannot be built at the same time on PLD builders}
25 exit 1
26 %endif
27
28 %if %{without userspace}
29 # nothing to be placed to debuginfo package
30 %define         _enable_debug_packages  0
31 %endif
32
33 %ifnarch %{ix86}
34 %undefine       with_drivers_isa
35 %endif
36 %if %{without python}
37 %undefine       with_python2
38 %endif
39
40 %define         php_name        php%{?php_suffix}
41
42 %define         rel     4
43 %define         pname   linux-gpib
44 Summary:        GPIB (IEEE 488) Linux support
45 Summary(pl.UTF-8):      Obsługa GPIB (IEEE 488) dla Linuksa
46 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
47 Version:        4.3.4
48 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
49 License:        GPL v2+
50 Group:          Applications/System
51 Source0:        http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
52 # Source0-md5:  d42b04d3b27a601c9b893915d5fded37
53 Patch2:         %{pname}-python.patch
54 Patch3:         %{pname}-perl.patch
55 Patch4:         %{pname}-firmwaredir.patch
56 Patch5:         %{pname}-guile2.patch
57 Patch6:         %{pname}-php7.patch
58 Patch8:         kernel-5.2.patch
59 Patch9:         kernel-5.10.patch
60 Patch10:        pkgconfig-version.patch
61 URL:            http://linux-gpib.sourceforge.net/
62 BuildRequires:  autoconf >= 2.50
63 BuildRequires:  automake
64 BuildRequires:  libtool
65 BuildRequires:  rpmbuild(macros) >= 1.745
66 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.32}}
67 %if %{with userspace}
68 BuildRequires:  bison
69 %{?with_doc:BuildRequires:      docbook-utils}
70 BuildRequires:  flex
71 %{?with_guile:BuildRequires:    guile-devel >= 1.4}
72 %{?with_perl:BuildRequires:     perl-devel}
73 %{?with_php:BuildRequires:      %{php_name}-devel >= 3:5}
74 %{?with_python:BuildRequires:   python-devel >= 2}
75 BuildRequires:  readline-devel
76 %{?with_tcl:BuildRequires:      tcl-devel}
77 %endif
78 Requires:       %{pname}-libs = %{version}-%{release}
79 # for agilent_82357a and ni_usb_gpib
80 Suggests:       fxload
81 # for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
82 Suggests:       linux-gpib-firmware
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %description
86 The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
87
88 %description -l pl.UTF-8
89 Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
90
91 %package hotplug
92 Summary:        Linux GPIB support for legacy USB hotplug
93 Summary(pl.UTF-8):      Obsługa Linux GPIB dla starego systemu hotplug USB
94 Group:          Applications/System
95 Requires:       %{pname} = %{version}-%{release}
96 Requires:       hotplug
97
98 %description hotplug
99 Linux GPIB support for legacy USB hotplug.
100
101 %description hotplug -l pl.UTF-8
102 Obsługa Linux GPIB dla starego systemu hotplug USB.
103
104 %package libs
105 Summary:        Shared GPIB library
106 Summary(pl.UTF-8):      Biblioteka współdzielona GPIB
107 Group:          Libraries
108
109 %description libs
110 Shared GPIB library.
111
112 %description libs -l pl.UTF-8
113 Biblioteka współdzielona GPIB.
114
115 %package devel
116 Summary:        Header file for GPIB library
117 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki GPIB
118 Group:          Development/Libraries
119 Requires:       %{pname}-libs = %{version}-%{release}
120
121 %description devel
122 Header file for GPIB library.
123
124 %description devel -l pl.UTF-8
125 Plik nagłówkowy biblioteki GPIB.
126
127 %package static
128 Summary:        Static GPIB library
129 Summary(pl.UTF-8):      Biblioteka statyczna GPIB
130 Group:          Development/Libraries
131 Requires:       %{pname}-devel = %{version}-%{release}
132
133 %description static
134 Static GPIB library.
135
136 %description static -l pl.UTF-8
137 Biblioteka statyczna GPIB.
138
139 %package -n guile-gpib
140 Summary:        Guile bindings for GPIB library
141 Summary(pl.UTF-8):      Wiązania Guile do biblioteki GPIB
142 Group:          Development/Languages/Perl
143 Requires:       %{pname}-libs = %{version}-%{release}
144 Requires:       guile-libs
145
146 %description -n guile-gpib
147 Guile bindings for GPIB library.
148
149 %description -n guile-gpib -l pl.UTF-8
150 Wiązania Guile do biblioteki GPIB.
151
152 %package -n perl-gpib
153 Summary:        Perl bindings for GPIB library
154 Summary(pl.UTF-8):      Wiązania Perla do biblioteki GPIB
155 Group:          Development/Languages/Perl
156 Requires:       %{pname}-libs = %{version}-%{release}
157
158 %description -n perl-gpib
159 Perl bindings for GPIB library.
160
161 %description -n perl-gpib -l pl.UTF-8
162 Wiązania Perla do biblioteki GPIB.
163
164 %package -n %{php_name}-gpib
165 Summary:        PHP bindings for GPIB library
166 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GPIB
167 Group:          Development/Languages/PHP
168 Provides:       php(gpib) = %{version}
169 Requires:       %{pname}-libs = %{version}-%{release}
170 %{?requires_php_extension}
171
172 %description -n %{php_name}-gpib
173 PHP bindings for GPIB library.
174
175 %description -n %{php_name}-gpib -l pl.UTF-8
176 Wiązania PHP do biblioteki GPIB.
177
178 %package -n python-gpib
179 Summary:        Python 2 bindings for GPIB library
180 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki GPIB
181 Group:          Libraries/Python
182 Requires:       %{pname}-libs = %{version}-%{release}
183 Requires:       python-libs
184
185 %description -n python-gpib
186 Python 2 bindings for GPIB library.
187
188 %description -n python-gpib -l pl.UTF-8
189 Wiązania Pythona 2 do biblioteki GPIB.
190
191 %package -n python3-gpib
192 Summary:        Python 3 bindings for GPIB library
193 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki GPIB
194 Group:          Libraries/Python
195 Requires:       %{pname}-libs = %{version}-%{release}
196 Requires:       python3-libs
197
198 %description -n python3-gpib
199 Python 3 bindings for GPIB library.
200
201 %description -n python3-gpib -l pl.UTF-8
202 Wiązania Pythona 3 do biblioteki GPIB.
203
204 %package -n tcl-gpib
205 Summary:        Tcl bindings for GPIB library
206 Summary(pl.UTF-8):      Wiązania Tcl-a do biblioteki GPIB
207 Group:          Libraries
208 Requires:       %{pname}-libs = %{version}-%{release}
209 Requires:       tcl
210
211 %description -n tcl-gpib
212 Tcl bindings for GPIB library.
213
214 %description -n tcl-gpib -l pl.UTF-8
215 Wiązania Tcl-a do biblioteki GPIB.
216
217 %package doc
218 Summary:        Linux-GPIB tools and library documentation
219 Summary(pl.UTF-8):      Dokumentacja narzędzi i biblioteki Linux-GPIB
220 License:        GFDL v1.2+ or GPL v2+
221 Group:          Documentation
222
223 %description doc
224 Linux-GPIB tools and library documentation.
225
226 %description doc -l pl.UTF-8
227 Dokumentacja narzędzi i biblioteki Linux-GPIB.
228
229 %define kernel_pkg()\
230 %package -n kernel%{_alt_kernel}-gpib\
231 Summary:        Linux GPIB drivers\
232 Summary(pl.UTF-8):      Sterowniki GPIB dla Linuksa\
233 Release:        %{rel}@%{_kernel_ver_str}\
234 Group:          Base/Kernel\
235 Requires(post,postun):  /sbin/depmod\
236 %requires_releq_kernel\
237 Requires(postun):       %releq_kernel\
238 \
239 %description -n kernel%{_alt_kernel}-gpib\
240 This package contains Linux drivers for GPIB (IEEE 488) hardware.\
241 \
242 %description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
243 Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
244 \
245 %if %{with kernel}\
246 %files -n kernel%{_alt_kernel}-gpib\
247 %defattr(644,root,root,755)\
248 /lib/modules/%{_kernel_ver}/kernel/gpib\
249 %endif\
250 \
251 %post -n kernel%{_alt_kernel}-gpib\
252 %depmod %{_kernel_ver}\
253 \
254 %postun -n kernel%{_alt_kernel}-gpib\
255 %depmod %{_kernel_ver}\
256 %{nil}
257
258 %define build_kernel_pkg()\
259 %{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir} clean\
260 %{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
261 cd drivers/gpib\
262 %if %{_kernel_version_code} < %{_kernel_version_magic 5 10 0}\
263 %if %{with drivers_usb}\
264 %install_kernel_modules -D installed -m lpvo_usb_gpib/lpvo_usb_gpib -d kernel/gpib\
265 %endif\
266 %endif\
267 %ifarch %{ix86}\
268 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
269 %else\
270 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
271 %endif\
272 cd ../..\
273 %{nil}
274
275 %define install_kernel_pkg()\
276 %{nil}
277
278 %{?with_kernel:%{expand:%create_kernel_packages}}
279
280 %prep
281 %setup -q -n %{pname}-%{version}
282 %if %{with userspace}
283 tar xzf linux-gpib-user-%{version}.tar.gz
284 cd linux-gpib-user-%{version}
285 %patch2 -p1
286 %patch3 -p1
287 %patch4 -p1
288 %patch5 -p1
289 #%patch6 -p1
290 %patch10 -p1
291 cd ..
292 %endif
293
294 %if %{with kernel}
295 tar xzf linux-gpib-kernel-%{version}.tar.gz
296 cd linux-gpib-kernel-%{version}
297 %patch9 -p1
298 %ifarch %{ix86}
299 %patch8 -p1
300 %endif
301 %endif
302
303 %build
304 %if %{with userspace}
305 cd linux-gpib-user-%{version}
306 %{__libtoolize}
307 %{__aclocal}
308 %{__autoconf}
309 %{__autoheader}
310 %{__automake}
311 %if %{with guile}
312 CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
313 %endif
314 %configure \
315         --with-udev-libdir=/lib/udev \
316         %{!?with_doc:--disable-documentation} \
317         %{!?with_guile:--disable-guile-binding} \
318         %{!?with_perl:--disable-perl-binding} \
319         %{!?with_php:--disable-php-binding} \
320         %{!?with_python:--disable-python-binding} \
321         %{?with_static_libs:--enable-static} \
322         %{!?with_tcl:--disable-tcl-binding}
323
324 %{__make}
325
326 %if %{with python2}
327 cd language/python
328 %py_build
329 cd ../..
330 %endif
331 cd ..
332 %endif
333
334 %if %{with kernel}
335 cd linux-gpib-kernel-%{version}
336 %{expand:%build_kernel_packages}
337 %endif
338
339 %install
340 rm -rf $RPM_BUILD_ROOT
341 install -d $RPM_BUILD_ROOT%{_examplesdir}
342
343 %if %{with kernel}
344 cd linux-gpib-kernel-%{version}
345 %{expand:%install_kernel_packages}
346 cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
347 cd ..
348 %endif
349
350 %if %{with userspace}
351 cd linux-gpib-user-%{version}
352 %{__make} install \
353         DESTDIR=$RPM_BUILD_ROOT \
354         HOTPLUG_USB_CONF_DIR=/lib/udev \
355         UDEV_RULES_DIR=/lib/udev/rules.d \
356         USB_FIRMWARE_DIR=/lib/firmware
357
358 %if %{with python2}
359 cd language/python
360 %py_install
361 cd ../..
362 %endif
363
364 %if %{with hotplug}
365 # use udev paths as base and legacy hotplug as addon (not the opposite)
366 install -d $RPM_BUILD_ROOT/etc/hotplug/usb
367 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
368 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
369 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
370 %endif
371
372 # obsoleted by pkg-config
373 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
374
375 %if %{with guile}
376 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
377 %if %{with static_libs}
378 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
379 %endif
380 %endif
381
382 %if %{with perl}
383 %{__make} -C language/perl pure_install \
384         DESTDIR=$RPM_BUILD_ROOT
385
386 cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
387
388 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
389 %endif
390
391 %if %{with php}
392 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
393 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
394 ; Enable gpib extension module
395 extension=gpib_php.so
396 EOF
397
398 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
399 %if %{with static_libs}
400 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
401 %endif
402 %endif
403
404 %if %{with python}
405 %py_postclean
406 %endif
407
408 %if %{with tcl}
409 cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
410
411 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
412 %if %{with static_libs}
413 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
414 %endif
415 %endif
416
417 %if %{with doc}
418 # packaged as %doc
419 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
420 %endif
421 %endif
422
423 %clean
424 rm -rf $RPM_BUILD_ROOT
425
426 %post   libs -p /sbin/ldconfig
427 %postun libs -p /sbin/ldconfig
428
429 %post   -n guile-gpib -p /sbin/ldconfig
430 %postun -n guile-gpib -p /sbin/ldconfig
431
432 %post   -n tcl-gpib -p /sbin/ldconfig
433 %postun -n tcl-gpib -p /sbin/ldconfig
434
435 %post   -n %{php_name}-gpib
436 %php_webserver_restart
437
438 %postun -n %{php_name}-gpib
439 if [ "$1" = 0 ]; then
440         %php_webserver_restart
441 fi
442
443 %if %{with userspace}
444 %files
445 %defattr(644,root,root,755)
446 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
447 %attr(755,root,root) %{_bindir}/ibterm
448 %attr(755,root,root) %{_bindir}/ibtest
449 %attr(755,root,root) %{_bindir}/findlisteners
450 %attr(755,root,root) %{_sbindir}/gpib_config
451 /lib/udev/rules.d/98-gpib-generic.rules
452 /lib/udev/rules.d/99-agilent_82357a.rules
453 /lib/udev/rules.d/99-lpvo_usb_gpib.rules
454 /lib/udev/rules.d/99-ni_usb_gpib.rules
455 %attr(755,root,root) /lib/udev/gpib_udev_config
456 %attr(755,root,root) /lib/udev/gpib_udev_fxloader
457 %attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
458
459 %if %{with hotplug}
460 %files hotplug
461 %defattr(644,root,root,755)
462 %attr(755,root,root) /etc/hotplug/usb/agilent_82357a
463 %attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
464 /etc/hotplug/usb/agilent_82357a.usermap
465 /etc/hotplug/usb/ni_usb_gpib.usermap
466 %endif
467
468 %files libs
469 %defattr(644,root,root,755)
470 %doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
471 %attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
472 %attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
473
474 %files devel
475 %defattr(644,root,root,755)
476 %attr(755,root,root) %{_libdir}/libgpib.so
477 %{_includedir}/gpib
478 %{_pkgconfigdir}/libgpib.pc
479
480 %if %{with static_libs}
481 %files static
482 %defattr(644,root,root,755)
483 %{_libdir}/libgpib.a
484 %endif
485
486 %if %{with guile}
487 %files -n guile-gpib
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
490 %attr(755,root,root) %{_libdir}/libgpib-guile.so
491 %endif
492
493 %if %{with perl}
494 %files -n perl-gpib
495 %defattr(644,root,root,755)
496 %doc linux-gpib-user-%{version}/language/perl/{Changes,README}
497 %{perl_vendorarch}/LinuxGpib.pm
498 %dir %{perl_vendorarch}/auto/LinuxGpib
499 %attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
500 %{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
501 %{_mandir}/man3/LinuxGpib.3pm*
502 %{_examplesdir}/perl-gpib-%{version}
503 %endif
504
505 %if %{with php}
506 %files -n %{php_name}-gpib
507 %defattr(644,root,root,755)
508 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
509 %attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
510 %attr(755,root,root) %{php_extensiondir}/gpib_php.so
511 %endif
512
513 %if %{with python2}
514 %files -n python-gpib
515 %defattr(644,root,root,755)
516 %doc linux-gpib-user-%{version}/language/python/README
517 %attr(755,root,root) %{py_sitedir}/gpib.so
518 %{py_sitedir}/Gpib.py[co]
519 %{py_sitedir}/gpib-1.0-py*.egg-info
520 %endif
521
522 %if %{with python}
523 %files -n python3-gpib
524 %defattr(644,root,root,755)
525 %doc linux-gpib-user-%{version}/language/python/README
526 %attr(755,root,root) %{py3_sitedir}/gpib.cpython-*.so
527 %{py3_sitedir}/Gpib.py
528 %{py3_sitedir}/__pycache__/Gpib.cpython-*.py[co]
529 %{py3_sitedir}/gpib-1.0-py*.egg-info
530 %endif
531
532 %if %{with tcl}
533 %files -n tcl-gpib
534 %defattr(644,root,root,755)
535 %doc linux-gpib-user-%{version}/language/tcl/README
536 %attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
537 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
538 %{_examplesdir}/tcl-gpib-%{version}
539 %endif
540
541 %if %{with doc}
542 %files doc
543 %defattr(644,root,root,755)
544 %doc linux-gpib-user-%{version}/doc/doc_html/*
545 %endif
546 %endif
This page took 0.127983 seconds and 2 git commands to generate.