]> git.pld-linux.org Git - packages/linux-gpib.git/blob - linux-gpib.spec
- change order of conflicting patches and rediff
[packages/linux-gpib.git] / linux-gpib.spec
1 #
2 # Conditional build:
3 %bcond_without  kernel          # kernel modules
4 %bcond_without  drivers_isa     # ISA kernel drivers [ix86 only]
5 %bcond_without  drivers_usb     # USB kernel drivers
6 %bcond_without  userspace       # userspace packages
7 %bcond_without  verbose         # verbose modules build (V=1)
8
9 %bcond_without  doc             # documentation build
10 %bcond_with     hotplug         # legacy hotplug support
11 %bcond_without  static_libs     # static library
12 %bcond_without  guile           # guile binding
13 %bcond_without  perl            # Perl binding
14 %bcond_with     php             # PHP binding
15 %bcond_without  python          # Python (any) binding
16 %bcond_without  python2         # Python 2.x binding
17 %bcond_without  tcl             # Tcl binding
18
19 # The goal here is to have main, userspace, package built once with
20 # simple release number, and only rebuild kernel packages with kernel
21 # version as part of release number, without the need to bump release
22 # with every kernel change.
23 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24 %{error:kernel and userspace cannot be built at the same time on PLD builders}
25 exit 1
26 %endif
27
28 %ifnarch %{ix86}
29 %undefine       with_drivers_isa
30 %endif
31 %if %{without python}
32 %undefine       with_python2
33 %endif
34
35 %define         php_name        php%{?php_suffix}
36
37 %define         rel     3
38 %define         pname   linux-gpib
39 Summary:        GPIB (IEEE 488) Linux support
40 Summary(pl.UTF-8):      Obsługa GPIB (IEEE 488) dla Linuksa
41 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
42 Version:        4.3.3
43 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
44 License:        GPL v2+
45 Group:          Applications/System
46 Source0:        http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
47 # Source0-md5:  1243aa44f788cf23f9b40ded54c14685
48 Patch2:         %{pname}-python.patch
49 Patch3:         %{pname}-perl.patch
50 Patch4:         %{pname}-firmwaredir.patch
51 Patch5:         %{pname}-guile2.patch
52 Patch6:         %{pname}-php7.patch
53 Patch8:         kernel-5.2.patch
54 Patch9:         kernel-5.10.patch
55 Patch10:        pkgconfig-version.patch
56 URL:            http://linux-gpib.sourceforge.net/
57 BuildRequires:  autoconf >= 2.50
58 BuildRequires:  automake
59 BuildRequires:  libtool
60 BuildRequires:  rpmbuild(macros) >= 1.745
61 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.32}}
62 %if %{with userspace}
63 BuildRequires:  bison
64 %{?with_doc:BuildRequires:      docbook-utils}
65 BuildRequires:  flex
66 %{?with_guile:BuildRequires:    guile-devel >= 1.4}
67 %{?with_perl:BuildRequires:     perl-devel}
68 %{?with_php:BuildRequires:      %{php_name}-devel >= 3:5}
69 %{?with_python:BuildRequires:   python-devel >= 2}
70 BuildRequires:  readline-devel
71 %{?with_tcl:BuildRequires:      tcl-devel}
72 %endif
73 Requires:       %{pname}-libs = %{version}-%{release}
74 # for agilent_82357a and ni_usb_gpib
75 Suggests:       fxload
76 # for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
77 Suggests:       linux-gpib-firmware
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
82
83 %description -l pl.UTF-8
84 Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
85
86 %package hotplug
87 Summary:        Linux GPIB support for legacy USB hotplug
88 Summary(pl.UTF-8):      Obsługa Linux GPIB dla starego systemu hotplug USB
89 Group:          Applications/System
90 Requires:       %{pname} = %{version}-%{release}
91 Requires:       hotplug
92
93 %description hotplug
94 Linux GPIB support for legacy USB hotplug.
95
96 %description hotplug -l pl.UTF-8
97 Obsługa Linux GPIB dla starego systemu hotplug USB.
98
99 %package libs
100 Summary:        Shared GPIB library
101 Summary(pl.UTF-8):      Biblioteka współdzielona GPIB
102 Group:          Libraries
103
104 %description libs
105 Shared GPIB library.
106
107 %description libs -l pl.UTF-8
108 Biblioteka współdzielona GPIB.
109
110 %package devel
111 Summary:        Header file for GPIB library
112 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki GPIB
113 Group:          Development/Libraries
114 Requires:       %{pname}-libs = %{version}-%{release}
115
116 %description devel
117 Header file for GPIB library.
118
119 %description devel -l pl.UTF-8
120 Plik nagłówkowy biblioteki GPIB.
121
122 %package static
123 Summary:        Static GPIB library
124 Summary(pl.UTF-8):      Biblioteka statyczna GPIB
125 Group:          Development/Libraries
126 Requires:       %{pname}-devel = %{version}-%{release}
127
128 %description static
129 Static GPIB library.
130
131 %description static -l pl.UTF-8
132 Biblioteka statyczna GPIB.
133
134 %package -n guile-gpib
135 Summary:        Guile bindings for GPIB library
136 Summary(pl.UTF-8):      Wiązania Guile do biblioteki GPIB
137 Group:          Development/Languages/Perl
138 Requires:       %{pname}-libs = %{version}-%{release}
139 Requires:       guile-libs
140
141 %description -n guile-gpib
142 Guile bindings for GPIB library.
143
144 %description -n guile-gpib -l pl.UTF-8
145 Wiązania Guile do biblioteki GPIB.
146
147 %package -n perl-gpib
148 Summary:        Perl bindings for GPIB library
149 Summary(pl.UTF-8):      Wiązania Perla do biblioteki GPIB
150 Group:          Development/Languages/Perl
151 Requires:       %{pname}-libs = %{version}-%{release}
152
153 %description -n perl-gpib
154 Perl bindings for GPIB library.
155
156 %description -n perl-gpib -l pl.UTF-8
157 Wiązania Perla do biblioteki GPIB.
158
159 %package -n %{php_name}-gpib
160 Summary:        PHP bindings for GPIB library
161 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GPIB
162 Group:          Development/Languages/PHP
163 Provides:       php(gpib) = %{version}
164 Requires:       %{pname}-libs = %{version}-%{release}
165 %{?requires_php_extension}
166
167 %description -n %{php_name}-gpib
168 PHP bindings for GPIB library.
169
170 %description -n %{php_name}-gpib -l pl.UTF-8
171 Wiązania PHP do biblioteki GPIB.
172
173 %package -n python-gpib
174 Summary:        Python 2 bindings for GPIB library
175 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki GPIB
176 Group:          Libraries/Python
177 Requires:       %{pname}-libs = %{version}-%{release}
178 Requires:       python-libs
179
180 %description -n python-gpib
181 Python 2 bindings for GPIB library.
182
183 %description -n python-gpib -l pl.UTF-8
184 Wiązania Pythona 2 do biblioteki GPIB.
185
186 %package -n python3-gpib
187 Summary:        Python 3 bindings for GPIB library
188 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki GPIB
189 Group:          Libraries/Python
190 Requires:       %{pname}-libs = %{version}-%{release}
191 Requires:       python3-libs
192
193 %description -n python3-gpib
194 Python 3 bindings for GPIB library.
195
196 %description -n python3-gpib -l pl.UTF-8
197 Wiązania Pythona 3 do biblioteki GPIB.
198
199 %package -n tcl-gpib
200 Summary:        Tcl bindings for GPIB library
201 Summary(pl.UTF-8):      Wiązania Tcl-a do biblioteki GPIB
202 Group:          Libraries
203 Requires:       %{pname}-libs = %{version}-%{release}
204 Requires:       tcl
205
206 %description -n tcl-gpib
207 Tcl bindings for GPIB library.
208
209 %description -n tcl-gpib -l pl.UTF-8
210 Wiązania Tcl-a do biblioteki GPIB.
211
212 %package doc
213 Summary:        Linux-GPIB tools and library documentation
214 Summary(pl.UTF-8):      Dokumentacja narzędzi i biblioteki Linux-GPIB
215 License:        GFDL v1.2+ or GPL v2+
216 Group:          Documentation
217
218 %description doc
219 Linux-GPIB tools and library documentation.
220
221 %description doc -l pl.UTF-8
222 Dokumentacja narzędzi i biblioteki Linux-GPIB.
223
224 %define kernel_pkg()\
225 %package -n kernel%{_alt_kernel}-gpib\
226 Summary:        Linux GPIB drivers\
227 Summary(pl.UTF-8):      Sterowniki GPIB dla Linuksa\
228 Release:        %{rel}@%{_kernel_ver_str}\
229 Group:          Base/Kernel\
230 Requires(post,postun):  /sbin/depmod\
231 %requires_releq_kernel\
232 Requires(postun):       %releq_kernel\
233 \
234 %description -n kernel%{_alt_kernel}-gpib\
235 This package contains Linux drivers for GPIB (IEEE 488) hardware.\
236 \
237 %description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
238 Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
239 \
240 %if %{with kernel}\
241 %files -n kernel%{_alt_kernel}-gpib\
242 %defattr(644,root,root,755)\
243 /lib/modules/%{_kernel_ver}/kernel/gpib\
244 %endif\
245 \
246 %post -n kernel%{_alt_kernel}-gpib\
247 %depmod %{_kernel_ver}\
248 \
249 %postun -n kernel%{_alt_kernel}-gpib\
250 %depmod %{_kernel_ver}\
251 %{nil}
252
253 %define build_kernel_pkg()\
254 %{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
255 cd drivers/gpib\
256 %if %{_kernel_version_code} < %{_kernel_version_magic 5 10 0}\
257 %if %{with drivers_usb}\
258 %install_kernel_modules -D installed -m lpvo_usb_gpib/lpvo_usb_gpib -d kernel/gpib\
259 %endif\
260 %endif\
261 %ifarch %{ix86}\
262 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
263 %else\
264 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
265 %endif\
266 cd ../..\
267 %{nil}
268
269 %define install_kernel_pkg()\
270 %{nil}
271
272 %{?with_kernel:%{expand:%create_kernel_packages}}
273
274 %prep
275 %setup -q -n %{pname}-%{version}
276 %if %{with userspace}
277 tar xzf linux-gpib-user-%{version}.tar.gz
278 cd linux-gpib-user-%{version}
279 %patch2 -p1
280 %patch3 -p1
281 %patch4 -p1
282 %patch5 -p1
283 #%patch6 -p1
284 %patch10 -p1
285 cd ..
286 %endif
287
288 %if %{with kernel}
289 tar xzf linux-gpib-kernel-%{version}.tar.gz
290 cd linux-gpib-kernel-%{version}
291 %patch9 -p1
292 %ifarch %{ix86}
293 %patch8 -p1
294 %endif
295 %endif
296
297 %build
298 %if %{with userspace}
299 cd linux-gpib-user-%{version}
300 %{__libtoolize}
301 %{__aclocal}
302 %{__autoconf}
303 %{__autoheader}
304 %{__automake}
305 %if %{with guile}
306 CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
307 %endif
308 %configure \
309         --with-udev-libdir=/lib/udev \
310         %{!?with_doc:--disable-documentation} \
311         %{!?with_guile:--disable-guile-binding} \
312         %{!?with_perl:--disable-perl-binding} \
313         %{!?with_php:--disable-php-binding} \
314         %{!?with_python:--disable-python-binding} \
315         %{?with_static_libs:--enable-static} \
316         %{!?with_tcl:--disable-tcl-binding}
317
318 %{__make}
319
320 %if %{with python2}
321 cd language/python
322 %py_build
323 cd ../..
324 %endif
325 cd ..
326 %endif
327
328 %if %{with kernel}
329 cd linux-gpib-kernel-%{version}
330 %{expand:%build_kernel_packages}
331 %endif
332
333 %install
334 rm -rf $RPM_BUILD_ROOT
335 install -d $RPM_BUILD_ROOT%{_examplesdir}
336
337 %if %{with kernel}
338 cd linux-gpib-kernel-%{version}
339 %{expand:%install_kernel_packages}
340 cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
341 cd ..
342 %endif
343
344 %if %{with userspace}
345 cd linux-gpib-user-%{version}
346 %{__make} install \
347         DESTDIR=$RPM_BUILD_ROOT \
348         HOTPLUG_USB_CONF_DIR=/lib/udev \
349         UDEV_RULES_DIR=/lib/udev/rules.d \
350         USB_FIRMWARE_DIR=/lib/firmware
351
352 %if %{with python2}
353 cd language/python
354 %py_install
355 cd ../..
356 %endif
357
358 %if %{with hotplug}
359 # use udev paths as base and legacy hotplug as addon (not the opposite)
360 install -d $RPM_BUILD_ROOT/etc/hotplug/usb
361 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
362 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
363 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
364 %endif
365
366 # obsoleted by pkg-config
367 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
368
369 %if %{with guile}
370 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
371 %if %{with static_libs}
372 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
373 %endif
374 %endif
375
376 %if %{with perl}
377 %{__make} -C language/perl pure_install \
378         DESTDIR=$RPM_BUILD_ROOT
379
380 cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
381
382 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
383 %endif
384
385 %if %{with php}
386 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
387 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
388 ; Enable gpib extension module
389 extension=gpib_php.so
390 EOF
391
392 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
393 %if %{with static_libs}
394 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
395 %endif
396 %endif
397
398 %if %{with python}
399 %py_postclean
400 %endif
401
402 %if %{with tcl}
403 cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
404
405 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
406 %if %{with static_libs}
407 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
408 %endif
409 %endif
410
411 %if %{with doc}
412 # packaged as %doc
413 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
414 %endif
415 %endif
416
417 %clean
418 rm -rf $RPM_BUILD_ROOT
419
420 %post   libs -p /sbin/ldconfig
421 %postun libs -p /sbin/ldconfig
422
423 %post   -n guile-gpib -p /sbin/ldconfig
424 %postun -n guile-gpib -p /sbin/ldconfig
425
426 %post   -n tcl-gpib -p /sbin/ldconfig
427 %postun -n tcl-gpib -p /sbin/ldconfig
428
429 %post   -n %{php_name}-gpib
430 %php_webserver_restart
431
432 %postun -n %{php_name}-gpib
433 if [ "$1" = 0 ]; then
434         %php_webserver_restart
435 fi
436
437 %if %{with userspace}
438 %files
439 %defattr(644,root,root,755)
440 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
441 %attr(755,root,root) %{_bindir}/ibterm
442 %attr(755,root,root) %{_bindir}/ibtest
443 %attr(755,root,root) %{_sbindir}/gpib_config
444 /lib/udev/rules.d/98-gpib-generic.rules
445 /lib/udev/rules.d/99-agilent_82357a.rules
446 /lib/udev/rules.d/99-ni_usb_gpib.rules
447 %attr(755,root,root) /lib/udev/gpib_udev_config
448 %attr(755,root,root) /lib/udev/gpib_udev_fxloader
449 %attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
450
451 %if %{with hotplug}
452 %files hotplug
453 %defattr(644,root,root,755)
454 %attr(755,root,root) /etc/hotplug/usb/agilent_82357a
455 %attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
456 /etc/hotplug/usb/agilent_82357a.usermap
457 /etc/hotplug/usb/ni_usb_gpib.usermap
458 %endif
459
460 %files libs
461 %defattr(644,root,root,755)
462 %doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
463 %attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
464 %attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
465
466 %files devel
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_libdir}/libgpib.so
469 %{_includedir}/gpib
470 %{_pkgconfigdir}/libgpib.pc
471
472 %if %{with static_libs}
473 %files static
474 %defattr(644,root,root,755)
475 %{_libdir}/libgpib.a
476 %endif
477
478 %if %{with guile}
479 %files -n guile-gpib
480 %defattr(644,root,root,755)
481 %attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
482 %attr(755,root,root) %{_libdir}/libgpib-guile.so
483 %endif
484
485 %if %{with perl}
486 %files -n perl-gpib
487 %defattr(644,root,root,755)
488 %doc linux-gpib-user-%{version}/language/perl/{Changes,README}
489 %{perl_vendorarch}/LinuxGpib.pm
490 %dir %{perl_vendorarch}/auto/LinuxGpib
491 %attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
492 %{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
493 %{_mandir}/man3/LinuxGpib.3pm*
494 %{_examplesdir}/perl-gpib-%{version}
495 %endif
496
497 %if %{with php}
498 %files -n %{php_name}-gpib
499 %defattr(644,root,root,755)
500 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
501 %attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
502 %attr(755,root,root) %{php_extensiondir}/gpib_php.so
503 %endif
504
505 %if %{with python2}
506 %files -n python-gpib
507 %defattr(644,root,root,755)
508 %doc linux-gpib-user-%{version}/language/python/README
509 %attr(755,root,root) %{py_sitedir}/gpib.so
510 %{py_sitedir}/Gpib.py[co]
511 %{py_sitedir}/gpib-1.0-py*.egg-info
512 %endif
513
514 %if %{with python}
515 %files -n python3-gpib
516 %defattr(644,root,root,755)
517 %doc linux-gpib-user-%{version}/language/python/README
518 %attr(755,root,root) %{py3_sitedir}/gpib.cpython-*.so
519 %{py3_sitedir}/Gpib.py
520 %{py3_sitedir}/__pycache__/Gpib.cpython-*.py[co]
521 %{py3_sitedir}/gpib-1.0-py*.egg-info
522 %endif
523
524 %if %{with tcl}
525 %files -n tcl-gpib
526 %defattr(644,root,root,755)
527 %doc linux-gpib-user-%{version}/language/tcl/README
528 %attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
529 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
530 %{_examplesdir}/tcl-gpib-%{version}
531 %endif
532
533 %if %{with doc}
534 %files doc
535 %defattr(644,root,root,755)
536 %doc linux-gpib-user-%{version}/doc/doc_html/*
537 %endif
538 %endif
This page took 0.102393 seconds and 3 git commands to generate.