]> git.pld-linux.org Git - packages/linux-gpib.git/blame - linux-gpib.spec
- fix patch depth
[packages/linux-gpib.git] / linux-gpib.spec
CommitLineData
d4054fe9 1#
d4054fe9 2# Conditional build:
2ee896be 3%bcond_without kernel # kernel modules
d5b04c61 4%bcond_without drivers_isa # ISA kernel drivers [ix86 only]
25beb8e8 5%bcond_without drivers_usb # USB kernel drivers
2ee896be
JB
6%bcond_without userspace # userspace packages
7%bcond_without verbose # verbose modules build (V=1)
df990a65 8
635db00a 9%bcond_without doc # documentation build
08f3bc97 10%bcond_with hotplug # legacy hotplug support
2ee896be 11%bcond_without static_libs # static library
91dbb874 12%bcond_without guile # guile binding
2ee896be 13%bcond_without perl # Perl binding
b3693ec1 14%bcond_with php # PHP binding
fb21f50f
JB
15%bcond_without python # Python (any) binding
16%bcond_without python2 # Python 2.x binding
2ee896be 17%bcond_without tcl # Tcl binding
df990a65 18
4c4f156c
JR
19# The goal here is to have main, userspace, package built once with
20# simple release number, and only rebuild kernel packages with kernel
21# version as part of release number, without the need to bump release
22# with every kernel change.
23%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24%{error:kernel and userspace cannot be built at the same time on PLD builders}
25exit 1
26%endif
27
eda43fa2
JR
28%if %{without userspace}
29# nothing to be placed to debuginfo package
30%define _enable_debug_packages 0
31%endif
32
25beb8e8
JB
33%ifnarch %{ix86}
34%undefine with_drivers_isa
fb21f50f
JB
35%endif
36%if %{without python}
37%undefine with_python2
25beb8e8 38%endif
4c4f156c 39
76a67c9a 40%define php_name php%{?php_suffix}
4c4f156c 41
77eee7b9 42%define rel 2
4c4f156c 43%define pname linux-gpib
2ee896be
JB
44Summary: GPIB (IEEE 488) Linux support
45Summary(pl.UTF-8): Obsługa GPIB (IEEE 488) dla Linuksa
4c4f156c 46Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
6ecb5cd3 47Version: 4.3.6
2d0c8827 48Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
2ee896be 49License: GPL v2+
cc64c2aa 50Group: Applications/System
996e3d04 51Source0: http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
6ecb5cd3 52# Source0-md5: ffefc4e5c03b891c57f406a4b82395b7
4c4f156c
JR
53Patch2: %{pname}-python.patch
54Patch3: %{pname}-perl.patch
55Patch4: %{pname}-firmwaredir.patch
56Patch5: %{pname}-guile2.patch
57Patch6: %{pname}-php7.patch
82a3ed18 58Patch8: kernel-5.2.patch
403be2a0 59Patch9: kernel-5.10.patch
659cb172 60Patch10: pkgconfig-version.patch
346fe22b 61Patch11: linux-gpib-guile3.patch
d5b04c61 62Patch12: isa-dma.patch
d4054fe9 63URL: http://linux-gpib.sourceforge.net/
2ee896be
JB
64BuildRequires: autoconf >= 2.50
65BuildRequires: automake
66BuildRequires: libtool
fb21f50f 67BuildRequires: rpmbuild(macros) >= 1.745
0a86a1d5 68%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.32}}
2ee896be
JB
69%if %{with userspace}
70BuildRequires: bison
635db00a 71%{?with_doc:BuildRequires: docbook-utils}
2ee896be 72BuildRequires: flex
91dbb874 73%{?with_guile:BuildRequires: guile-devel >= 1.4}
df990a65 74%{?with_perl:BuildRequires: perl-devel}
76a67c9a 75%{?with_php:BuildRequires: %{php_name}-devel >= 3:5}
2ee896be
JB
76%{?with_python:BuildRequires: python-devel >= 2}
77BuildRequires: readline-devel
df990a65 78%{?with_tcl:BuildRequires: tcl-devel}
2ee896be 79%endif
4c4f156c 80Requires: %{pname}-libs = %{version}-%{release}
4ffc9310
JB
81# for agilent_82357a and ni_usb_gpib
82Suggests: fxload
83# for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
84Suggests: linux-gpib-firmware
d4054fe9 85BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87%description
cc64c2aa 88The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
d4054fe9 89
bc9733fa
JR
90%description -l pl.UTF-8
91Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
d4054fe9 92
08f3bc97
JB
93%package hotplug
94Summary: Linux GPIB support for legacy USB hotplug
95Summary(pl.UTF-8): Obsługa Linux GPIB dla starego systemu hotplug USB
96Group: Applications/System
4c4f156c 97Requires: %{pname} = %{version}-%{release}
08f3bc97
JB
98Requires: hotplug
99
100%description hotplug
101Linux GPIB support for legacy USB hotplug.
102
103%description hotplug -l pl.UTF-8
104Obsługa Linux GPIB dla starego systemu hotplug USB.
105
2ee896be
JB
106%package libs
107Summary: Shared GPIB library
108Summary(pl.UTF-8): Biblioteka współdzielona GPIB
109Group: Libraries
d7b3679a 110
2ee896be
JB
111%description libs
112Shared GPIB library.
113
114%description libs -l pl.UTF-8
115Biblioteka współdzielona GPIB.
116
117%package devel
118Summary: Header file for GPIB library
119Summary(pl.UTF-8): Plik nagłówkowy biblioteki GPIB
120Group: Development/Libraries
4c4f156c 121Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
122
123%description devel
124Header file for GPIB library.
125
126%description devel -l pl.UTF-8
127Plik nagłówkowy biblioteki GPIB.
128
129%package static
130Summary: Static GPIB library
131Summary(pl.UTF-8): Biblioteka statyczna GPIB
132Group: Development/Libraries
4c4f156c 133Requires: %{pname}-devel = %{version}-%{release}
2ee896be
JB
134
135%description static
136Static GPIB library.
137
138%description static -l pl.UTF-8
139Biblioteka statyczna GPIB.
140
91dbb874
JB
141%package -n guile-gpib
142Summary: Guile bindings for GPIB library
143Summary(pl.UTF-8): Wiązania Guile do biblioteki GPIB
144Group: Development/Languages/Perl
4c4f156c 145Requires: %{pname}-libs = %{version}-%{release}
91dbb874
JB
146Requires: guile-libs
147
148%description -n guile-gpib
149Guile bindings for GPIB library.
150
151%description -n guile-gpib -l pl.UTF-8
152Wiązania Guile do biblioteki GPIB.
153
2ee896be
JB
154%package -n perl-gpib
155Summary: Perl bindings for GPIB library
156Summary(pl.UTF-8): Wiązania Perla do biblioteki GPIB
157Group: Development/Languages/Perl
4c4f156c 158Requires: %{pname}-libs = %{version}-%{release}
d7b3679a 159
2ee896be
JB
160%description -n perl-gpib
161Perl bindings for GPIB library.
d7b3679a 162
2ee896be
JB
163%description -n perl-gpib -l pl.UTF-8
164Wiązania Perla do biblioteki GPIB.
d7b3679a 165
76a67c9a
JB
166%package -n %{php_name}-gpib
167Summary: PHP bindings for GPIB library
168Summary(pl.UTF-8): Wiązania PHP do biblioteki GPIB
169Group: Development/Languages/PHP
170Provides: php(gpib) = %{version}
4c4f156c 171Requires: %{pname}-libs = %{version}-%{release}
76a67c9a
JB
172%{?requires_php_extension}
173
174%description -n %{php_name}-gpib
175PHP bindings for GPIB library.
176
177%description -n %{php_name}-gpib -l pl.UTF-8
178Wiązania PHP do biblioteki GPIB.
179
2ee896be 180%package -n python-gpib
fb21f50f
JB
181Summary: Python 2 bindings for GPIB library
182Summary(pl.UTF-8): Wiązania Pythona 2 do biblioteki GPIB
2ee896be 183Group: Libraries/Python
4c4f156c 184Requires: %{pname}-libs = %{version}-%{release}
2ee896be 185Requires: python-libs
d7b3679a 186
2ee896be 187%description -n python-gpib
fb21f50f 188Python 2 bindings for GPIB library.
2ee896be
JB
189
190%description -n python-gpib -l pl.UTF-8
fb21f50f
JB
191Wiązania Pythona 2 do biblioteki GPIB.
192
193%package -n python3-gpib
194Summary: Python 3 bindings for GPIB library
195Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki GPIB
196Group: Libraries/Python
197Requires: %{pname}-libs = %{version}-%{release}
198Requires: python3-libs
199
200%description -n python3-gpib
201Python 3 bindings for GPIB library.
202
203%description -n python3-gpib -l pl.UTF-8
204Wiązania Pythona 3 do biblioteki GPIB.
2ee896be
JB
205
206%package -n tcl-gpib
207Summary: Tcl bindings for GPIB library
208Summary(pl.UTF-8): Wiązania Tcl-a do biblioteki GPIB
209Group: Libraries
4c4f156c 210Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
211Requires: tcl
212
213%description -n tcl-gpib
214Tcl bindings for GPIB library.
215
216%description -n tcl-gpib -l pl.UTF-8
217Wiązania Tcl-a do biblioteki GPIB.
218
219%package doc
220Summary: Linux-GPIB tools and library documentation
221Summary(pl.UTF-8): Dokumentacja narzędzi i biblioteki Linux-GPIB
222License: GFDL v1.2+ or GPL v2+
223Group: Documentation
224
225%description doc
226Linux-GPIB tools and library documentation.
227
228%description doc -l pl.UTF-8
229Dokumentacja narzędzi i biblioteki Linux-GPIB.
230
231%define kernel_pkg()\
232%package -n kernel%{_alt_kernel}-gpib\
233Summary: Linux GPIB drivers\
234Summary(pl.UTF-8): Sterowniki GPIB dla Linuksa\
235Release: %{rel}@%{_kernel_ver_str}\
236Group: Base/Kernel\
237Requires(post,postun): /sbin/depmod\
238%requires_releq_kernel\
239Requires(postun): %releq_kernel\
240\
241%description -n kernel%{_alt_kernel}-gpib\
242This package contains Linux drivers for GPIB (IEEE 488) hardware.\
243\
244%description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
245Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
246\
247%if %{with kernel}\
248%files -n kernel%{_alt_kernel}-gpib\
249%defattr(644,root,root,755)\
250/lib/modules/%{_kernel_ver}/kernel/gpib\
251%endif\
252\
253%post -n kernel%{_alt_kernel}-gpib\
254%depmod %{_kernel_ver}\
255\
256%postun -n kernel%{_alt_kernel}-gpib\
257%depmod %{_kernel_ver}\
258%{nil}
259
260%define build_kernel_pkg()\
13cab497 261%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir} clean\
d5b04c61 262%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
2ee896be 263cd drivers/gpib\
403be2a0
JR
264%if %{_kernel_version_code} < %{_kernel_version_magic 5 10 0}\
265%if %{with drivers_usb}\
266%install_kernel_modules -D installed -m lpvo_usb_gpib/lpvo_usb_gpib -d kernel/gpib\
267%endif\
268%endif\
82a3ed18 269%ifarch %{ix86}\
403be2a0 270%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 271%else\
403be2a0 272%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 273%endif\
b69cc3e0 274cd ../..\
2ee896be
JB
275%{nil}
276
277%define install_kernel_pkg()\
278%{nil}
279
280%{?with_kernel:%{expand:%create_kernel_packages}}
d7b3679a 281
d4054fe9 282%prep
996e3d04 283%setup -q -n %{pname}-%{version}
16f00101
JR
284%if %{with userspace}
285tar xzf linux-gpib-user-%{version}.tar.gz
286cd linux-gpib-user-%{version}
2ee896be
JB
287%patch2 -p1
288%patch3 -p1
08f3bc97 289%patch4 -p1
91dbb874 290%patch5 -p1
16f00101 291#%patch6 -p1
659cb172 292%patch10 -p1
346fe22b 293%patch11 -p1
16f00101
JR
294cd ..
295%endif
296
297%if %{with kernel}
298tar xzf linux-gpib-kernel-%{version}.tar.gz
299cd linux-gpib-kernel-%{version}
41ab8c5b 300%patch9 -p1
5e300ced
JR
301%ifarch %{ix86}
302%patch8 -p1
303%endif
d5b04c61 304%patch12 -p1
16f00101 305%endif
d7b3679a 306
d4054fe9 307%build
16f00101
JR
308%if %{with userspace}
309cd linux-gpib-user-%{version}
302b72f6
JR
310%{__libtoolize}
311%{__aclocal}
312%{__autoconf}
313%{__autoheader}
314%{__automake}
91dbb874 315%if %{with guile}
346fe22b 316CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/3.0"
91dbb874 317%endif
d7b3679a 318%configure \
55cbc6e3 319 --with-udev-libdir=/lib/udev \
635db00a 320 %{!?with_doc:--disable-documentation} \
2ee896be
JB
321 %{!?with_guile:--disable-guile-binding} \
322 %{!?with_perl:--disable-perl-binding} \
323 %{!?with_php:--disable-php-binding} \
324 %{!?with_python:--disable-python-binding} \
325 %{?with_static_libs:--enable-static} \
16f00101 326 %{!?with_tcl:--disable-tcl-binding}
d7b3679a 327
9e3b7024 328%{__make}
fb21f50f
JB
329
330%if %{with python2}
331cd language/python
332%py_build
333cd ../..
334%endif
16f00101 335cd ..
2ee896be 336%endif
d7b3679a 337
2ee896be 338%if %{with kernel}
16f00101 339cd linux-gpib-kernel-%{version}
2ee896be
JB
340%{expand:%build_kernel_packages}
341%endif
d4054fe9 342
343%install
344rm -rf $RPM_BUILD_ROOT
2ee896be 345install -d $RPM_BUILD_ROOT%{_examplesdir}
d4054fe9 346
8eefbf3b 347%if %{with kernel}
16f00101 348cd linux-gpib-kernel-%{version}
2ee896be
JB
349%{expand:%install_kernel_packages}
350cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
302b72f6 351cd ..
8eefbf3b
MWP
352%endif
353
d4054fe9 354%if %{with userspace}
302b72f6
JR
355cd linux-gpib-user-%{version}
356%{__make} install \
08f3bc97
JB
357 DESTDIR=$RPM_BUILD_ROOT \
358 HOTPLUG_USB_CONF_DIR=/lib/udev \
359 UDEV_RULES_DIR=/lib/udev/rules.d \
360 USB_FIRMWARE_DIR=/lib/firmware
25beb8e8 361
fb21f50f
JB
362%if %{with python2}
363cd language/python
364%py_install
365cd ../..
366%endif
367
25beb8e8 368%if %{with hotplug}
08f3bc97
JB
369# use udev paths as base and legacy hotplug as addon (not the opposite)
370install -d $RPM_BUILD_ROOT/etc/hotplug/usb
371%{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
372ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
373ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
25beb8e8 374%endif
2ee896be
JB
375
376# obsoleted by pkg-config
377%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
378
91dbb874
JB
379%if %{with guile}
380%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
381%if %{with static_libs}
382%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
383%endif
384%endif
385
2ee896be
JB
386%if %{with perl}
387%{__make} -C language/perl pure_install \
388 DESTDIR=$RPM_BUILD_ROOT
76a67c9a 389
2ee896be 390cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
76a67c9a 391
2ee896be
JB
392%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
393%endif
394
76a67c9a
JB
395%if %{with php}
396install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
397cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
398; Enable gpib extension module
399extension=gpib_php.so
400EOF
401
402%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
403%if %{with static_libs}
404%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
405%endif
406%endif
407
2ee896be
JB
408%if %{with python}
409%py_postclean
410%endif
411
412%if %{with tcl}
413cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
76a67c9a 414
2ee896be
JB
415%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
416%if %{with static_libs}
417%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
418%endif
419%endif
420
635db00a 421%if %{with doc}
2ee896be 422# packaged as %doc
302b72f6 423%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
d4054fe9 424%endif
82a3ed18 425%endif
d4054fe9 426
d4054fe9 427%clean
428rm -rf $RPM_BUILD_ROOT
429
2ee896be
JB
430%post libs -p /sbin/ldconfig
431%postun libs -p /sbin/ldconfig
d4054fe9 432
91dbb874
JB
433%post -n guile-gpib -p /sbin/ldconfig
434%postun -n guile-gpib -p /sbin/ldconfig
435
436%post -n tcl-gpib -p /sbin/ldconfig
437%postun -n tcl-gpib -p /sbin/ldconfig
438
76a67c9a
JB
439%post -n %{php_name}-gpib
440%php_webserver_restart
441
442%postun -n %{php_name}-gpib
443if [ "$1" = 0 ]; then
444 %php_webserver_restart
445fi
446
2ee896be
JB
447%if %{with userspace}
448%files
449%defattr(644,root,root,755)
302b72f6 450%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
2ee896be
JB
451%attr(755,root,root) %{_bindir}/ibterm
452%attr(755,root,root) %{_bindir}/ibtest
00074c36 453%attr(755,root,root) %{_bindir}/findlisteners
2ee896be 454%attr(755,root,root) %{_sbindir}/gpib_config
55cbc6e3 455/lib/udev/rules.d/98-gpib-generic.rules
08f3bc97 456/lib/udev/rules.d/99-agilent_82357a.rules
00074c36 457/lib/udev/rules.d/99-lpvo_usb_gpib.rules
08f3bc97 458/lib/udev/rules.d/99-ni_usb_gpib.rules
55cbc6e3
JR
459%attr(755,root,root) /lib/udev/gpib_udev_config
460%attr(755,root,root) /lib/udev/gpib_udev_fxloader
461%attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
08f3bc97
JB
462
463%if %{with hotplug}
464%files hotplug
465%defattr(644,root,root,755)
2ee896be
JB
466%attr(755,root,root) /etc/hotplug/usb/agilent_82357a
467%attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
468/etc/hotplug/usb/agilent_82357a.usermap
469/etc/hotplug/usb/ni_usb_gpib.usermap
08f3bc97 470%endif
d4054fe9 471
2ee896be 472%files libs
0e4898e2 473%defattr(644,root,root,755)
302b72f6 474%doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
2ee896be
JB
475%attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
476%attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
477
478%files devel
479%defattr(644,root,root,755)
480%attr(755,root,root) %{_libdir}/libgpib.so
481%{_includedir}/gpib
482%{_pkgconfigdir}/libgpib.pc
483
484%if %{with static_libs}
485%files static
486%defattr(644,root,root,755)
487%{_libdir}/libgpib.a
488%endif
489
91dbb874
JB
490%if %{with guile}
491%files -n guile-gpib
492%defattr(644,root,root,755)
996e3d04 493%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
91dbb874
JB
494%attr(755,root,root) %{_libdir}/libgpib-guile.so
495%endif
496
2ee896be
JB
497%if %{with perl}
498%files -n perl-gpib
499%defattr(644,root,root,755)
302b72f6 500%doc linux-gpib-user-%{version}/language/perl/{Changes,README}
2ee896be
JB
501%{perl_vendorarch}/LinuxGpib.pm
502%dir %{perl_vendorarch}/auto/LinuxGpib
503%attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
504%{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
505%{_mandir}/man3/LinuxGpib.3pm*
506%{_examplesdir}/perl-gpib-%{version}
507%endif
508
76a67c9a
JB
509%if %{with php}
510%files -n %{php_name}-gpib
511%defattr(644,root,root,755)
512%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
996e3d04 513%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
76a67c9a
JB
514%attr(755,root,root) %{php_extensiondir}/gpib_php.so
515%endif
516
fb21f50f 517%if %{with python2}
2ee896be
JB
518%files -n python-gpib
519%defattr(644,root,root,755)
302b72f6 520%doc linux-gpib-user-%{version}/language/python/README
2ee896be
JB
521%attr(755,root,root) %{py_sitedir}/gpib.so
522%{py_sitedir}/Gpib.py[co]
523%{py_sitedir}/gpib-1.0-py*.egg-info
524%endif
525
fb21f50f
JB
526%if %{with python}
527%files -n python3-gpib
528%defattr(644,root,root,755)
529%doc linux-gpib-user-%{version}/language/python/README
530%attr(755,root,root) %{py3_sitedir}/gpib.cpython-*.so
531%{py3_sitedir}/Gpib.py
532%{py3_sitedir}/__pycache__/Gpib.cpython-*.py[co]
533%{py3_sitedir}/gpib-1.0-py*.egg-info
534%endif
535
2ee896be
JB
536%if %{with tcl}
537%files -n tcl-gpib
538%defattr(644,root,root,755)
302b72f6 539%doc linux-gpib-user-%{version}/language/tcl/README
996e3d04 540%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
2ee896be
JB
541%attr(755,root,root) %{_libdir}/libgpib_tcl.so
542%{_examplesdir}/tcl-gpib-%{version}
543%endif
544
635db00a 545%if %{with doc}
2ee896be
JB
546%files doc
547%defattr(644,root,root,755)
302b72f6 548%doc linux-gpib-user-%{version}/doc/doc_html/*
2ee896be 549%endif
1fc85825 550%endif
This page took 0.234537 seconds and 4 git commands to generate.