]> git.pld-linux.org Git - packages/linux-gpib.git/blame - linux-gpib.spec
- release 3 (by relup.sh)
[packages/linux-gpib.git] / linux-gpib.spec
CommitLineData
d4054fe9 1#
d4054fe9 2# Conditional build:
2ee896be 3%bcond_without kernel # kernel modules
25beb8e8 4%bcond_without drivers_isa # ISA kernel drivers [ix86 only]
25beb8e8 5%bcond_without drivers_usb # USB kernel drivers
2ee896be
JB
6%bcond_without userspace # userspace packages
7%bcond_without verbose # verbose modules build (V=1)
df990a65 8
635db00a 9%bcond_without doc # documentation build
08f3bc97 10%bcond_with hotplug # legacy hotplug support
2ee896be 11%bcond_without static_libs # static library
91dbb874 12%bcond_without guile # guile binding
2ee896be 13%bcond_without perl # Perl binding
b3693ec1 14%bcond_with php # PHP binding
fb21f50f
JB
15%bcond_without python # Python (any) binding
16%bcond_without python2 # Python 2.x binding
2ee896be 17%bcond_without tcl # Tcl binding
df990a65 18
4c4f156c
JR
19# The goal here is to have main, userspace, package built once with
20# simple release number, and only rebuild kernel packages with kernel
21# version as part of release number, without the need to bump release
22# with every kernel change.
23%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24%{error:kernel and userspace cannot be built at the same time on PLD builders}
25exit 1
26%endif
27
eda43fa2
JR
28%if %{without userspace}
29# nothing to be placed to debuginfo package
30%define _enable_debug_packages 0
31%endif
32
25beb8e8
JB
33%ifnarch %{ix86}
34%undefine with_drivers_isa
fb21f50f
JB
35%endif
36%if %{without python}
37%undefine with_python2
25beb8e8 38%endif
4c4f156c 39
76a67c9a 40%define php_name php%{?php_suffix}
4c4f156c 41
35c96389 42%define rel 3
4c4f156c 43%define pname linux-gpib
2ee896be
JB
44Summary: GPIB (IEEE 488) Linux support
45Summary(pl.UTF-8): Obsługa GPIB (IEEE 488) dla Linuksa
4c4f156c 46Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
00074c36 47Version: 4.3.4
2d0c8827 48Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
2ee896be 49License: GPL v2+
cc64c2aa 50Group: Applications/System
996e3d04 51Source0: http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
00074c36 52# Source0-md5: d42b04d3b27a601c9b893915d5fded37
4c4f156c
JR
53Patch2: %{pname}-python.patch
54Patch3: %{pname}-perl.patch
55Patch4: %{pname}-firmwaredir.patch
56Patch5: %{pname}-guile2.patch
57Patch6: %{pname}-php7.patch
82a3ed18 58Patch8: kernel-5.2.patch
403be2a0 59Patch9: kernel-5.10.patch
659cb172 60Patch10: pkgconfig-version.patch
d4054fe9 61URL: http://linux-gpib.sourceforge.net/
2ee896be
JB
62BuildRequires: autoconf >= 2.50
63BuildRequires: automake
64BuildRequires: libtool
fb21f50f 65BuildRequires: rpmbuild(macros) >= 1.745
0a86a1d5 66%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.32}}
2ee896be
JB
67%if %{with userspace}
68BuildRequires: bison
635db00a 69%{?with_doc:BuildRequires: docbook-utils}
2ee896be 70BuildRequires: flex
91dbb874 71%{?with_guile:BuildRequires: guile-devel >= 1.4}
df990a65 72%{?with_perl:BuildRequires: perl-devel}
76a67c9a 73%{?with_php:BuildRequires: %{php_name}-devel >= 3:5}
2ee896be
JB
74%{?with_python:BuildRequires: python-devel >= 2}
75BuildRequires: readline-devel
df990a65 76%{?with_tcl:BuildRequires: tcl-devel}
2ee896be 77%endif
4c4f156c 78Requires: %{pname}-libs = %{version}-%{release}
4ffc9310
JB
79# for agilent_82357a and ni_usb_gpib
80Suggests: fxload
81# for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
82Suggests: linux-gpib-firmware
d4054fe9 83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85%description
cc64c2aa 86The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
d4054fe9 87
bc9733fa
JR
88%description -l pl.UTF-8
89Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
d4054fe9 90
08f3bc97
JB
91%package hotplug
92Summary: Linux GPIB support for legacy USB hotplug
93Summary(pl.UTF-8): Obsługa Linux GPIB dla starego systemu hotplug USB
94Group: Applications/System
4c4f156c 95Requires: %{pname} = %{version}-%{release}
08f3bc97
JB
96Requires: hotplug
97
98%description hotplug
99Linux GPIB support for legacy USB hotplug.
100
101%description hotplug -l pl.UTF-8
102Obsługa Linux GPIB dla starego systemu hotplug USB.
103
2ee896be
JB
104%package libs
105Summary: Shared GPIB library
106Summary(pl.UTF-8): Biblioteka współdzielona GPIB
107Group: Libraries
d7b3679a 108
2ee896be
JB
109%description libs
110Shared GPIB library.
111
112%description libs -l pl.UTF-8
113Biblioteka współdzielona GPIB.
114
115%package devel
116Summary: Header file for GPIB library
117Summary(pl.UTF-8): Plik nagłówkowy biblioteki GPIB
118Group: Development/Libraries
4c4f156c 119Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
120
121%description devel
122Header file for GPIB library.
123
124%description devel -l pl.UTF-8
125Plik nagłówkowy biblioteki GPIB.
126
127%package static
128Summary: Static GPIB library
129Summary(pl.UTF-8): Biblioteka statyczna GPIB
130Group: Development/Libraries
4c4f156c 131Requires: %{pname}-devel = %{version}-%{release}
2ee896be
JB
132
133%description static
134Static GPIB library.
135
136%description static -l pl.UTF-8
137Biblioteka statyczna GPIB.
138
91dbb874
JB
139%package -n guile-gpib
140Summary: Guile bindings for GPIB library
141Summary(pl.UTF-8): Wiązania Guile do biblioteki GPIB
142Group: Development/Languages/Perl
4c4f156c 143Requires: %{pname}-libs = %{version}-%{release}
91dbb874
JB
144Requires: guile-libs
145
146%description -n guile-gpib
147Guile bindings for GPIB library.
148
149%description -n guile-gpib -l pl.UTF-8
150Wiązania Guile do biblioteki GPIB.
151
2ee896be
JB
152%package -n perl-gpib
153Summary: Perl bindings for GPIB library
154Summary(pl.UTF-8): Wiązania Perla do biblioteki GPIB
155Group: Development/Languages/Perl
4c4f156c 156Requires: %{pname}-libs = %{version}-%{release}
d7b3679a 157
2ee896be
JB
158%description -n perl-gpib
159Perl bindings for GPIB library.
d7b3679a 160
2ee896be
JB
161%description -n perl-gpib -l pl.UTF-8
162Wiązania Perla do biblioteki GPIB.
d7b3679a 163
76a67c9a
JB
164%package -n %{php_name}-gpib
165Summary: PHP bindings for GPIB library
166Summary(pl.UTF-8): Wiązania PHP do biblioteki GPIB
167Group: Development/Languages/PHP
168Provides: php(gpib) = %{version}
4c4f156c 169Requires: %{pname}-libs = %{version}-%{release}
76a67c9a
JB
170%{?requires_php_extension}
171
172%description -n %{php_name}-gpib
173PHP bindings for GPIB library.
174
175%description -n %{php_name}-gpib -l pl.UTF-8
176Wiązania PHP do biblioteki GPIB.
177
2ee896be 178%package -n python-gpib
fb21f50f
JB
179Summary: Python 2 bindings for GPIB library
180Summary(pl.UTF-8): Wiązania Pythona 2 do biblioteki GPIB
2ee896be 181Group: Libraries/Python
4c4f156c 182Requires: %{pname}-libs = %{version}-%{release}
2ee896be 183Requires: python-libs
d7b3679a 184
2ee896be 185%description -n python-gpib
fb21f50f 186Python 2 bindings for GPIB library.
2ee896be
JB
187
188%description -n python-gpib -l pl.UTF-8
fb21f50f
JB
189Wiązania Pythona 2 do biblioteki GPIB.
190
191%package -n python3-gpib
192Summary: Python 3 bindings for GPIB library
193Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki GPIB
194Group: Libraries/Python
195Requires: %{pname}-libs = %{version}-%{release}
196Requires: python3-libs
197
198%description -n python3-gpib
199Python 3 bindings for GPIB library.
200
201%description -n python3-gpib -l pl.UTF-8
202Wiązania Pythona 3 do biblioteki GPIB.
2ee896be
JB
203
204%package -n tcl-gpib
205Summary: Tcl bindings for GPIB library
206Summary(pl.UTF-8): Wiązania Tcl-a do biblioteki GPIB
207Group: Libraries
4c4f156c 208Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
209Requires: tcl
210
211%description -n tcl-gpib
212Tcl bindings for GPIB library.
213
214%description -n tcl-gpib -l pl.UTF-8
215Wiązania Tcl-a do biblioteki GPIB.
216
217%package doc
218Summary: Linux-GPIB tools and library documentation
219Summary(pl.UTF-8): Dokumentacja narzędzi i biblioteki Linux-GPIB
220License: GFDL v1.2+ or GPL v2+
221Group: Documentation
222
223%description doc
224Linux-GPIB tools and library documentation.
225
226%description doc -l pl.UTF-8
227Dokumentacja narzędzi i biblioteki Linux-GPIB.
228
229%define kernel_pkg()\
230%package -n kernel%{_alt_kernel}-gpib\
231Summary: Linux GPIB drivers\
232Summary(pl.UTF-8): Sterowniki GPIB dla Linuksa\
233Release: %{rel}@%{_kernel_ver_str}\
234Group: Base/Kernel\
235Requires(post,postun): /sbin/depmod\
236%requires_releq_kernel\
237Requires(postun): %releq_kernel\
238\
239%description -n kernel%{_alt_kernel}-gpib\
240This package contains Linux drivers for GPIB (IEEE 488) hardware.\
241\
242%description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
243Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
244\
245%if %{with kernel}\
246%files -n kernel%{_alt_kernel}-gpib\
247%defattr(644,root,root,755)\
248/lib/modules/%{_kernel_ver}/kernel/gpib\
249%endif\
250\
251%post -n kernel%{_alt_kernel}-gpib\
252%depmod %{_kernel_ver}\
253\
254%postun -n kernel%{_alt_kernel}-gpib\
255%depmod %{_kernel_ver}\
256%{nil}
257
258%define build_kernel_pkg()\
13cab497 259%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir} clean\
55cbc6e3 260%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
2ee896be 261cd drivers/gpib\
403be2a0
JR
262%if %{_kernel_version_code} < %{_kernel_version_magic 5 10 0}\
263%if %{with drivers_usb}\
264%install_kernel_modules -D installed -m lpvo_usb_gpib/lpvo_usb_gpib -d kernel/gpib\
265%endif\
266%endif\
82a3ed18 267%ifarch %{ix86}\
403be2a0 268%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 269%else\
403be2a0 270%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 271%endif\
b69cc3e0 272cd ../..\
2ee896be
JB
273%{nil}
274
275%define install_kernel_pkg()\
276%{nil}
277
278%{?with_kernel:%{expand:%create_kernel_packages}}
d7b3679a 279
d4054fe9 280%prep
996e3d04 281%setup -q -n %{pname}-%{version}
16f00101
JR
282%if %{with userspace}
283tar xzf linux-gpib-user-%{version}.tar.gz
284cd linux-gpib-user-%{version}
2ee896be
JB
285%patch2 -p1
286%patch3 -p1
08f3bc97 287%patch4 -p1
91dbb874 288%patch5 -p1
16f00101 289#%patch6 -p1
659cb172 290%patch10 -p1
16f00101
JR
291cd ..
292%endif
293
294%if %{with kernel}
295tar xzf linux-gpib-kernel-%{version}.tar.gz
296cd linux-gpib-kernel-%{version}
41ab8c5b 297%patch9 -p1
5e300ced
JR
298%ifarch %{ix86}
299%patch8 -p1
300%endif
16f00101 301%endif
d7b3679a 302
d4054fe9 303%build
16f00101
JR
304%if %{with userspace}
305cd linux-gpib-user-%{version}
302b72f6
JR
306%{__libtoolize}
307%{__aclocal}
308%{__autoconf}
309%{__autoheader}
310%{__automake}
91dbb874 311%if %{with guile}
d53b2ad5 312CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
91dbb874 313%endif
d7b3679a 314%configure \
55cbc6e3 315 --with-udev-libdir=/lib/udev \
635db00a 316 %{!?with_doc:--disable-documentation} \
2ee896be
JB
317 %{!?with_guile:--disable-guile-binding} \
318 %{!?with_perl:--disable-perl-binding} \
319 %{!?with_php:--disable-php-binding} \
320 %{!?with_python:--disable-python-binding} \
321 %{?with_static_libs:--enable-static} \
16f00101 322 %{!?with_tcl:--disable-tcl-binding}
d7b3679a 323
9e3b7024 324%{__make}
fb21f50f
JB
325
326%if %{with python2}
327cd language/python
328%py_build
329cd ../..
330%endif
16f00101 331cd ..
2ee896be 332%endif
d7b3679a 333
2ee896be 334%if %{with kernel}
16f00101 335cd linux-gpib-kernel-%{version}
2ee896be
JB
336%{expand:%build_kernel_packages}
337%endif
d4054fe9 338
339%install
340rm -rf $RPM_BUILD_ROOT
2ee896be 341install -d $RPM_BUILD_ROOT%{_examplesdir}
d4054fe9 342
8eefbf3b 343%if %{with kernel}
16f00101 344cd linux-gpib-kernel-%{version}
2ee896be
JB
345%{expand:%install_kernel_packages}
346cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
302b72f6 347cd ..
8eefbf3b
MWP
348%endif
349
d4054fe9 350%if %{with userspace}
302b72f6
JR
351cd linux-gpib-user-%{version}
352%{__make} install \
08f3bc97
JB
353 DESTDIR=$RPM_BUILD_ROOT \
354 HOTPLUG_USB_CONF_DIR=/lib/udev \
355 UDEV_RULES_DIR=/lib/udev/rules.d \
356 USB_FIRMWARE_DIR=/lib/firmware
25beb8e8 357
fb21f50f
JB
358%if %{with python2}
359cd language/python
360%py_install
361cd ../..
362%endif
363
25beb8e8 364%if %{with hotplug}
08f3bc97
JB
365# use udev paths as base and legacy hotplug as addon (not the opposite)
366install -d $RPM_BUILD_ROOT/etc/hotplug/usb
367%{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
368ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
369ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
25beb8e8 370%endif
2ee896be
JB
371
372# obsoleted by pkg-config
373%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
374
91dbb874
JB
375%if %{with guile}
376%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
377%if %{with static_libs}
378%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
379%endif
380%endif
381
2ee896be
JB
382%if %{with perl}
383%{__make} -C language/perl pure_install \
384 DESTDIR=$RPM_BUILD_ROOT
76a67c9a 385
2ee896be 386cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
76a67c9a 387
2ee896be
JB
388%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
389%endif
390
76a67c9a
JB
391%if %{with php}
392install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
393cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
394; Enable gpib extension module
395extension=gpib_php.so
396EOF
397
398%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
399%if %{with static_libs}
400%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
401%endif
402%endif
403
2ee896be
JB
404%if %{with python}
405%py_postclean
406%endif
407
408%if %{with tcl}
409cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
76a67c9a 410
2ee896be
JB
411%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
412%if %{with static_libs}
413%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
414%endif
415%endif
416
635db00a 417%if %{with doc}
2ee896be 418# packaged as %doc
302b72f6 419%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
d4054fe9 420%endif
82a3ed18 421%endif
d4054fe9 422
d4054fe9 423%clean
424rm -rf $RPM_BUILD_ROOT
425
2ee896be
JB
426%post libs -p /sbin/ldconfig
427%postun libs -p /sbin/ldconfig
d4054fe9 428
91dbb874
JB
429%post -n guile-gpib -p /sbin/ldconfig
430%postun -n guile-gpib -p /sbin/ldconfig
431
432%post -n tcl-gpib -p /sbin/ldconfig
433%postun -n tcl-gpib -p /sbin/ldconfig
434
76a67c9a
JB
435%post -n %{php_name}-gpib
436%php_webserver_restart
437
438%postun -n %{php_name}-gpib
439if [ "$1" = 0 ]; then
440 %php_webserver_restart
441fi
442
2ee896be
JB
443%if %{with userspace}
444%files
445%defattr(644,root,root,755)
302b72f6 446%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
2ee896be
JB
447%attr(755,root,root) %{_bindir}/ibterm
448%attr(755,root,root) %{_bindir}/ibtest
00074c36 449%attr(755,root,root) %{_bindir}/findlisteners
2ee896be 450%attr(755,root,root) %{_sbindir}/gpib_config
55cbc6e3 451/lib/udev/rules.d/98-gpib-generic.rules
08f3bc97 452/lib/udev/rules.d/99-agilent_82357a.rules
00074c36 453/lib/udev/rules.d/99-lpvo_usb_gpib.rules
08f3bc97 454/lib/udev/rules.d/99-ni_usb_gpib.rules
55cbc6e3
JR
455%attr(755,root,root) /lib/udev/gpib_udev_config
456%attr(755,root,root) /lib/udev/gpib_udev_fxloader
457%attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
08f3bc97
JB
458
459%if %{with hotplug}
460%files hotplug
461%defattr(644,root,root,755)
2ee896be
JB
462%attr(755,root,root) /etc/hotplug/usb/agilent_82357a
463%attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
464/etc/hotplug/usb/agilent_82357a.usermap
465/etc/hotplug/usb/ni_usb_gpib.usermap
08f3bc97 466%endif
d4054fe9 467
2ee896be 468%files libs
0e4898e2 469%defattr(644,root,root,755)
302b72f6 470%doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
2ee896be
JB
471%attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
472%attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
473
474%files devel
475%defattr(644,root,root,755)
476%attr(755,root,root) %{_libdir}/libgpib.so
477%{_includedir}/gpib
478%{_pkgconfigdir}/libgpib.pc
479
480%if %{with static_libs}
481%files static
482%defattr(644,root,root,755)
483%{_libdir}/libgpib.a
484%endif
485
91dbb874
JB
486%if %{with guile}
487%files -n guile-gpib
488%defattr(644,root,root,755)
996e3d04 489%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
91dbb874
JB
490%attr(755,root,root) %{_libdir}/libgpib-guile.so
491%endif
492
2ee896be
JB
493%if %{with perl}
494%files -n perl-gpib
495%defattr(644,root,root,755)
302b72f6 496%doc linux-gpib-user-%{version}/language/perl/{Changes,README}
2ee896be
JB
497%{perl_vendorarch}/LinuxGpib.pm
498%dir %{perl_vendorarch}/auto/LinuxGpib
499%attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
500%{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
501%{_mandir}/man3/LinuxGpib.3pm*
502%{_examplesdir}/perl-gpib-%{version}
503%endif
504
76a67c9a
JB
505%if %{with php}
506%files -n %{php_name}-gpib
507%defattr(644,root,root,755)
508%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
996e3d04 509%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
76a67c9a
JB
510%attr(755,root,root) %{php_extensiondir}/gpib_php.so
511%endif
512
fb21f50f 513%if %{with python2}
2ee896be
JB
514%files -n python-gpib
515%defattr(644,root,root,755)
302b72f6 516%doc linux-gpib-user-%{version}/language/python/README
2ee896be
JB
517%attr(755,root,root) %{py_sitedir}/gpib.so
518%{py_sitedir}/Gpib.py[co]
519%{py_sitedir}/gpib-1.0-py*.egg-info
520%endif
521
fb21f50f
JB
522%if %{with python}
523%files -n python3-gpib
524%defattr(644,root,root,755)
525%doc linux-gpib-user-%{version}/language/python/README
526%attr(755,root,root) %{py3_sitedir}/gpib.cpython-*.so
527%{py3_sitedir}/Gpib.py
528%{py3_sitedir}/__pycache__/Gpib.cpython-*.py[co]
529%{py3_sitedir}/gpib-1.0-py*.egg-info
530%endif
531
2ee896be
JB
532%if %{with tcl}
533%files -n tcl-gpib
534%defattr(644,root,root,755)
302b72f6 535%doc linux-gpib-user-%{version}/language/tcl/README
996e3d04 536%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
2ee896be
JB
537%attr(755,root,root) %{_libdir}/libgpib_tcl.so
538%{_examplesdir}/tcl-gpib-%{version}
539%endif
540
635db00a 541%if %{with doc}
2ee896be
JB
542%files doc
543%defattr(644,root,root,755)
302b72f6 544%doc linux-gpib-user-%{version}/doc/doc_html/*
2ee896be 545%endif
1fc85825 546%endif
This page took 0.153148 seconds and 4 git commands to generate.