]> git.pld-linux.org Git - packages/linux-gpib.git/blame - linux-gpib.spec
- rediff patch
[packages/linux-gpib.git] / linux-gpib.spec
CommitLineData
d4054fe9 1#
d4054fe9 2# Conditional build:
2ee896be 3%bcond_without kernel # kernel modules
25beb8e8 4%bcond_without drivers_isa # ISA kernel drivers [ix86 only]
25beb8e8 5%bcond_without drivers_usb # USB kernel drivers
2ee896be
JB
6%bcond_without userspace # userspace packages
7%bcond_without verbose # verbose modules build (V=1)
df990a65 8
635db00a 9%bcond_without doc # documentation build
08f3bc97 10%bcond_with hotplug # legacy hotplug support
2ee896be 11%bcond_without static_libs # static library
91dbb874 12%bcond_without guile # guile binding
2ee896be 13%bcond_without perl # Perl binding
b3693ec1 14%bcond_with php # PHP binding
fb21f50f
JB
15%bcond_without python # Python (any) binding
16%bcond_without python2 # Python 2.x binding
2ee896be 17%bcond_without tcl # Tcl binding
df990a65 18
4c4f156c
JR
19# The goal here is to have main, userspace, package built once with
20# simple release number, and only rebuild kernel packages with kernel
21# version as part of release number, without the need to bump release
22# with every kernel change.
23%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24%{error:kernel and userspace cannot be built at the same time on PLD builders}
25exit 1
26%endif
27
25beb8e8
JB
28%ifnarch %{ix86}
29%undefine with_drivers_isa
fb21f50f
JB
30%endif
31%if %{without python}
32%undefine with_python2
25beb8e8 33%endif
4c4f156c 34
76a67c9a 35%define php_name php%{?php_suffix}
4c4f156c 36
659cb172 37%define rel 3
4c4f156c 38%define pname linux-gpib
2ee896be
JB
39Summary: GPIB (IEEE 488) Linux support
40Summary(pl.UTF-8): Obsługa GPIB (IEEE 488) dla Linuksa
4c4f156c 41Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
fb21f50f 42Version: 4.3.3
2d0c8827 43Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
2ee896be 44License: GPL v2+
cc64c2aa 45Group: Applications/System
996e3d04 46Source0: http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
fb21f50f 47# Source0-md5: 1243aa44f788cf23f9b40ded54c14685
4c4f156c
JR
48Patch2: %{pname}-python.patch
49Patch3: %{pname}-perl.patch
50Patch4: %{pname}-firmwaredir.patch
51Patch5: %{pname}-guile2.patch
52Patch6: %{pname}-php7.patch
82a3ed18 53Patch8: kernel-5.2.patch
403be2a0 54Patch9: kernel-5.10.patch
659cb172 55Patch10: pkgconfig-version.patch
d4054fe9 56URL: http://linux-gpib.sourceforge.net/
2ee896be
JB
57BuildRequires: autoconf >= 2.50
58BuildRequires: automake
59BuildRequires: libtool
fb21f50f 60BuildRequires: rpmbuild(macros) >= 1.745
d4054fe9 61%if %{with kernel}
2ee896be 62BuildRequires: kernel-module-build >= 3:2.6.8
d4054fe9 63%endif
2ee896be
JB
64%if %{with userspace}
65BuildRequires: bison
635db00a 66%{?with_doc:BuildRequires: docbook-utils}
2ee896be 67BuildRequires: flex
91dbb874 68%{?with_guile:BuildRequires: guile-devel >= 1.4}
df990a65 69%{?with_perl:BuildRequires: perl-devel}
76a67c9a 70%{?with_php:BuildRequires: %{php_name}-devel >= 3:5}
2ee896be
JB
71%{?with_python:BuildRequires: python-devel >= 2}
72BuildRequires: readline-devel
df990a65 73%{?with_tcl:BuildRequires: tcl-devel}
2ee896be 74%endif
4c4f156c 75Requires: %{pname}-libs = %{version}-%{release}
4ffc9310
JB
76# for agilent_82357a and ni_usb_gpib
77Suggests: fxload
78# for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
79Suggests: linux-gpib-firmware
d4054fe9 80BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82%description
cc64c2aa 83The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
d4054fe9 84
bc9733fa
JR
85%description -l pl.UTF-8
86Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
d4054fe9 87
08f3bc97
JB
88%package hotplug
89Summary: Linux GPIB support for legacy USB hotplug
90Summary(pl.UTF-8): Obsługa Linux GPIB dla starego systemu hotplug USB
91Group: Applications/System
4c4f156c 92Requires: %{pname} = %{version}-%{release}
08f3bc97
JB
93Requires: hotplug
94
95%description hotplug
96Linux GPIB support for legacy USB hotplug.
97
98%description hotplug -l pl.UTF-8
99Obsługa Linux GPIB dla starego systemu hotplug USB.
100
2ee896be
JB
101%package libs
102Summary: Shared GPIB library
103Summary(pl.UTF-8): Biblioteka współdzielona GPIB
104Group: Libraries
d7b3679a 105
2ee896be
JB
106%description libs
107Shared GPIB library.
108
109%description libs -l pl.UTF-8
110Biblioteka współdzielona GPIB.
111
112%package devel
113Summary: Header file for GPIB library
114Summary(pl.UTF-8): Plik nagłówkowy biblioteki GPIB
115Group: Development/Libraries
4c4f156c 116Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
117
118%description devel
119Header file for GPIB library.
120
121%description devel -l pl.UTF-8
122Plik nagłówkowy biblioteki GPIB.
123
124%package static
125Summary: Static GPIB library
126Summary(pl.UTF-8): Biblioteka statyczna GPIB
127Group: Development/Libraries
4c4f156c 128Requires: %{pname}-devel = %{version}-%{release}
2ee896be
JB
129
130%description static
131Static GPIB library.
132
133%description static -l pl.UTF-8
134Biblioteka statyczna GPIB.
135
91dbb874
JB
136%package -n guile-gpib
137Summary: Guile bindings for GPIB library
138Summary(pl.UTF-8): Wiązania Guile do biblioteki GPIB
139Group: Development/Languages/Perl
4c4f156c 140Requires: %{pname}-libs = %{version}-%{release}
91dbb874
JB
141Requires: guile-libs
142
143%description -n guile-gpib
144Guile bindings for GPIB library.
145
146%description -n guile-gpib -l pl.UTF-8
147Wiązania Guile do biblioteki GPIB.
148
2ee896be
JB
149%package -n perl-gpib
150Summary: Perl bindings for GPIB library
151Summary(pl.UTF-8): Wiązania Perla do biblioteki GPIB
152Group: Development/Languages/Perl
4c4f156c 153Requires: %{pname}-libs = %{version}-%{release}
d7b3679a 154
2ee896be
JB
155%description -n perl-gpib
156Perl bindings for GPIB library.
d7b3679a 157
2ee896be
JB
158%description -n perl-gpib -l pl.UTF-8
159Wiązania Perla do biblioteki GPIB.
d7b3679a 160
76a67c9a
JB
161%package -n %{php_name}-gpib
162Summary: PHP bindings for GPIB library
163Summary(pl.UTF-8): Wiązania PHP do biblioteki GPIB
164Group: Development/Languages/PHP
165Provides: php(gpib) = %{version}
4c4f156c 166Requires: %{pname}-libs = %{version}-%{release}
76a67c9a
JB
167%{?requires_php_extension}
168
169%description -n %{php_name}-gpib
170PHP bindings for GPIB library.
171
172%description -n %{php_name}-gpib -l pl.UTF-8
173Wiązania PHP do biblioteki GPIB.
174
2ee896be 175%package -n python-gpib
fb21f50f
JB
176Summary: Python 2 bindings for GPIB library
177Summary(pl.UTF-8): Wiązania Pythona 2 do biblioteki GPIB
2ee896be 178Group: Libraries/Python
4c4f156c 179Requires: %{pname}-libs = %{version}-%{release}
2ee896be 180Requires: python-libs
d7b3679a 181
2ee896be 182%description -n python-gpib
fb21f50f 183Python 2 bindings for GPIB library.
2ee896be
JB
184
185%description -n python-gpib -l pl.UTF-8
fb21f50f
JB
186Wiązania Pythona 2 do biblioteki GPIB.
187
188%package -n python3-gpib
189Summary: Python 3 bindings for GPIB library
190Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki GPIB
191Group: Libraries/Python
192Requires: %{pname}-libs = %{version}-%{release}
193Requires: python3-libs
194
195%description -n python3-gpib
196Python 3 bindings for GPIB library.
197
198%description -n python3-gpib -l pl.UTF-8
199Wiązania Pythona 3 do biblioteki GPIB.
2ee896be
JB
200
201%package -n tcl-gpib
202Summary: Tcl bindings for GPIB library
203Summary(pl.UTF-8): Wiązania Tcl-a do biblioteki GPIB
204Group: Libraries
4c4f156c 205Requires: %{pname}-libs = %{version}-%{release}
2ee896be
JB
206Requires: tcl
207
208%description -n tcl-gpib
209Tcl bindings for GPIB library.
210
211%description -n tcl-gpib -l pl.UTF-8
212Wiązania Tcl-a do biblioteki GPIB.
213
214%package doc
215Summary: Linux-GPIB tools and library documentation
216Summary(pl.UTF-8): Dokumentacja narzędzi i biblioteki Linux-GPIB
217License: GFDL v1.2+ or GPL v2+
218Group: Documentation
219
220%description doc
221Linux-GPIB tools and library documentation.
222
223%description doc -l pl.UTF-8
224Dokumentacja narzędzi i biblioteki Linux-GPIB.
225
226%define kernel_pkg()\
227%package -n kernel%{_alt_kernel}-gpib\
228Summary: Linux GPIB drivers\
229Summary(pl.UTF-8): Sterowniki GPIB dla Linuksa\
230Release: %{rel}@%{_kernel_ver_str}\
231Group: Base/Kernel\
232Requires(post,postun): /sbin/depmod\
233%requires_releq_kernel\
234Requires(postun): %releq_kernel\
235\
236%description -n kernel%{_alt_kernel}-gpib\
237This package contains Linux drivers for GPIB (IEEE 488) hardware.\
238\
239%description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
240Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
241\
242%if %{with kernel}\
243%files -n kernel%{_alt_kernel}-gpib\
244%defattr(644,root,root,755)\
245/lib/modules/%{_kernel_ver}/kernel/gpib\
246%endif\
247\
248%post -n kernel%{_alt_kernel}-gpib\
249%depmod %{_kernel_ver}\
250\
251%postun -n kernel%{_alt_kernel}-gpib\
252%depmod %{_kernel_ver}\
253%{nil}
254
255%define build_kernel_pkg()\
55cbc6e3 256%{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
2ee896be 257cd drivers/gpib\
403be2a0
JR
258%if %{_kernel_version_code} < %{_kernel_version_magic 5 10 0}\
259%if %{with drivers_usb}\
260%install_kernel_modules -D installed -m lpvo_usb_gpib/lpvo_usb_gpib -d kernel/gpib\
261%endif\
262%endif\
82a3ed18 263%ifarch %{ix86}\
403be2a0 264%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 265%else\
403be2a0 266%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
82a3ed18 267%endif\
b69cc3e0 268cd ../..\
2ee896be
JB
269%{nil}
270
271%define install_kernel_pkg()\
272%{nil}
273
274%{?with_kernel:%{expand:%create_kernel_packages}}
d7b3679a 275
d4054fe9 276%prep
996e3d04 277%setup -q -n %{pname}-%{version}
16f00101
JR
278%if %{with userspace}
279tar xzf linux-gpib-user-%{version}.tar.gz
280cd linux-gpib-user-%{version}
2ee896be
JB
281%patch2 -p1
282%patch3 -p1
08f3bc97 283%patch4 -p1
91dbb874 284%patch5 -p1
16f00101 285#%patch6 -p1
659cb172 286%patch10 -p1
16f00101
JR
287cd ..
288%endif
289
290%if %{with kernel}
291tar xzf linux-gpib-kernel-%{version}.tar.gz
292cd linux-gpib-kernel-%{version}
5e300ced
JR
293%ifarch %{ix86}
294%patch8 -p1
295%endif
403be2a0 296%patch9 -p1
16f00101 297%endif
d7b3679a 298
d4054fe9 299%build
16f00101
JR
300%if %{with userspace}
301cd linux-gpib-user-%{version}
302b72f6
JR
302%{__libtoolize}
303%{__aclocal}
304%{__autoconf}
305%{__autoheader}
306%{__automake}
91dbb874 307%if %{with guile}
d53b2ad5 308CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
91dbb874 309%endif
d7b3679a 310%configure \
55cbc6e3 311 --with-udev-libdir=/lib/udev \
635db00a 312 %{!?with_doc:--disable-documentation} \
2ee896be
JB
313 %{!?with_guile:--disable-guile-binding} \
314 %{!?with_perl:--disable-perl-binding} \
315 %{!?with_php:--disable-php-binding} \
316 %{!?with_python:--disable-python-binding} \
317 %{?with_static_libs:--enable-static} \
16f00101 318 %{!?with_tcl:--disable-tcl-binding}
d7b3679a 319
9e3b7024 320%{__make}
fb21f50f
JB
321
322%if %{with python2}
323cd language/python
324%py_build
325cd ../..
326%endif
16f00101 327cd ..
2ee896be 328%endif
d7b3679a 329
2ee896be 330%if %{with kernel}
16f00101 331cd linux-gpib-kernel-%{version}
2ee896be
JB
332%{expand:%build_kernel_packages}
333%endif
d4054fe9 334
335%install
336rm -rf $RPM_BUILD_ROOT
2ee896be 337install -d $RPM_BUILD_ROOT%{_examplesdir}
d4054fe9 338
8eefbf3b 339%if %{with kernel}
16f00101 340cd linux-gpib-kernel-%{version}
2ee896be
JB
341%{expand:%install_kernel_packages}
342cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
302b72f6 343cd ..
8eefbf3b
MWP
344%endif
345
d4054fe9 346%if %{with userspace}
302b72f6
JR
347cd linux-gpib-user-%{version}
348%{__make} install \
08f3bc97
JB
349 DESTDIR=$RPM_BUILD_ROOT \
350 HOTPLUG_USB_CONF_DIR=/lib/udev \
351 UDEV_RULES_DIR=/lib/udev/rules.d \
352 USB_FIRMWARE_DIR=/lib/firmware
25beb8e8 353
fb21f50f
JB
354%if %{with python2}
355cd language/python
356%py_install
357cd ../..
358%endif
359
25beb8e8 360%if %{with hotplug}
08f3bc97
JB
361# use udev paths as base and legacy hotplug as addon (not the opposite)
362install -d $RPM_BUILD_ROOT/etc/hotplug/usb
363%{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
364ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
365ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
25beb8e8 366%endif
2ee896be
JB
367
368# obsoleted by pkg-config
369%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
370
91dbb874
JB
371%if %{with guile}
372%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
373%if %{with static_libs}
374%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
375%endif
376%endif
377
2ee896be
JB
378%if %{with perl}
379%{__make} -C language/perl pure_install \
380 DESTDIR=$RPM_BUILD_ROOT
76a67c9a 381
2ee896be 382cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
76a67c9a 383
2ee896be
JB
384%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
385%endif
386
76a67c9a
JB
387%if %{with php}
388install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
389cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
390; Enable gpib extension module
391extension=gpib_php.so
392EOF
393
394%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
395%if %{with static_libs}
396%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
397%endif
398%endif
399
2ee896be
JB
400%if %{with python}
401%py_postclean
402%endif
403
404%if %{with tcl}
405cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
76a67c9a 406
2ee896be
JB
407%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
408%if %{with static_libs}
409%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
410%endif
411%endif
412
635db00a 413%if %{with doc}
2ee896be 414# packaged as %doc
302b72f6 415%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
d4054fe9 416%endif
82a3ed18 417%endif
d4054fe9 418
d4054fe9 419%clean
420rm -rf $RPM_BUILD_ROOT
421
2ee896be
JB
422%post libs -p /sbin/ldconfig
423%postun libs -p /sbin/ldconfig
d4054fe9 424
91dbb874
JB
425%post -n guile-gpib -p /sbin/ldconfig
426%postun -n guile-gpib -p /sbin/ldconfig
427
428%post -n tcl-gpib -p /sbin/ldconfig
429%postun -n tcl-gpib -p /sbin/ldconfig
430
76a67c9a
JB
431%post -n %{php_name}-gpib
432%php_webserver_restart
433
434%postun -n %{php_name}-gpib
435if [ "$1" = 0 ]; then
436 %php_webserver_restart
437fi
438
2ee896be
JB
439%if %{with userspace}
440%files
441%defattr(644,root,root,755)
302b72f6 442%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
2ee896be
JB
443%attr(755,root,root) %{_bindir}/ibterm
444%attr(755,root,root) %{_bindir}/ibtest
445%attr(755,root,root) %{_sbindir}/gpib_config
55cbc6e3 446/lib/udev/rules.d/98-gpib-generic.rules
08f3bc97 447/lib/udev/rules.d/99-agilent_82357a.rules
08f3bc97 448/lib/udev/rules.d/99-ni_usb_gpib.rules
55cbc6e3
JR
449%attr(755,root,root) /lib/udev/gpib_udev_config
450%attr(755,root,root) /lib/udev/gpib_udev_fxloader
451%attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
08f3bc97
JB
452
453%if %{with hotplug}
454%files hotplug
455%defattr(644,root,root,755)
2ee896be
JB
456%attr(755,root,root) /etc/hotplug/usb/agilent_82357a
457%attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
458/etc/hotplug/usb/agilent_82357a.usermap
459/etc/hotplug/usb/ni_usb_gpib.usermap
08f3bc97 460%endif
d4054fe9 461
2ee896be 462%files libs
0e4898e2 463%defattr(644,root,root,755)
302b72f6 464%doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
2ee896be
JB
465%attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
466%attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
467
468%files devel
469%defattr(644,root,root,755)
470%attr(755,root,root) %{_libdir}/libgpib.so
471%{_includedir}/gpib
472%{_pkgconfigdir}/libgpib.pc
473
474%if %{with static_libs}
475%files static
476%defattr(644,root,root,755)
477%{_libdir}/libgpib.a
478%endif
479
91dbb874
JB
480%if %{with guile}
481%files -n guile-gpib
482%defattr(644,root,root,755)
996e3d04 483%attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
91dbb874
JB
484%attr(755,root,root) %{_libdir}/libgpib-guile.so
485%endif
486
2ee896be
JB
487%if %{with perl}
488%files -n perl-gpib
489%defattr(644,root,root,755)
302b72f6 490%doc linux-gpib-user-%{version}/language/perl/{Changes,README}
2ee896be
JB
491%{perl_vendorarch}/LinuxGpib.pm
492%dir %{perl_vendorarch}/auto/LinuxGpib
493%attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
494%{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
495%{_mandir}/man3/LinuxGpib.3pm*
496%{_examplesdir}/perl-gpib-%{version}
497%endif
498
76a67c9a
JB
499%if %{with php}
500%files -n %{php_name}-gpib
501%defattr(644,root,root,755)
502%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
996e3d04 503%attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
76a67c9a
JB
504%attr(755,root,root) %{php_extensiondir}/gpib_php.so
505%endif
506
fb21f50f 507%if %{with python2}
2ee896be
JB
508%files -n python-gpib
509%defattr(644,root,root,755)
302b72f6 510%doc linux-gpib-user-%{version}/language/python/README
2ee896be
JB
511%attr(755,root,root) %{py_sitedir}/gpib.so
512%{py_sitedir}/Gpib.py[co]
513%{py_sitedir}/gpib-1.0-py*.egg-info
514%endif
515
fb21f50f
JB
516%if %{with python}
517%files -n python3-gpib
518%defattr(644,root,root,755)
519%doc linux-gpib-user-%{version}/language/python/README
520%attr(755,root,root) %{py3_sitedir}/gpib.cpython-*.so
521%{py3_sitedir}/Gpib.py
522%{py3_sitedir}/__pycache__/Gpib.cpython-*.py[co]
523%{py3_sitedir}/gpib-1.0-py*.egg-info
524%endif
525
2ee896be
JB
526%if %{with tcl}
527%files -n tcl-gpib
528%defattr(644,root,root,755)
302b72f6 529%doc linux-gpib-user-%{version}/language/tcl/README
996e3d04 530%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
2ee896be
JB
531%attr(755,root,root) %{_libdir}/libgpib_tcl.so
532%{_examplesdir}/tcl-gpib-%{version}
533%endif
534
635db00a 535%if %{with doc}
2ee896be
JB
536%files doc
537%defattr(644,root,root,755)
302b72f6 538%doc linux-gpib-user-%{version}/doc/doc_html/*
2ee896be 539%endif
1fc85825 540%endif
This page took 0.160484 seconds and 4 git commands to generate.